Описание стандарта GSM, оглавление.

сборка специально для http://www.natahaus.ru/
Что такое GSM?
Глава 1
ЦИФРОВАЯ СОТОВАЯ СИСТЕМА ПОДВИЖНОЙ РАДИОСВЯЗИ СТАНДАРТА GSM
1.1. Общие характеристики стандарта GSM
1.2. Структурная схема и состав оборудования сетей связи

1.3. Сетевые и радиоинтерфейсы

1.4. Структура служб и передача данных в стандарте GSM

1.6. Структура ТDМА кадров и формирование сигналов в стандарте GSM

Литература к Главе 1

Глава 2
ОРГАНИЗАЦИЯ ФИЗИЧЕСКИХ И ЛОГИЧЕСКИХ КАНАЛОВ В СТАНДАРТЕ GSM
2.1. Частотный план стандарта GSM
2.2. Структура логических каналов связи

2.3. Структура логических каналов управления

2.4. Организация физических каналов

2.5. Модуляция радиосигнала

Литература к Главе 2

Глава 3
3.3. Кодирование и перемежение в полноскоростном канале передачи данных
3.4. Кодирование и перемежение в каналах управления

Глава 4
ОБРАБОТКА РЕЧИ В СТАНДАРТЕ GSM
4.1. Общее описание процессов обработки речи
4.2. Выбор речевого кодека для стандарта GSM

4.4. Детектор активности речи

4.5. Формирование комфортного шума

4.6. Экстраполяция потерянного речевого кадра

Литература к Главе 4

Глава 5
АСПЕКТЫ БЕЗОПАСНОСТИ В СТАНДАРТЕ GSM
5.1 Общее описание характеристик безопасности
5.2 Механизмы аутентификации

5.3 Секретность передачи данных

5.4 Обеспечение секретности абонента

5.5 Обеспечение секретности в процедуре корректировки местоположения

5.6 Общий состав секретной информации и ее распределение в аппаратных средствах GSM

5.7 Обеспечение секретности при обмене сообщениями между HLR, VLR и MSC

5.8 Модуль подлинности абонента

Литература к Главе 5

Глава 6
УПРАВЛЕНИЕ СЕТЯМИ СВЯЗИ В СТАНДАРТЕ GSM
6.1 Задачи системы сетевого управления
6.2 Принципы построения системы сетевого управления

6.3 Распределение функций сетевого управления в GSM

6.4 Стандартные интерфейсы в системе сетевого управления GSM

6.4 Стандартные интерфейсы в системе сетевого управления

Литература к Главе 6


Глава 1

Глава 1. ЦИФРОВАЯ СОТОВАЯ СИСТЕМА ПОДВИЖНОЙ РАДИОСВЯЗИ СТАНДАРТА GSM

1.1. Общие характеристики стандарта GSM

В соответствии с рекомендацией СЕРТ 1980 г., касающейся использования спектра частот подвижной связи в диапазоне частот 862-960 МГц, стандарт GSM на цифровую общеевропейскую (глобальную) сотовую систему наземной подвижной связи предусматривает работу передатчиков в двух диапазонах частот: 890-915 МГц (для передатчиков подвижных станций - MS), 935-960 МГц (для передатчиков базовых станций - BTS) [1.1, 1.2].

В стандарте GSM используется узкополосный многостанционный доступ с временным разделением каналов (NB ТDМА). В структуре ТDМА кадра содержится 8 временных позиций на каждой из 124 несущих.

Для защиты от ошибок в радиоканалах при передаче информационных сообщений применяется блочное и сверточное кодирование с перемежением. Повышение эффективности кодирования и перемежения при малой скорости перемещения подвижных станций достигается медленным переключением рабочих частот (SFH) в процессе сеанса связи со скоростью 217 скачков в секунду.

Для борьбы с интерференционными замираниями принимаемых сигналов, вызванными многолучевым распространением радиоволн в условиях города, в аппаратуре связи используются эквалайзеры, обеспечивающие выравнивание импульсных сигналов со среднеквадратическим отклонением времени задержки до 16 мкс.

Система синхронизации рассчитана на компенсацию абсолютного времени задержки сигналов до 233 мкс, что соответствует максимальной дальности связи или максимальному радиусу ячейки (соты) 35 км.

В стандарте GSM выбрана гауссовская частотная манипуляция с минимальным частотным сдвигом (GMSK). Обработка речи осуществляется в рамках принятой системы прерывистой передачи речи (DTX), которая обеспечивает включение передатчика только при наличии речевого сигнала и отключение передатчика в паузах и в конце разговора. В качестве речепреобразующего устройства выбран речевой кодек с регулярным импульсным возбуждением/долговременным предсказанием и линейным предикативным кодированием с предсказанием (RPE/LTR-LTP-кодек). Общая скорость преобразования речево, о сигнала - 13 кбит/с.

В стандарте GSM достигается высокая степень безопасности передачи сообщений; осуществляется шифрование сообщений по алгоритму шифрования с открытым ключом (RSA).

В целом система связи, действующая в стандарте GSM, рассчитана на ее использование в различных сферах. Она предоставляет пользователям широкий диапазон услуг и возможность применять разнообразное оборудование для передачи речевых сообщений и данных, вызывных и аварийных сигналов; подключаться к телефонным сетям общего пользования (PSTN), сетям передачи данных (PDN) и цифровым сетям с интеграцией служб (ISDN).

Основные характеристики стандарта GSM

Частоты передачи подвижной станциии приема базовой станции, МГц | 890-915
Частоты приема подвижной станции и передачи базовой станции, МГц | 935-960
Дуплексный разнос частот приема и передачи, МГц | 45
Скорость передачи сообщений в радиоканале, кбит/с | 270, 833
Скорость преобразования речевого кодека, кбит/с | 13
Ширина полосы канала связи, кГц | 200
Максимальное количество каналов связи | 124
Максимальное количество каналов, организуемых в базовой станции | 16-20
Вид модуляции | GMSK
Индекс модуляции | ВТ 0,3
Ширина полосы предмодуляционного гауссовского фильтра, кГц | 81,2
Количество скачков по частоте в секунду | 217
Временное разнесение в интервалах ТDМА кадра (передача/прием) для подвижной станции | 2
Вид речевого кодека | RPE/LTP
Максимальный радиус соты, км | до 35
Схема организации каналов комбинированная TDMA/FDMA

1.2. Структурная схема и состав оборудования сетей связи

1-1.jpg (55615 bytes)

Рис. 1.1

Функциональное построение и интерфейсы, принятые в стандарте GSM, иллюстрируются структурной схемой рис, 1.1, на которой MSC (Mobile Switching Centre) - центр коммутации подвижной связи; BSS (Base Station System) - оборудование базовой станции; ОМС (Operations and Maintenance Centre) - центр управления и обслуживания; MS (Mobile Stations) - подвижные станции.

Функциональное сопряжение элементов системы осуществляется рядом интерфейсов. Все сетевые функциональные компоненты в стандарте GSM взаимодействуют в соответствии с системой сигнализации МККТТ SS N 7 (CCITT SS. N 7).

Центр коммутации подвижной связи обслуживает группу сот и обеспечивает все виды соединений, в которых нуждается в процессе работы подвижная станция. MSC аналогичен ISDN коммутационной станции и представляет собой интерфейс между фиксированными сетями (PSTN, PDN, ISDN и т.д.) и сетью подвижной связи. Он обеспечивает маршрутизацию вызовов и функции управления вызовами. Кроме выполнения функций обычной ISDN коммутационной станции, на MSC возлагаются функции коммутации радиоканалов. К ним относятся "эстафетная передача", в процессе которой достигается непрерывность связи при перемещении подвижной станции из соты в соту, и переключение рабочих каналов в соте при появлении помех или неисправностях.

Каждый MSC обеспечивает обслуживание подвижных абонентов, расположенных в пределах определенной географической зоны (например, Москва и область). MSC управляет процедурами установления вызова и маршрутизации. Для телефонной сети общего пользования (PSTN) MSC обеспечивает функции сигнализации по протоколу SS N 7, передачи вызова или другие виды интерфейсов в соответствии с требованиями конкретного проекта.

MSC формирует данные, необходимые для выписки счетов за предоставленные сетью услуги связи, накапливает данные по состоявшимся разговорам и передает их в центр расчетов (биллинг-центр). MSC составляет также статистические данные, необходимые для контроля работы и оптимизации сети.

MSC поддерживает также процедуры безопасности, применяемые для управления доступами к радиоканалам.

MSC не только участвует в управлении вызовами, но также управляет процедурами регистрации местоположения и передачи управления, кроме передачи управления в подсистеме базовых станций (BSS). Регистрация местоположения подвижных станций необходима для обеспечения доставки вызова перемещающимся подвижным абонентам от абонентов телефонной сети общего пользования или других подвижных абонентов. Процедура передачи вызова позволяет сохранять соединения и обеспечивать ведение разговора, когда подвижная станция перемещается из одной зоны обслуживания в другую. Передача вызовов в сотах, управляемых одним контроллером базовых станций (BSC), осуществляется этим BSC. Когда передача вызовов осуществляется между двумя сетями, управляемыми разными BSC, то первичное управление осуществляется в MSC. В стандарте GSM также предусмотрены процедуры передачи вызова между сетями (контроллерами), относящимися к разным MSC. Центр коммутации осуществляет постоянное слежение за подвижными станциями, используя регистры положения (HLR) и перемещения (VLR). В HLR хранится та часть информации о местоположении какой-либо подвижной станции, которая позволяет центру коммутации доставить вызов станции. Регистр HLR содержит международный идентификационный номер подвижного абонента (IMSI). Он используется для опознавания подвижной станции в центре аутентификации (AUC) (рис. 1.2, 1.3).

1-2.jpg (171936 bytes)

Практически HLR представляет собой справочную базу данных о постоянно прописанных в сети абонентах. В ней содержатся опознавательные номера и адреса, а также параметры подлинности абонентов, состав услуг связи, специальная информация о маршрутизации. Ведется регистрация данных о роуминге (блуждании) абонента, включая данные о временном идентификационном номере подвижного абонента (TMSI) и соответствующем VLR.

К данным, содержащимся в HLR, имеют дистанционный доступ все MSC и VLR сети и, если в сети имеются несколько HLR, в базе данных содержится только одна запись об абоненте, поэтому каждый HLR представляет собой определенную часть общей базы данных сети об абонентах. Доступ к базе данных об абонентах осуществляется по номеру IMSI или MSISDN (номеру подвижного абонента в сети ISDN). К базе данных могут получить доступ MSC или VLR, относящиеся к другим сетям, в рамках обеспечения межсетевого роуминга абонентов.

Второе основное устройство, обеспечивающее контроль за передвижением подвижной станции из зоны в зону, - регистр перемещения VLR. С его помощью достигается функционирование подвижной станции за пределами зоны, контролируемой HLR. Когда в процессе перемещения подвижная станция переходит из зоны действия одного контроллера базовой станции BSC, объединяющего группу базовых станций, в зону действия другого BSC, она регистрируется новым BSC, и в VLR заносится информация о номере области связи, которая обеспечит доставку вызовов под-

Состав временных данных, хранящихся в HLR и VLR

1-3.jpg (44806 bytes)

Практически HLR представляет собой справочную базу данных о постоянно прописанных в сети абонентах. В ней содержатся опознавательные номера и адреса, а также параметры подлинности абонентов, состав услуг связи, специальная информация о маршрутизации. Ведется регистрация данных о роуминге (блуждании) абонента, включая данные о временном идентификационном номере подвижного абонента (TMSI) и соответствующем VLR.

К данным, содержащимся в HLR, имеют дистанционный доступ все MSC и VLR сети и, если в сети имеются несколько HLR, в базе данных содержится только одна запись об абоненте, поэтому каждый HLR представляет собой определенную часть общей базы данных сети об абонентах. Доступ к базе данных об абонентах осуществляется по номеру IMSI или MSISDN (номеру подвижного абонента в сети ISDN). К базе данных могут получить доступ MSC или VLR, относящиеся к другим сетям, в рамках обеспечения межсетевого роуминга абонентов.

Второе основное устройство, обеспечивающее контроль за передвижением подвижной станции из зоны в зону, - регистр перемещения VLR. С его помощью достигается функционирование подвижной станции за пределами зоны, контролируемой HLR. Когда в процессе перемещения подвижная станция переходит из зоны действия одного контроллера базовой станции BSC, объединяющего группу базовых станций, в зону действия другого BSC, она регистрируется новым BSC, и в VLR заносится информация о номере области связи, которая обеспечит доставку вызовов под-

вижной станции. Для сохранности данных, находящихся в HLR и VLR, в случае сбоев предусмотрена защита устройств памяти этих регистров.

VLR содержит такие же данные, как и HLR, однако эти данные содержатся в VLR только до тех пор, пока абонент находится в зоне, контролируемой VLR.

В сети подвижной связи GSM соты группируются в географические зоны (LA), которым присваивается свой идентификационный номер (LAC). Каждый VLR содержит данные об абонентах в нескольких LA. Когда подвижный абонент перемещается из одной LA в другую, данные о его местоположении автоматически обновляются в VLR. Если старая и новая LA находятся под управлением различных VLR, то данные на старом VLR стираются после их копирования в новый VLR. Текущий адрес VLR абонента, содержащийся в HLR, также обновляется.

VLR обеспечивает также присвоение номера "блуждающей" подвижной станции (MSRN). Когда подвижная станция принимает входящий вызов, VLR выбирает его MSRN и передает его на MSC, который осуществляет маршрутизацию этого вызова к базовым станциям, находящимся рядом с подвижным абонентом.

VLR также распределяет номера передачи управления при передаче соединений от одного MSC к другому. Кроме того, VLR управляет распределением новых TMSI и передает их в HLR. Он также управляет процедурами установления подлинности во время обработки вызова. По решению оператора TMSI может периодически изменяться для усложнения процедуры идентификации абонентов. Доступ к базе данных VLR может обеспечиваться через IMSI, TMSI или MSRN. В целом VLR представляет собой локальную базу данных о подвижном абоненте для той зоны, где находится абонент, что позволяет исключить постоянные запросы в HLR и сократить время на обслуживание вызовов.

Для исключения несанкционированного использования ресурсов системы связи вводятся механизмы аутентификации - удостоверения подлинности абонента. Центр аутентификации состоит из нескольких блоков и формирует ключи и алгоритмы аутентификации. С его помощью проверяются полномочия абонента и осуществляется его доступ к сети связи. AUC принимает решения о параметрах процесса аутентификации и определяет ключи шифрования абонентских станций на основе базы данных, сосредоточенной в регистре идентификации оборудования (EIR - Equipment Identification Register).

Каждый подвижный абонент на время пользования системой связи получает стандартный модуль подлинности абонента (SIM), который содержит: международный идентификационный номер (IMSI), свой индивидуальный ключ аутентификации (Ki), алгоритм аутентификации (A3).

С помощью записанной в SIM информации в результате взаимного обмена данными между подвижной станцией и сетью осуществляется полный цикл аутентификации и разрешается доступ абонента к сети.

Процедура проверки сетью подлинности абонента реализуется следующим образом. Сеть передает случайный номер (RAND) на подвижную станцию. На ней с помощью Ki и алгоритма аутентификации A3 определяется значение отклика (SRES), т.е.

SRES = Ki * [ RAND]

Подвижная станция посылает вычисленное значение SRES в сеть, которая сверяет значение принятого SRES со значением SRES, вычисленным сетью. Если оба значения совпадают, подвижная станция приступает к передаче сообщений. В противном случае связь прерывается, и индикатор подвижной станции показывает, что опознавание не состоялось. Для обеспечения секретности вычисление SRES происходит в рамках SIM. Несекретная информация (например, Ki) не подвергается обработке в модуле SIM.

EIR - регистр идентификации оборудования, содержит централизованную базу данных для подтверждения подлинности международного идентификационного номера оборудования подвижной станции (1МЕ1). Эта база данных относится исключительно к оборудованию подвижной станции. Бзза данных EIR состоит из списков номеров 1МЕ1, организованных следующим образом:

БЕЛЫЙ СПИСОК - содержит номера 1МЕ1, о которых есть сведения, что они закреплены за санкционированными подвижными станциями.

ЧЕРНЫЙ СПИСОК - содержит номера 1МЕ1 подвижных станций, которые украдены или которым отказано в обслуживании по другой причине.

СЕРЫЙ СПИСОК - содержит номера 1МЕ1 подвижных станций, у которых существуют проблемы, выявленные по данным программного обеспечения, что не является основанием для внесения в "черный список".

К базе данных EIR получают дистанционный доступ MSC данной сети, а также MSC других подвижных сетей.

Как и в случае с HLR, сеть может иметь более одного EIR, при этом каждый EIR управляет определенными группами 1МЕ1. В состав MSC входит транслятор, который при получении номера 1МЕ1 возвращает адрес EIR, управляющий соответствующей частью базы данных об оборудовании.

IWF - межсетевой функциональный стык, является одной из составных частей MSC. Он обеспечивает абонентам доступ к средствам преобразования протокола и скорости передачи данных так, чтобы можно было передавать их между его терминальным оборудованием (DIE) сети GSM и обычным терминальным оборудованием фиксированной сети. Межсетевой функциональный стык также "выделяет" модем из своего банка оборудования для сопряжения с соответствующим модемом фиксированной сети. IWF также обеспечивает интерфейсы типа прямого соединения для оборудования, поставляемого клиентам, например, для пакетной передачи данных PAD по протоколу Х.25.

ЕС - эхоподавитель, используется в MSC со стороны PSTN для всех телефонных каналов (независимо от их протяженности) из-за физических задержек в трактах распространения, включая радиоканал, сетей GSM. Типовой эхоподавитель может обеспечивать подавление в интервале 68 миллисекунд на участке между выходом ЕС и телефоном фиксированной телефонной сети. Общая задержка в канале GSM при распространении в прямом и обратном направлениях, вызванная обработкой сигнала, кодированием/декодированием речи, канальным кодированием и т.д., составляет около 180 мс. Эта задержка была бы незаметна подвижному абоненту, если бы в телефонный канал не был включен гибридный трансформатор с преобразованием тракта с двухпроводного на четырехпроводный режим, установка которого необходима в MSC, так как стандартное соединение с PSTN является двухпроводным. При соединении двух абонентов фиксированной сети эхо-сигналы отсутствуют. Без включения ЕС задержка от распространения сигналов в тракте GSM будет вызывать раздражение у абонентов, прерывать речь и отвлекать внимание.

ОМС - центр эксплуатации и технического обслуживания, является центральным элементом сети GSM, который обеспечивает контроль и управление другими компонентами сети и контроль качества ее работы. ОМС соединяется с другими компонентами сети GSM по каналам пакетной передачи протокола Х.25. ОМС обеспечивает функции обработки аварийных сигналов, предназначенных для оповещения обслуживающего персонала, и регистрирует сведения об аварийных ситуациях в других компонентах сети. В зависимости от характера неисправности ОМС позволяет обеспечить ее устранение автоматически или при активном вмешательстве персонала. ОМС может обеспечить проверку состояния оборудования сети и прохождения вызова подвижной станции. ОМС позволяет производить управление нагрузкой в сети. Функция эффективного управления включает сбор статистических данных о нагрузке от компонентов сети GSM, записи их в дисковые файлы и вывод на дисплей для визуального анализа. ОМС обеспечивает управление изменениями программного обеспечения и базами данных о конфигурации элементов сети. Загрузка программного обеспечения в память может производиться из ОМС в другие элементы сети или из них в ОМС.

NMC - центр управления сетью, позволяет обеспечивать рациональное иерархическое управление сетью GSM. Он обеспечивает эксплуатацию и техническое обслуживание на уровне всей сети, поддерживаемой центрами ОМС, которые отвечают за управление региональными сетями. NMC обеспечивает управление трафиком во всей сети и обеспечивает диспетчерское управление сетью при сложных аварийных ситуациях, как например, выход из строя или перегрузка узлов. Кроме того, он контролирует состояние устройств автоматического управления, задействованных в оборудовании сети, и отражает на дисплее состояние сети для операторов NMC. Это позволяет операторам контролировать региональные проблемы и, при необходимости, оказывать помощь ОМС, ответственному за конкретный регион. Таким образом, персонал NMC знает состояние всей сети и может дать указание персоналу ОМС изменить стратегию решения региональной проблемы.

NMC концентрирует внимание на маршрутах сигнализации и соединениях между узлами с тем, чтобы не допускать условий для возникновения перегрузки в сети. Контролируются также

маршруты соединений между сетью GSM и PSTN во избежание распространений условий перегрузки между сетями. При этом персонал NMC координирует вопросы управления сетью с персоналом других NMC. NMC обеспечивает также возможность управления трафиком для сетевого оборудования подсистемы базовых станций (BSS). Операторы NMC в экстремальных ситуациях могут задействовать такие процедуры управления, как "приоритетный доступ", когда только абоненты с высоким приоритетом (экстренные службы) могут получить доступ к системе.

NMC может брать на себя ответственность в каком-либо регионе, когда местный ОМС является необслуживаемым, при этом ОМС действует в качестве транзитного пункта между NMC и оборудованием сети. NMC обеспечивает операторов функциями, аналогичными функциям ОМС.

NMC является также важным инструментом планирования сети, так как NMC контролирует сеть и ее работу на сетевом уровне, а, следовательно, обеспечивает планировщиков сети данными, определяющими ее оптимальное развитие.

BSS - оборудование базовой станции, состоит из контроллера базовой станции (BSC) и приемо-передающих базовых станций (BTS). Контроллер базовой станции может управлять несколькими приемо-передающими блоками. BSS управляет распределением радиоканалов, контролирует соединения, регулирует их очередность, обеспечивает режим работы с прыгающей частотой, модуляцию и демодуляцию сигналов, кодирование и декодирование сообщений, кодирование речи, адаптацию скорости передачи для речи, данных и вызова, определяет очередность передачи сообщений персонального вызова.

BSS совместно с MSC, HLR, VLR выполняет некоторые функции, например: освобождение канала, главным образом, под контролем MSC, но MSC может запросить базовую станцию обеспечить освобождение канала, если вызов не проходит из-за радиопомех. BSS и MSC совместно осуществляют приоритетную передачу информации для некоторых категорий подвижных станций.

ТСЕ- транскодер, обеспечивает преобразование выходных сигналов канала передачи речи и данных MSC (64 кбит/с ИКМ) к виду, соответствующему рекомендациям GSM по радиоинтерфейсу (Рек. GSM 04.08). В соответствии с этими требованиями скорость передачи речи, представленной в цифровой форме, составляет 13 кбит/с. Этот канал передачи цифровых речевых сигналов называется "полноскоростным". Стандартом предусматривается в перспективе использование полускоростного речевого канала (скорость передачи 6,5 кбит/с).

Снижение скорости передачи обеспечивается применением специального речепреобразую-щего устройства, использующего линейное предикативное кодирование (LPC), долговременное предсказание (LTP), остаточное импульсное возбуждение (RPE - иногда называется RELP).

Транскодер обычно располагается вместе с MSC, тогда передача цифровых сообщений в направлении к контроллеру базовых станций - BSC ведется с добавлением к потоку со скоростью передачи 13 кбит/с, дополнительных битов (стафингование) до скорости передачи данных 16 кбит/с. Затем осуществляется уплотнение с кратностью 4 в стандартный канал 64 кбит/с. Так формируется определенная Рекомендациями GSM ЗО-канальная ИКМ линия, обеспечивающая передачу 120 речевых каналов. Шестнадцатый канал (64 кбит/с), "временное окно", выделяется отдельно для передачи информации сигнализации и часто содержит трафик SS N7 или LAPD. В другом канале (64 кбит/с) могут передаваться также пакеты данных, согласующиеся с протоколом X.25 МККТТ.

Таким образом, результирующая скорость передачи по указанному интерфейсу составляет 30х64 кбит/с + 64 кбит/с + 64 кбит/с = 2048 кбит/с.

MS - подвижная станция, состоит из оборудования, которое служит для организации доступа абонентов сетей GSM к существующим фиксированным сетям электросвязи. В рамках стандарта GSM приняты пять классов подвижных станций от модели 1-го класса с выходной мощностью 20 Вт, устанавливаемой на транспортном средстве, до портативной модели 5-го класса, максимальной мощностью 0,8 Вт (табл. 1.1). При передаче сообщений предусматривается адаптивная регулировка мощности передатчика, обеспечивающая требуемое качество связи.

Подвижный абонент и станция независимы друг от друга. Как уже отмечалось, каждый абонент имеет свой международный идентификационный номер (IMSI), записанный на его интеллектуальную карточку. Такой подход позволяет устанавливать радиотелефоны, например, в такси и автомобилях, сдаваемых на прокат. Каждой подвижной станции также присваивается свой международный идентификационный номер (1МЕ1). Этот номер используется для предотвращения доступа к сетям GSM похищенной станции или станции без полномочий [1.2].

Таблица 1.1

Класс мощности | Максимальный уровень мощности передатчика | Допустимые отклонения
1 | 20 Вт | 1,5 дБ
2 | 8 Вт | 1,5 дБ
3 | 5 Вт | 1,5 дБ
4 | 2 Вт | 1,5 дБ
5 | 0,8 Вт | 1,5 дБ

1.3. Сетевые и радиоинтерфейсы

При проектировании цифровых сотовых систем подвижной связи стандарта GSM рассматриваются интерфейсы трех видов: для соединения с внешними сетями; между различным оборудованием сетей GSM; между сетью GSM и внешним оборудованием. Все существующие внутренние интерфейсы сетей GSM показаны на структурной схеме рис. 1.1. Они полностью соответствуют требованиям Рекомендаций ETSI/GSM 03.02.

Интерфейсы с внешними сетями

Соединение с PSTN

Соединение с телефонной сетью общего пользования осуществляется MSC по линии связи 2 Мбит/с в соответствии с системой сигнализации SS N 7. Электрические характеристики 2 Мбит/с интерфейса соответствуют Рекомендациям МККТТ G.732.

Соединение с ISDN

Для соединения с создаваемыми сетями ISDN предусматриваются четыре линии связи 2 Мбит/с, поддерживаемые системой сигнализации SS N 7 и отвечающие Рекомендациям Голубой книги МККТТ Q.701-Q.710, Q.711-Q.714, Q.716, Q.781, 0.782, 0.791, 0.795, 0.761-0.764, 0.766.

Соединение с существующей сетью NMT-450

Центр коммутации подвижной связи соединяется с сетью NMT-450 через четыре стандартные линии связи 2 Мбит/с и системы сигнализации SS N7. При этом должны обеспечиваться требования Рекомендаций МККТТ по подсистеме пользователей телефонной сетью (TUP - Telephone User Part) и подсистеме передачи сообщений (МТР - Message Transfer Part) Желтой книги. Электрические характеристики линии 2 Мбит/с соответствуют Рекомендациям МККТТ G.732.

Соединения с международными сетями GSM

В настоящее время обеспечивается подключение сети GSM в Москве к общеевропейским сетям GSM. Эти соединения осуществляются на основе протоколов систем сигнализации (SCCP) и межсетевой коммутации подвижной связи (GMSC).

Внутренние GSM - интерфейсы

Интерфейс между MSC и BSS (А-интерфейс) обеспечивает передачу сообщений для управления BSS, передачи вызова, управления передвижением. А-интерфейс объединяет каналы связи и линии сигнализации. Последние используют протокол SS N7 МККТТ. Полная спецификация А-ин-терфейса соответствует требованиям серии 08 Рекомендаций ETSI/GSM.

Интерфейс между MSC и HLR совмещен с VLR (В-интерфейс). Когда MSC необходимо определить местоположение подвижной станции, он обращается к VLR. Если подвижная станция инициирует процедуру местоопределения с MSC, он информирует свой VLR, который заносит всю изменяющуюся информацию в свои регистры. Эта процедура происходит всегда, когда MS переходит из одной области местоопределения в другую. В случае, если абонент запрашивает специальные дополнительные услуги или изменяет некоторые свои данные, MSC также информирует VLR, который регистрирует изменения и при необходимости сообщает о них HLR.

Интерфейс между MSC и HLR (С-интерфейс) используется для обеспечения взаимодействия между MSC и HLR. MSC может послать указание (сообщение) HLR в конце сеанса связи для того, чтобы абонент мог оплатить разговор. Когда сеть фиксированной телефонной связи не способна исполнить процедуру установления вызова подвижного абонента, MSC может запросить HLR с целью определения местоположения абонента для того, чтобы послать вызов MS.

Интерфейс между HLR и VLR (D-интерфейс) используется для расширения обмена данными о положении подвижной станции, управления процессом связи. Основные услуги, предоставляемые подвижному абоненту, заключаются в возможности передавать или принимать сообщения независимо от местоположения. Для этого HLR должен пополнять свои данные. VLR сообщает HLR о положении MS, управляя ею и переприсваивая ей номера в процессе блуждания, посылает все необходимые данные для обеспечения обслуживания подвижной станции.

Интерфейс между MSC (Е-интерфейс) обеспечивает взаимодействие между разными MSC при осуществлении процедуры HANDOVER - "передачи" абонента из зоны в зону при его движении в процессе сеанса связи без ее перерыва.

Интерфейс между BSC и BTS(A-bis интерфейс) служит для связи BSC с BTS и определен Рекомендациями ETSI/GSM для процессов установления соединений и управления оборудованием, передача осуществляется цифровыми потоками со скоростью 2,048 Мбит/с. Возможно использование физического интерфейса 64 кбит/с.

Интерфейс между BSC и ОМС (О-интерфейс) предназначен для связи BSC с ОМС, используется в сетях с пакетной коммутацией МККТТ Х.25.

Внутренний BSC-интерфейс контроллера базовой станции обеспечивает связь между различным оборудованием BSC и оборудованием транскодирования (ТСЕ); использует стандарт ИКМ-пе-редачи 2,048 Мбит/с и позволяет организовать из четырех каналов со скоростью 16 кбит/с один канал на скорости 64 кбит/с.

Интерфейс между MS и BTS (Um-радиоинтерфейс) определен в сериях 04 и 05 Рекомендаций ETSI/GSM.

Сетевой интерфейс между ОМС и сетью, так называемый управляющий интерфейс между ОМС и элементами сети, определен ETSI/GSM Рекомендациями 12.01 и является аналогом интерфейса Q.3, который определен в многоуровневой модели открытых сетей ISO OSI.

Соединение сети с ОМС могут обеспечиваться системой сигнализации МККТТ SS N7 или сетевым протоколом Х.25. Сеть Х.25 может соединяться с объединенными сетями или с PSDN в открытом или замкнутом режимах.

GSM - протокол управления сетью и обслуживанием также должен удовлетворять требованиям Q.3 интерфейса, который определен в ETSI/GSM Рекомендациях 12.01.

Интерфейсы между сетью GSM и внешним оборудованием

Интерфейс между MSC и сервис-центром (SC) необходим для реализации службы коротких сообщений. Он определен в ETSI/GSM Рекомендациях 03.40.

Интерфейс к другим ОМС. Каждый центр управления и обслуживания сети должен соединяться с другими ОМС, управляющими сетями в других регионах или другими сетями. Эти соединения обеспечиваются Х-интерфейсами в соответствии с Рекомендациями МККТТ М.ЗО. Для взаимодействия ОМС с сетями высших уровней используется О.З-интерфейс.

1.4. Структура служб и передача данных в стандарте GSM

Стандарт GSM содержит два класса служб: основные службы и телеслужбы. Основные службы обеспечивают: передачу данных (асинхронно) в дуплексном режиме со скоростями 300, 600, 1200, 2400, 4800 и 9600 бит/с через телефонные сети общего пользования; передачу данных (синхронно) в дуплексном режиме со скоростями 1200, 2400, 4800 и 9600 бит/с через телефонные сети общего пользования, коммутируемые сети передачи данных общего пользования (CSPDN) и ISDN; доступ с помощью адаптера к пакетной асинхронной передаче данных со стандартными скоростями 300-9600 бит/с через коммутируемые сети пакетной передачи данных общего пользования (PSPDN), например, Datex-P; синхронный дуплексный доступ к сети пакетной передачи данных со стандартными скоростями 2400-9600 бит/с [1.1, 1.2].

При передаче данных со скоростью 9,6 кбит/с всегда используется канал связи с полной скоростью передачи. В случае передачи на скоростях ниже 9,6 кбит/с могут использоваться полускоростные каналы связи.

Перечисленные функции каналов передачи данных предусмотрены для терминального оборудования, в котором используются интерфейсы МККТТ со спецификациями V.24 или Х.21 серий. Эти спецификации определяют вопросы передачи данных по обычным каналам телефонной связи. Телеслужбы предоставляют следующие услуги:

1) телефонная связь (совмещается со службой сигнализации: охрана квартир, сигналы бедствия и пр.);

2) передача коротких сообщений;

3) доступ к службам "Видеотекс", "Телетекс";

4) служба "Телефакс" (группа 3).

Дополнительно стандартизован широкий спектр особых услуг (передача вызова, оповещения о тарифных расходах, включение в закрытую группу пользователей).

Так как ожидается, что большинство абонентов будет использовать услуги GSM в деловых целях, особое внимание уделяется аспектам безопасности и качеству предоставляемых услуг.

Структурная схема служб связи в GSM PLMN показана на рис. 1.4 (GSM PLMN - GSM Public Land Mobile Network - сеть связи с наземными подвижными объектами; ТЕ (Terminal Equipment) -терминальное оборудование, МТ (Mobile Terminal) - подвижный терминал, IWF (Interworking Function) - межсетевой функциональный стык). К передаче данных относится и новый вид службы, используемый в GSM, - передача коротких сообщений (передача служебных буквенно-цифровых сообщений для отдельных групп пользователей).

1-4.jpg (29809 bytes) 1-5.jpg (49362 bytes)

При передаче коротких сообщений используется пропускная способность каналов сигнализации. Сообщения могут передаваться и приниматься подвижной станцией. Для передачи коротких сообщений могут использоваться общие каналы управления. Объем сообщений ограничен 160-ю символами, которые могут приниматься в течение текущего вызова либо в нерабочем цикле. В

управление радиоканалами, защиту от ошибок в радиоканале, кодирование-декодирование речи, текущий контроль и распределение данных пользователя и вызовов, адаптацию по скорости передачи между радиоканалом и данными, обеспечение параллельной работы нагрузок (терминалов), обеспечение непрерывной работы в процессе движения.

Используется три типа оконечного оборудования подвижной станции: МТО (Mobile Termination 0) - многофункциональная подвижная станция, в состав которой входит терминал данных с возможностью передачи и приема данных и речи: МТ1 (Mobile Termination 1) - подвижная станция с возможностью связи через терминал с ISDN; МТ2 (Mobile Termination 2) - подвижная станция с возможностью подключения терминала для связи по протоколу МККТТ V или Х серий.

Терминальное оборудование может состоять из оборудования одного или нескольких типов, такого как телефонная трубка с номеронабирателем, аппаратуры передачи данных (DTE), телекс и т.д.

Различают следующие типы терминалов: ТЕ1 (Terminal Equipment 1) - терминальное оборудование, обеспечивающее связь с ISDN; ТЕ2 (Terminal Equipment 2) - терминальное оборудование, обеспечивающее связь с любым оборудованием через протоколы МККТТ V или Х серий (связь с ISDN не обеспечивает). Терминал ТЕ2 может быть подключен как нагрузка к МТ1 (подвижной станции с возможностью связи с ISDN) через адаптер ТА.

Система характеристик стандарта GSM, принятая функциональная схема сетей связи и совокупность интерфейсов обеспечивают высокие параметры передачи сообщений, совместимость с существующими и перспективными информационными сетями, предоставляют абонентам широкий спектр услуг цифровой связи.

1.6. Структура ТDМА кадров и формирование сигналов в стандарте GSM

В результате анализа различных вариантов построения цифровых сотовых систем подвижной связи (ССПС) в стандарте GSM принят многостанционный доступ с временным разделением каналов (TDMA). Общая структура временных кадров показана на рис. 1.6 [1.4]. Длина периода последовательности в этой структуре, которая называется гиперкадром, равна Тг = 3 ч 28 мин 53 с 760 мс (12533,76 с). Гиперкадр делится на 2048 суперкадров, каждый из которых имеет длительность Те = 12533,76/2048 = 6,12 с.

1-6.jpg (155718 bytes)

Суперкадр состоит из мультикадров. Для организации различных каналов связи и управления в стандарте GSM используются два вида мультикадров:

1) 26-позиционные TDMA кадры мультикадра;

2) 51-позиционные TDMA кадры мультикадра.

Суперкадр может содержать в себе 51 мультикадр первого типа или 26 миультикадров второго типа. Длительности мультикадров соответственно:

1) Тм= 6120/51 = 120 мс;

2) Тм = 6120/26 = 235,385 мс (3060/13 мс). Длительность каждого TDMA кадра

Тк = 120/26 = 235,385/51 = 4,615 мс (60/13 мс).

В периоде последовательности каждый TDMA кадр имеет свой порядковый номер (NF) от О до NFmax, где NFmax = (26х51х2048) -1 = 2715647.

Таким образом, гиперкадр состоит из 2715647 TDMA кадров. Необходимость такого большого периода гиперкадра объясняется требованиями применяемого процесса криптографической защиты, в котором номер кадра NF используется как входной параметр. TDMA кадр делится на восемь временных позиций с периодом

То = 60/13:8 = 576,9 мкс (15/26 мс)

Каждая временная позиция обозначается TN с номером от 0 до 7. Физический смысл временных позиций, которые иначе называются окнами, - время, в течение которого осуществляется модуляция несущей цифровым информационным потоком, соответствующим речевому сообщению или данным.

Цифровой информационный поток представляет собой последовательность пакетов, размещаемых в этих временных интервалах (окнах). Пакеты формируются немного короче, чем интервалы, их длительность составляет 0,546 мс, что необходимо для приема сообщения при наличии временной дисперсии в канале распространения.

Информационное сообщение передается по радиоканалу со скоростью 270,833 кбит/с.

Это означает, что временной интервал TDMA кадра содержит 156,25 бит.

Длительность одного информационного бита 576,9 мкс/156,25 = 3,69 мкс.

Каждый временной интервал, соответствующий длительности бита, обозначается BN с номером от 0 до 155; последнему интервалу длительностью 1/4 бита присвоен номер 156.

Для передачи информации по каналам связи и управления, подстройки несущих частот, обеспечения временной синхронизации и доступа к каналу связи в структуре TDMA кадра используются пять видов временных интервалов (окон):

NB используется для передачи информации по каналам связи и управления, за исключением канала доступа RACH. Он состоит из 114 бит зашифрованного сообщения и включает защитный интервал (GP) в 8,25 бит длительностью 30,46 мкс. Информационный блок 114 бит разбит на два самостоятельных блока по 57 бит, разделенных между собой обучающей последовательностью в 26 бит, которая используется для установки эквалайзера в приемнике в соответствии с характеристиками канала связи в данный момент времени.

В состав NB включены два контрольных бита (Steeling Flag), которые служат признаком того, содержит ли передаваемая группа речевую информацию или информацию сигнализации. В последнем случае информационный канал (Traffic Channel) "украден" для обеспечения сигнализации.

Между двумя группами зашифрованных бит в составе NB находится обучающая последовательность из 26 бит, известная в приемнике. С помощью этой последовательности обеспечивается:

- оценка частоты появления ошибок в двоичных разрядах по результатам сравнения принятой и эталонной последовательностей. В процессе сравнения вычисляется параметр RXQUAL, принятый для оценки качества связи. Конечно, речь идет только об оценке связи, а не о точных измерениях, так как проверяется только часть передаваемой информации. Параметр RXQUAL используется при вхождении в связь, при выполнении процедуры "эстафетной передачи" (Handover) и при оценке зоны покрытия радиосвязью;

- оценка импульсной характеристики радиоканала на интервале передачи NB для последующей коррекции тракта приема сигнала за счет использования адаптивного эквалайзера в тракте приема;

-определение задержек распространения сигнала между базовой и подвижной станциями для оценки дальности связи. Эта информация необходима для того, чтобы пакеты данных от разных подвижных станций не накладывались при приеме на базовой станции. Поэтому удаленные на большее расстояние подвижные станции должны передавать свои пакеты раньше станций, находящихся в непосредственной близости от базовой станции. FB предназначен для синхронизации по частоте подвижной станции. Все 142 бита в этом време.нном интервале - нулевые, что соответствует немодулированной несущей со сдвигом 1625/24 кГц выше номинального значения частоты несущей. Это необходимо для проверки работы

своего передатчика и приемника при небольшом частотном разносе каналов (200 кГц), что составляет около 0,022% от номинального значения полосы частот 900 МГц. FB содержит защитный интервал 8,25 бит так же, как и нормальный временной интервал. Повторяющиеся временные интервалы подстройки частоты (FB) образуют канал установки частоты (FCCH).

SB используется для синхронизации по времени базовой и подвижной станций. Он состоит из синхропоследовательности длительностью 64 бита, несет информацию о номере ТОМА кадра и идентификационный код базовой станции. Этот интервал передается вместе с интервалом установки частоты. Повторяющиеся интервалы синхронизации образуют так называемый канал синхронизации (SCH).

DB обеспечивает установление и тестирование канала связи. По своей структуре DB совпадает с NB (рис. 1.6) и содержит установочную последовательность длиной 26 бит. В DB отсутствуют контрольные биты и не передается никакой информации. DB лишь информирует о том, что передатчик функционирует.

АВ обеспечивает разрешение доступа подвижной станции к новой базовой станции. АВ передается подвижной станцией при запросе канала сигнализации. Это первый передаваемый подвижной станцией пакет, следовательно, время прохождения сигнала еще не измерено. Поэтому пакет имеет специфическую структуру. Сначала передается концевая комбинация 8 бит, затем - последовательность синхронизации для базовой станции (41 бит), что позволяет базовой станции обеспечить правильный прием последующих 36 зашифрованных бит. Интервал содержит большой защитный интервал (68,25 бит, длительностью 252 мкс), что обеспечивает (независимо от времени прохождения сигнала) достаточное временное разнесение от пакетов других подвижных станций,

Этот защитный интервал соответствует двойному значению наибольшей возможной задержки сигнала в рамках одной соты и тем самым устанавливает максимально допустимые размеры соты. Особенность стандарта GSM - возможность обеспечения связью подвижных абонентов в сотах с радиусом около 35 км. Время распространения радиосигнала в прямом и обратном направлениях составляет при этом 233,3 мкс.

В структуре GSM строго определены временные характеристики огибающей сигнала, излучаемого пакетами на канальном временном интервале TDMA кадра, и спектральная характеристика сигнала. Временная маска огибающей для сигналов, излучаемых на интервале АВ полного TDMA кадра, показана на рис. 1.7, а маска огибающей для сигналов NB, FB, DB и SB полного TDMA кадра - на рис. 1.8. Различные формы огибающих излучаемых сигналов соответствуют разным длительностям интервала АВ (88 бит) по отношению к другим указанным интервалам полного TDMA кадра (148 бит). Нормы на спектральную характеристику излучаемого сигнала показаны на рис. 1.9.

1-7-8.jpg (71255 bytes)

Одна из особенностей формирования сигналов в стандарте GSM - использование медленных скачков по частоте в процессе сеанса связи. Главное назначение таких скачков (SFH - Slow Frequency Hopping) - обеспечение частотного разнесения в радиоканалах, функционирующих в условиях многолучевого распространения радиоволн. SFH используется во всех подвижных сетях, что повышает эффективность кодирования и перемежения при медленном движении абонентских станций. Принцип формирования медленных скачков по частоте состоит в том, что сообщение, передаваемое в выделенном абоненту временном интервале TDMA кадра (577 мкс), в каждом последующем кадре передается (принимается) на новой фиксированной частоте. В соответствии со структурой кадров время для перестройки частоты составляет около 1 мс.

В процессе скачков по частоте постоянно сохраняется дуплексный разнос 45 МГц между каналами приема и передачи. Всем активным абонентам, находящимся в одной соте, ставятся в соответствие ортогональные формирующие последовательности, что исключает взаимные помехи при приеме сообщений абонентами в соте. Параметры последовательности переключения частот (частотно-временная матрица и начальная частота) назначаются каждой подвижной станции в процессе установления канала. Ортогональность последовательностей переключения частот в соте обеспечивается начальным частотным сдвигом одной и той же (по алгоритму формирования) последовательности. В смежных сотах используются различные формирующие последовательности.

Комбинированная TDMA/FDMA схема организации каналов в стандарте GSM и принцип использования медленных скачков по частоте при передаче сообщений во временных кадрах показаны на рис. 1.10,1.11.

1-9-10.jpg (51101 bytes)

1-11.jpg (29377 bytes)

Для сравнения можно отметить, что по результатам экспериментальных исследований, проведенных на действующих сетях GSM, пространственное разнесение приемных антенн на базовой станции дает выигрыш 3-4 дБ.

Принятая структура ТDМА кадров и принципы формирования сигналов в стандарте GSM в совокупности с методами капельного кодирования позволили снизить требуемое для приема отношение сигнал/помеха до 9 дБ, тогда как в стандартах аналоговых сотовых сетей связи оно составляет 17-18 дБ.

Литература к Главе 1

1.1 M.Mouly, M.B.Pautet. The GSM System for Mobile Communications. 1992. p.p. 702.

1.2 Ю.А. Громаков. Сотовые системы подвижной радиосвязи. Технологии электронныхкоммуникаций. Том 48. "Эко-Трендз". Москва. 1994.

1.3 A. Mehrotra. Cellular Radio: Analog and Digital Systems. Artech House, Boston-London. 1994. p.p. 460.

1.4 Ю.А. Громаков. Структура TDMA кадров и формирование сигналов в стандарте GSM. "Электросвязь". N 10. 1993. с. 9-12.

1.5 W. Heger. GSM vs. CDMA. GSM Global System for Mobile Communications. Proceedings of the GSM Promotion Seminar 1994 GSM MoU Group in Cooperation with ETSI GSM Members. 15 December 1994. p.p. 3.1-1 - 3.1-18.

сборка специально для http://www.natahaus.ru/


Глава 2.

Глава 2. ОРГАНИЗАЦИЯ ФИЗИЧЕСКИХ И ЛОГИЧЕСКИХ КАНАЛОВ В СТАНДАРТЕ GSM

2.1. Частотный план стандарта GSM

Стандарт GSM разработан для создания сотовых систем подвижной связи (ССПС) в следующих полосах частот: 890-915 МГц - для передачи подвижными станциями (линия "вверх"); 935-960 МГц - для передачи базовыми станциями (линия "вниз") [2.1].

Сети GSM функционируют параллельно с существующими европейскими национальными сетями аналоговых ССПС стандартов NMT-900, TAGS, ETACS. Частотные планы ССПС, включая стандарт GSM, показаны на рис. 2.1.

рис. 2.1

Каждая из полос, выделенных для сетей GSM, разделяется на частотные каналы. Разнос каналов составляет 200 кГц, что позволяет организовать в сетях GSM 124 частотных канала. Частоты, выделенные для передачи сообщений подвижной станцией на базовую и в обратном направлении, группируются парами, организуя дуплексный канал с разносом 45 МГц. Эти пары частот сохраняются и при перескоках частоты. Каждая сота характеризуется фиксированным присвоением определенного количества пар частот.

Если обозначить FI (п) - номер несущей частоты в полосе 890-915 МГц, Fu (п) - номер несущей частоты в полосе 935-960 МГц, то частоты каналов определяются по следующим формулам:

FI (п) = 890,2 + 0,2 (п-1), МГц: Fu (п) = FI (п) + 45, МГц; 1 < п < 124.

В таблице 2.1 приведены номиналы частот каналов для приема (RX) и передачи (ТХ) базовыми станциями и соответствующие им номера каналов.

Каждая частотная несущая содержит 8 физических каналов, размещенных в 8 временных окнах в пределах TDMA кадра и в последовательности кадров. Каждый физический канал использует одно и то же временное окно в каждом временном TDMA кадре.

До формирования физического канала сообщения и данные, представленные в цифровой форме, группируются и объединяются в логические каналы двух типов: каналы связи - для передачи кодированной речи или данных (ТСН); каналы управления - для передачи сигналов управления и синхронизации (ССН).

Более чем один тип логического канала может быть размещен на одном и том же физическом канале, но только при их соответствующей комбинации.

2.2. Структура логических каналов связи

В стандарте GSM различают логические каналы связи двух основных видов: TCH/F (Full Rate Traffic Channel) - канал передачи сообщений с полной скоростью

22,8 кбит/с (другое обозначение Вт);

TCH/H (Half Rate Traffic Channel) - канал передачи сообщений с половинной скоростью

11,4 кбит/с (другое обозначение Lm).

Один физический канал может представлять собой канал передачи сообщений с полной скоростью или два канала с половинной скоростью передачи. В первом случае канал связи занимает одно временное окно; во втором - два канала связи занимают то же самое временное окно, но с перемежением в соседних кадрах (т.е. каждый канал - через кадр).

Таблица 2.1

Channel |  | RX Frequency | TX Frequency | Channel |  | RX Frequency | TX Frequency
Decimal Hexadecimal |  | MHz | MHz | Decimal | Hexadecimal | MHz | MHz
1 | 01 | 890.20 | 935.20 | 63 | 3F | 902.60 | 947.60
2 | 02 | 890.40 | 935.40 | 64 | 40 | 902.80 | 947.80
3 | 03 | 890.60 | 935.60 | 65 | 41 | 903.00 | 948.00
4 | 04 | 890.80 | 935.80 | 66 | 42 | 903.20 | 948.20
5 | 05 | 891.00 | 936.00 | 67 | 43 | 903.40 | 948.40
6 | 06 | 891.20 | 936.20 | 68 | 44 | 903.60 | 948.60
7 | 07 | 891.40 | 936.40 | 69 | 45 | 903.80 | 948.80
8 | 08 | 891.60 | 936.60 | 70 | 46 | 904,00 | 949.00
9 | 09 | 891.80 | 936.80 | 71 | 47 | 904.20 | 949.20
10 | OA | 892.00 | 937.00 | 72 | 48 | 904.40 | 949.40
11 | 0В | 892.20 | 937.20 | 73 | 49 | 904.60 | 949.60
12 | ОС | 892.40 | 937.40 | 74 | 4A | 904.80 | 949.80
13 | OD | 892.60 | 937.60 | 75 | 4В | 905.00 | 950.00
14 | OE | 892.80 | 937.80 | 76 | 4C | 905.20 | 950.20
15 | OF | 893.00 | 938.00 | 77 | 4D | 905.40 | 950.40
16 | 10 | 893.20 | 938.20 | 78 | 4E | 905.60 | 950.60
17 | 11 | 893.40 | 938.40 | 79 | 4F | 905.80 | 950.80
18 | 12 | 893.60 | 938.60 | 80 | 50 | 906.00 | 951.00
19 | 13 | 893.80 | 938.80 | 81 | 51 | 906.20 | 951.20
20 | 14 | 894.00 | 939.00 | 82 | 52 | 906.40 | 951.40
21 | 15 | 894.20 | 939.20 | 83 | 53 | 906.60 | 951.60
22 | 16 | 894.40 | 939.40 | 84 | 54 | 906.80 | 951.80
23 | 17 | 894.60 | 939.60 | 85 | 55 | 907.00 | 952.00
24 | 18 | 894.80 | 939.80 | 86 | 56 | 907.20 | 952.20
25 | 19 | 895.00 | 940.00 | 87 | 57 | 907.40 | 952.40
26 | 1A | 895.20 | 940.20 | 88 | 58 | 907.60 | 952.60
27 | 1В | 895.40 | 940.40 | 89 | 59 | 907.80 | 952.80
28 | 1C | 895.60 | 940.60 | 90 | 5A | 908.00 | 953.00
29 | ID | 895.80 | 940.80 | 91 | 5В | 908.20 | 953.20
30 | IE | 896.00 | 941.00 | 92 | 5C | 908.40 | 953.40
31 . | IF | 896.20 | 941.20 | 93 | 5D | 908.60 | 953.60
32 | 20 | 896.40 | 941.40 | 94 | 5E | 908.80 | 953.80
33 | 21 | 896.60 | 941.60 | 95 | 5F | 909.00 | 954.00
34 | 22 | 896.80 | 941.80 | 96 | 60 | 909.20 | 954.20
35 | 23 | 897.00 | 942.00 | 97 | 61 | 909.40 | 954.40
36 | 24 | 897.20 | 942.20 | 98 | 62 | 909.60 | 954.60
37 | 25 | 897.40 | 942.40 | 99 | 63 | 909.80 | 954.80
38 | 26 | 897.60 | 942.60 | 100 | 64 | 910.00 | 955.00
39 | 27 | 897.80 | 942.80 | 101 | 65 | 910.20 | 955.20
40 | 28 | 898.00 | 943.00 | 102 | 66 | 910.40 | 955.40
41 | 29 | 898.20 | 943.20 | 103 | 67 | 910.60 | 955.60
42 | 2A | 898.40 | 943.40 | 104 | 68 | 910.80 | 955.80
43 | 2В | 898.60 | 943.60 | 105 | 69 | 911.00 | 956.00
44 | 2C | 898.80 | 943.80 | 106 | 6A | 911.20 | 956.20
45 | 2D | 899.00 | 944.00 | 107 | 6В | 911.40 | 956.40
46 | 2E | 899.20 | 944.20 | 108 | 6C | 911.60 | 956.60
47 | 2F | 899.40 | 944.40 | 109 | 6D | 911.80 | 956.80
48 | 30 | 899.60 | 944.60 | 110 | 6E | 912.00 | 957.00
49 | 31 | 899.80 | 944.80 | 111 | 6F | 912.20 | 957.20
50 | 32 | 900.00 | 945.00 | 112 | 70 | 912.40 | 957.40
51 | 33 | 900.20 | 945.20 | 113 | 71 | 912.60 | 957.60
52 | 34 | 900.40 | 945.40 | 114 | 72 | 912.80 | 957.80
53 | 35 | 900.60 | 945.60 | 115 | 73 | 913.00 | 958.00
54 | 36 | 900.80 | 945.80 | 116 | 74 | 913,20 | 958.20
55 | 37 | 901.00 | 946.00 | 117 | 75 | 913.40 | 958.40
56 | 38 | 901.20 | 946.20 | 118 | 76 | 913.60 | 958.60
57 | 39 | 901.40 | 946.40 | 119 | 77 | 913.80 | 958.80
58 | ЗА | 901.60 | 946.60 | 120 | 78 | 914.00 | 959.00
59 | 3В | 901.80 | 946.80 | 121 | 79 | 914.20 | 959.20
60 | ЗС | 902.00 | 947.00 | 122 | 7A | 914.40 | 959.40
61 | 3D | 902.20 | 947.20 | 123 | 7В | 914.60 | 959.60
62 | ЗЕ | 902.40 | 947.40 | 124 | 7C | 914.80 | 959.80

Для передачи кодированной речи и данных предназначены каналы связи следующих типов: TCH/FS (Full Rate Traffic Channel for Speech)

- канал для передачи речи с полной скоростью; TCH/HS (Half Rate Traffic Channel for Speech)

- канал для передачи речи с половинной скоростью; TCH/F 9,6 (Full Rate Traffic Channel for 9,6 kbit/s User Data)

- канал передачи данных с полной скоростью 9,6 кбит/с: TCH/F 4,8 (Full Rate Traffic Channel for 4,8 kbit/s User Data)

- канал передачи данных с полной скоростью 4,8 кбит/с; TCH/F 2,4 (Full Rate Traffic Channel for 2,4 kbit/s User Data)

- канал передачи данных с полной скоростью 2,4 кбит/с; ТСН/Н 4,8 (Half Rate Traffic Channel for 9,6 kbit/s User Data)

- канал передачи данных с половинной скоростью 4,8 кбит/с; СН/Н 2,4 (Half Rate Traffic Channel for 9,6 kbit/s User Data) - канал передачи данных с половинной скоростью 2,4 кбит/с.

Скорость передачи цифрового речевого сигнала в канале TCH/FS равна 13 кбит/с (за счет кодирования увеличивается до 22,8 кбит/с в канале TCH/F). Передача речи в канале с половинной скоростью TCH/HS еще не используется. Этот канал рассматривается как перспективный при дальнейшем развитии GSM, его применение позволит практически удвоить емкость трафика. Внедрение низкоскоростного речевого кодека стандарта GSM ожидается к 1997 году.

Каналы связи могут передавать широкий набор информационных сообщений, но они не используются для передачи сигналов управления. Кроме того, для передачи данных по каналам связи могут использоваться разные протоколы, например, МККТТ Х.25.

2.3. Структура логических каналов управления

Каналы управления (ССН) обеспечивают передачу сигналов управления и синхронизации. Различают четыре вида каналов управления:

ВССН (Broadcast Control Channels) - каналы передачи сигналов управления; СССН (Common Control Channels) - общие каналы управления; SDCCH ( Stand-alone Dedicated Control Channels) - индивидуальные каналы управления; АССН (Associated Control Channels) - совмещенные каналы управления. Каналы передачи сигналов управления используются только в направлении с базовой станции на все подвижные станции. Они несут информацию, которая необходима подвижным станциям для работы в системе. Различают три вида каналов передачи сигналов управления ВССН:

FCCH (Frequency Correction Channel) - канал подстройки частоты, который используется для синхронизации несущей в подвижной станции. По этому каналу передается немодулированная несущая с фиксированным частотным сдвигом относительно номинального значения частоты канала связи;

SCH (Synchronization Channel) - канал синхронизации, по которому передается информация на подвижную станцию о кадровой (временной) синхронизации:

ВССН (Broadcast Control Channel) - канал управления передачей, обеспечивает передачу основных команд по управлению передачей (номер общих каналов управления тех из них, которые объединяются с другими каналами, в том числе и с физическими и т.д.).

Используются три типа общих каналов управления СССН:

РСН (Paging Channel) - канал вызова, используется только в направлении от базовой станции к подвижной для ее вызова:

RACH (Random Access Channel) - канал параллельного доступа, используется только в направлении от подвижной станции к базовой для запроса о назначении индивидуального канала управления;

AGCH (Access Grant Channel) - канал разрешенного доступа, используется только для передачи с базовой станции на подвижную (для выделения специального канала управления, обеспечивающего прямой доступ к каналу связи).

Выделенные индивидуальные каналы управления используются в двух направлениях для связи между базовой и подвижной станциями. Различают два вида таких каналов: SDCCH/4 (Stand-alone Dedicated Control Channel)

- индивидуальный канал управления, состоит из четырех подканалов; SDCCH/8 (Stand-alone Dedicated Control Channel) - индивидуальный канал управления, состоит из восьми подканалов.

Эти каналы предназначены для установки требуемого пользователем вида обслуживания. По ним обеспечивается запрос подвижной станции о требуемом виде обслуживания, контроль правильного ответа базовой станции и выделение свободного канала связи, если это возможно.

Совмещенные каналы управления также используются в двух направлениях между базовой и подвижной станциями. По направлению "вниз" они передают команду управления с базовой станции, а по направлению "вверх" - информацию о статусе подвижной станции. Различают два вида АССН:

FACCH (Fast Associated Control Channel) - быстрый совмещенный канал управления, служит для передачи команд при переходе подвижной станции из соты в соту, т.е. при "эстафетной передаче" подвижной станции;

SACCH (Slow Assocaited Control Channel) - медленный совмещенный канал управления, по направлению "вниз" передает команды для установки выходного уровня мощности передатчика подвижной станции. По направлению "вверх" подвижная станция посылает данные, касающиеся уровня установленной выходной мощности, измеренного приемником уровня радиосигнала и его качества.

В совмещенном канале управления всегда содержится один из двух каналов: канал связи или индивидуальный канал управления.

Совмещенные каналы управления всегда объединяются вместе с каналами связи или с индивидуальными каналами управления. При этом различают шесть видов объединенных каналов управления:

FACCH/F, объединенный с TCH/F; FACCH/H, объединенный с ТСН/Н; SACCH/TF, объединенный с TCH/F; SACCH/TH, объединенный с ТСН/Н; SACCH/C4, объединенный с SDCCH/4; SACCH/C8, объединенный с SDCCH/8. Состав и назначение логических каналов показаны на рис. 2.2.

рис. 2.2

2.4. Организация физических каналов

Для передачи каналов связи ТСН и совмещенных каналов управления FACCH и SACCH используется 26-кадровый мультикадр. Объединение каналов связи с полной и половинной скоростью с медленным совмещенным каналов управления SACCH показано на рис. 2.3. В полноскоростном канале связи в каждом 13-м TDMA кадре мультикадра передается пакет информации канала SACCH; каждый 26-й TDMA кадр мультикадра свободен. В полускоростном канале связи пакет информации канала SACCH передается в каждом 13-м и 26-м TDMA кадрах мультикадра.

рис. 2.3

Для одного физического канала в каждом TDMA кадре используется 114 бит. Так как в муль-тикадре для передачи канала связи ТСН используется 24 TDMA кадра из 26 и длительность мультикадра составляет 120 мс, общая скорость передачи информационных сообщений по ТСН каналу составляет 22,8 кбит/с. Канал SACCH занимает в полноскоростном канале связи только один TDMA кадр, то есть 114 бит, когда скорость передачи по SACCH каналу составит 950 бит/с. Полная скорость передачи в объединенном TCH/SACCH канале с учетом пустого (свободного) 26-го TDMA кадра составит 22,8 + 0,950 +0,950 - 24,7 кбит/с.

Как показано на рис. 2.3 б), за время 26-кадрового мультикадра (в одном физическом канале) может передаваться два полускоростных ТСН канала, каждый по 12 TDMA кадров (Т и t). Пустой 26-й TDMA кадр в полноскоростном канале ТСН отводится для канала SACCH во втором полускоростном канале ТСН. Для каждого полускоростного канала ТСН скорость передачи составляет 11,4 кбит/с; полная скорость передачи в объединенном полускоростном канале TCH/SACCH остается прежней - 24,7 кбит/с.

Быстрый совмещенный канал управления FACCH передается половиной информационных бит временного интервала TDMA кадра в канале ТСН, с которым он совмещается в восьми последовательных Т или t кадрах.

Для передачи каналов управления (за исключением FACCH и SACCH) используется 51-кадровый мультикадр. Организация каналов управления в 51-кадровом мультикадре иллюстрируется рис. 2.4.

рис. 2.4

Объединение ВССН/СССН каналов

В отличие от структуры объединенного канала TCH/SACCH, где физический канал выделяется для одного или двух абонентов, объединенный канал ВССН/СССН предназначен для всех подвижных станций, которые в одно и то же время находятся в одной соте. Более того, все подканалы, передаваемые в этой структуре, являются симплексными.

В канале передачи сигналов управления (ВССН, "сеть - подвижная станция") передается общая информация о сети (соте), в которой подвижная станция находится в данный момент, и о смежных сотах.

В канале синхронизации (SCH, "сеть - подвижная станция") передается информация о временной (цикловой) синхронизации и опознавании приемопередатчика базовой станции.

В канале подстройки частоты (FCCH, "сеть - подвижная станция") передается информация для синхронизации несущей.

Канал параллельного доступа (RACH, "подвижная станция - сеть") используется подвижной станцией в режиме пакетной передачи ALOHA для доступа к сети в случае, если надо пройти регистрацию при включении или сделать вызов.

Канал разрешенного доступа (AGCH, "сеть - подвижная станция") используется для занятия специальных видов обслуживания (SDCCH или ТСН) подвижной станцией, которая ранее запрашивала их через канал RACH.

Канал вызова (РСН, "сеть - подвижная станция") используется для вызова подвижной станции в случае, когда инициатором вызова является сеть (абонент сети).

На рис. 2.4 а, б показано отображение рассматриваемых каналов на одном физическом канале в структуре 51-кадрового мультикадра.

Линия "вверх" ВССН/СССН каналов используется только для передачи канала параллельного доступа RACH, который является единственным каналом управления от подвижной станции к сети. Подвижная станция может использовать нулевой временной интервал в любом из кадров для осуществления доступа к сети.

На линии "вниз" 51 кадр группируется в 5 групп по 10 кадров, при этом один кадр остается свободным, каждая из этих групп начинается с канала FCCH, за которым следует канал SCH. Остальные 8 кадров в каждой группе образуют два блока из четырех кадров. Первый блок первой группы предназначен для канала ССН, тогда как другие 9 блоков (они называются блоками передачи сигнала вызова) используются для передачи каналов РСН и AGCH общего канала управления СССН. Таким образом, в рассматриваемом случае: 4 кадра используются для канала ВССН, 5 - для FCCH, 5 - для SCH и 36 либо для AGCH, либо для РСН (9 блоков вызова).

Каждая подвижная станция может занимать один из девяти блоков вызова, но каждый вызывной блок может использоваться для вызова более одной станции.

Полная скорость передачи для канала ВССН, а также для канала AGCH/PCH составляет 1,94 кбит/с (4х114 бит за 235 мс).

Существуют и другие переменные структуры, которые могут использоваться в 51-кадровом мультикадре. "Переменными" их называют потому, что их структура изменяется в зависимости от нагрузки в соте. В одном случае может рассматриваться индивидуальный канал управления 8SDCCH/8 в одном физическом канале (рис. 2.4 в, г). Однако, если нагрузка в соте мала, структу-y BCCH/CCCH можно объединить с индиаидуальным каналом управления SDCCH/4 (рис. 2.4 д, е) в одном физическом канале. Если сота испытывает большую нагрузку, одного физического канала может быть недостаточно для всего трафика BCCH/CCCH. В этом случае временные интервалы 2, 4 и 6 б структуре ВССН также используют для этой цели, однако в этом случае передаются пустые интервалы вместо SCH и FCCH.

Отображение логических каналов на физические каналы осуществляется через процессы кодирования и шифрования передаваемых сообщений.

Для защиты логических каналов от ошибок, которые имеют место в процессе передачи, используют 1ри вида кодирования: блочное - для быстрого обнаружения ошибок при приеме; свер-точное - для исправления одиночных ошибок; перемежение - для преобразования пакетов ошибок в одиночные.

Для защиты каналов от подслушивания в каналах связи и управления применяется шифрование.

Дня передачи сообщений по физическим каналам используется гауссовская частотная манипуляция с минимальным частотным сдвигом (GMSK).

2.5. Модуляция радиосигнала

В стандарте GSM применяется спектрально-эффективная гауссовская частотная манипуляция п минимальным частотным сдвигом (GMSK). Манипуляция называется "гауссовской" потому, что последовательность информационных бит до модулятора проходит через фильтр нижних частот (ФНЧ) с характеристикой Гаусса, что дает значительное уменьшение полосы частот излучаемого радиосигнала [2.2, 2.3]. формирование GMSK радиосигнала осуществляется таким образом, что на интервале одного информационного бита фаза несущей изменяется на 90°. Это наименьшее возможное изменение фазы, распознаваемое при данном типе модуляции. Непрерывное измене ние фазы синусоидального сигнала дает в результате частотную модуляцию с дискпстн^м и^меч^ нием частоты. Применение фильтра Гаусса позволяет при дискрегном изменении частоты получить "гладкие переходы". В стандарте GSM применяется GMSK-модуляция с величиной нормированной полосы ВТ = 0,3, где В - ширина полосы фильтра по уровню минус 3 дБ, Т - длительность одного бита цифрового сообщения. Принципиальная схема модулятора показана на рис. 2.5.

рис. 2.5

рис. 2.6

рис. 2.7

рис. 2.8

Литература к Главе 2

2.1 Ю.А. Громаков. Организация физических и логических каналов в стандарте GSM."Электросвязь". N 10, 1993. с. 9-12.

2.2 М. Mouly, М.В. Pautet. The GSM System for Mobile Communications. 1992. p.p. 702. 2.3 A. Mehrotra. Cellular Radio Performance Engineering. Artech House. 1994. p.p. 536.


Глава 3

рис. 3.1

рис. 3.2

рис.3.3

рис. 3.4

Кодирование осуществляется следующим образом: биты класса 1 разделяются дополнительно на 50 бит класса 1а и 132 бита класса 16 (рис. 3.4а). Биты класса 1а дополняются тремя битами проверки на четкость (рис. 3.4б). Блочный код представляет собой укороченный систематический циклический код (53, 50) с формирующим полиномом вида

д (D)=D3+D+1.

Структурная схема кодирующего устройства показана на рис. 3.5. В соответствии с принятым правилом формирования систематического кода, ключ Sw закрыт на время первых пяти-десяти тактовых импульсов, а информационные биты, поступающие на вход кодирующего устройства, одновременно поступают на блок переупорядочения и формирования бит проверки на четность (рис. 3.2). После пятидесяти тактовых импульсов переключатель Sw срабатывает и биты проверки на четность поступают из кодирующего устройства. Сформированный в результате кадр показан на рис. 3.4. На этой стадии проводится первый шаг перемежения, показанный на рис. 3.4. Биты с четными индексами собираются в первой части информационного слова, за которыми следуют три бита проверки на четность. Затем биты с нечетными индексами запоминаются в буферной памяти и переставляются так, как показано на рис. 3.4в. Далее следуют четыре нулевых бита, которые необходимы для работы кодера, формирующего код, исправляющий случайные ошибки в канале. После чего 189 бит класса 1 кодируются сверточным кодом (2,1,5) со скоростью г=1/2 (рис. 3.2). Структурная схема кодера и его формирующие полиномы приведены на рис. 3.6 [3.2].

рис. 3.5

рис. 3.6

Как показано на рис. 3.4г, после сверточного кодирования общая длина кадра составляет 2х189+78^456 бит. После этого кадр из 456 бит делится на восемь 57 битовых подблоков (рис. 3.4д), которые подвергаются диагональному и внутрикадровому перемежению (рис. 3.3, 3.4). Результаты перемежения показаны на рис. 3.4 ж, з. Более точно подблоки Во и В4 формируются в пакеты по 114 бит, которые являются результатом блочно-диагонального перемежения (DI/B). На рис. 3.4е биты Во и В4 подблоков попарно перемежаются, образуя процесс внутрикадрового битового перемежения (1В1/В). В результирующий пакет (рис. 3.43) включены два опережающих флага hi, h0, которые используются для классификации различных пакетов передачи.

3.3. Кодирование и перемежение в полноскоростном канале передачи данных

Для повышения эффективности применения сверточного кодирования в полноскоростных каналах передачи данных необходим длительный период перемежения. В этих каналах внутрикадро-вое перемежение (1В1/В) реализуется для степени перемежения 1^19, что приводит к задержке передачи данных на 19х116=2204 бит. Если биты 1-го пакета (временного интервала) до перемежения обозначить как С (Кт), т=1 ...116, то схема перемежения, то есть позиции бит после перемежения, определяются следующей формулой:

1 (К + j, j + 19t) = С (К, m) для всех К j = m mod 19, t=m mod 6.

Эта схема перемежения иллюстрируется примером на рис. 3.7 [3.2).

рис. 3.7

3.4. Кодирование и перемежение в каналах управления

На рис. 3.8 показан принцип защиты от ошибок данных, передаваемых по каналам управления. Эта схема используется для всех логических каналов управления, за исключением блоков данных в канале синхронизации (SCH) и данных в канале параллельного доступа (RACH). Радиосистема принимает по линии передачи данных блоки длиной п=184 бита. Сначала они защищаются укороченным двоичным циклическим кодом (Fire код) с формирующим полиномом вида

д (D)=(D^+ 1)“(D^+ D^+ 1)

рис. 3.8

В систематическом виде последовательность кодированных циклическим кодом информационных бит над полем GF (2) отображается полиномом вида U (0) • 0223 + и (1) 0222 + ... U (222) • D+U (223),

где U (0), U (1)...U (183) - информационные биты. U (184), U (185)...U (223) - биты проверки на четность.

В результате сформированный блок из 224 бит (включая 40 бит проверки на четность) дополняется четырьмя концевыми (нулевыми) битами для получения равной защиты для последних бит.

Заметим, что этот же способ уже использовался для формирования временных интервалов TDMA кадра, в котором предусматриваются 3 защитных бита для обеспечения правильного восстановления последних 5 бит в эквалайзере.

Полученная в результате блочного кодирования последовательность подвергается кодированию сверточным кодом со скоростью г=1/2 (идентичен коду в канале TCH/FS), который задается полиномами

GO = 1 + 03+04 G1 = 1+0+02+04

В результате сверточного кодирования формируется блок из 456 кодированных бит {С(0),...С(455)}.

Так же как и в полноскоростном речевом канале (рис. 3.4), полученная кодированная последовательность подвергается упорядочению и разделению на 8 по 57-бит пакетов (ВО...В7). Каждый пакет состоит из блоков. Блок j, обозначаемый

Bj = {b (j,0), b (j,1)...b (i,56)},

формируемых из 456 кодированных бит по правилу

b (j,i) = c(k), определяемому таблицей 3.2.

Продолжение таблицы 3.2

г0 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
 | 168 | 225 | 292 | 339 | 396 | 453 | 54 | 111
25 | 232 | 289 | 346 | 403 | 4 | 61 | 118 | 175
 | 296 | 353 | 410 | 11 | 58 | 125 | 182 | 239
 | 360 | 417 | 18 | 775 | 132 | 189 | 246 | 303
 | 424 | 25 | 82 | 139 | 196 | 253 | 310 | 367
 | 32 | 89 | 146 | 203 | 250 | 317 | 374 | 431
30 | 96 | 153 | 210 | 257 | 324 | 381 | 438 | 39
 | 160 | 217 | 274 | 331 | 388 | 445 | 46 | 103
 | 224 | 281 | 338 | 395 | 452 | 33 | 110 | 157
 | 288 | 345 | 402 | 3 | 60 | 117 | 174 | 231
 | 352 | 409 | 10 | 57 | 124 | 181 | 238 | 295
35 | 416 | 17 | 74 | 131 | 138 | 245 | 302 | 359
 | 24 | 81 | 138 | 195 | 252 | 309 | 366 | 423
 | 88 | 145 | 202 | 259 | 316 | 373 | 430 | 31
 | 152 | 209 | 256 | 323 | 380 | 437 | 38 | 95
 | 216 | 273 | 330 | 387 | 444 | 45 | 102 | 159
40 | 280 | 337 | 394 | 451 | 32 | 109 | 156 | 223
 | 344 | 401 | 2 | 59 | 115 | 173 | 230 | 287
 | 408 | 9 | 56 | 123 | 180 | 237 | 294 | 351
 | 16 | 73 | 130 | 187 | 244 | 301 | 358 | 415
 | 80 | 137 | 194 | 251 | 308 | 365 | 422 | 23
45 | 144 | 201 | 258 | 315 | 372 | 429 | 30 | 87
 | 208 | 255 | 322 | 379 | 436 | 37 | 94 | 131
 | 272 | 329 | 386 | 443 | 44 | 101 | 158 | 215
 | 336 | 393 | 450 | 51 | 108 | 165 | 222 | 279
 | 400 | 1 | 58 | 115 | 172 | 229 | 286 | 343
50 | 8 | 55 | 122 | 179 | 236 | 293 | 350 | 407
 | 72 | 129 | 186 | 243 | 300 | 357 | 414 | 25
 | 136 | 193 | 250 | 307 | 364 | 421 | 22 | 79
 | 200 | 257 | 314 | 371 | 428 | 29 | 86 | 143
 | 254 | 321 | 376 | 435 | 36 | 93 | 150 | 207
55 | 328 | 385 | 442 | 43 | 100 | 157 | 214 | 271
56 | 392 | 449 | 50 | 107 | 164 | 221 | 278 | 235

Блочно-диагональное и внутрикадровое перемежение осуществляются так же, как и в полноскоростном речевом канале (рис. 3.6е).

Полная последовательность выполнения операций кодирования и перемежения для всех каналов связи и управления GSM показана на рис. 3.9. В представленной схеме для каналов управления SACCH, РСН, AGCH, SDCCH используется блочное прямоугольное перемежение/депереме-жение. Алгоритм прямоугольного перемежения иллюстрируется на рис. 3.10. При перемежении кода (n, k, t) с^п-символьных длинных кодированных слов записываются кодирующим устройством в память перемежителя строка за строкой, а затем передаются в модулятор столбец за столбцом. В приемнике после демодулятора деперемежитель обратной операцией восстанавливает первоначальный порядок символов, после чего осуществляется декодирование.

рис. 3.9

На рис. 3.11, 3.12 приведены значения скорости передачи в логических каналах управления и связи, а также задержки в передаче сигналов управления и речи, вызванные процессами кодирования и перемежения.


Глава 4

Глава 4. ОБРАБОТКА РЕЧИ В СТАНДАРТЕ GSM

4.1. Общее описание процессов обработки речи

Процессы обработки речи в стандарте GSM направлены на обеспечение высокого качества передаваемых сообщений, реализацию дополнительных сервисных возможностей и повышение потребительских качеств абонентских терминалов.

Обработка речи осуществляется в рамках принятой системы прерывистой передачи речи. Система прерывистой передачи речи (DTX) обеспечивает включение передатчика только тогда, когда пользователь начинает разговор и отключает его в паузах и в конце разговора. DTX управляется детектором активности речи (VAD), который обеспечивает обнаружение и выделение интервалов передачи речи с шумом и шума без речи даже в тех случаях, когда уровень шума соизмерим с уровнем речи. В состав системы прерывистой передачи речи входит также устройство формирования комфортного шума, который включается и прослушивается в паузах речи, когда передатчик отключен. Экспериментально показано, что отключение фонового шума на выходе приемника в паузах при отключении передатчика раздражает абонента и снижает разборчивость речи, поэтому применение комфортного шума в паузах считается необходимым. DTX процесс з приемнике включает также интерполяцию фрагментов речи, потерянных из-за ошибок в канале.

Структурная схема процессов обработки речи в стандарте GSM показана на рис. 4.1, главным устройством в этой схеме является речевой кодек [4.1, 4.2, 4.3].

рис. 4.1

рис. 4.2

рис. 4.3

4.2. Выбор речевого кодека для стандарта GSM

Рабочей группой по разработке стандарта GSM были предъявлены следующие основные требования к речевому кодеку [4.3]:

- высокое качество речи, не уступающее качеству передачи речи в лучших существующих аналоговых сотовых системах связи;

- низкая скорость передачи речи, обеспечивающая возможность эффективного канального кодирования и результирующую скорость передачи в канале связи не выше 16 кбит/с,

- малую задержку сообщения в процессе преобразования речи;

- устойчивость к ошибкам в канале передачи;

- возможность работы в широком динамическом диапазоне входных воздействий как сигнала, так и шума;

- большой динамический диапазон выходных сигналов;

- незначительное снижение качества речи при каскадном соединении кодеков:

- прозрачность для сигналов данных;

- прямое сопряжение со смежными устройствами терминалов;

- простота реализации;

- малое потребление;

- низкая стоимость.

Для выбора речевого кодека GSM был организован конкурс проектов. Первоначально для рассмотрения было предложено 20 различных кодеков от 9 европейских стран. После международного формального тестирования это количество было сокращено до 6 из 6 стран. На следующем этапе два из четырех подполосных (SBC) кодеков (норвежский и итальянский) были сняты с рассмотрения, к окончательному этапу конкурса осталось два SBC кодека и два кодека в предикативным кодированием [4.4].

RPE-LPC - Regular-Pulse Excitation/Linear Predicative Coding (Германия, Philips) -кодек с регулярным импульсным возбуждением и линейным кодированием с предсказанием;

MPE-LTP - Multi-Pulse Excitation/Long-Term Prediction (Франция, IBM) -кодек с многоимпульсным возбуждением и долговременным предсказанием:

На втором этапе происходит дальнейшее снижение динамического диапазона за счет долговременного предсказания, в процессе которого каждый сегмент выравнивается до уровня следующих друг за другом сегментов речи. В принципе, LTP фильтр вычитает предыдущий период сигнала из текущего периода.

Этот фильтр характеризуется параметром задержки N и коэффициентом усиления Ь. Период вычисления этих параметров равен 5 мс.

Восемь коэффициентов r (i) LPC анализирующего фильтра и параметры фильтра LTP анализа кодируются и передаются со скоростью 3,6 кбит/с.

Для формирования последовательности возбуждения остаточный сигнал пропускают через фильтр нижних частот с частотой среза 3-4 кГц.

Окончательно периодическая последовательность фрагментов передается со скоростью 9,4 кбит/с. Общая скорость передачи составляет 3,6+9,4 = 13 кбит/с.

В декодере речевой сигнал восстанавливается по откликам последовательности регулярного импульсного возбуждения (RPE) двухступенчатым синтезирующим фильтром, как показано на рис. 4.3.

При этом качество речи соответствует качеству речи, передаваемой по ISDN, и превосходит качество речи в аналоговых радиотелефонных системах.

Теоретически время задержки речевого сигнала в кодекс равно длительности сегмента и составляет 20 мс. Реальное время задержки, с учетом операций канального кодирования и переме-жения, а также физического выполнения рассматриваемых операций, составляет 70-80 мс.

4.4. Детектор активности речи

Детектор активности речи (VAD) играет решающую роль в снижении потребления энергии от аккумуляторной батареи в портативных абонентских терминалах. Он также снижает интерференционные помехи за счет переключения свободных каналов в пассивный режим. Реализация VAD зависит от типа применяемого речевого кодека. Главная задача при проектировании VAD - обеспечить надежное отличие между условиями активного и пассивного каналов. Если канал на мгновение свободен, его можно заблокировать, поскольку средняя активность речи говорящего ниже 50%, то это может привести к существенной экономии энергии аккумуляторной батареи. К устройствам VAD предъявляются следующие основные требования [4.6]:

- минимизация вероятности ложной тревоги при воздействии только шума с высоким уровнем;

- высокая вероятность правильного обнаружения речи низкого уровня;

- высокое быстродействие распознавания речи, для исключения задержек включения:

- минимальное время задержки выключения. В стандарте GSM принята схема VAD с обработкой в частотной области. Структурная схема VAD приведена на рис. 4.4. Ее работа основана на различии спектральных характеристик речи и шума. Считается, что фоновый шум является стационарным в течение относительно большого периода времени, его спектр также медленно изменяется во времени. VAD определяет спектральные отклонения входного воздействия от спектра фонового шума. Эта операция осуществляется инверсным фильтром, коэффициенты которого устанавливаются применительно к воздействию на входе только фонового шума. При наличии на входе речи и шума инверсный фильтр осуществляет подавление компонентов шума и, в целом, снижает его интенсивность. Энергия смеси сигнал+шум на выходе инверсного фильтра сравнивается с порогом, который устанавливается в период воздействия на входе только шума. Этот порог находится выше уровня энергии шумового сигнала. Превышение порогового уровня принимается за наличие на входе реализации (сигнал+шум). Коэффициенты инверсного фильтра и уровень порога изменяются во времени в зависимости от текущего значения уровня шума при воздействии на входе только шума. Поскольку эти параметры (коэффициенты и порог) используются детектором VAD для обнаружения речи, сам VAD не может на этой же основе принимать решение, когда их изменять. Это решение принимается вторичным VAD на основе сравнения огибающих спектров в последовательные моменты времени. Если они аналогичны для относительно длительного периода времени, предполагается, что имеет место шум, икоэффициенты фильтра и шумовой порог можно изменять, то есть адаптировать под текущий уровень и спектральные характеристики входного шума [4.6].

рис. 4.4

VAD с обработкой в спектральной области удачно сочетается с речевым RPE/LTP-LPC коде-ком, так как в процессе LPC анализа уже определяется огибающая спектра входного воздействия, необходимая для работы вторичного VAD.

4.5. Формирование комфортного шума

Формирование комфортного шума осуществляется в паузах активной речи и управляется речевым декодером. Когда детектор активности речи (VAD) в передатчике обнаружит, что говорящий прекращает разговор, передатчик остается еще включенным в течение следующих пяти речевых кадров. Во время первых четырех из них характеристики фонового шума оцениваются путем усреднения коэффициента усиления и коэффициентов фильтра LPC анализа. Эти усредненные значения передаются в следующем пятом кадре, в котором содержат информацию о комфортном шуме (SID кадр).

В речевом декодере комфортный шум генерируется на основе LPC анализа SID кадра. Чтобы исключить раздражающее влияние модуляции шума, комфортный шум должен соответствовать по амплитуде и спектру реальному фоновому шуму в месте передачи. В условиях подвижной связи фоновый шум может постоянно изменяться. Это значит, что характеристики шума должны передаваться с передающей стороны на приемную сторону не только в конце каждого речевого всплеска, но и в речевых паузах так, чтобы между комфортным и реальным шумом не было бы резких рассогласований в следующих речевых кадрах. По этой причине SID кадры посылаются каждые 480 мс в течение речевых пауз.

Динамическое изменение характеристик комфортного шума обеспечивает натуральность воспроизведения речевого сообщения при использовании системы прерывистой передачи речи.

4.6. Экстраполяция потерянного речевого кадра

В условиях замираний сигналов в подвижной связи речевые фрагменты могут подвергаться значительным искажениям. При этом для исключения раздражающего эффекта при воспроизведении необходимо осуществлять экстраполяцию речевого кадра.

Было установлено, что потеря одного речевого кадра может быть значительно компенсирована путем повторения предыдущего фрагмента. При значительных по продолжительности перерывах в связи предыдущий фрагмент больше не повторяется, и сигнал на выходе речевого декодера постепенно заглушается, чтобы указать пользователю на разрушение канала.

То же самое происходит и с SID кадром. Если SID кадр потерян во время речевой паузы, то формируется комфортный шум с параметрами предыдущего SID кадра. Если потерян еще один SID кадр, то комфортный шум постепенно заглушается.

Применение экстраполяции речи при цифровой передаче, формирование плавных акустических переходов при замираниях сигнала в каналах в совокупности с полным DTX процессом значительно улучшает потребительские качества связи с GSM PLMN по сравнению с существующими аналоговыми сотовыми системами связи.

Литература к Главе 4

4.1 М. Mouly, М-В. Pautet. The GSM System for Mobile Communications. 1992. p. 701.

4.2 A. Mehrotra. Cellular Radio Performance Engineering. Artech House. Boston-London. 1994. p. 536.

4.3 P. Vary. GSM Speech Codec. Conference Proceedings DCRC, 12-14 October. 1988. Hagen FRG. p.p.2a/1-2a/6.

4.4 С. Sonthcott. Speech Proceeding in the Pan-European Cellular Mobile Telephone System. IEE Colloquium: "Digitized Speech Communication via Mobile Radio". London. 19 December, 1988. p.p. 5/1-5/5.

4.5 P. Vary, R. Hofman. Sprachcodec ftir das Europaische Funkfernsprechnetz. Frequenz. 42, 1988. s.s. 85-92.

4.6 D. Freeman, С. Sonthcott, 1. Boyd. A Voice Activity Detector for the Pan-European Digital Cellular Mobile Telephone Service. IEE Colloquium ""Digitized Speech Communication via Mobile Radio". London. 19 December, 1988. p.p. 6/1-6/5.


Глава 5

Глава 5. АСПЕКТЫ БЕЗОПАСНОСТИ В СТАНДАРТЕ GSM

5.1 Общее описание характеристик безопасности

Сотовые системы подвижной связи нового поколения в состоянии принять всех потенциальных пользователей, если будут гарантированы безопасность связи: секретность и аутентификация. Секретность должна исключить возможность извлечения информации из каналов связи кому-либо, кроме санкционированного получателя. Проблема аутентификации заключается в том, чтобы помешать кому-либо, кроме санкционированного пользователя (отправителя), изменить канал, то есть получатель должен быть уверен, что в настоящий момент он принимает сообщение от санкционированного пользователя. Основным способом обеспечения секретности является шифрование. Относительно новая концепция - использование шифрования как способа аутентификации сообщений.

Аутентификация сообщений через шифрование осуществляется за счет включения в текст так называемого кода идентификации (то есть фиксированного или зависящего от передаваемых данных слова, которое знают отправитель и получатель или которое они могут выделить в процессе передачи). Получатель расшифровывает сообщение, путем сравнения получает удостоверение, что принимаемые данные являются именно данными санкционированного отправителя.

К системе шифрования предъявляются следующие основные требования:

1) нелинейные связи между исходным текстом и зашифрованным текстом;

2) изменение параметров шифрования во времени.

Если алгоритмы шифрования отвечают первому требованию, то, не зная ключа, исключается возможность изменить код идентификации, чтобы избежать обнаружения факта несанкционированного доступа. Второе требование исключает возможность нарушения работы системы за счет воспроизведения "обнаружителем" принятого ранее и записанного в память сообщения.

Один путь обеспечения этих требований - применение синхронных систем передачи, но при этом необходимы системы цикловой и тактовой синхронизации, что во многих случаях неприемлемо.

Второй путь - включение в информационную последовательность (каждое сообщение) временных меток так, чтобы зашифрованные данные были бы однозначно с ними связаны. Алгоритмы шифрования делятся на два класса [5.1-5.3];

- классические алгоритмы;

- алгоритмы с открытым ключом.

Классические алгоритмы используют один ключ для шифрования-дешифрования. Алгоритмы с открытым ключом используют два ключа:

первый - для перехода от нешифрованного текста к шифрованному; второй - для обратного перехода от шифрованного к нешифрованному. Причем знание одного ключа не должно обеспечить обнаружение второго ключа. В этих алгоритмах один из ключей, обычно используемый для шифрования, можно сделать общим, и только ключ, используемый для расшифровки, должен быть засекречен. Эта особенность очень полезна для снижения сложности протокола и интеграции структур шифрования в сетях связи.

Алгоритмы шифрования с открытым ключом построены на определении односторонней функции, то есть некоторой функции f, такой, что для любого х из ее области определения f (х) легко вычислима, однако практически для всех у из ее области значений нахождение х, для которого y=f(x) вычислительно, не осуществимо [5.1-5.3]. То есть, односторонняя функция является отдельной функцией, которая легко рассчитывается ЭВМ в приемлемом объеме времени, но время расчета обратной функции в существующих условиях недопустимо большое.

Первый алгоритм шифрования с общим ключом был назван RSA (первые буквы фамилий авторов Rivest, Shamir, Adieman) [5.1-5.3]. Алгоритм базируется на двух функциях Е и D, связанных соотношением:

D (Е(*) = Е (D(*)).

Одна из этих функций используется для шифрования сообщений, другая - для дешифрования. Секретность алгоритма основана на том, что знание функции Е (или D) не открывает легкого способа вычисления D (или Е). Каждый пользователь делает общей функцию Е и хранит в секрете функцию D, то есть для пользователя Х есть открытый ключ Ех и секретный Dx.

Два пользователя А и В могут использовать алгоритм RSA, чтобы передать любое зашифрованное сообщение. Если абонент А хочет отправить сообщение М абоненту В, то он может сделать это следующим образом:

- зашифровать сообщение М;

- подписать сообщение М;

- зашифровать и подписать М. В первом случае: А обеспечивает преобразование М, используя открытый ключ

С = Ев (М)

и посылает его абоненту В. В принимает С и вычисляет db (с) = db (Ев (М)) = М.

Во втором случае: А подписывает М посредством вычисления F = Da (М)

и посылает F абоненту В (эти операции может осуществлять только пользователь А, которому известен секретный ключ Da). В получает F и вычисляет

Еа (F) = Еа (Da (М)) = М.

В теперь известно, что сообщение М действительно послано пользователем А. В этом случае секретность сообщения М не гарантируется, так как все могут осуществить такую же операцию с использованием общего ключа Еа. В третьем случае: А вычисляет

F = Da (М) и С = Ев (F) = Ев (Da (М);

А посылает С к В. В получает С и вычисляет db (с) = db (Ев (F)) = Da (М); В может теперь легко получить М, вычислив Еа (Da (М)) = М.

До операции шифрования и подшей каждое сообщение М должно разделяться на блоки фиксированной длины, затем каждый блок кодируется как совокупность фиксированного числа цифр. RSA кодер оперирует такими отдельными блоками в каждом цикле кодирования. Полное описание алгоритма RSA изложено, например, в [5.1, 5.2].

Алгоритм шифрования с открытым ключом RSA обеспечивает высокую степень безопасности передачи речевых сообщений и рекомендован к использованию в цифровых системах подвижной радиосвязи нового поколения.

В стандарте GSM термин "безопасность" понимается как исключение несанкционированного использования системы и обеспечение секретности переговоров подвижных абонентов. Определены следующие механизмы безопасности в стандарте GSM [5.4, 5.5]:

- аутентификация;

- секретность передачи данных;

- секретность абонента;

- секретность направлений соединения абонентов.

Защита сигналов управления и данных пользователя осуществляется только по радиоканалу. Режимы секретности в стандарте GSM определяются Рекомендациями, приведенными в таблице 5.1.

Таблица 5.1

GSM 02.09 | Аспекты секретности | Определяет характеристики безопасности, применяемые в сетях GSM. Регламентируется их применение в подвижных станциях и сетях
GSM 03.20 | Секретность, связанная с функциями сети | Определяет функции сети, необходимые для обеспечения характеристик безопасности, рассматриваемых в рекомендациях GSM 02.09
GSM 03.21 | Алгоритмы секретности | Определяет криптографические алгоритмы в системе связи
GSM 02.17 | Модули подлинности абонентов (SIM) | Определяет основные характеристики модуля SIM

Рассмотрим последовательно механизмы безопасности в стандарте GSM, общий состав секретной информации, а также ее распределение в аппаратных средствах GSM системы. При этом будем использовать термины и обозначения, принятые в рекомендациях GSM.

5.2 Механизмы аутентификации

Для исключения несанкционированного использования ресурсов системы связи вводятся иопределяются механизмы аутентификации - удостоверения подлинности абонента. Каждый подвижный абонент на время пользования системой связи получает стандартный модуль подлинности абонента (SIM-карту), который содержит:

- международный идентификационный номер подвижного абонента (IMSI);

- свол индивидуальный ключ аутентификации (Ki);

- алгоритм аутентификации (A3). С помощью заложенной в SIM информации в результате взаимного обмена данными между

подвижной станцией и сетью осуществляется полный цикл аутентификации и разрешается доступ абонента к сети.

Процедура проверки сетью подлинности абонента реализуется следующим образом. Сеть передает случайный номер (RAND) на подвижную станцию. Подвижная станция определяет значение отклика (SRES), используя RAND, Ki и алгоритм A3:

SRES = Ki [RAND].

Подвижная станция посылает вычисленное значение SRES в сеть, которая сверяет значение принятого SRES со значением SRES, вычисленным сетью. Если оба значения совпадают, подвижная станция может осуществлять передачу сообщений. В противном случае связь прерывается, и индикатор подвижной станции должен показать, что опознавание не состоялось.

По причине секретности вычисление SRES происходит в рамках SIM. Несекретная информация (такая как Ki) не подвергается обработке в модуле SIM. Процедура аутентификации иллюстрируется рис. 5.1.

рис. 5.1

5.3 Секретность передачи данных

Ключ шифрования

Для обеспечения секретности передаваемой по радиоканалу информации вводится следующий механизм защиты. Все конфиденциальные сообщения должны передаваться в режиме защиты информации. Алгоритм формирования ключей шифрования (А8) хранится в модуле SIM. После приема случайного номера RAND подвижная станция вычисляет, кроме отклика SRES, также и ключ шифрования (Кс), используя RAND, Ki и алгоритм А8 (рис. 5.2):

Кс = Ki [RAND].

Ключ шифрования Кс не передается по радиоканалу. Как подвижная станция, так и сеть вычисляют ключ шифрования, который используется другими подвижными абонентами. По причине секретности вычисление Кс происходит в SIM.

Числовая последовательность ключа шифрования

Кроме случайного числа RAND сеть посылает подвижной станции числовую последовательность ключа шифрования. Это число связано с действительным значением Кс и позволяет избежать формирование неправильного ключа. Число хранится подвижной станцией и содержится в каждом первом сообщении, передаваемом в сеть. Некоторые сети принимают решение о наличии числовой последовательности действующего ключа шифрования в случае, если необходимо приступить к опознаванию или, если выполняется предварительное опознавание, используя правильный ключ шифрования. В некоторых случаях это допущение реально не обеспечивается.

Установка режима шифрования

Для установки режима шифрования сеть передает подвижной станции команду CMC (Ciphering Mode Command) на переход в режим шифрования. После получения команды CMC подвижная станция, используя имеющийся у нее ключ, приступает к шифрованию и дешифрованию сообщений. Поток передаваемых данных шифруется бит за битом или поточным шифром, исполь-

5.4 Обеспечение секретности абонента

Для исключения определения (идентификации) абонента путем перехвата сообщений, пере даваемых по радиоканалу, каждому абоненту системы связи присваивается "временное удостове рение личности" - временный международный идентификационный номер пользователя (TMSI), ко торый действителен только в пределах зоны расположения (LA). В другой зоне расположения ем' присваивается новый TMSI. Если абоненту еще не присвоен временный номер (например, при пер вом включении подвижной станции), идентификация проводится через международный идентифи кационный номер (IMSI). После окончания процедуры аутентификации и начала режима шифрова ния временный идентификационный номер TMSI передается на подвижную станцию только в за шифрованном виде. Этот TMSI будет использоваться при всех последующих доступах к системе Если подвижная станция переходит в новую область расположения, то ее TMSI должен передавать ся вместе с идентификационным номером зоны (LAI), в которой TMSI был присвоен абоненту.

5.5 Обеспечение секретности в процедуре корректировки местоположения

При выполнении процедуры корректировки местоположения по каналам управления осуще ствляется двухсторонний обмен между MS и BTS служебными сообщениями, содержащими вре менные номера абонентов TMSI. В этом случае в радиоканале необходимо обеспечить секретност переименования TMSI и их принадлежность конкретному абоненту.

Рассмотрим, как обеспечивается секретность в процедуре корректировки местоположения i случае, когда абонент проводит сеанс связи и при этом осуществляет перемещение из одной зот расположения в другую.

В этом случае подвижная станция уже зарегистрирована в регистре перемещения VLR с вре менным номером TMSI, соответствующим прежней зоне расположения. При входе в новую зон расположения осуществляется процедура опознавания, которая проводится по старому, зашифро ванному в радиоканале TMSI, передаваемому одновременно с наименованием зоны расположени LAI. LAI дает информацию центру коммутации и центру управления о направлении перемещени подвижной станции и позволяет запросить прежнюю зону располбжения о статусе абонента и ег данные, исключив'обмен этими служебными сообщениями по радиоканалам управления. При это1

5.6 Общий состав секретной информации и ее распределение в аппаратных средствах GSM

В соответствии с рассмотренными механизмами безопасности, действующими в стандарте GSM, секретной считается следующая информация: RAND - случайное число, используемое для аутентификации подвижного абонента;

- значение отклика - ответ подвижной станции на полученное случайное число;

- индивидуальный ключ аутентификации пользователя, используемый для вычисления значения отклика и ключа шифрования;

- ключ шифрования, используемый для шифрования/дешифрования сообщений, сигналов управления и данных пользователя в радиоканале;

- алгоритм аутентификации, используемый для вычисления значения отклика из случайного числа с использованием ключа Ki;

- алгоритм формирования ключа шифрования, используемый для вычисления ключа Кс из случайного числа с использованием ключа Ki;

- алгоритм шифрования/дешифрования сообщений, сигналов управления и данных пользователя с использованием ключа Кс;

- номер ключевой последовательности шифрования, указывает на действительное число Кс, чтобы избежать использования разных ключей на передающей и приемной сторонах;

- временный международный идентификационный номер пользователя.

В таблице 5.2 показано распределение секретной информации в аппаратных средствах системы связи GSM. Таблица 5.2

NN п.п. | Аппаратные средства | Вид секретной информации
1 | Подвижная станция (без SIM) | А5
2 | Модуль подлинности абонента (SIM) | A3; А8; IMSI; Ki; TMSI/LAI; Kc/CKSN
3 | Центр аутентификации (AUC) | A3; А8; IMSI/Ki
4 | Регистр местоположения (HLR) | Группы IMSI/RAND/SRES/Kc
5 | Регистр перемещения (VLR) | Группы IMSI/RAND/SRES/Kc, IMSI/TMSI/LAI/Kc/CKSN
6 | Центр коммутации (MSC) | А5, TMSI/IMSI/Kc
7 | Контроллер базовой станции (BSC) | А5, TMSI/IMSI/Kc

5.7 Обеспечение секретности при обмене сообщениями между HLR, VLR и MSC

Основным объектом, отвечающим за все аспекты безопасности, является центр аутентификации (AUC). Этот центр может быть отдельным объектом или входить в состав какого-либо оборудования, например, в регистр местоположения (HLR). Как управлять AUC будет решать тот, кому будет поручена эксплуатация сети. Интерфейс GSM с AUC не определен.

AUC может решать следующие задачи:

- формирование индивидуальных ключей аутентификации пользователей Ki и соответствующих им международных идентификационных номеров абонентов (IMSI);

- формирование набора RAND/SRES/Kc для каждого IMSI и раскрытие этих групп для HLR при необходимости.

Если подвижная станция переходит в новую зону расположения с новым VLR, новый VLR должен получить секретную информацию об этой подвижной станции. Это может быть обеспечено следующими двумя способами:

- подвижная станция проводит процедуру идентификации по своему международному номе- . ру IMSI. При этом VLR запрашивает у регистра местоположения HLR группы данных '' RAND/SRES/Kc, принадлежащих данному IMSI;

- подвижная станция проводит процедуру аутентификации, используя прежний временный номере TMSI с наименованием зоны расположения LAI. Новый VLR запрашивает прежний VLR для посылки международного номера IMSI и оставшихся групп из RAND/SRES/Kc, принадлежащих этим TMSI/LAI,

Если подвижный абонент остается на более длительный период в VLR, тогда после некоторого количества доступов с аутентификацией VLR из соображений секретности потребует новые группы RAND/SRES/Kc от HLR.

Все эти процедуры определены в рекомендации GSM 09.02.

Проверка аутентификации выполняется в VLR. VLR посылает RAND на коммутационный центр (MSC) и принимает соответствующие отклики SRES. После положительной аутентификации TMSI размещается с IMSI. TMSI и используемый ключ шифрования Кс посылаются в центр коммутации (MSC). Эти же процедуры определяются в рекомендации GSM 09.02.

Передача секретной информации по радиоканалу уже описана в предыдущих разделах и определена в рекомендации GSM 04.08.

5.8 Модуль подлинности абонента

Введение режима шифрования в стандарте GSM выдвигает особые требования к подвижным станциям, В частности, индивидуальный ключ аутентификации пользователя Ki, связанный с международным идентификационным номером абонента IMSI, требует высокой степени защиты. Он также используется в процедуре аутентификации.

Модуль подлинности абонента SIM содержит полный объем информации о конкретном абоненте. SIM реализуется конструктивно в виде карточки с встроенной электронной схемой. Введение SIM делает подвижную станцию универсальной, так как любой абонент, используя свою личную SIM-карту, может обеспечить доступ к сети GSM через любую подвижную станцию.

Несанкционированное использование SIM исключается введением в SIM индивидуального идентификационного номера (PIN), который присваивается пользователю при получении разрешения на работу в системе связи и регистрации его индивидуального абонентского устройства.

Основные характеристики модуля SIM определены в Рекомендации GSM 02.17. Состав секретной информации, содержащейся в SIM, показан в таблице 5.2.

В заключение следует отметить, что выбранные в стандарте GSM механизмы секретности и методы их реализации определили основные элементы передаваемых информационных блоков и направления передачи, на которых должно осуществляться шифрование: (RAND/SRES/Kc от HLR к VLR; RAND и SRES - в радиоканале). Для обеспечения режима секретности в стандарте GSM решены вопросы минимизации времени соединения абонентов. При организации систем сотовой радиосвязи по стандарту GSM имеется некоторая свобода в применении аспектов безопасности. В частности, не стандартизованы вопросы использования центра аутентификации AUC (интерфейс с сетью, структурное размещение AUC в аппаратных средствах). Нет строгих рекомендаций на формирование закрытых групп пользователей и системы приоритетов, принятых в GSM. В этой связи в каждой системе связи, использующей стандарт GSM, эти вопросы решаются самостоятельно.

Литература к Главе 5

5.1 У. Диффи. Н. Хелтан. Защищенность и имитостойкость: введение в криптографию. ТИИЭР.1979, т. 67. N 3. с. 71-109.

5.2 Л. Месси. Введение в современную криптографию. ТИИЭР. 1988. т. 76. N 5, с. 24-42.

5.3 У. Диффи. Первые десять лет шифрования с открытым ключом, ТИИЭР. 1988. т. 76, N5, с. 55-74.

5.4 P. Vander. Arend Security Aspects and the Implementation in the GSM-System. ConferenceProceedings DCRC, 12-14 October 1988. Hagen FRG. p.p. 4a/1-4a/7.

5.5 V. Michel. The Security Features in the GSM-System. 6-th World Telecommunication Forum Proceedings. Geneva, 10-15 October, 1991. Part 2. p.p. 385-389.


Глава 6

Глава 6. УПРАВЛЕНИЕ СЕТЯМИ СВЯЗИ В СТАНДАРТЕ GSM

6.1 Задачи системы сетевого управления

Задачи управления процессами связи в системе GSM решаются ОМС - центром управлени? и обслуживания (рис. 6.1). В основе построения ОМС заложен принцип сетевого управления, в соответствии с которым для системы сетевого управления (GSM NM) были определены следующие задачи проектирования [6.1 - 6.3]:

1, Система GSM NM должна обеспечивать взаимодействие с существующими системами связи общего пользования и быть их естественным продолжением.

2. Система GSM NM должна быть достаточно гибкой, чтобы обеспечивать перспективное развитие наземных сетей связи общего пользования (PLMN), а также функций и служб сетевогс управления.

3. Система GSM NM должна быть настолько прозрачной для технологий, используемых в су ществующих PLMN, насколько это возможно.

4. Система GSM NM должна иметь модульную структуру, чтобы независимо от размеров се ти, где осуществляется управление, обеспечивать требуемые функции.

5. Система GSM NM не должна иметь зависимости от изготовителя, то есть должна преду сматривать взаимозаменяемость оборудования.

6, Структура и функции GSM NM не должны ограничивать деятельность и выбор операторы и изготовителей, а также возможность индивидуального использования, например, для организа ции частных локальных сетей связи.

7. Система GSM NM должна быть отказоустойчивой, то есть ни отказ оборудования, ни чело веческий фактор не должны приводить систему или сеть связи в нерабочее состояние.

Перечисленные задачи решены путем принятия для сетей связи GSM модели открытых сете1 (OSI) международной организации стандартов (ISO), выбором функциональной архитектуры систе мы сетевого управления, учитывающей различное физическое исполнение, четким определение? сопряжения стандартов и протоколов передачи сообщений.

6.2 Принципы построения системы сетевого управления

В основу построения системы сетевого управления электросвязью (TMN) в стандарте GSM положена структурированная концепция МККТТ [6.1, 6.2], которая учитывает возможность разви тия и интеграции создаваемых и существующих сетей управления.

В соответствии с выбранной концепцией GSM TMN должна обеспечить организованную сете вую структуру для достижения взаимосвязи различных операционных систем (для TMN) и уст ройств связи (для PLMN) на основе согласованной архитектуры со стандартными протоколами устройствами сопряжения.

Концептуально TMN представляет собой отдельную сеть, которая сопрягается с PLMN в не скольких различных точках с целью получения от нее информации и контроля ее работы. Для обес печения управления TMN может использовать отдельные структурные части PLMN (например, сие тему сигнализации SS N7, В-канал в структуре канала связи ISDN). Исходя из общей концепц^ GSM TMN обеспечивает высокую степень гибкости, что отвечает различным технологическим услс виям построения PLMN и различным операторам.

Функционально TMN обеспечивает средства для транспортировки и обработки информаци1 относящейся к управлению PLMN. Как показано на рис. 6.1, обобщенная функциональная архите” тура для GSM TMN и PLMN включает в себя OSF функциональные блоки операционных систе (OS), промежуточные функциональные блоки MF и функциональные блоки передачи данных DSI Они включают в себя основные функции TMN, что позволяет ей решать свои прикладные задач” TMN подключается к функциональным блокам элементов сети PLMN (NEF), а также непосредств^ но к функциональным блокам рабочей станции (WSF). Рабочая станция может непосредствень подключаться к различным элементам сети через внешние для TMN соединения.

RP - контрольные точки (интерфейсы)

q -класс контрольных точек между OS,M и NE функциями;

f -класс контрольных точек рабочей станции (с абонентами сетей GSM);

д -класс контрольных точек от рабочей станции до пользователя (ММ1); х -класс рабочих точек для связи с

другими сетями, включая другие TMN;

m -нестандартные внутренние контрольные точки;

t -контрольные точки для связи с другими сетями;

FB - функциональные блоки

WSF -функциональный блок рабочейстанции;

OSF -функциональный блок операционных систем;

MF -промужуточный функциональный блок;

DCF -функции системы связи GSM, связанные с передачей данных;

QAF -функции адаптора Q-интерфейса;

SEF -функции поддержки (обеспечения) абонента;

MEF -функции технического обслуживания абонентов;

NEF -функции элементов сети.

рис. 6.1

Контрольные точки, показанные на рис. 6.1, определяют концептуальные точки информационного обмена между функциональными блоками. Контрольная точка становится интерфейсом, когда функциональные блоки включаются в отдельные части оборудования [6.3].

Такая функциональная концепция GSM TMN обеспечивает выполнение функций сетевого управления на оборудовании PLMN (в смысле использования одних и тех же ресурсов для обработки), над операционными системами и промежуточными устройствами, ориентированными на сетевое управление.

Следует отметить, что в случае применения одного процессора для выполнения функций сетевого управления и функций связи, они всегда логически разделяются.

6.3 Распределение функций сетевого управления в GSM

Операционные системы

Физическая конфигурация TMN обеспечивает альтернативные решения как централизации, так и распределения общих функций операционных систем (OS), что включает в себя:

- обслуживающие прикладные программы;

- функции базы данных;

- обеспечение абонентского терминала;

- анализирующие программы;

- форматирование данных и передачу сообщений.

В GSM TMN все эти функции представлены для централизованной дистанционной обработки, т.е. в центре управления и обслуживания ОМС (в терминологии TMN нужно рассматривать как сетевую OS), тогда как специальные части этих функций (так называемые функции жизнеобеспечения) должны локально присутствовать в узловой базовой OS.

Процессы сопряжения

Составной частью функций сети управления связью являются процессы сопряжения - процессы, которые определяют направления соединений и/или воздействий на информацию, передаваемую между отдельными элементами сети (NE) и операционными системами по каналам передачи данных. Процессы сопряжения классифицируются по пяти общим категориям:

1) управление связью;

2) сопряжение протоколов и обработка данных;

3) сопряжение (объединение) простых функций:

4) процессы принятия решений;

5) хранение данных.

Процессы сопряжения имеют место как в автономном оборудовании, так и в отдельных элементах сети.

Передача данных в GSM TMN

Функции передачи данных (DCF) для GSM TMN обеспечиваются сетью передачи данных (DCN) или локальными сетями связи (LCN).

DCN для GSM TMN соответствует эталонной модели OSI [6.2]. Функции передачи данных включают в себя обеспечение соединения через соответствующие сопряжения различных элементов сети к операционным системам. Интерфейс, используемый в процессе соединений, определяется в Рекомендациях МККТТ М.2х [6.3] как Q3 интерфейс. Этот интерфейс обеспечивает полный доступ ко всем частям TMN. Некоторые функции определены тем, что система сигнализации МККТТ SS N7 должна относиться к интерфейсу Q3.

Для других функций оператор имеет возможность использовать закрепленные каналы с протоколом серии Х.25 или коммутируемые сети пакетной передачи данных общего пользования (PC PDN).

В локальных сетях связи (LCN) при осуществлении соединений с PLMN для реализации функций передачи данных TMN могут использоваться интерфейс Q2 МККТТ и A-bis интерфейс.

Элементы сети

В системе связи GSM элементами сети (NE) являются узлы PLMN, например, MSC, HLR, BSS или любая часть связного оборудования. Элементы сети могут обеспечивать следующие группы функций сетевого управления:

- функции обслуживания объекта (MEF), сопряжены с процессами связи. Обслуживаемый объект (ME) может иметь одну иди более функций MEF;

- функции обеспечения объекта (SEF), непосредственно не включены в процесс связи. К ним относятся, например, локализация отказов, сбор данных. Объект обеспечения (SE) может иметь одну или более функций SEF.

Элементы сети могут иметь функции первой или второй группы, а также то и другое одновременно.

6.4 Стандартные интерфейсы в системе сетевого управления GSM

Стандартные интерфейсы в системе сетевого управления обеспечивают взаимодействие элементов сети, операционных систем и рабочих станций через сети передачи данных (DCN) или локальные сети связи (LCN).

Для гарантированной совместной работы соединяемых элементов сети необходимы четкие технические требования к интерфейсу, функционально независимые от типа устройства и поставщика. Это требует совместимых протоколов связи и совместимого метода представления данных для передачи сообщений, включая совместимые описания групповых сообщений для функций сети управления.

Интерфейсы между TMN

Состав и функциональное назначение интерфейсов в GSM TMN показаны на рис. 6.2. Для передачи сообщений между сетями управления, используемыми, например, разными операторами применяется система сигнализации МККТТ SS N7 или Х.25.

рис. 6.2

При применении SS N7 используются протоколы МККТТ (Голубая книга) Рекомендация Q.795 [6.4].

При использовании сетей Х.25 необходимы дополнительные соглашения между операторами по использованию протоколов более высокого уровня. Некоторые функции сетевого управления определены СЕРТ рабочей подгруппой SPS 6 в Рекомендации GSM 09.02 [6.5], которая требует использования SS N7 в следующих случаях:

- передачи информации между MSC и HLR другой PLMN;

- идентификации оборудования;

- обмене сообщениями между регистрами положения;

- при запросе на "эстафетную передачу".

TMN интерфейс между PLMN и узлами TMN

В общем случае операторы сетей могут свободно использовать либо систему сигнализации SS N7, предусмотренную в PLMN, либо специализированную сеть Х.25 в соответствии с Рекомендациями МККТТ (Голубая кни^а) Q.513 [6.6]. При использовании сетей Х.25 могут быть необходимы средства для преобразования протоколов обмена (Х.25 - SS N7).

Информационный обмен в процессе сетевого управления между BSS и MSC (А-интерфейс, рис. 6.3) обеспечивается SS N7.

Требования к средствам файлового обмена обеспечиваются использованием элементов управления сигнализационными соединениями (SCCP) класса 2 и транспортного протокола X.224 класса 2, либо SCCP класса 3 и Х.224 класса 0. Также предусмотрена специальная версия GSM относительно применения Х.25 соединений на А-интерфейсе.

Интерфейс между BTS и BSC (GSM A-bis интерфейс) основан на применении Lap-D протоколов для информационного обмена при сетевом управлении.

Все узлы PLMN, за исключением BTS, оснащены общим Х.25 интерфейсом. Это обеспечивает полный доступ к TMN на уровне Q3 либо локально, либо дистанционно за счет использования отдельного подключения к PS PDN.

При использовании в PLMN локальных сетей связи TMN интерфейсы определяются СЕРТ Рекомендацией Т/К 02-11 [6.7].

Полная структурная схема процессов управления системой связи GSM, состав и сопряжения протоколов связи показаны на рис. 6.3.

Протоколы более высоких уровней, используемые в GSM TMN

Сопряжение на более высоких уровнях (выше слоя 3) может быть предусмотрено при использовании стандартных протоколов, основанных на МККТТ Рекомендациях (Голубая книга) Q.795

или на стандартах ISO для общих информационных служб управления (CMIS) и доступа и управления файловым обменом (FTAM), как это иллюстрируется на рис. 6.3 [6.8, 6.9].

Однако, на первом этапе не рекомендуется использование ОМАР в GSM TMN, так как этс требует сетевого обслуживания без подключений, которое не может быть поддержано со сторонь SS N7 и Х.25. Кроме того, способы файлового обмена, которые являются обязательными для эф фективного управления PLMN, полностью не определены в ОМАР.

рис. 6.3

Литература к Главе 6

6.1 Bernd F. GSM Network Management.

6.2 С. Smythe Networks and their protocols, Electronics & Communication Engineering Journal, February 1990, pp. 27-34.

6.3 CCITT Recomendation M.2x (Amended third draft; to become M.30 in Blue Book). Principles for a Telecommunications Management Network, March 1988.

6.4 CCITT (Draft Blue Book) Recomendation Q.795, Operations Administration and Maintenance Application Part (ОМАР).

6.5 CEPT Draft Recomendation GSM 09.02, CCITT Signalling System N7, Mobile Application Part (MAP); also referenced as CEPT T/S 43-10.

6.6 CCITT (Draft Blue Book) Recomendation Q.513 "Interfaces for Operations, Administration and Maintenance".

6.7 CEPT Recomendation I/L 02-11, Interfaces for Operation, Maintenance and Supervision of Telecommunications Equipment in Telecommunications Centres, Copenhagen 1987.

6.8 ISO/IEC D7 9595/9596 series, OSI-Management Information Service Definition/Protocol Specification, Dec. 1987.

6.9 ISO/IEC DIS 8571 Series, OSI-File Transfer, Access and Management, April 1988