Заключение

В данной работе содержится исчерпывающее описание беспроводных технологий, начиная с геостационарной спутниковой телефонии и заканчивая технологий, используемой беспроводной гарнитурой сотовой телефонии. Приводится описание протоколов, сравнение технологий, особенности применения. Разумеется. данная работа не претендует на абсолютный охват тематики: подобное потребовало бы написание не одной книги, однако основные положения описаны.

Беспроводные технологии не стоят на месте и к моменту выхода данной работы, наверняка, появятся в Институте инженеров по электротехнике и радиоэлектронике новые проекты беспроводных сетей. Объем работы не позволил включить в нее описания проектов, находящихся на этапе разработки, однако изложенные фундаментальные принципы относятся и к неутвержденным проектам.


Беспроводные сети. Содержание.

Введение

Организация беспроводных сетей

Спутниковая связь

1.1 Параметры и конфигурации спутников

Спутниковые орбиты

Полосы частот

Ухудшение качества связи

Конфигурации спутниковой сети

1.2 Распределение пропускной способности - частотное разделение

Уплотнение с частотным разделением (FDM)

Множественный доступ с частотным разделением (FDMA)

1.3 Распределение пропускной способности - временное разделение

Беспроводные сотовые сети

2.1 Принципы сотовой связи

Организация сотовой сети

Функционирование сотовой системы

Эффекты распространения радиоволн в мобильной связи

Переключение

Регулирование мощности

Регулирование трафика

2.2 Аналоговые системы первого поколения

Распределение спектра

Функционирование систем первого поколения

Каналы управления в системе AMPS

2.3 Системы TDMA второго поколения

Сотовые системы первого и второго поколений

Множественный доступ с временным разделением каналов

Вопросы проектирования мобильных беспроводных систем TDMA

Глобальная система мобильной связи

Архитектура сети GSM

Аспекты радиосвязи

Протокольная архитектура передачи сигналов GSM

2.4 Системы CDMA второго поколения

Множественный доступ с кодовым разделением каналов

Вопросы проектирования мобильных беспроводных систем CDMA

IS-95

Прямой канал системы IS-95

Обратный канал системы IS-95

2.5 Системы третьего поколения

Альтернативные интерфейсы

Бесшнуровые системы и беспроводные абонентские линии

3.1 Бесшнуровые системы

Дуплекс с временным разделением

Формат кадра DECT

Работа схемы DECT

Адаптивная дифференциальная импульсно-кодовая модуляция

3.2 Беспроводные абонентские линии связи

Роль линий WLL

Распространение сигнала в системах WLL

Ортогональное уплотнение с частотным разделением

Многоканальные многоточечные распределительные услуги (MMDS)

Локальные многоточечные распределительные услуги (LMDS)

3.3 Стандарт IEEE 802.16

Архитектура IEEE 802.16

Услуги

Уровень MAC стандарта IEEE 802.16.1

Физический уровень стандарта IEEE 802.16.1

Беспроводные локальные сети

Технология беспроводных локальных сетей

4.1 Обзор

Применение беспроводных локальных сетей

Требования к беспроводным локальным сетям

Технология беспроводных локальных сетей

4.2 Инфракрасные локальные сети

Плюсы и минусы

Методы передачи

4.3 Сети с расширенным спектром

Конфигурация

4.4 Сети с узкополосной СВЧ-передачей

Лицензируемые узкополосные системы

Нелицензируемые узкополосные системы

Стандарт беспроводных локальных сетей 802.11.

5.1 Архитектура IEEE 802.11

Архитектура протоколов

Формат кадра MAC

Управление логическим каналом

5.2 Архитектура и услуги IEEE 802.11

Архитектура IEEE 802.11

Услуги IEEE 802.11

5.3 Управление доступом к среде в IEEE 802.11

Надежная доставка данных

Управление доступом к среде в IEEE 802.11

Кадр MAC

Вопросы безопасности

5.4 Физический уровень IEEE 802.11

Исходный физический уровень IEEE 802.11

IEEE 802.11a

IEEE 802.11b

Bluetooth

6.1 Обзор

Области применения Bluetooth

Стандарты Bluetooth

Архитектура протоколов

Модели использования

Пикосети и рассеянные сети

6.2 Радиоспецификация

6.3 Узкополосная спецификация

Перестройка частоты

Физические каналы

Пакеты

Исправление ошибок

Логические каналы

Управление каналом

Аудио

Безопасность

6.4 Спецификация администратора связей

6.5 Протокол управления логическим каналом а адаптации (L2CAP)

Каналы L2CAP

Пакеты L2CAP

Сигнальные команды

Качество обслуживания

Заключение

Глоссарий

Список использованной литературы


Беспроводные сети.

Эта страница использует рамки, однако ваш обозреватель их не поддерживает.


Введение

Эта работа представляет собой обзор беспроводных коммуникаций и сетей. Многие факторы, включая повышенную конкуренцию и внедрение цифровых технологий, привели к беспрецедентному развитию рынка беспроводных средств. В данном разделе мы рассмотрим некоторые наиболее важные факторы, ставшие движущей силой этой революции в сфере коммуникаций.

БЕСПРОВОДНЫЕ ТЕХНОЛОГИИ ДОСТИГАЮТ ЗРЕЛОСТИ

Гильельмо Маркони изобрел беспроволочный телеграф в 1896 году (Собственно изобретение радиосвязи следует приписать Николе Тесле, который еще в 1893 г. произвел публичную демонстрацию своего устройства. В 1943 г. патенты Маркони были аннулированы в пользу Теслы). В 1901 году он послал телеграфный сигнал через Атлантический океан от Корнуолла до Сент-Джонса на Ньюфаундленде на расстояние 1800 миль. Это изобретение сделало возможным связь двух сторон, посылающих друг другу буквы и цифры, закодированные в аналоговом сигнале. В последующие сто лет развитие технологий беспроводной связи привело к появлению радиовещания, телевидения, мобильного телефона и спутников связи. Теперь можно послать информацию любого типа почти в каждый уголок мира. В последнее время наибольшее внимание к себе привлекают спутниковая связь, беспроводные сети и сотовая технология.

Запуск спутников связи начался в 1960-х годах. Первые спутники могли обслуживать лишь 240 телефонных каналов. В наше время с помощью спутников осуществляется приблизительно третья часть телефонного трафика и все телепередачи между странами. Современные каналы спутниковой связи вносят в обрабатываемые ими сигналы задержку, обычно не превышающую четверти секунды. Вскоре появятся более новые спутники, на более низких орбитах, имеющие еще меньшую задержку сигнала, которые предоставят такие услуги передачи данных, как доступ в Internet.

Средства беспроводных сетей позволяют развертывать глобальные, региональные и локальные сети без необходимости создания кабельной структуры. Институтом IEEE разработан стандарт 802.11 для беспроводных локальных сетей. Кроме него, над созданием интегральных технологий беспроводных сетей работает промышленный консорциум Bluetooth.

Современным эквивалентом беспроволочного телеграфа Маркони, обеспечивающим двустороннюю двунаправленную связь, является сотовый или мобильный телефон. В радиотелефонах первого поколения использовалась аналоговая технология. Эти устройства были громоздки и имели ограниченную зону обслуживания, но на их примере ясно были видны преимущества мобильной системы связи. Теперешнее поколение беспроводных устройств построено уже на базе цифровой, а не аналоговой технологии. Цифровые сети могут передавать намного больший телефонный трафик, и обеспечиваемые ими качество приема и безопасность выше, чем в аналоговых системах. Кроме того, цифровая технология позволяет вводить дополнительные услуги, такие, как идентификация вызывающего абонента. Беспроводные устройства следующего поколения также будут цифровыми, с подключением к Internet и использованием новых частотных диапазонов и более высоких скоростей передачи информации.

Значение беспроводной связи настолько велико, что ей принадлежит будущее. Очень немногим изобретениям удавалось так сократить расстояния. Стандарты, определяющие характер взаимодействия устройств беспроводной связи, быстро унифицируются и скоро позволят создать глобальную беспроводную сеть, предоставляющую все многообразие услуг.

СОТОВАЯ РЕВОЛЮЦИЯ

Одно лишь увеличение рынка мобильных телефонов наглядно свидетельствует о том, что в мире технологий произошла революция. В 1990 году количество пользователей готовых телефонов составляло приблизительно 11 миллионов. В 2004 году оно, вероятно, возрастет до одного миллиарда. Этому росту обязательно будут способствовать устройства следующего поколения, с доступом в Internet. По одному из прогнозов к 2005 году число устройств беспроводного доступа в Internet превысит число устройств с доступом по проводным линиям.

В настоящее время наиболее очевидный признак успеха беспроводных технологий — распространение телефонов. Начиная с 1996 года количество новых абонентов мобильных телефонов превышает количество новых абонентов стационарных телефонов. Так получилось по многим причинам. Мобильные телефоны удобны; они перемещаются вместе с людьми. Кроме того, по самой своей природе средства мобильной связи "знают" свое местоположение. Каждый мобильный телефон связывается с региональными базовыми станциями, расположение которых твердо установлено.

В успех мобильных телефонов внесли свой вклад различные технические новшества. Телефонные трубки стали меньше и легче, срок службы батарей увеличился, ж цифровая технология повысила качество приема и позволила лучше использовать доступный спектр. Как и во многих других случаях, переход к цифровому оборудованию позволил снизить затраты на мобильную связь. В тех областях, где процветает конкуренция, цены начиная с 1996 года значительно снизились.

Во многих регионах распространение мобильных телефонов — единственный экономичный способ предоставить населению телефонную связь. Базовые станции можно создавать быстро и недорого по сравнению с рытьем траншей и прокладкой кабелей, особенно в сложных условиях местности.

Мобильные телефоны — лишь начало сотовой революции. Появляется все больше и больше новых типов беспроводных устройств, которые имеют доступ в Internet. К ним относятся персональные органайзеры и те же телефоны, но теперь уже с Web-доступом, функциями мгновенных сообщений, электронной почты и другими услугами, доступными в Internet. Беспроводные устройства в автомобилях позволяют загружать карты и маршруты. Скоро такие устройства смогут вызывать помощь, если произошла авария, или даже сообщать пользователю о самых низких ценах на бензин в ближайшей окрестности. Будут доступны и другие удобные функции. Например, восполнение через Internet запасов домашних холодильников.

Первым заданием для мобильных устройств была передача речи. Теперь акцент переместился на передачу данных. Предполагается, что в следующие пять лет сложится многомиллионный рынок услуг беспроводной передачи данных. Большая часть этого рынка — "беспроводная" Internet. Беспроводные устройства потребуют использовать Internet иначе, чем стационарные. Беспроводные устройства имеют меньше возможностей отображения и ввода данных по сравнению с обычными стационарными устройствами, такими, как персональные компьютеры. Нормой станут не длинные сеансы просмотра Web-страниц, а транзакции и обмен сообщениями. Поскольку беспроводные устройства "знают" свое расположение, можно будет адаптировать информацию к географическому местоположению пользователя. Таким образом, уже не пользователи будут искать информацию, а информация сможет сама находить пользователей.

ГЛОБАЛЬНАЯ СОТОВАЯ СЕТЬ

Сейчас не существует какой-то единой сотовой сети. Обычно существующие устройства поддерживают одну или две из несметного числа технологий и работают только в пределах зоны обслуживания одного оператора. Чтобы выйти за пределы этой модели, надо проделать много работы, особенно в определении и реализации стандартов.

Комплекс стандартов для беспроводных устройств следующего поколения разрабатывает Международный телекоммуникационный союз (International Telecommunication Union — ITU). В новых стандартах будут использоваться более высокие частоты, что позволит увеличить пропускную способность. Новые стандарты также помогут преодолеть несовместимость различных сетей первого и второго поколений, разработанных и развернутых за последние десять лет.

Преобладающей цифровой беспроводной сетью первого поколения в Северной Америке была система AMPS (Advanced Mobile Phone System — усовершенствованная система мобильной телефонной связи). Эта сеть предоставляла услуги передачи данных на базе перекрывающихся сетей CDPD (Cellular Digital Packet Data — сотовая система передачи пакетов цифровых данных) со скоростью 19,2 Кбит/с. В системе CDPD передача данных производилась в незанятые интервалы в обычных каналах телефонной связи.

Важнейшие беспроводные системы второго поколения — GSM (Global System for Mobile Communications — глобальная система мобильной связи), PCS (Personal Communications Service — персональная служба связи) IS-136 и PCS IS-95. В стандарте PCS IS-136 используется множественный доступ с временным разделением, а в IS-95 — с кодовым разделением. В системах GSM и PCS IS-136 передача данных производится через выделенные каналы со скоростью 9,6 Кбит/с.

Сейчас Международный телекоммуникационный союз разрабатывает стандарты IMT-2000 (International Mobile Telecommunications — международные мобильные телекоммуникации). Эта группа стандартов должна определить глобальную интегрированную сеть. В стандартах используется диапазон 2 ГГц. Новые стандарты и новый диапазон позволят достичь скорости передачи данных 2 Мбит/с.

Кроме определения использования частот, схем кодирования и передачи, в стандартах также должно быть указано, как мобильные устройства будут взаимодействовать с Internet. В этой области работают несколько специализированных организаций по стандартам и промышленных консорциумов. В частности, Форум WAP (Wireless Application Protocol — протокол беспроводных приложений) разрабатывает общий протокол для обращения к Internet устройств с ограниченными возможностями отображения и ввода. Проблемная группа проектирования Internet (IETF) разрабатывает стандарт протокола Mobile IP, который представляет собой адаптацию общепринятого протокола IP к работе в мобильном окружении.

ШИРОКОПОЛОСНЫЕ ТЕХНОЛОГИ

Все более важное место в Internet занимает мультимедиа. Графика, видео и звук в изобилии встречаются на Web-страницах. Та же тенденция наблюдается и в коммерческой связи. Например, сообщения электронной почты часто содержат приложения мультимедиа. Чтобы полностью включиться в эту среду, беспроводные сети должны обеспечивать такие же высокие скорости передачи данных, как и их стационарные аналоги. Этих скоростей позволяет достичь широкополосная технология.

Широкополосные беспроводные службы имеют те же преимущества, что и все беспроводные средства: удобство и сниженные затраты. За счет отказа от кабелей операторы могут развертывать беспроводные службы быстрее и дешевле, чем проводные. Кроме того, беспроводные службы мобильны и могут разворачиваться почти в любом месте.

Существует много проектов разработки стандартов широкополосной беспроводной связи для множества различных приложений. Эти стандарты охватывают все области — от беспроводных локальных сетей до небольших домашних сетей. Скорости передачи данных варьируются от 2 Мбит/с до более чем 100 Мбит/с. Уже доступны многие из этих технологий и число их значительно увеличится в следующие несколько лет.

Беспроводные локальные сети предоставляют возможность работы в сети там, гае бывает трудно или слишком дорого развернуть стационарную инфраструктуру. Основные стандарты беспроводных локальных сетей— IEEE 802.11b в Америке и HiperLAN в Европе. Стандарт IEEE предусматривает скорость передачи данных до И Мбит/с. Европейский стандарт определяет максимальную скорость 24 Мбит/с, а в Идущей редакции скорость передачи будет повышена до 54 Мбит/с.

Потенциальная проблема стандарта 802.11b — совместимость с Bluetooth. Спецификация беспроводных сетей Bluetooth определяет связь между такими устройствами, как лэптопы, карманные компьютеры и мобильные телефоны. В Bluetooth и 802.11b используется один и тот же диапазон частот. При реализации в одном устройстве эти технологии, скорее всего, будут мешать друг другу.

В рамках проекта HomeRF разрабатываются стандарты беспроводной связи между домашними компьютерами и внешними устройствами. В настоящее время в HomeRF применяются скорости передачи до 2 Мбит/с, но новая редакция будет рассчитана на скорости порядка 10 Мбит/с.

ПРОБЛЕМЫ БЕСПРОВОДНОЙ СВЯЗИ

Беспроводные службы удобны и часто более дешевы в развертывании, чем стационарные, но они несовершенны. Существуют ограничения, трудности политического и технического характера, которые в конечном счете могут помешать беспроводным технологиям полностью реализовать свой потенциал. Две основные проблемы — несовместимость стандартов и ограничения устройств.

Как было сказано выше, в Северной Америке существует два стандарта цифровых сотовых систем. В остальном мире существует по крайней мере еще один стандарт. Устройство, в котором используется PCS IS-136, не будет работать в районе, где развернутая система связи построена на стандарте PCS IS-95. Мы говорили также о невозможности применять Bluetooth и 802.11b в одном и том же устройстве. Это лишь два примера проблем, возникающих в ситуации, когда нет единого стандарта для всей отрасли. Отсутствие такого стандарта мешает технологиям достичь одного из настоящих идеалов беспроводной связи — повсеместного доступа к данным.

Ограничения, присущие устройствам, также сдерживают свободное движение данных. Маленький жидкокристаллический дисплей мобильного телефона неспособен отобразить больше нескольких строк текста. Кроме того, большинство мобильных беспроводных устройств может обращаться лишь к небольшой части огромного множества Web-сайтов в Internet. В браузерах этих устройств используется специальный язык разметки для беспроводных приложений (Wireless Markup Language — WML), а не стандартный язык HTML.

Вероятнее всего, невозможно создать такое беспроводное устройство, которое могло бы удовлетворить любую потребность. Потенциал беспроводной связи можно реализовать, но не в каком-то одном изделии. Беспроводная связь будет иметь успех при интегрировании в различные устройства, предназначенные для удовлетворения разнообразных потребностей.


Назад

Список использованной литературы

  1. Столллингс В. Компьютерные системы передачи данных, 6-е изд. - М.: Издательский дом "Вильямс", 2002.
  2. Скляр Б. Цифровая связь. Теоретические основы и практическое применение. - М.: Издательский дом "Вильямс", 2002.
  3. Анабел З. Дод. Мир телекоммуникаций. Обзор технологий и отрасли. - М.: ЗАО "Олимп-Бизнес", 2002.
  4. Танненбаум Э. Компьютерные сети. - СПб.: Питер, 2002.
  5. Олифер В. Г., Олифер Н. А. Компьютерные сети. Принципы, технологии, протоколы. -М.: Питер, 2004.
  6. Андрианов В., Соколов А. Средства мобильной связи, СПб.: БХВ, 2001.
  7. Гук М. Аппаратные средства локальных сетей. СПб.: Питер, 2000.
  8. Бройдо В. Вычислительные системы, сети и телекоммуникации. СПб.: Питер, 2002.
  9. www.citforum.ru\htdocs\hardware\pc\light.shtml. Череповский К. Самым легким посвящается…
  10. www.citforum.ru\htdocs\internet\iinet97\17.shtml. КочегаровП. Применение оборудования Radio-Ethernet для построения корпоративных сетей доступа к Internet
  11. www.osp.ru\lan\2004\02\086.htm. Мучлер Ш. Построение беспроводной сети
  12. www.osp.ru\lan\2003\09\099.htm. Мойзер П. На трудном пути к стандарту
  13. www.osp.ru\lan\2003\07-08\030.htm. Зельграт Б. 54 Мбит/с в полосе частот 2,4 и 5 ГГц
  14. www.osp.ru\lan\2003\06\028.htm. Мут М. Качество сервиса для 802.11а/b
  15. www.osp.ru\lan\2003\05\084.htm. Бетс В. Мобильные сотрудники под контролем
  16. www.osp.ru\lan\2003\03\036.htm. Мучлер Ш. В третий раунд без проводов
  17. www.osp.ru\lan\2002\11\092.htm. Дорнан Э. Bluetooth: полезная возможность или медвежья услуга?
  18. www.osp.ru\lan\2002\04\044.htm. Григонис Р. Беспроводные локальные сети становятся практичными
  19. www.osp.ru\lan\2002\04\036.htm. Иванов П. Беспроводные сети: час настал
  20. www.osp.ru\lan\2002\03\078.htm. Дорнан Э. Беспроводные локальные сети на коротком проводке
  21. www.osp.ru\nets\2004\04\028_1.htm. Коржов А. Вместе или раздельно?
  22. www.osp.ru\nets\2004\03\040_1.htm. Коржов А. GSM: вскрытие покажет
  23. www.osp.ru\lan\2004\02\086.htm. Мучлер Ш. Построение беспроводной сети
  24. www.osp.ru\lan\2000\12\040.htm. Дорнан Э. По зубам ли Bluetooth сетевые технологии?
  25. www.osp.ru\lan\2000\06\095.htm. Ризави П. Беспроводные чудеса в решете
  26. www.osp.ru\lan\2001\06\094.htm. Иванов П. Bluetooth готовится к взлету
  27. www.compress.ru\main\misc\article_read.asp_id_1556.htm. Фильчаков А. Новые возможности мобильных "персоналок"
  28. www.compress.ru\main\misc\article_read.asp_id_1780.htm. Фильчаков А. Даешь мегабиты по гигагерцам!
  29. www.compress.ru\main\misc\article_read.asp_id_2387.htm. Фильчаков А. Локальные беспроводные сети — новый рывок
  30. www.compress.ru\main\misc\article_read.asp_id_3269.htm. Федоров А., Елманова Н. Корпоративные мобильные решения
  31. www.compress.ru\main\misc\article_read.asp_id_3483.htm. Пахомов С. Анатомия беспроводных сетей
  32. www.compress.ru\main\misc\article_read.asp_id_4085.htm. Пахомов С. Экспансия закона Мура
  33. www.compress.ru\main\misc\article_read.asp_id_4474.htm. Беспроводные технологии в цифрах и фактах
  34. www.compress.ru\main\misc\article_read.asp_id_4479.htm. Самохин С. "Голубой зуб" — смотрим в корень
  35. www.compress.ru\main\misc\article_read.asp_id_4480.htm. Асмаков. С. Периферия без проводов
  36. www.compress.ru\main\misc\article_read.asp_id_4483.htm. Пахомов С. Технологии беспроводных сетей семейства 802.11
  37. www.compress.ru\main\misc\article_read.asp_id_1015.htm. Богданов В. Коротко о handsfree в автомобиле
  38. www.compress.ru\main\misc\article_read.asp_id_1556.htm. Фильчаков А. Новые возможности мобильных "персоналок"
  39. www.compress.ru\main\misc\article_read.asp_id_2016.htm. Поваляев Е., Прохоров А. Персональная спутниковая связь
  40. www.compress.ru\main\misc\article_read.asp_id_2846.htm. Дадали А. Рынок сотовой связи России
  41. http://cdmaonline.ru/cdma.htm

Назад


Глоссарий

2G Second Generation (второе поколение)

3G Third Generation (третье поколение)

AM Amplitude Modulation (амплитудная модуляция)

AMPS Advances Mobile Phone System (усовершенствованная система мобильнойтелефонной связи)

ARQ Automatic Repeat Request (автоматический запрос повторной передачи)

ASK Amplitude-Shift Keying (амплитудная манипуляция)

ATM Asynchronous Transfer Mode (асинхронный режим передачи)

BER Bit Error Rate (уровень ошибок битов)

bps Bits Per Second (биты в секунду, бит/с)

CDMA Code Division Multiple Access (множественный доступ с кодовым разделением каналов)

CRC Cyclic Redundancy Check (циклическая проверка четности с избыточностью)

DAMA Demand Assignment Multiple Access (множественный доступ с распределением по запросу)

dBm decibel-milliWatt (децибел-милливатт, дБмВт)

dBW decibel-Watt (децибел-ватт, дБВт)

DECT Digital Enhanced Cordless Telecommunications (цифровые расширенные беспроводные телекоммуникации)

DM Delta Modulation (дельта-модуляция)

DSSS Direct Sequence Spread Spectrum (расширение спектра методом прямой последовательности)

ECC Error Correction Code (код с коррекцией ошибок)

EHF Extremely High Frequency (крайне высокая частота, КВЧ)

ELF Extremely Low Frequency (крайне низкая частота, КНЧ)

FAMA Fixed Assignment Multiple Access (множественный доступ с фиксированным распределением)

FCC Federal Communications Commission (Федеральная комиссия по средствам связи США)

FCS Frame Check Sequence (контрольная последовательность кадра)

DM Frequency Division Multiplexing (уплотнение с частотным разделением)

FDMA Frequency Division Multiple Access (множественный доступ с частотным разделением)

FEC Forward Error Correction (прямое исправление ошибок)

FHSS Frequency-Hopping Spread Spectrum (расширение спектра методом скачкообразной перестройки частоты)

FM Frequency Modulation (частотная модуляция)

FSK Frequency-Shift Keying (частотная манипуляция)

GEO Geostationary (геостационарный); Geosynchronous (геосинхронный)

GSM Global System for Mobile Communications (глобальная система мобильной связи)

GW Ground Wave (земная волна)

HDLC High-Level Data Link Control (высокоуровневый протокол управления каналом)

HF High Frequency (высокая частота, ВЧ)

IAB Internet Architecture Board (Совет по архитектуре Internet)

ICMP Internet Control Message Protocol (протокол управляющих сообщений Internet)

IEEE Institute of ]Electrical and Electronics Engineers (Институт инженеров по электротехнике и радиоэлектронике, ИИЭР)

IETF Internet Engineering Task Force (Проблемная группа проектирования Internet)

IP Internet Protocol (протокол Internet)

ISO International Organization for Standardization (Международная организация по стандартизации)

ITU International Telecommunication Union (Международный телекоммуникационный союз)

ITU-T ITU Telecommunication Standardization Sector (Сектор стандартизации телекоммуникаций Международного телекоммуникационного союза)

LAN Local Area Network (локальная сеть)

LEO Low Earth Orbit (низкая околоземная орбита)

LF Low Frequency (низкая частота, НЧ)

LLC Logical Link Control (управление логическим каналом)

LMDS Local Multipoint Distribution Service (локальная многоточечная распределительная служба)

LOS Line of Sight (линия прямой видимости)

LSFR Linear Feedback Shift Register (линейный регистр сдвига с обратной связью)

MAC Medium Access Control (управление доступом к среде)

MAN Metropolitan-Area Network (городская сеть) МЕО Medium Earth Orbit (средняя околоземная орбита)

MF Medium Frequency (средняя частота, СЧ)

MMDS Multichannel Multipoint Distribution Service (многоканальная многоточечная распределительная служба)

MOS Mean Opinion Score (усредненная оценка разборчивости речи)

MSS Mobile Service Satellite (спутник службы мобильной связи)

OFDM Orthogonal Frequency Division Multiplexing (ортогональное уплотнение с частотным разделением)

OSI Open Systems Interconnection (взаимодействие открытых систем)

PCM Pulse Code Modulation (импульсно-кодовая модуляция)

PDU Protocol Data Unit (модуль данных протокола)

РМ Phase Modulation (фазовая модуляция)

PN Pseudonoise (псевдошум)

PRN Pseudorandom Number (псевдослучайное число)

PSK Phase-Shift Keying (фазовая манипуляция)

PWT Personal Wireless Telecommunications (персональные беспроводные телекоммуникации)

QAM Quadrature Amplitude Modulation (квадратурная амплитудная модуляция)

QoS Quality of Service (качество обслуживания)

RF Radio Frequency (радиочастота)

SAP Service Access Point (точка доступа к службе)

SDU Service Data Unit (модуль данных службы)

SHF Super High Frequency (сверхвысокая частота, СВЧ)

SS Spread Spectrum (расширенный спектр)

SW Sky Wave (ионосферная волна); Short Wave (короткая волна)

TCP Transmission Control Protocol (протокол управления передачей)

TDD Time Division Duplex (дуплекс с временным разделением)

TDM Time Division Multiplexing (уплотнение с временным разделением)

TDMA Time Division Multiple Access (множественный доступ с временным разделением)

UDP User Datagram Protocol (протокол пользовательских дейтаграмм)

UHF Ultra High Frequency (ультравысокая частота, УВЧ)

VF Voice Frequency (частота речевого диапазона)

VHF Very High Frequency (очень высокая частота, ОВЧ)

VLF Very Low Frequency (очень низкая частота, ОНЧ)

WAN Wide Area Network (глобальная сеть)

WAP Wireless Application Protocol (протокол беспроводных приложений)

WLL Wireless Local Loop (беспроводная абонентская линия)

XOR Exclusive OR (исключающее ИЛИ)


Беспроводные сети. Титульный лист.

Вперед

Беспроводные сети. Современное состояние и перспективы развития

Вперед


Беспроводные сети. Современное состояние и перспективы развития. 5.1. АРХИТЕКТУРА IEEE 802

Наиболее популярной спецификацией беспроводных локальных сетей является стандарт, разработанный рабочей группой IEEE 802.11. В начале данной главы рассматривается общая архитектура стандартов IEEE 802, затем речь пойдет об особенностях стандарта IEEE 802.11.

5.1. АРХИТЕКТУРА IEEE 802

Архитектуру локальной сети лучше всего описывать через многоуровневую протокольную структуру, упорядочивающую основные функции локальной сети. Данный раздел начинается с описания стандартизированной протокольной архитектуры для локальных сетей, которая включает физический уровень, уровень управления доступом к среде и уровень управления логическим каналом. Затем подробно рассматриваются два последних.

Архитектура протоколов

Протоколы, определенные специально для передачи по локальным и городским сетям, решают вопросы, связанные с передачей блоков данных по сети. В терминах OSI протоколы высокого уровня (уровень 3 или 4 и выше) независимы от архитектуры сети и применимы в локальных, городских и глобальных сетях. Таким образом, обсуждение протоколов локальных сетей в основном связано с нижними уровнями модели OSI.

На рис. 5.1 сопоставляются протоколы локальных сетей и архитектура OSI (рис. 4.3). Эта архитектура была разработана комитетом IEEE 802 и принята всеми организациями, работающими в области спецификации стандартов локальных сетей. Обычно она называется эталонной моделью IEEE 802 (IEEE 802 reference model)1.

Рассмотрим эталонную модель IEEE 802. Нижний уровень этой модели соответствует физическому уровню модели OSI и включает следующие функции:

• кодирование/декодирование сигнала;

• генерирование/удаление начальной комбинации битов (для синхронизации);

• прием/передача битов.

Кроме того, физический уровень модели 802 включает спецификацию среды передачи и топологии (поскольку выбор среды передачи и топологии является важным вопросом в определении структуры локальной сети).

Над физическим уровнем рассматриваются функции, связанные с предоставлением услуг пользователям локальной сети.

• При передаче — дополнение данных кадра информацией относительно адреса и полями выявления ошибок.

• При приеме — выделение информационной части кадра, распознавание адреса и выявление ошибок.

• Регулирование доступа к среде передачи локальной сети.

• Организация сопряжения с вышестоящими уровнями и реализация управления потоком и защиты от ошибок.

Рисунок 5.1 - Сопоставление моделей OSI и IEEE 802

Эти функции обычно связываются со вторым уровнем модели OSI. Набор функций в последнем пункте списка выделяется в уровень управления логическим каналом (logical link control — LLC). Функции, перечисленные в первых трех пунктах списка, также рассматриваются как отдельный уровень, называющийся уровнем управления доступом к среде (medium access control — MAC). Назовем причины такого разделения.

Логика, необходимая для управления доступом к среде совместного использования, не находится на традиционном уровне 2 управления каналом передачи данных.

При одинаковом управлении логическим каналом могут быть реализованы разные схемы управления доступом к среде.

На рис. 5.2 показана связь уровней архитектуры. Высокоуровневые данные спускаются на уровень LLC, на котором к ним в виде заголовка присоединяется управляющая информация, при этом создается модуль данных протокола LLC, или PDU LLC. Эта управляющая информация используется в операциях протокола LLC. PDU LCC спускается на Уровень MAC, где к нему в начале и конце пакета присоединяется управляющая информация, формируя в итоге кадр MAC. Эта дополнительная управляющая информация необходима для работы протокола MAC. Для полноты картины на рисунке над протоколами локальной сети показан также уровень приложений и использование протокола TCP/IP.

Рисунок 5.2 - Протоколы IEEE 802 в контексте

Формат кадра MAC

Уровень MAC получает блок данных от уровня LLC и отвечает за выполнение функций, связанных с доступом к среде, и за передачу данных. Как и другие протокольные уровни, MAC реализует указанные функции, используя на своем уровне модуль данных протокола (protocol data unit — PDU). В этом случае PDU называется МАС-кадром.

Точный формат МАС-кадра несколько отличается для различных используемых протоколов MAC. Вообще все МАС-кадры имеют формат, подобный тому, что показан на рис. 5.3. Перечислим поля этого кадра.

• Управление MAC. Это поле содержит всю управляющую информацию, необходимую для функционирования протокола MAC. Например, здесь может указываться уровень приоритета.

• МАС-адрес получателя. Целевая физическая точка подключения к локальной сети для этого кадра.

• МАС-адрес отправителя. Исходная физическая точка подключения к локальной сети для этого кадра.

• Данные. Тело МАС-кадра. Здесь могут находиться данные LLC от вышестоящего уровня или управляющая информация, связанная с работой протокола MAC.

Рисунок 5.3 - PDU LLC в общем формате МАС-кадра

• CRC. Поле циклической проверки четности с избыточностью (cyclic redundancy check — CRC), называемое также полем контрольной последовательности кадра (frame check sequence — FCS). Это код выявления ошибок, как было показано для протокола HDLC и других протоколов управления каналом передачи данных.

В большинстве протоколов управления каналом передачи данных объект протокола канала передачи данных отвечает не только за выявление ошибок с использованием CRC, но и за исправление этих ошибок путем повторной передачи поврежденных кадров. В протокольной архитектуре локальной сети эти две функции разделены между уровнями MAC и LLC. Уровень MAC отвечает за выявление ошибок и отклонение кадров с ошибками. Уровень LLC может отслеживать, какие кадры были успешно приняты, и повторно передавать остальные.

Управление логическим каналом

Уровень LLC для локальных сетей во многих отношениях подобен другим широко используемым канальным уровням. Он связан с передачей PDU канального уровня между двумя станциями, без промежуточных коммутационных узлов. Отличают протокол LLC от других протоколов управления каналом передачи | данных следующие две характеристики.

1. Он должен поддерживать множественный доступ, составляющий природу канала с совместно используемой средой (что отличается от многоточечной линии, в которой отсутствует выделенный основной узел).

2. Протокол LLC несколько упрощен за счет передачи уровню MAC некоторых элементов управления доступом.

Адресация в LLC включает задание исходного и целевого пользователей LLC. Обычно пользователь — это вышестоящий протокол или функция управления сетью на станции. Эти адреса пользователей LLC называются точками доступа к службе (service access point — SAP), что согласуется с терминологией OSI Для пользователя протокольного уровня.

Рассмотрим услуги, которые LLC предоставляет пользователю вышестоящего уровня, после чего перейдем к самому протоколу LLC.

Услуги LLC

LLC определяет механизмы задания в среде адресов станций и управления информационным обменом между двумя пользователями. В основе работы и формата этих стандартов лежит протокол HDLC. Подключенным устройствам использующим LLC, предлагаются на выбор три вида услуг.

• Услуги без подтверждений и без организации соединения. Эти услуги работают по принципу использования дейтаграмм. Они крайне просты и не включают механизмы управления потоком и защиты от ошибок. Таким образом, доставка данных не гарантируется. Впрочем, в большинстве устройств за надежность отвечает некоторый более высокий программный уровень.

• Услуги с установкой соединения. Подобны аналогичным услугам, предлагаемым протоколом HDLC. Между двумя пользователями, обменивающимися данными, устанавливается логическое соединение; кроме того, обеспечивается управление потоком и защита от ошибок.

• Услуги с подтверждениями без организации соединения. Это нечто среднее между двумя видами услуг, описанными выше. Дейтаграммы при этом подтверждаются, но логическое соединение не устанавливается.

Обычно поставщик предлагает эти услуги как альтернативные варианты, из которых заказчик может выбрать желаемый, приобретая оборудование. Возможна также ситуация, когда заказчик приобретает оборудование, предлагающее два или все три вида услуг, и выбирает нужное исходя из конкретных обстоятельств.

Услуги без подтверждений и без организации соединения требуют минимальной логики и полезны в двух случаях. Во-первых, часто бывает так, что вышестоящие уровни программного обеспечения гарантируют необходимую надежность и предлагают механизм управления потоком, поэтому целесообразнее избежать ненужного дублирования. Например, TCP может предлагать механизмы, необходимые для гарантирования надежной доставки данных. Во-вторых, бывает, что служебные издержки по установке и поддержанию соединения неоправданны или даже вредны (например, действия по сбору данных, включающие периодическую выборку из источников информации, таких, как сенсоры, или автоматические самотестирующиеся отчеты, поступающие от средств обеспечения безопасности или сетевых компонентов). При организации наблюдения потеря одного из периодически поступающих модулей данных не составит большой проблемы, если следующий отчет поступит в скором времени. Следовательно, в большинстве описанных случаев неподтвержденная служба без организации соединения является предпочтительным вариантом.

Услуги с установкой соединения могут использоваться в очень простых устройствах, таких, как терминальные контроллеры, имеющих малофункциональные высшие программные уровни. В этих случаях предлагаемые услуги будут обеспечивать управление потоком и надежность, что обычно реализуется на более высоких уровнях программного обеспечения связи.

Услуги с подтверждениями без организации соединения также полезны в нескольких случаях. Если используются услуги с установкой соединения, программа, управляющая логическим каналом, должна хранить какую-то таблицу для каждого активного соединения, чтобы отслеживать его состояние. Если пользователю требуется гарантировать доставку, но при этом существует большое число адресатов данных, то услуги с установкой соединения могут оказаться непрактичными из-за большого числа требуемых таблиц. Пример: управление процессом или автоматизированная промышленная среда, где центральному узлу может потребоваться связаться с большим числом устройств обработки или программируемых контроллеров. Другим применением данной службы является обработка важных и требующих немедленного реагирования сигналов тревоги или аварийного управления. Вследствие важности этих сигналов необходимо подтверждение их приема, чтобы отправитель был уверен, что сигнал дошел по назначению. Пользователь может передать срочный сигнал, не тратя времени на установку соединения.

Протокол LLC

Основной протокол LLC моделировался после протокола HDLC, поэтому формат и функции этих протоколов очень похожи. Отличия же можно сформулировать следующим образом.

LLC использует асинхронный сбалансированный режим работы HDLC для поддержки службы LLC, ориентированной на установление соединения; это называется режимом работы 2. Другие режимы HDLC не используются.

LLC поддерживает неподтвержденную службу без организации соединения с использованием ненумерованных PDU; это называется режимом работы 1.

LLC поддерживает подтвержденную службу без организации соединения путем использования двух новых ненумерованных PDU; это называется режимом работы 3.

LLC допускает уплотнение путем использования точек доступа к службе LLC (LLC service access point — LSAP).
Все три протокола LLC используют одинаковый формат PDU (см. рис. 5.3), состоящий из четырех полей. Поля DSAP и SSAP содержат адреса исходного и целевого пользователей LLC по 7 бит каждый. Один бит DSAP показывает, является DSAP индивидуальным или групповым адресом. Один бит SSAP указывает, является PDU командой или откликом. Формат управляющего поля LLC идентичен формату аналогичного поля HDLC (см. рис. Г.1, приложение Г) и использует расширенные порядковые номера (состоящие из 7 бит).

В режиме работы 1, поддерживающем неподтвержденную службу без организации соединения, для передачи пользовательских данных служат ненумерованные информационные (unnumbered information — UI) PDU. Подтверждение отсутствует, управление потоком не осуществляется, защита от ошибок не обеспечивается. Впрочем, функции выявления ошибок и отклонения кадров имеются на уровне MAC.

Два других типа PDU используются для поддержки функций управления, связанных со всеми тремя режимами работы. Оба типа PDU используются следующим образом. Объект LLC может выдать команду (бит C/R = 0) XID или TEST. Принимающий объект LLC выдает соответствующую команду XID или TEST в ответ. PDU XID используется для обмена информацией двух типов: о поддерживаемых режимах и о размере окна. PDU TEST используется для проведения теста канала передачи данных между двумя объектами LLC методом обратной петли. После получения команды TEST целевой объект LLC должен кап можно быстрее ответить PDU TEST.

В режиме работы 2 соединение с использованием канала передачи данных устанавливается между двумя SAP LLC до обмена данными. Протокол режима 2 пытается установить соединение в ответ на запрос пользователя. Объект LLC выдает PDU SABME2 для запроса логического соединения с другим объектом LLC. Если соединение принято пользователем LLC, указанным точкой DSAP, то целевой объект LLC возвращает PDU с ненумерованным подтверждением (unnumbered acknowledgment — UA). С этого момента соединение уникально определяется парой пользовательских SAP. Если целевой пользователь LLC отклоняет запрос на установление соединения, объект LLC возвращает PDU режима разрыва (disconnected mode — DM).

После установления соединения обмен данными, как и в протоколе HDLC, выполняется посредством информационных PDU. Эти PDU включают порядковые номера приема и передачи, необходимые для упорядочения потока и управления им. PDU управления используются, как и в протоколе HDLC, для управления потоком и защиты от ошибок. Любой объект LLC может разорвать логическое соединение, передав PDU разрыва соединения (disconnect — DISC).

При режиме работы 3 каждый переданный PDU подтверждается. В отличие от протокола HDLC, в LLC определен новый ненумерованный модуль PDU, информационный PDU с подтверждением без организации соединения (Acknowledged Connectionless — АС). Пользовательские данные передаются в командных модулях PDU АС, и их прием должен подтверждаться с использованием отклика PDU АС. Для защиты от потери PDU используется 1-битовый порядковый номер. Отправитель чередует 0 и 1 в передаваемых командных PDU АС, а приемник отвечает PDU АС с номерами, противоположными соответствующим командным PDU. В каждый момент времени в обращении может находиться не более одного PDU с каждой стороны.


Беспроводные сети. Современное состояние и перспективы развития. 5.2 АРХИТЕКТУРА И УСЛУГИ IEEE 802.11

5.2 АРХИТЕКТУРА И УСЛУГИ IEEE 802.11

Работу по стандартизации беспроводных локальных сетей в комитете IEEE 802 начала в 1987 году группа IEEE 802.4. Изначально планировалось разработать беспроводную локальную сеть, являющуюся эквивалентом шинного протокола MAC с передачей маркера, функционирующую в диапазоне ISM. После некоторой работы было признано, что шинная топология с передачей маркера является не самой удачной схемой для радиопередачи с точки зрения эффективного использования спектра радиочастот. В 1990 году было принято решение о создании новой рабочей группы IEEE 802.11, задачей которой стало рассмотрение беспроводных локальных сетей и которая получила право разрабатывать спецификации протокола MAC и физической среды. Ключевые термины, фигурирующие в стандартах IEEE 802.11, перечислены в табл. 5.1.

Таблица 5.1 Терминология IEEE 802.11

Базовый набор услуг (basic service set - BBS) | Набор станций, которыми управляет одна координационная функция
Координационная функция | Логическая функция, определяющая, когда станция может передавать и получать PDU
Модуль данных протокола MAC (MPDU) | Модуль данных, которым обмениваются два одноранговых объекта MAC, используя услуги физического уровня
Модуль данных службы MAC (MSDU) | Информация, передаваемая единим блоком между пользователями MAC
Распределительная система (distribution system set - DS) | Система, которая используется для соединения нескольких базовых наборов услуг и интеграции локальной сети в расширенный набор услуг
Расширенный набор услуг (extended service set - ESS) | Две или большее число базовых наборов услуг, соединенных распределительной системой. Для уровня управления логическим каналом (logical link control — LLC) расширенный набор услуг представляется единой логической локальной сетью
Станция | Любое устройство, физический уровень и МАС-уровень которого соответствуют стандарту IEEE 802.11
Точка доступа (access point - AP) | Любой объект, обладающий функциональными возможностями станции и обеспечивающий доступ соотнесенных с ним станций к распределительной системе посредством беспроводной среды

Архитектура IEEE 802.11

На рис. 5.4 показана модель, разработанная рабочей группой 802.11. Элементарной структурной единицей беспроводной локальной сети является базовый набор услуг (basic service set — BSS), который состоит из нескольких станций, реализующих одинаковый протокол MAC и состязающихся за доступ к одной совместно используемой среде. BSS может быть изолирован или соединен с магистральной распределительной системой через точку доступа. Точка доступа в этой ситуации играет роль моста. Протокол MAC может быть полностью распределенным или управляемым центральной координационной функцией, размещенной в точке доступа. Базовый набор услуг обычно соответствует тому, что в литературе называют ячейкой. Распределительная система может быть коммутатором, проводной или беспроводной сетью.

На рис. 5.4 показана простейшая конфигурация, при которой каждая станция принадлежит к одному BSS; т.е. каждая станция находятся в пределах досягаемости только станций того же BSS. Диапазоны охвата BSS могут перекрываться (географически), так что одна станция может входить в несколько BSS. Более того, соотнесение станции и BSS является динамическим. Станции могут отключаться, выходить из диапазона охвата и входить в этот диапазон.

Расширенный набор услуг (extended service set — ESS) состоит из двух или большего числа базовых наборов услуг, соединенных распределительной системой. Обычно в качестве распределительной системы выступает проводная магистральная локальная сеть. Для уровня управления логическим каналом (logical link control — LLC) расширенный набор услуг представлен единой логической локальной сетью.

На рис. 5.4 показано, что точка доступа (access point — АР) реализуется как часть станции. Точка доступа — это логика в пределах станции, обеспечивающая доступ к распределительной системе путем предоставления ей услуг; кроме того, точка действует как станция. Для интеграции архитектуры IEEE 802.11 с традиционной проводной локальной сетью используется портал. Логика портала реализуется в устройстве, таком, как мост или маршрутизатор, являющемся частью проводкой локальной сети и присоединенном к распределительной системе.

Рисунок 5.4 - Архитектура IEEE 802.11

Услуги IEEE 802.11

Группа IEEE 802.11 определила девять услуг, которые должна предлагать беспроводная локальная сеть для обеспечения функциональных возможностей проводной сети. Данные услуги перечислены в табл. 5.2, там также представлены два способа группировки этих услуг.

Таблица 5.2 Услуги IEEE 802.11

Услуга | Поставщик | Объект поддержки
Ассоциация | Распределительная система | Доставка MSDU
Аутентификация | Станция | Доступ к ЛВС и безопасность
Доставка MSDU | Станция | Доставка MSDU
Интеграция | Распределительная система | Доставка MSDU
Конфиденциальность | Станция | Доступ к ЛВС и безопасность
Отмена аутентификации | Станция | Доступ к ЛВС и безопасность
Повторная ассоциация | Распределительная система | Доставка MSDU
Разрыв ассоциации | Распределительная система | Доставка MSDU
Распределение | Распределительная система | Доставка MSDU

1. Поставщиком услуги может быть либо станция, либо распределительная система (DS). Услуги станций реализуются на каждой станции 802.11, в том числе на станциях, являющихся точками доступа (АР). Услуги распределительных систем предлагаются между базовыми наборами услуг (BSS); эти услуги могут реализовываться на точках доступа или на других специализированных устройствах, присоединенных к распределительной системе.

2. Для управления доступом к ЛВС и безопасностью используются три услуги. Еще шесть услуг используются для поддержки доставки модулей данных службы MAC (MSDU) от станции к станции. MSDU — это блок данных, передаваемых пользователем MAC на уровень MAC; обычно это PDU уровня LLC. Если модуль MSDU чересчур большой для передачи одним кадром MAC, его можно фрагментировать и передать в последовательности кадров MAC. Вопросы фрагментации рассмотрены в разделе 5.3.

Приведенные ниже услуги описаны так, как они определены в документах IEEE 802.11, причем выбран такой порядок их рассмотрения, чтобы была максимально понятна работа сети IEEE 802.11. Основная служба, именуемая доставкой MSDU, рассматривалась выше.

Распределение сообщений в пределах распределительной системы

В распределении сообщений в пределах DS задействованы две услуги: распределение и интеграция. Распределение — это основная услуга, используемая станциями для обмена МАС-кадрами, когда кадр должен пройти через распределительную систему, чтобы проследовать от станции из одного BSS к станции, находящейся в другом BSS. Предположим, например, что требуется доставить кадр от станции 2 (STA2) к станции 7 (STA7) (рис. 5.4). Кадр передается от STA2 к STA1, которая для данного BSS является точкой доступа. Точка доступа передает кадр распределительной системе, которая должна направить кадр к точке доступа (STA5) целевого BSS. STA5 получает кадр и передает его STA7. Как сообщение передается через распределительную систему, в стандарте IEEE 802.11 не описывается.

Если две станции сообщаются в пределах одного BSS, услуга распределения предоставляется точкой доступа этого BS8. Услуга интеграции позволяет передавать данные между станцией локальной сети IEEE 802.11 и станцией интегральной локальной сети IEEE 802.x. Термином интегральная называется проводная локальная сеть, физически соединенная с распределительной системой, причем станции этой сети могут логически соединяться с локальной сетью IEEE 802.11 посредством услуги интеграции. Услуга интеграции разрешает все вопросы, связанные с логикой трансляции адресов и преобразований среды, требуемых для обмена данными.

Услуги, связанные с ассоциацией

Основной задачей уровня MAC является передача модулей MSDU между объектами MAC; выполняет эту задачу распределительная система, для функционирования которой требуется информация о станциях в пределах ESS. Эта информация поставляется услугами, связанными с ассоциацией. Перед тем как распределительная система сможет передавать или принимать информацию станции, требуется установить ассоциацию. Данную концепцию мы рассмотрим немного позже,; пока необходимо описать понятие мобильности. На основе мобильности станций в стандарте определены три типа переходов.

• Без перехода. Станция либо стационарна, либо перемещается в пределах досягаемости станций, принадлежащих к тому же BSS.

• Переход BSS. Переход станции из одного BSS в другой в пределах одного ESS. В этом случае для доставки данных требуется найти новое местоположение станции.

• Переход ESS. Перемещение стации из ВSS одного ESS в BSS другого ESS. Переход этого типа поддерживается только в том смысле, что станция может двигаться. Сохранность соединений высшего уровня, поддерживаемых сетью 802.11, гарантировать нельзя. Фактически наиболее вероятным следствием подобного перехода является разрыв услуги.

Для доставки сообщений в пределах распределительной системы услуге распределения должно быть известно, где расположена станция-адресат. В частности, распределительная система должна знать, какая станция выступает в роли точки доступа, т.е. кому передавать сообщения, предназначенные станции-адресату. Для удовлетворения этого требования станция должна поддерживать ассоциацию с точкой доступа в пределах текущего BSS. С этим требованием связаны три услуги.

• Ассоциация. Установление первоначальной ассоциации между станцией и точкой доступа. Перед тем как станция начнет передавать или получать кадры в беспроводной локальной сети, ее нужно идентифицировать. Для этого станция должна установить ассоциацию с точкой доступа в пределах конкретного BSS. Затем эта точка доступа может передать необходимую информацию о станции остальным точкам доступа данного ESS, что облегчит будущую маршрутизацию и адресную доставку.

• Повторная ассоциация. Разрешает передавать установленную ассоциацию между точками доступа, позволяя мобильной станции перемещаться между наборами BSS.

• Разрыв ассоциации. Уведомление от станции или точки доступа об аннуляции существующей ассоциации. Станция должна получить это уведомление до выхода из ESS или отключения. В то же время средство управления MAC защищено от станций, которые исчезают без уведомления.

Услуги доступа и безопасности

Существуют две характеристики проводной локальной сети, отличающие ее от беспроводной.

1. Для передачи по проводной ЛВС станция должна быть физически соединена с этой сетью. С другой стороны, в беспроводной сети передавать может любая станция, находящаяся в пределах радиосвязи других устройств. В определенном смысле в проводной сети имеется некоторая разновидность аутентификации — для соединения с сетью станция должна выполнить кое-какие предопределенные действия.

2. Подобным образом, для приема передачи от станции, принадлежащей проводной локальной сети, принимающая станция должна также быть присоединена к проводной сети. С другой стороны, в беспроводной сети принимать может любая станция, находящаяся в пределах радиосвязи других устройств. Таким образом, проводная ЛВС обеспечивает некоторую конфиденциальность, ограничивая .число возможных получателей сообщения станциями, соединенными с сетью.

Поскольку беспроводная локальная сеть не имеет данных характеристик, в стандарте IEEE 802.11 определены следующие услуги.

• Аутентификация. Используется для идентификации станций. В проводной ЛВС обычно предполагается, что доступ к физическому соединению дает право на связь с ЛВС. Это предположение не является верным для беспроводных сетей, где связность устройств обуславливается простым наличием антенны, настроенной соответствующим образом. Услуга аутентификации используется станциями для идентификации себя в среде уже сообщающихся станций. В IEEE 802.11 определены несколько схем аутентификации, имеется также возможность расширения этих схем. Стандарт не навязывает никакой обязательной схемы, поэтому может использоваться как относительно небезопасная схема квитирования, так и весьма надежная схема шифрования с открытым ключом. При этом, правда, требуется взаимно приемлемая, успешная аутентификация, только после которой станция может устанавливать ассоциацию с точкой доступа.

• Отмена аутентификации. Эта услуга используется при аннуляции существующей аутентификации.

• Конфиденциальность. Предотвращает чтение сообщения теми, кому оно не предназначено. Для обеспечения конфиденциальности стандарт предлагает (но не навязывает) использовать шифрование, согласно алгоритму WEP, который рассмотрен в разделе 5.3.


Беспроводные сети. Современное состояние и перспективы развития. 5.3 УПРАВЛЕНИЕ ДОСТУПОМ К СРЕДЕ В IEEE 802.11

5.3 УПРАВЛЕНИЕ ДОСТУПОМ К СРЕДЕ В IEEE 802.11

Уровень MAC стандарта IEEE 802.11 охватывает три функциональные области: надежную доставку данных, управление доступом и безопасность. Все они подробно рассмотрены ниже.

Надежная доставка данных

Как и в любой беспроводной сети, физический уровень и МАС-уровень сети IEEE 802.11 довольно ненадежны. Шум, интерференция и другие эффекты распространения приводят к потере большого числа кадров. Даже при использовании кодов с коррекцией ошибок успешно принять удается не все кадры MAC. Решение данной проблемы можно поручить вышестоящему уровню, такому, как TCP. В то же время использовать таймеры повторной передачи высших уровней — это терять порядка нескольких секунд. Следовательно, обработку ошибок эффективнее производить на уровне MAC. С этой целью в стандарте IEEE 802.11 определен протокол обмена кадров. Когда станция получает от другой станции информационный кадр, она возвращает исходной станции кадр подтверждения (acknowledgement — АСК). Данный сеанс считается элементарным актом, который не должен прерываться передачей другой станции. Если станция не получает кадра АСК в течение короткого периода времени (либо по причине повреждения информационного кадра, либо вследствие повреждения подтверждения), источник передает кадр повторно.

Таким образом, базовый механизм передачи в стандарте IEEE 802.11 включает обмен двумя кадрами. Для дальнейшего повышения надежности может использоваться обмен четырьмя кадрами. В этой схеме источник вначале передает запрос на передачу (request to send — RTS). Адресат отвечает кадром "готов к приему" (clear to send — CTS). После приема кадра CTS источник передает кадр данных, а адресат отвечает подтверждением (АСК). Кадр RTS оповещает все станции в пределах области приема исходной станции, что происходит обмен информацией; все станции, принявшие этот кадр, воздерживаются от передачи, чтобы избежать конфликта вследствие одновременной передачи двух кадров. Подобным образом, кадр CTS оповещает все станции, находящиеся в пределах области приема адресата, что происходит обмен информацией. В заключение отметим, что кадры RTS/CTS требуются MAC, но их использование можно заблокировать.

Управление доступом к среде в IEEE 802.11

Рабочая группа 802.11 рассмотрела два типа предложенных алгоритмов MAC: протоколы распределенного доступа, которые, подобно Ethernet, распределяют решение относительно передачи по всем узлам, используя для этого механизм детектирования несущей; протоколы централизованного доступа, которые включают регулирование передачи централизованным средством принятия решений. Протокол распределенного доступа имеет смысл использовать в эпизодических сетях равноправных рабочих станций, его также целесообразно применять в других беспроводных конфигурациях, трафик в которых носит преимущественно пульсирующий характер. Централизованный протокол доступа естественным образом подходит для конфигураций, в которых несколько беспроводных станций связаны между собой и имеется также определенная базовая станция, подключенная к магистральной проводной локальной сети; особенно полезны такие протоколы, если некоторые данные требуют немедленного реагирования или имеют высокий приоритет.

Конечным результатом работы комитета 802.11 является алгоритм MAC, называемый DFWMAC (distributed foundation wireless MAC — распределенный основной беспроводный протокол MAC), предоставляющий механизм распределенного управления доступом с возможным надстроенным централизованным управлением. На рис. 5.5 показана соответствующая архитектура. Нижний подуровень уровня MAC представляет собой распределенную координационную функцию (distributed coordination function — DCF). DCF использует алгоритм состязания для обеспечения доступа ко всему информационному потоку. Обычный асинхронный информационный поток напрямую использует DCF. Точечная координационная функция (point coordination function — PCF) — это централизованный алгоритм управления доступом к среде, используемый для обеспечения бесконфликтного обслуживания. PCF надстраивается над DCF и использует функции DCF для обеспечения доступа всем пользователям. Ниже последовательно рассматриваются оба названных подуровня.

Рисунок 5.5 - Протокольная архитектура IEEE 802.11

Распределенная координационная функция

Подуровень DCF использует простой алгоритм CSMA. Если станция имеет готовый к передаче кадр MAC, она прослушивает среду. Если среда свободна, станция может передавать; в противном случае стация должна подождать, пока не завершится текущая передача, а лишь затем передавать. DCF не содержит функций обнаружения конфликтов (например, CSMA/CD), поскольку обнаружение конфликтов в беспроводной среде непрактично. Динамический диапазон сигналов в среде очень велик, так что передающая станция не может эффективно отличить поступающий слабый сигнал от шума и результатов собственной передачи.

Для обеспечения бесперебойной и ровной работы описанного алгоритма подуровень DCF включает набор задержек, которые эквивалентны схеме приоритетов. Рассмотрим вначале отдельную задержку, называемую межкадровым промежутком (interframe space — IFS). На самом деле существует три различных значения IFS, но действие алгоритма более понятно, если вначале проигнорировать эти детали. Использование IFS следующим образом меняет правила доступа алгоритма CSMA (рис. 5.6).

1. Станция, имеющая готовые к передаче кадры, прослушивает среду. Если среда свободна, станция ожидает, будет ли среда свободна в течение времени IFS. Если да, то станция может передавать немедленно.

2. Если среда занята (либо была занята на начало прослушивания, либо стала занятой за время IFS), станция откладывает передачу и продолжает наблюдать за средой, пока не будет завершена текущая передача.

3. Как только будет завершена текущая передача, станция выдерживает еще один промежуток времени IFS. Если в течение этого времени среда остается свободной, станция освобождает среду и снова прослушивает ее. Если среда по-прежнему остается свободной, станция может начинать передачу. Если в течение времени отсрочки среда занимается, таймер отсрочки останавливается и запускается после освобождения среды.

Для обеспечения устойчивости схемы используется метод двоичной экспоненциальной отсрочки. Станция постоянно пытается начать передачу, каждый раз сталкиваясь с конфликтом, но после каждого конфликта среднее время случайной задержки удваивается. Двоичная экспоненциальная отсрочка позволяет справиться со значительной нагрузкой. Постоянные попытки передачи, заканчивающиеся конфликтами, приводят к увеличению времени ожидания, что, в свою очередь, сглаживает нагрузку. Без подобной отсрочки может произойти следующее: две или более станции одновременно пытаются начать передачу, что приводит к конфликту, станции немедленно пытаются передать данные повторно, возникает новый конфликт и т.д.

Рисунок 5.6 - Логика управления доступом к среде стандарта IEEE 802.11

Для создания схемы, подобной алгоритму доступа с использованием приоритетов, описанная схема несколько уточняется, для чего вводятся три значения IFS.

• SIFS (short IFS — краткий IFS). Минимальный IFS, используемый для всех немедленных ответных действий, как будет объяснено далее.

• PIFS (point coordination function IFS — IFS точечной координационной функции). IFS среднего размера, используемый централизованным средством управления в схеме PCF при организации опроса.

• DIFS (distributed coordination function IFS — IFS распределенной координационной функции). Наибольший IFS, используемый как минимальная задержка для асинхронных кадров, состязающихся за доступ.

На рис. 5.7, а показано использование описанных временных промежутков, рассмотрим вначале SIFS. Каждая станция, использующая SIFS для определения возможности передачи, имеет, по сути, наивысший приоритет, поскольку при получении доступа она всегда имеет преимущество перед станцией, ожидающей в течение времени PIFS или DIFS. SIFS используется в следующих ситуациях.

Рисунок 5.7 - Временная диаграмма управления доступом к среде IEEE 802.11

• Подтверждение (acknowledgment — АСК). Когда станция получает кадр, адресованный только ей (т.е. имеем не групповую или широковещательную передачу), она отвечает кадром АСК после ожидания только в течение времени SIFS. Получаем два желательных результата. Во первых, поскольку не используется обнаружение конфликтов, вероятность их возникновения больше, чем в схеме CSMA/CD, а подтверждение на уровне MAC обеспечивает эффективное восстановление после ошибок. Во-вторых, SIFS может использоваться для обеспечения эффективной доставки модуля данных протокола (protocol data unit — PDU) LLC, которая требует нескольких кадров MAC. В этом случае имеем следующий сценарий. Станция с готовым к передаче многокадровым PDU LLC последовательно передает кадры MAC. Каждый кадр подтверждается получателем по прошествии времени SIFS. Когда станция-источник получает кадр АСК, она немедленно (по прошествии времени SIFS) посылает следующий кадр последовательности. В результате как только станция захватывает контроль над каналом, она будет его удерживать до окончания передачи всех фрагментов PDU LLC.

• "Свободен для передачи" (clear to send — CTS). Станция может гарантировать доставку своего кадра, выпустив небольшой кадр RTS (Request to Send — запрос на передачу). Станция, которой адресован этот кадр, должна немедленно ответить кадром CTS, если она готова к приему. Все остальные станции получают кадр RTS и выжидают, используя среду, пока не увидят соответствующий кадр CTS или пока не истечет предопределенное время ожидания.

• Ответ на опрос (poll response). Этот момент будет объяснен позднее, при рассмотрении PCF.

Следующим по размеру интервалом IFS является PIFS. Он используется централизованным средством управления при организации упорядоченных опросов и имеет преимущество перед обычным конкурирующим информационным потоком. В то же время кадры, переданные с использованием SIFS, имеют преимущество перед опросом PCF.

И последний интервал, DIFS, используется для организации обычного асинхронного информационного потока.

Точечная координационная функция

PCF — это альтернативный метод доступа, реализованный на один уровень выше DCF. Его работа заключается в опросе, производимом централизованным мастером опроса (точечным координатором). Точечный координатор используется PIFS при отправке запросов. Поскольку время PIFS меньше времени DIFS, точечный координатор может захватывать среду и блокировать асинхронный поток информации на время отправки запросов и получения ответов.

Рассмотрим следующий предельный случай. Беспроводная сеть сконфигурирована так, что несколько станций с чувствительным ко времени информационным потоком контролируются точечным координатором, тогда как оставшийся поток состязается за доступ с использованием CSMA. Точечный координатор может циклически выпускать запросы ко всем станциям, сконфигурированным для упорядоченного опроса. При запуске запроса опрашиваемая станция может ответить, используя SIFS. Если точечный координатор получает ответ, он выпускает другой запрос, используя PIFS. Если в течение предопределенного времени не получено отклика, координатор выпускает запрос.

Если был реализован порядок, описанный в предыдущем абзаце, точечный координатор может заблокировать весь асинхронный поток, выпуская повторные запросы. Для предотвращения блокировки определяется интервал, известный как суперкадр (superframe). В течение первой части этого интервала точечный координатор циклически выпускает запросы ко всем станциям, сконфигурированным для упорядоченного опроса. Затем точечный координатор выключается на оставшееся время, давая возможность станциям посоревноваться за асинхронный доступ.

Использование суперкадра показано на рис. 5.7, б. В начале суперкадра точечный координатор может захватить управление и выпускать запросы в течение данного периода времени. Этот промежуток переменный, поскольку опрашиваемые станции выпускают кадры переменного размера. К оставшейся части суперкадра имеется доступ, определяемый состязанием. В конце интервала суперкадра точечный координатор состязается за доступ к среде, используя PIFS. рели среда свободна, точечный координатор получает немедленный доступ, и Начинается новый период суперкадра. Однако среда может быть занята в конце периода суперкадра. В этом случае точечный координатор должен подождать, пока среда не освободится, и лишь затем получить доступ; в результате сокращается период суперкадра на следующий цикл.

Кадр MAC

На рис. 5.8, а изображен формат кадра 802.11. Приведенная общая структура Используется для всех информационных и управляющих кадров, хотя не все портя используются во всех случаях. Перечислим поля общего кадра.

Рисунок 5.8 - Формат кадра MAC IEEE 802.11

• Управление кадром. Указывается тип кадра и предоставляется управляющая информация (объясняется ниже).

• Идентификатор длительности/соединения. Если используется поле длительности, указывается время (в микросекундах), на которое требуется выделить канал для успешной передачи кадра MAC. В некоторых кадрах управления в этом поле указывается идентификатор ассоциации, или соединения.

• Адреса. Число и значение полей адреса зависит от контекста. Возможны следующие типы адреса: источника, назначения, передающей станции, принимающей станции.

• Управление очередностью. Содержит 4-битовое подполе номера фрагмента, используемое для фрагментации и повторной сборки, и 12-битовый порядковый номер, используемый для нумерации кадров, передаваемых между данными приемником и передатчиком.

• Тело кадра. Содержит модуль MSDU или фрагмент MSDU. В данном случае MSDU — это модуль данных протокола LLC или управляющая информация MAC.

• Контрольная последовательность кадра. 32-битовая проверка четности с избыточностью.

Поле управления кадром, показанное на рис. 5.8, б, состоит из следующих полей.

• Версия протокола. Версия 802.11, текущая версия — 0.

• Тип. Определим тип кадра: контроль, управление или данные.

• Подтип. Дальнейшая идентификация функций кадра. Разрешенные сочетания типов и подтипов перечислены в табл. 5.3.

Значение типа | Описание типа | Значение подтипа | Описание
00 | Управление | 0000 | Запрос ассоциации
00 | Управление | 0001 | Ответ на запрос ассоциации
00 | Управление | 0010 | Запрос повторной ассоциации
00 | Управление | 0011 | Ответ на запрос повторной ассоциации
00 | Управление | 0100 | Пробный запрос
00 | Управление | 0101 | Ответ на пробный запрос
00 | Управление | 1000 | Сигнальный кадр
00 | Управление | 1001 | Объявление наличия трафика
00 | Управление | 1010 | Разрыв ассоциации
00 | Управление | 1011 | Аутентификация
00 | Управление | 1100 | Отмена аутентификации
01 | Контроль | 1010 | PS-опрос
01 | Контроль | 1011 | Запрос передачи
01 | Контроль | 1100 | "Готов к передаче"
01 | Контроль | 1101 | Подтверждение
01 | Контроль | 1110 | Без состязания (CF)-конец
01 | Контроль | 1111 | CF-конец + CF-подтверждение
10 | Данные | 0000 | Данные
10 | Данные | 0001 | Данные + CF-подтверждение
10 | Данные | 0010 | Данные + CF-опрос
10 | Данные | 0011 | Данные + CF-подтверждение + CF-опрос
10 | Данные | 0100 | Нулевая функция (без данных)
10 | Данные | 0101 | Данные + CF-подтверждение
10 | Данные | 0110 | Данные + CF-опрос
10 | Данные | 0111 | Данные + CF-подтверждение + CF-опрос

• К DS. Координационная функция MAC присваивает этому биту значение 1, если кадр предназначен распределительной системе.

• От DS. Координационная функция MAC присваивает этому биту значение О, если кадр исходит от распределительной системы.

• Больше фрагментов. 1, если за данным фрагментом следует еще несколько.

• Повтор. 1, если данный кадр является повторной передачей предыдущего.

• Управление мощностью. 1, если передающая станция находится в режиме ожидания.

• Больше данных. Указывает, что станция передала не все данные. Каждый блок данных может передаваться как один кадр или как группа фрагментов в нескольких кадрах.

• WEP. 1, если реализован алгоритм конфиденциальности проводного эквивалента (wired equivalent privacy — WEP). Протокол WEP используется для обмена ключами шифрования при безопасном обмене данными.

• Порядок. 1, если используется услуга строгого упорядочения, указывающая адресату, что кадры должны обрабатываться строго по порядку.

Рассмотрим теперь различные типы кадров MAC.

Контрольные кадры

Контрольные кадры способствуют надежной доставке информационных кадров. Существует шесть подтипов контрольных кадров.

• Опрос после выхода из экономичного режима (PS-опрос). Данный кадр передается любой станцией станции, включающей точку доступа. В кадре запрашивается передача кадра, прибывшего, когда станция находилась в режиме энергосбережения, и в данный момент размещенного в буфере точки доступа.

• Запрос передачи (RTS). Данный кадр является первым из четверки, используемой для обеспечения надежной передачи данных (см. начало раздела 5.3). Станция, пославшая это сообщение, предупреждает адресата и остальные станции, способные принять данное сообщение, о своей попытке передать адресату информационный кадр.

• "Готов к передаче" (CTS). Второй кадр четырехкадровой схемы. Передаете я станцией-адресатом станции-источнику и предоставляет право отправки информационного кадра.

• Подтверждение (АСК). Подтверждение успешного приема предыдущих данных, кадра управления или кадра PS-опрос.

• Без состязания(СР)-конец. Объявляет конец периода без состязания; часть стратегии использования точечной координационной функции.

• CF-конец + CF-подтверждение. Подтверждает кадр CF-конец. Данный кадр завершает период без состязания и освобождает станции от ограничений, связанных с этим периодом.

Информационные кадры

Существует восемь подтипов информационных кадров, собранных в две группы. Первые четыре подтипа определяют кадры, переносящие данные высших уровней от исходной станции к станции-адресату. Перечислим эти кадры.

• Данные. Просто информационный кадр. Может использоваться как в пери од состязания, так и в период без. состязания.

• Данные + CF-подтверждение. Может передаваться только в период без состязания. Помимо данных в этом кадре имеется подтверждение полученной ранее информации.

• Данные + CF-опрос. Используется точечным координатором для доставки данных к мобильной станции и для запроса у мобильной станции информационного кадра, который находится в ее буфере.

• Данные + CF-подтверждение + CF-опрос. Объединяет в одном кадре функции двух описанных выше кадров.

Остальные четыре подтипа информационных кадров фактически не переносят данных пользователя. Информационный кадр "нулевая функция" не переносит ни данных, ни запросов, ни подтверждений. Он используется только для передачи точке доступа бита управления питанием в поле управления кадром, указывая, что станция перешла в режим работы с пониженным энергопотреблением. Оставшиеся три кадра (CF-подтверждение, CF-опрос, CF-подтверждение + CF-опрос) имеют те же функции, что и описанные выше подтипы кадров (данные + CF-подтверждение, данные + CF-опрос, данные + CF-подтверждение + CF-опрос), но не несут пользовательских данных.

Кадры управления

Кадры управления используются для управления связью станций и точек доступа. Возможны следующие подтипы.

• Запрос ассоциации. Посылается станцией к точке доступа с целью запроса ассоциации с данным BSS. Кадр включает информацию о возможностях, например, будет ли использоваться шифрование, или способна ли станция отвечать при опросе.

• Ответ на запрос ассоциации. Возвращается точкой доступа и указывает, что запрос ассоциации принят.

Запрос повторной ассоциации. Посылается станцией при переходе между BSS, когда требуется установить ассоциацию с точкой доступа в новом BSS. Использование повторной ассоциации, а не просто ассоциации позволяет новой точке доступа договариваться со старой о передаче информационных кадров по новому адресу.

Ответ на запрос повторной ассоциации. Возвращается точкой доступа и указывает, что запрос повторной ассоциации принят.

• Пробный запрос. Используется станцией для получения информации от другой станции или точки доступа. Кадр используется для локализации BSS стандарта IEEE 802.11.

• Ответ на пробный запрос. Отклик на пробный запрос.

• Сигнальный кадр. Передается периодически, позволяет мобильным станциям локализировать и идентифицировать BSS.

• Объявление наличия трафика. Посылается мобильной станцией с целью уведомления других (которые могут находиться в режиме пониженного энергопотребления), что в буфере данной станции находятся кадры, адресованные другим.

• Разрыв ассоциации. Используется станцией для аннуляции ассоциации.

• Аутентификация. Как объясняется ниже, для аутентификации станций используются множественные кадры.

• Отмена аутентификации. Передается для прекращения безопасного соединения.

Вопросы безопасности

Стандарт IEEE 802.11 предлагает и механизм конфиденциальности, и механизм аутентификации.

Алгоритм конфиденциальности проводного эквивалента

В беспроводной локальной сети вопрос прослушивания имеет особую важность — ведь уловить передачу так просто! Для обеспечения современного уровня безопасности стандарт IEEE 802.11 включает схему WEP. Для обеспечения конфиденциальности (а также целостности данных) используется алгоритм, основанный на алгоритме шифрования RC4.

На рис. 5.9 представлен процесс шифрования. Алгоритм обеспечения целостности — это простая 32-битовая последовательность циклической проверки четности с избыточностью (CRC), присоединяемая к концу кадра MAC (рис. 5.8, а). Для процесса шифрования 40-битовый секретный ключ делится между двумя сообщающимися сторонами. К секретному ключу присоединяется вектор инициализации (IV). Получившийся блок — это начальное число генератора псевдослучайной последовательности (PRNG), определенного в RC4. Генератор создает последовательность битов, длина которой равна длине кадра MAC плюс CRC. Побитовое применение операции исключающего ИЛИ к кадру MAC и псевдослучайной последовательности дает шифрованный текст. К данному тексту присоединяется вектор инициализации, и результат передается. Вектор инициализации периодически меняется (при каждой новой передаче), следовательно, меняется и псевдослучайная последовательность, что усложняет задачу расшифровки перехваченного текста.

Рисунок 5.9 - Формат кадра MAC IEEE 802.11

После получения сообщения (рис. 5.9, б) приемник извлекает вектор инициализации и присоединяет его к совместно используемому секретному ключу, после его генерирует ту же псевдослучайную последовательность, что и источник. К поученному таким образом ключу и поступившим данным побитово применяется операция исключающего ИЛИ, результатом которой является исходный текст. Данный алгоритм основан на следующем свойстве исключающего ИЛИ:

A [image] B [image] B = A

Таким образом, если взять исходный текст, применить к нему и ключевой последовательности операцию исключающего ИЛИ, а затем применить операцию исключающего ИЛИ к результату и той же ключевой последовательности, то в итоге получится исходный текст. В заключение приемник сравнивает поступившую последовательность CRC и CRC, вычисленную по восстановленным данным: :ли величины совпадают, данные считаются неповрежденными.

Аутентификация

Стандарт IEEE 802.11 предлагает два типа аутентификации: "открытая система" и "общий ключ". Аутентификация открытых систем просто позволяет двум сторонам договориться о передаче данных без рассмотрения вопросов безопасности. В этом случае одна станция передает другой управляющий кадр MAC, именуемый кадром аутентификации. В данном кадре указывается, что имеет место аутентификация открытых систем. Другая сторона отвечает собственным кадром аутентификации — и процесс завершен. Таким образом, при аутентификации открытых систем стороны просто обмениваются информацией о себе. Аутентификация с общим ключом требует, чтобы две стороны совместно владели секретным ключом, не доступным третьей стороне. Процедура аутентификации между двумя сторонами, А и В, выглядит следующим образом.

1. А посылает кадр аутентификации, в котором указан тип "общий ключ" и ; идентификатор станции, определяющий станцию-отправителя.

2. В отвечает кадром аутентификации, который включает 128-октетный текст запроса. Текст запроса создается с использованием генератора случайных чисел WEP. Ключ и вектор инициализации, используемые при генерации текста запроса, не важны, поскольку далее в процедуре они не используются.

3. А передает кадр аутентификации, который включает полученный от В текст запроса. Кадр шифруется с использованием схемы WEP.

4. В получает зашифрованный кадр и дешифрует его, используя WEP и секретный ключ, которым владеют А и В. Если дешифрование»прошло успешно (совпали CRC), В сравнивает принятый текст запроса с текстом, который был послан на втором этапе процедуры. После этого В передает А сообщение аутентификации, содержащее код состояния (успех или неудача).


Беспроводные сети. Современное состояние и перспективы развития. 5.4 ФИЗИЧЕСКИЙ УРОВЕНЬ IEEE 802.11

5.4 ФИЗИЧЕСКИЙ УРОВЕНЬ IEEE 802.11

Спецификация физического уровня стандарта IEEE 802.11 выпускалась в три этапа: первая часть увидела свет в 1997 году, остальные две — в 1999. Первая часть, именуемая просто IEEE 802.11, включала описание уровня MAC и три спецификации физического уровня — две в диапазоне 2,4 ГГц и одну в инфракрасном диапазоне, — работающие при скоростях 1 и 2 Мбит/с. Спецификация IEEE 802а — это полоса 5 ГГц и скорость до 54 Мбит/с; IEEE 802.b — 2,4 ГГц и 5,5 и 11 Мбит/с, соответственно. Все спецификации последовательно изучаются ниже.

Исходный физический уровень IEEE 802.11

В исходном стандарте 802.11 были определены три физические среды передачи.

• Спектр, расширенный методом прямой последовательности. Полоса ISM 2,4 ГГц, скорость передачи данных 1 или 2 Мбит/с.

• Спектр, расширенный методом скачкообразной перестройки частоты. Полоса ISM 2,4 ГГц, скорость передачи данных 1 или 2 Мбит/с.

• Инфракрасный диапазон (длина волны 850-950 нм). Скорость передачи данных 1 или 2 Мбит/с.

Ключевые элементы спецификаций перечислены в табл. 5.4.

Таблица 5.4 Спецификации физического уровня IEEE 802.11

а) Расширение спектра методом прямой последовательности
Скорость передачи данных | Длина раздробленного кода |  | Модуляция | Скорость передачи символов | Бит/символ
1 Мбит/с | 11 (последовательность Баркера) |  | DBPSK | 1 млн. символов/с | 1
2 Мбит/с | 11 (последовательность Баркера) |  | DQPSK | 1 млн. символов/с | 2
5,5 Мбит/с | 8 (ССК) |  | DBPSK | 1,375 млн. символов/с | 4
11 Мбит/с | 8 (ССК) |  | DQPSK | 1,375 млн. символов/с | 8
б). Расширение спектра методом скачкообразной перестройки частоты
Скорость передачи данных | Модуляция |  | Скорость передачи символов |  | Бит/символ
1 Мбит/с | Двухуровневая GFSK |  | 1 млн. символов/с |  | 1
2 Мбит/с | Четырехуровневая GFSK |  | 1 млн. символов/с |  | 2
в). Передача в инфракрасном диапазоне
Скорость передачи данных | Модуляция |  | Скорость передачи символов |  | Бит/символ
1 Мбит/с | 16-РРМ |  | 4 млн. символов/с |  | 0,25
2 Мбит/с | 4-РРМ |  | 4 млн. символов/с |  | 0,5
г) Ортогональное частотное уплотнение (OFDM)
Скорость передачи данных | Модуляция | Степень кодирования | Кодированных битов на поднесущую | Битов кода на символ OFDM | Битов данных на символ OFDM
6 Мбит/с | BPSK | 1/2 | 1 | 48 | 24
9 Мбит/с | BPSK | 3/4 | 1 | 48 | 36
12 Мбит/с | QPSK | 1/2 | 2 | 6 | 48
18 Мбит/с | QPSK | 3/4 | 2 | 96 | 72
24 Мбит/с | 16-QAM | 1/2 | 4 | 192 | 96
36 Мбит/с | 16-QAM | 3/4 | 4 | 192 | 144
49 Мбит/с | 64-QAM | 2/3 | 6 | 288 | 192
54 Мбит/с | 16-QAM | 3/4 | 6 | 288 | 216

Расширение спектра методом прямой последовательности (DSSS)

В системе DSSS может использоваться до семи каналов со скоростью передачи в каждом 1 или 2 Мбит/с. Количество доступных каналов зависит от ширины полосы, выделяемой конкретным государственным органом регулирования. В Европе, например, доступно до 13 каналов, а в Японии — только один. Ширина полосы каждого канала равна 5 МГц, схема кодирования: DBPSK — для скорости 1 Мбит/с и DQPSK — для скорости 2 Мбит/с.

Система DSSS использует раздробленный код, или псевдошумовую последовательность, для расширения скорости передачи данных, а следовательно, полосы сигнала. В стандарте ШЕЕ 802.11 определено использование последовательности Баркера.

Последовательность Баркера (Barker sequence) — это последовательность {(s(t))} элементов +1 и -1. Длина последовательности равна n, а для автокорреляционного значения R(t) справедливо следующее: |R(t)|<=1 для всех |t|<=(n - 1). Более того, данное свойство справедливо для таких преобразований (и их сочетаний):

s(t) -> -s(t) s(t) -> (-l)'s(t) и s(t) -> -s(n - 1 - t).

В настоящее время известны такие последовательности Баркера:

n = 2 + +

n = 4 + +-

n = 5 + + + -

n = 7 + + + - - + -

n = 11 + - + + - + + + - - -

n = 13 + + + + + - - + + - + - +

В 802.11 используется последовательность Баркера n = 11. Таким образом, каждая двоичная единица отображается в последовательность {+ - + + - + + + - - -}, а каждый двоичный нуль — в последовательность {- + - - + - - - + + +}.

Важной особенностью последовательностей Баркера является их устойчивость к интерференции и эффектам многолучевого распространения.

Расширение спектра методом скачкообразной перестройки частоты (FHSS)

Cистема FHSS использует множественные каналы, причем перестройка с одного канала на другой выполняется на основе псевдослучайной последовательности. В схеме IEEE 802.11 используются каналы шириной 1 МГц. Число каналов колеблется от 23 (Япония) до 70 (США).

Параметры схемы FHSS стандартом не задаются. В США, например, минимальная скорость перестройки частоты составляет 2,5 раза в секунду. Минимальное расстояние перехода (по частоте) в Северной Америке и большей части Европы составляет 6 МГц, в Японии — 5 МГц.

В качестве схемы модуляции для скорости 1 Мбит/с используется двухуровневая гауссова частотная манипуляция (GFSK). Двоичные нуль и единица кодируются как отклонение от текущей несущей частоты. Для скорости 2 Мбит/с используется четырехуровневая GFSK, в которой четыре различных отклонения от несущей представляют четыре 2-битовые комбинации нулей и единиц.

Передача в инфракрасном диапазоне

Схема передачи в инфракрасном диапазоне, как она определена в IEEE 802.11, является ненаправленной (рис. 5.10).

Связь возможна на расстоянии до 20 м. В качестве схемы модуляции для скорости 1 Мбит/с выбрана фазоимпульсная модуляция (pulse position modulation — PPM): каждая группа, состоящая из 4 бит данных, отображается в один из 16 символов РРМ; каждый символ представляет собой строку, включающую 16 бит, причем каждая такая строка состоит из 15 нулей и одной двоичной единицы. При скорости 2 Мбит/с каждая группа, состоящая из 2 бит, отображается в одну из четырех 4-битовых последовательностей, каждая из которых содержит три нуля и одну двоичную единицу. При передаче используется схема модуляции интенсивности, когда присутствие сигнала обозначает двоичную единицу, а отсутствие — двоичный нуль.

IEEE 802.11a

Спецификация IEEE 802.11а использует полосу 5 ГГц. В отличие от спецификации 2,4 ГГц, здесь применяется не расширенный спектр, а ортогональное частотное уплотнение (OFDM). При OFDM, также именуемом модуляцией со многими несущими, используется несколько несущих сигналов на различных частотах, посредством каждого из которых осуществляется передача части битов. Данная схема подобна частотному уплотнению (FDM), отличие состоит лишь в том, что все подканалы выделены одному источнику.

Стандарт IEEE 802.11а определяет такие скорости передачи данных: 6, 9, 12, 18, 24, 36, 48 и 54 Мбит/с. Имеется до 52 поднесущих, которые модулируются с использованием схем BPSK, QPSK, 16-QAM или 64-QAM, в зависимости о требуемой скорости передачи. Расстояние между поднесущими составляет 0,3125 МГц. Для прямой коррекции ошибок используются сверточный код со степенью кодирования 1/2, 2/3 или 3/4.

IEEE 802.11b

IEEE 802.11b — это расширение спецификации IEEE 802.11 DSSS, допускающее скорости передачи данных 5,5 и 11 Мбит/с. Скорость передачи раздробленного сигнала равна 11 МГц, т.е. такая же, как в исходной схеме DSSS, следовательно, обе схемы требуют одинаковой полосы. Для получения более высокой скорости при неизменной полосе и скорости передачи раздробленного сигнала используется манипуляция дополнительным кодом (complementary code keying — ССК).

Модуляция ССК является достаточно сложной и здесь рассматриваться не будет. Пример схемы ССК приводится на рис. 5.11 для скорости передачи 11 Мбит/с. Входные данные рассматриваются как 8-битовые блоки со скоростью 1,375 МГц (8 бит/символ х 1,375 МГц = 11 Мбит/с). Шесть битов отображаются в одну из 64 кодовых последовательностей, при этом применяется матрица Уолша 8x8 (рис. 5.12). Результат плюс оставшиеся два бита подаются на вход модулятора QPSK.

Рисунок 5.10 - Схема модуляции ССК для скорости 11 Мбит/с


Беспроводные сети. Современное состояние и перспективы развития. 15.1. ОБЗОР

Bluetooth — это внедренное в микрочип невыключающееся радиоустройство ближнего действия. Эта технология была представлена шведским производителем мобильных средств связи Ericsson в 1994 году как средство, позволяющее портативным компьютерам совершать звонки по мобильным телефонам. С тех пор несколько тысяч компаний работают над тем, чтобы технология Bluetooth стала стандартом множества маломощных, действующих на близком расстоянии беспроводных устройств. Промышленные наблюдатели считают, что к 2005 году чипами Bluetooth будут оборудованы миллиарды аппаратов (Business Week, 18 September 2000).

Название "Bluetooth" ("голубой зуб") произошло от прозвища датского короля Гарольда Блаатанда (Harald Blaatand), жившего в X веке нашей эры. В историю он вошел как человек, который принес христианство в Скандинавию и объединил разрозненные земли Дании и Норвегии. Логотип Bluetooth, которым помечаются устройства, поддерживающие данную технологию, представляет собой руническую запись инициалов короля.

Стандарты Bluetooth публикуются промышленным консорциумом Bluetooth SIG (Special Interest Group — специальная группа). Данная глава посвящена обзору этой технологии.

6.1. ОБЗОР

Цель Bluetooth — унифицировать возможности ближней радиосвязи. В диапазоне 2,4 ГГц (общедоступные нелицензируемые частоты для маломощных устройств) два аппарата Bluetooth, находящиеся на расстоянии до 10 м, могут совместно использовать пропускную способность до 720 Кбит/с. Bluetooth предназначена для поддержки многих приложений (полный список достаточно объемен и продолжает пополняться: передача данных, аудио, графики, видео и т.д.). Например, чип Bluetooth может внедряться в такие аудиоустройства, как наушники, беспроводные и обычные телефоны, домашние стереопроигрыватели и цифровые МРЗ-плейеры. С помощью Bluetooth потребители могут делать следующее:

• звонить с беспроводного головного телефона, удаленно связанного с телефоном ячейки сотовой связи;

• соединять компьютеры с периферией (принтеры, клавиатуры, мыши), не используя кабель;

• подключать без проводов МРЗ-плейеры к другим машинам с целью загрузки музыкальных файлов;

• организовывать домашние сети, чтобы пользователь-домосед мог, не двигаясь с места, наблюдать за кондиционером, микроволновой печью и тем, как его дети используют Internet;

• звонить домой для того, чтобы включить или выключить бытовой прибор, устройство аварийной сигнализации или просто понаблюдать, что происходит в отсутствие хозяина.

Области применения Bluetooth

Технология Bluetooth предназначена для работы в среде со многими пользователями. В маленькую сеть, называемую пикосетью (piconet), могут объединяться до восьми устройств. Десять таких пикосетей могут сосуществовать в одном радиодиапазоне Bluetooth. Для обеспечения безопасности каждый- канал связи кодируется и защищается от подслушивания и интерференции.

Bluetooth предусматривает поддержку трех основных областей применения с использованием беспроводной связи ближнего действия.

• Точки доступа для ввода данных (в том числе — посредством голоса).

Bluetooth способствует передаче в реальном времени данных и речи, обеспечивая удобную беспроводную связь портативных и стационарных аппаратов связи.

• Замена кабеля. При наличии Bluetooth отпадает необходимость в многочисленных кабельных проводках, которые сопровождают практически все устройства связи. Соединение Bluetooth устанавливается мгновенно, причем связываемые устройства не обязательно должны находиться в переделах прямой видимости. Радиус охвата — порядка 10 м, а если использовать усилитель, эту величину можно довести до 100 м.

Организация эпизодических сетей. Устройство, оснащенное чипом Bluetooth, может мгновенно устанавливать связь с другим устройством, находящимся в пределах области охвата.

Несколько примеров того, как можно использовать технологию Bluetooth, приведены в табл. 6.1.

Таблица 6.1 - Сценарии пользователя Bluetooth

Телефон "три в одном"
Если вы в офисе — телефон работает как интерком (не нужно платить за услуги телефонии), дома это беспроводный телефон (оплачивается как стационарное устройство), а если вы перемещаетесь, его можно использовать как обычный мобильный телефон (это уже сотовая связь)
Мост Internet
Портативный ПК можно связать с Internet откуда угодно либо посредством мобильного телефона (беспроводное соединение), либо с помощью кабеля (PSTN, ISDN, ЛВС, xDSL)
Интерактивная конференция
На встречах и конференциях информацию можно мгновенно распространять между всеми участниками. Кроме того, проектором можно управлять, и не имея проводного соединения
Удаленный головной телефон
Соедините головной телефон с вашим мобильным ПК или любым проводным соединением — и ваши руки свободны для более важных дел в офисе или в движущемся автомобиле Громкоговоритель портативного ПК '
Соедините беспроводный головной микрофон с вашим портативным ПК— и используйте его как микрофон в офисе, машине или дома
Почта из портфеля
Получите доступ к электронной почте, не вынимая портативный ПК из портфеля. Как только ПК получает почту, вам об этом сообщает ваш мобильный телефон. Используя тот же мобильный телефон, входящую почту можно просмотреть и прочитать сообщения
Задержанные сообщения
Если вы летите в самолете, электронную почту можно занести в ПК. Как только вы приземлитесь и сможете пользоваться мобильным телефоном, сообщения будут посланы немедленно
Автоматическая синхронизация
Автоматически синхронизируйте ваш настольный компьютер, портативный ПК, ноутбук и мобильный телефон. Как только вы войдете в офис, список адресов и календарь настольного ком-будут автоматически обновлены согласно файлам вашего ноутбука (или наоборот)
Мгновенная цифровая открытка
Подключите (без проводов!) камеру к мобильному телефону или к любому выходу проводной связи. Введите комментарий с мобильного телефона, ноутбука или портативного ПК — и готовую открытку можно отправлять немедленно
Беспроводный настольный компьютер
Вашему компьютеру не нужны провода, чтобы соединиться с принтером, сканером, клавиатурой, мышью или локальной сетью

Стандарты Bluetooth

Стандарты Bluetooth — это фундаментальный труд: более 1500 страниц, содержащих технологическую (внутреннюю) спецификацию Bluetooth и спецификация профиля. Внутренние спецификации описывают детали разнообразных уровней протокольной архитектуры Bluetooth (от радиоинтерфейса до управления каналом связи). Рассматриваются и родственные темы, такие, как возможность взаимодействия со сходными технологиями, требования к тестированию и определения разнообразных таймеров Bluetooth и связанных с ними значений.

В спецификациях профиля описано использование технологии Bluetooth для поддержки различных приложений. В каждой спецификации рассматривается применение технологии, определенной во внутренней спецификации, для реализации конкретной модели использования. В спецификации профиля указывается, какие аспекты внутренних спецификаций Bluetooth являются обязательными, необязательными и неприменимыми. Цель спецификации профиля — определить стандарт возможности взаимодействия, чтобы продукты разных производителей, заявленные как поддерживающие данную модель использования, могли действительно работать вместе. Грубо говоря, спецификации профиля относятся к одной из двух категорий: замена кабеля или беспроводное аудио. Профили замены кабеля дают близко расположенным устройствам удобное средство организации логического соединения и обмена данными. Например, если два аппарата попадают в диапазон взаимной досягаемости, они могут автоматически согласовать общий профиль. Возможно, в связи с этим пользователь будет предупрежден об установлении общего профиля или же произойдет автоматический обмен информацией. Профили беспроводного аудио занимаются созданием голосовых соединений ближнего действия.

На рис. 6.1 изображена схема, по которой разработчик, интересующийся конкретным приложением, может найти нужный ему документ среди множества существующих. Список начинается с обзора некоторых необходимых внутренних спецификаций и профиля общего доступа. Этот профиль является одним из многих, составляющих основу других профилей, и не задает каких-либо самодостаточных функциональных возможностей. Профиль общего доступа указывает, как узкополосная архитектура Bluetooth (определенная во внутренних спецификациях) должна использоваться между устройствами, которые реализуют один или несколько профилей. После базового набора документов список на рисунке .разделяется на два столбца, в одном из которых перечислены документы, относящиеся к замещению кабеля, а в другом — к беспроводному аудио.

Рисунок 6.1 - Документация Bluetooth

Архитектура протоколов

Bluetooth определяется как многоуровневая протокольная архитектура (рис. 6.2), состоящая из внутренних протоколов, протоколов замены кабеля и управления телефонией и адаптированных протоколов.

Рисунок 6.2 - Стек протоколов Bluetooth

Внутренние протоколы формируют пятиуровневый стек, состоящий из следующих элементов.

• Радио. Устанавливает детали радиоинтерфейса, включая используемые частоты, схему перестройки частоты, тип модуляции и мощность передачи.

• Узкололосная передача. На этом уровне решаются вопросы установления соединения в пределах пикосети, адресации, формата пакета и управления мощностью.

• Протокол администратора канала связи (Link Manager Protocol — LMP). Отвечает за установление канала связи между устройствами Bluetooth и его текущее администрирование, куда включается решение вопросов безопасности, таких, как аутентификация и шифрование, плюс контроль и согласование размеров узкополосных пакетов.

• Протокол управления логическим каналом и адаптации (Logical Link Control and Adaptation Protocol — L2CAP). Адаптирует протоколы высших уровней к уровню узкополосной передачи. L2CAP предлагает как службы без установления соединения, так и службы на основе соединения.

• Протокол обнаружения службы (Service Discovery Protocol — SDP). Для установления связи между двумя устройствами Bluetooth или большим числом устройств может запрашиваться информация об устройстве, службах и характеристиках служб.

В спецификацию Bluetooth включен еще один протокол: RFCOMM — протокол замещения кабеля. RFCOMM предоставляет виртуальный последовательный порт, задача которого — сделать замену кабельных технологий максимально незаметной для пользователей и программ. Последовательные порты — это один из наиболее общих типов интерфейсов связи, которые используются вычислительными устройствами и устройствами связи. Следовательно, RFCOMM позволяет замещать кабели последовательного порта с минимальной модификацией существующих устройств. RFCOMM обеспечивает транспортировку двоичных данных и эмулирует сигналы управления EIA-232 над узкополосным уровнем Bluetooth. EIA-232 (ранее известный как RS-232) — это широко используемый стандарт интерфейса последовательного порта.

В Bluetooth определен протокол управления телефонией. Протокол TCS BIN (telephony control specification — binary — спецификация управления телефонией — бинарная) — это протокол с битовой структурой, который определяет передачу сигналов управления вызовами с целью установления сеансов передачи речи и данных между устройствами Bluetooth. Кроме того, он определяет процедуры управления мобильностью для управления группами устройств Bluetooth TCS.

Адаптированный протокол определяется в спецификациях, выпускаемых другими организациями по стандартизации, и вводится в общую архитектуру Bluetooth. Стратегия Bluetooth заключается в создании только необходимых протоколов при максимально возможном использовании имеющихся стандартов. В число адаптированных протоколов входят следующие.

• РРР. Протокол двухточечного соединения — это стандартный протокол Internet для перемещения дейтаграммы IP по двухточечному каналу связи.

• TCP/UDP/IP. Фундаментальные протоколы из набора TCP/IP (описаны в главе 4).

• ОВЕХ. Протокол объектного обмена — это протокол сеансового уровня, разработанный Ассоциацией передачи данных в инфракрасном диапазоне (Infrared Data Association — IrDA) для обмена объектами. Функции ОВЕХ подобны функциям HTTP, но выполняются проще. Кроме того, данный протокол дает модель представления объектов и операций. Примерами форматов содержимого, передающегося посредством ОВЕХ, являются vCard и vCalendar, которые предлагают формат электронных визитных карточек и персонального календаря/делового расписания, соответственно.

• WAE/WAP. Bluetooth вмещает в своей архитектуре среду беспроводных приложений и протокол беспроводных приложений.

Модели использования

В документах по профилям Bluetooth определены несколько моделей использования. По сути, модель использования — это набор протоколов, которые реализуют конкретное приложение на основе Bluetooth. Каждый профиль определяет протоколы и свойства протоколов, поддерживающие конкретную модель использования. На рис. 6.3 представлены модели использования с наивысшим приоритетом. Перечислим эти модели.

• Передача файлов. Модель поддерживает прредачу каталогов, файлов, документов, изображений и потоковую информацию. Данная модель использования также содержит возможность просмотра папки с удаленного устройства.

• Мост Internet. Используя данную модель, ПК связывается без проводов с мобильным телефоном или беспроводным модемом для удаленного телефонного доступа к сети или факсу. Относительно удаленного -доступа следует сказать, что управление мобильным телефоном или модемом осуществляется с помощью команд AT, а для передачи данных используется другой стек протоколов (например, РРР над RFCOMM). При факсимильной же связи программное обеспечение факса работает непосредственно над уровнем RFCOMM.

• Доступ к локальной сети. Данная модель использования позволяет устройствам пикосети получить доступ к локальной сети. После соединения работа устройства та же, что и при проводном подключении.

• Синхронизация. Данная модель обеспечивает синхронизацию содержащейся на устройствах персональной информации, такой, как записи в телефонной книге, календаре, сообщения и заметки. Здесь следует упомянуть IrMC (Ir mobile communications — мобильная связь в инфракрасном диапазоне), протокол IrDA, который позволяет передавать между устройствами обновленную персональную информацию (по схеме клиент/сервер).

• Телефон "три в одном". Телефонные трубки, которые реализуют данную модель использования, могут работать как беспроводный телефон, подсоединенный к голосовой базовой станции, как интерком, связанный с другими телефонами, и как сотовый телефон.

• Головной телефон. Головной телефон может использоваться как устройство аудиоввода/вывода удаленного устройства.

Пикосети и рассеянные сети

Ранее уже упоминалось, что основные элементы организации сетей Bluetooth — это пикосети, состоящие из ведущего устройства (master) и из 1-7 активных подчиненных устройств (slave). Радиоустройство, обозначенное как ведущее, определяет канал (последовательность перестройки частоты) и фазу (т.е. когда передавать), которые будут использоваться всеми устройствами данной пикосети. Эти параметры определяются ведущим устройством на основе собственного адреса. Подчиненное устройство может сообщаться только с ведущим, причем лишь тогда, когда это разрешает ведущее устройство. Любое устройство одной пикосети может также входить в другую пикосеть в качестве как подчиненного, так и ведущего (рис. 6.4). Данная схема с перекрытием называется рассеянной сетью (scatternet). На рис. 6.5 архитектура пикосети/рассеянной сети сравнивается с другими формами беспроводных сетей.

Рисунок 6.3 - Модели использования Bluetooth

Рисунок 6.4 - Ведущие (М) и подчиненные (S) устройства

Рисунок 6.5 - Конфигурации беспроводной сети

Преимущество схемы пикосеть/рассеянная сеть состоит в том, что она позволяет многим аппаратам находиться в одной физической области и эффективно использовать общую полосу. В системе Bluetooth задействована схема перестройки частоты с расстоянием между несущими 1 МГц. Как правило, при общей полосе 80 МГц может быть до 80 различных частот. Если передача ведется на одной частоте, то каждый отдельный канал соответствует полосе 1 МГц. При перестройке частоты логический канал определяется последовательностью изменения частоты. В любой момент времени доступна полоса 1 МГц, а максимальное число устройств, совместно использующих полосу, — 8. В общей полосе 80 МГц могут одновременно функционировать различные логические каналы (с разными последовательностями перестройки). Если устройства из различных пикосетей, работающие в различных логических каналах, одновременно перестроятся на одну частоту, произойдет конфликт. С увеличением числа пикосетей в области и, соответственно, числа конфликтов падает производительность. Подытожим: в рассеянной сети совместно используются физическая область и суммарная полоса, а в пикосети — логический канал и возможность передачи данных.


Беспроводные сети. Современное состояние и перспективы развития. 15.2 РАДИОСПЕЦИФИКАЦИЯ

6.2 РАДИОСПЕЦИФИКАЦИЯ

Радиоспецификация Bluetooth — это небольшой документ, в котором представлены основные детали радиопередачи устройств Bluetooth. Некоторые ключевые параметры приведены в табл. 6.2.

Таблица 6.2 - Параметры Bluetooth

Топология | До 7 одновременных каналов в логической звездообразной сети
Модуляция | GFSK
Максимальная скорость передачи данных | 1 Мбит/с
Ширина полосы радиочастот | 220 кГц (по уровню -3 дБ), 1 МГц (по уровню -20 дБ)
Полоса радиочастот | 2,4 ГГц, диапазон ISM
Число радионесущих | 23/79
Расстояние между несущими | 1 МГц
Мощность передачи | 0,1 Вт
Схема доступа к пикосети | FH-TDD-TDMA
Скорость изменения частоты | 1600 раз в секунду
Схема доступа к рассеянной сети | FH-CDMA

Одним из аспектов радиоспецификации является определение трех классов передатчиков на основе выходной мощности.

• Класс 1. Минимальная мощность выходного сигнала — 1 мВт (0 дБмВт); для передачи на максимальное расстояние — 100 мВт (+20 дБмВт). В этом классе контроль мощности является обязательным, мощность должна находиться в диапазоне 4-20 дБмВт. Данный режим обеспечивает наибольшее расстояние связи.

• Класс 2. Минимальная мощность выходного сигнала— 0,25 мВт (-6 дБмВт), для передачи на максимальное расстояние— 2,4 мВт (+4 дБмВт). Контроль мощности — по желанию.

• Класс 3. Наименьшая мощность. Номинальный выход — 1 мВт.

Bluetooth использует полосу 2,4 ГГц в диапазоне ISM (полоса частот для промышленного, научного и медицинского использования). В большинстве стран этой полосы достаточно для определения 79 физических каналов шириной 1 МГц (табл. 6.3). Чтобы аппараты не излучали больше мощности, чем требуется, используется контроль мощности. Алгоритм контроля мощности реализуется посредством протокола администратора канала связи между ведущим и подчиненными устройствами в пикосети.

Таблица 6.3 - Международное распределение частот Bluetooth

Зона | Диапазон, ГГц | Радиоканалы
США, большая часть стран Европы и большинство других стран | 2,4-2,4835 | f = (2,402 + n) МГц, n = 0, ..., 78
Япония | 2,471-2,497 | f = (2,473 + n) МГц, n = 0, ..., 22
Испания | 2,445-2,475 | f= (2,449 + n) МГц, n = 0 ..... 22
Франция | 2,4465-2,4835 | f = (2,454 + n) МГц, n = 0, .... 22

Для модуляции в устройствах Bluetooth выбрана гауссова частотная манипуляция, причем двоичная единица представляется положительным отклонением от центральной частоты, а двоичный нуль — отрицательным. Минимальное отклонение — 115 кГц.


Беспроводные сети. Современное состояние и перспективы развития. 15.3 УЗКОПОЛОСНАЯ СПЕЦИФИКАЦИЯ

6.3 УЗКОПОЛОСНАЯ СПЕЦИФИКАЦИЯ

Один из наиболее сложных документов Bluetooth — узкополосная спецификация, ключевые элементы которой рассмотрены ниже.

Перестройка частоты

Перестройка частоты (Frequency Hopping — FH) в Bluetooth используется с двумя целями.

1. Обеспечить сопротивление интерференции и эффектам многолучевого распространения.

2. Предоставить некоторую схему множественного доступа соседствующим устройствам из разных пикосетей.

Опишем работу схемы FH. Общая полоса делится на 79 (почти во всех странах) физических каналов, каждый занимает полосу в 1 МГц. Перестройка частоты производится путем перехода из одного физического канала в другой, причем последовательность изменения частоты определяется псевдослучайной последовательностью. Все устройства отдельной пикосети используют одинаковые последовательности изменения частоты; далее такую последовательность будем называть FH-каналом. Скорость изменения частоты — 1600 раз в секунду, так что каждый физический канал занят в течение 0,625 мс. Каждый интервал в 0,625 мс называются слотом, все слоты нумеруются последовательно.

Радиоустройства Bluetooth сообщаются с использованием дуплекса с временным разделением (time division duplex — TDD). TDD — это схема передачи по каналу, в которой в любой момент времени данные передаются только в одну сторону, а направления передачи чередуются. Поскольку среду пикосети совместно используют более двух устройств, как схема доступа используется ТОМА. Таким образом, схему доступа к пикосети можно обозначить как FH - TDD - TDMA, а ее общий вид приведен на рис. 6.6. Здесь k обозначает номер слота, а f(k)) — физический канал, выбранный на это время.

Рисунок 6.6 - Дуплекс с временным разделением (TDD) с перестройкой частоты (FH)

Передача пакета начинается в начале слота. Длина пакета может равняться 1, 3 или 5 слотам. Передача многослотового пакета ведется на одной частоте, без перестройки (рис. 6.7). В течение следующего слота передатчик переходит на частоту, определенную для данного периода времени последовательностью изменения частоты (таким образом, несколько частот последовательности пропускаются).

Использование TDD предотвращает перекрестные помехи между операциями приема и передачи в радиотрансивере, что просто необходимо, если каждое устройство должно иметь один чип Bluetooth. Поскольку передача и прием происходят в разных слотах, в них используются разные частоты.

Последовательность перестройки частоты определяется ведущим устройством пикосети и является функцией его Bluetooth-адреса. При этом для генерации этой последовательности используется довольно сложная математическая операция, включающая перестановку и выполнение операций исключающего ИЛИ.

Поскольку разные пикосети в одной области будут использовать разные ведущие устройства, отличаться будут и последовательности перестройки частоты. Таким образом, большую часть времени передачи двух устройств разных пикосетей в одной области будут идти по разным каналам. В некоторые моменты времени передачи в двух пикосетях будут вестись по одному физическому каналу, что приведет к конфликту и потере данных. Впрочем, такое случается довольно редко, и для страховки достаточно использовать схемы прямого исправления ошибок и выявления ошибок/запроса ARQ. Итак, некая форма множественного доступа с кодовым разделением каналов (code division multiple access — CDMA) успешно применяется к аппаратам разных пикосетей в одной рассеянной сети; именуется эта схема FH - CDMA.

Рисунок 6.7 - Пример многослотовых пакетов

Физические каналы

Между ведущим и подчиненным устройствами могут устанавливаться каналы связи двух типов.

• Ориентированный на установление соединения синхронный канал (Synchronous Connection Oriented — SCO). Выделяет фиксированную полосу двухточечному соединению, в котором задействованы ведущее устройство и одно из подчиненных устройств. Ведущее устройство поддерживает канал SCO путем использования через постоянные интервалы зарезервированных слотов. Основная единица резервирования — два последовательных слота (по одному в каждом направлении передачи). Ведущее устройство может одновременно поддерживать до трех каналов SCO, а подчиненное устройство — два или три канала SCO. Пакеты SCO никогда не передаются повторно.

• Асинхронный канал без установления соединения (Asynchronous Connectionless — ACL). Многоточечный канал между ведущим и всеми подчиненными устройствами пикосети. В слотах, не зарезервированных для каналов SCO, ведущее устройство может обмениваться пакетами с любым подчиненным устройством, в том числе и с устройствами, с которыми уже установлены каналы SCO. Может существовать только единственный канал ACL. Вследствие различных сбоев большинство пакетов ACL передаются повторно.

В основном каналы SCO используются для обмена срочными данными, требующими гарантированной скорости передачи, но не требующих гарантированной доставки. Например, в нескольких профилях Bluetooth используются оцифрованные аудиоданные, которым присуща допустимость потери данных. Гарантированная скорость передачи данных достигается посредством резервирования для передачи определенного числа слотов.

Каналы ACL обеспечивают соединения по принципу коммутации пакетов. Резервирование полосы невозможно, и доставка гарантируется посредством использования схем обнаружения ошибок и повторной передачи. Подчиненному устройству разрешается возвращать пакет ACL в слоте передачи от подчиненного устройства ведущему тогда и только тогда, когда он был передан в предыдущем слоте передачи от ведущего устройства подчиненному. Для каналов ACL определены 1-слотовые, 3-слотовые и 5-слотовые пакеты. Данные могут посылаться незащищенными (хотя на более высоких уровнях может использоваться схема ARQ) или защищенными кодом прямого исправления ошибок со степенью кодирования 2/3. Максимальная скорость передачи данных достигается при использовании 5-слотовых незащищенных пакетов и асимметричного распределения пропускной способности, это скорость 721 Кбит/с в прямом направлении и 57,6 Кбит/с — в обратном. Все существующие возможности приведены в табл. 6.4.

Таблица 6.4 - Доступные скорости передачи данных по каналу ACL (Кбит/с)

Тип | Симметричная схема | Асимметричная схема
DM1 | 108,8 | 108,8 | 108,8
DH1 | 172,8 | 172,8 | 172,8
DM3 | 256,0 | 358,0 | 54,4
DH3 | 384,0 | 576,0 | 86,4
DM5 | 286,7 | 477,8 | 36,3
DH5 | 432,6 | 721,0 | 57,6

Пакеты

Формат всех пакетов Bluetooth показан на рис. 6.8. Он состоит из трех полей.

• Код доступа. Используется для временной синхронизации, компенсации сдвига, опроса и запроса.

• Заголовок. Используется для определения типа пакета' и переноса управляющей информации протокола.

• Полезная нагрузка. При наличии этого поля в нем содержатся речь или данные пользователя и (в большинстве случаев) заголовок полезной нагрузки.

Код доступа

Существует три типа кодов доступа.

• Код доступа к каналу (channel access code — САС). Определяет пикосеть (уникален для пикосети).

• Код доступа к устройству (device access code — DAC). Используется для избирательного доступа и передачи последующих откликов.

• Код доступа к опросу (inquiry access code — IAC), Используется при опросах.

Рисунок 6.8 - Узкополосные форматы Bluetooth

В код доступа входят начальная комбинация битов, синхронизирующее слово и завершитель. Начальная комбинация битов (preamble) используется для компенсации постоянной составляющей сигнала передачи и состоит из последовательности 0101, если младший (крайний левый) бит в синхронизирующем слове — 0, и последовательности 1010, если младший бит в синхронизирующем слове — 1. Подобным образом, завершитель (trailer) равен 0101, если старший (крайний справа) бит в синхронизирующем слове — 1, и 1010, если старший бит в синхронизирующем слове — 0.

64-битовое синхронизирующее слово состоит из трех компонентов (рис. 6.9), и его стоит рассмотреть подробнее. Каждому устройству Bluetooth присваивается глобально уникальный 48-битовый адрес. 24 младших бита называются нижней частью адреса (lower address part — LAP) и используются для формирования синхронизирующего слова. Для кода САС используется LAP ведущего устройства; для кода DAC — LAP устройства, к которому идет обращение. Существует два разных кода ГАС. Общий код IAC (General LAC — GIAC) — это сообщение общего опроса, которое используется для выявления всех устройств Bluetooth в радиусе действия; для этого имеется специальное зарезервированное значение LAP. Выделенный IAC (Dedicated IAC — DIAC) принадлежит выделенной группе устройств Bluetooth, которые имеют общие характеристики, и в этом случае используется адрес LAP, ранее определенный для этих характеристик.

Рисунок 6.9 - Структура синхронизирующего слова

Используя соответствующий адрес LAP, синхронизирующее слово создается следующим образом.

1. К LAP добавляется 6 бит 001101, если старший бит LAP равен 0, и 110010, если старший бит — 1. В результате получается 7-битовая последовательность Баркера. Цель введения последовательности Баркера — улучшить автокорреляционные свойства синхронизирующего слова.

2. Генерируется 64-битовая шумоподобная последовательность, р0, р1 ..., р63. Последовательность определяется уравнением Р(Х) = 1 + X + X3, и ее можно реализовать с помощью линейного регистра сдвига с обратной связью. Начальное значение для генерации псевдослучайной последовательности — 1000004.

3. К последовательности р34, р35, ..., р63 и 30-битовой последовательности, синтезированной на этапе 1, применяется операция исключающего ИЛИ, что позволяет скремблировать информацию, удаляя нежелательные регулярные последовательности.

4. Для скремблированного блока информации генерируется 34-битовый код с коррекцией ошибок, он помещается перед блоком, в результате чего формируется 64-битовое кодовое слово. Таким образом, имеем код (64, 30). Для генерации данного кода следует начать с кода БХЧ (63, 30). Потом определяется порождающий многочлен g(X) = (1 + X)g(X), где g'(X) — это порождающий многочлен кода БХЧ (63, 30). В результате имеем желаемый 34-битовый код.

5. К последовательностям р0, р1 ..., р63 и 64-битовой последовательности, синтезированной на этапе 4, применяется операция исключающего ИЛИ. На этом шаге дешифруется информационная часть кодового слова, так что передаются исходные часть LAP и последовательность Варкера. На данном этапе также скремблируется блочный код.

Скремблирование информационной части кодового слова на этапе 3 происходит с целью усиления устойчивости блочного кода к ошибкам. Последующее дешифрование позволяет получателю легко восстанавливать LAP. С точки зрения спецификации, дешифрование 34-битового кода с коррекцией ошибок устраняет цикличность исходного кода, благодаря чему улучшаются спектральные характеристики передачи и автокорреляционные свойства.

Заголовок пакета

Формат заголовка всех пакетов Bluetooth показан на рис. 6.8, в. Он состоит из трех полей.

• AM_ADDR. Напомним, что пикосеть может содержать не более семи активных подчиненных устройств. 3-битовое поле AM_Addr содержит адрес "активного режима" (временный адрес, присвоенный данному подчиненному устройству в данной пикосети) одного из подчиненных устройств. Передача от ведущего к подчиненному устройству содержит данный адрес подчиненного устройства, передача от подчиненного устройства — адрес этого подчиненного устройства. Значение 0 зарезервировано для передачи от ведущего устройства всем подчиненным устройством в пикосети.

• Тип. Определяет тип пакета (табл. 6.5). Для контрольных пакетов зарезервированы четыре кода, общие для каналов SCO и ACL. Остальные типы пакетов используются для передачи информации пользователя. Пакеты HV1, HV2, HV3 в каналах SCO применяются для передачи речи со скоростью 64 Кбит/с. Отличаются эти пакеты степенью защиты от ошибок, что, в свою очередь, определяет, насколько часто должны посылаться пакеты для поддержания скорости передачи данных 64 Кбит/с. Пакет DV переносит и речь, и данные. Для каналов ACL определены 6 разных пакетов. Эти пакеты плюс пакет DM1 переносят пользовательские данные с разной степенью защиты от ошибок и разной скоростью передачи информации (табл. 6.4). Существует еще один тип пакета, общий для обоих физических каналов; он состоит только из кода доступа, а его размер равен 68 бит (не включая завершитель). Этот пакет обозначается ID и используется в процедурах опроса и доступа.

• Поток. Предоставляет 1-битовый механизм управления потоком только для трафика ACL. При приеме пакета с нулевым значением данного поля станция должна временно остановить передачу пакетов ACL по этому каналу. При приеме пакета со значением 1 передача может возобновляться.

• ARQN. Обеспечивает 1-битовый механизм подтверждения для трафика ACL, защищенного CRC (табл. 6.5). После успешного приема возвращается подтверждение АСК (ARQN = 1); в противном случае возвращается отрицательное подтверждение NAK (ARQN = 0). При отсутствии ответа предполагается отрицательное подтверждение, а если получено (или предполагается) отрицательное подтверждение, соответствующий пакет передается повторно.

Таблица 6.5 - Типы пакетов Bluetooth

Код типа | Физический канал | Название | Число слотов | Описание
0000 | Общий | NULL | 1 | Нет полезной нагрузки. Используется для возвращения источнику информации о канале в зависимости от успеха предыдущей передачи (ARQN) или о состоянии буфера приемника (Поток). Не подтверждается
0001 | Общий | POLL | 1 | Нет полезной нагрузки. Используется ведущим устройством для опроса подчиненного устройства. Подтверждается
0010 | Общий | FHS | 1 | Специальный управляющий пакет для определения адреса устройства и времени отправителя. Используется в ответе ведущего устройства на запрос, на опрос и при синхронизации перестройки частоты. Защита: FEC 2/3
0011 | Общий | DM1 | 1 | Поддерживает управляющие сообщения, может также переносить данные пользователя. Защита: 16-битовая CRC, FEC 2/3
0101 | SCO | HV1 | 1 | Переносится 10 байт информации; обычно используется для передачи речи со скоростью 64 Кбит/с. Защита: FEC 1/3
0110 | SCO | HV2 | 1 | Переносится 20 байт информации; обычно используется для передачи речи со скоростью 64 Кбит/с. Защита: FEC 2/3
0111 | SCO | HV3 | 1 | Переносится 30 байт информации; обычно используется для передачи речи со скоростью 64 Кбит/с. Не защищается FEC
1000 | SCO | DV | 1 | Данные (150 бит) и речь (50 бит). Поле данных защищается схемой FEC 2/3
1000 | ACL | DH1 | 1 | Переносится 28 байт информации плюс '16-битовое поле CRC. Не защищается FEC. Обычно используется для передачи высокоскоростных данных
1001 | ACL | AUX1 | 1 | Переносится 30 байт информации без защиты CRC или FEC. Обычно используется для передачи высокоскоростных данных .
1010 | ACL | DM3 | 3 | Переносится 123 байт информации плюс 16-битовое поле CRC, Защита: FEC 2/3.
1011 | ACL | DH3 | 3 | Переносится 185 байт информации шнюе!4йЦ1$£-битовое поле CRC. Не защищается FEC
1110 | ACL | DM5 | 5 | Переносится 226 байт информации плюс 16-битовое поле CRC. Защита: FEC 2/3.
1111 | ACL | DH5 | 5 | Переносится 341 байт информации плюс 16-битовое поле CRC. Не защищается FEC.

• SEQN. Предоставляет 1-битовую схему последовательной нумерации. Передаваемые пакеты поочередно помечаются 1 или 0. Это нужно адресату для фильтрации повторных передач; если повторная передача вызвана потерей подтверждения АСК, адресат получает один пакет дважды.

• Контроль ошибок в заголовке (Header Error Check — НЕС). 8-битовый код выявления ошибок. Используется для защиты заголовка пакета.

Формат полезной нагрузки

Для некоторых типов пакетов узкополосная спецификация определяет формат поля полезной нагрузки. Если ею является речь, заголовок не определен. В то же время заголовок определяется для всех пакетов ACL и данных в пакете DV SCO. Формат полезной нагрузки для данных состоит из трех полей.

• Заголовок полезной нагрузки. 8-битовый заголовок определяется для пакетов из одного слота, и 16-битовый заголовок — для многослотовых пакетов.

• Тело полезной нагрузки. Содержит пользовательскую информацию.

• CRC. 16-битовый код проверки четности с избыточностью, который используется для защиты всех полей полезной нагрузки, исключая поля в пакетах AUX1.

Заголовок полезной нагрузки (если он есть) состоит из трех полей (рис. 6.8, г).

• L_CH. Определяет логический канал (описаны ниже). Возможны следующие опции: сообщение LMP (11); нефрагментированное сообщение L2CAP или начало фрагментированного сообщения L2CAP (10); продолжение фрагментированного сообщения L2CAP (01); другое (00).

• Поток. Используется для управления потоком на уровне L2CAP. Аналогичен механизму включения/выключения, который предлагает поле потока в заголовке пакета трафика ACL.

• Длина. Число байтов данных в полезной нагрузке, исключая заголовок полезной нагрузки и CRC.

Исправление ошибок

На узкополосном уровне Bluetooth использует три схемы исправления ошибок:

• FEC (forward error correction — прямое исправление ошибок) со степенью кодирования 1/3;

• FEC со степенью кодирования 2/3;

• ARQ (automatic repeat request — автоматический запрос повторной передачи).

Эти схемы исправления ошибок предназначены для удовлетворения противоречивых требований. Схемы исправления ошибок должно быть достаточно для организации связи по потенциально надежному беспроводному каналу, но при этом она должна быть простой и рациональной.

Схема FEC 1/3 используется в 18-битовом заголовке пакета и поле передачи речи в пакете HV1. Данная схема — это просто передача трех копий каждого бита. Используется мажоритарная логика: каких битов в принятой тройке больше, такая величина и считается переданной.

Схема FEC 1/2 используется во всех пакетах DM, в поле данных пакета DV, в пакете FHS и в пакете HV2. Кодер реализует разновидность кода Хэмминга с параметрами (15, 10). Этот код в каждом кодовом слове может исправлять все 1-битовые ошибки и обнаруживать все 2-битовые ошибки.

Схема ARQ используется с пакетами DM и DH, с полем данных пакета DV и подобна схемам ARQ, которые применяются в протоколах управления каналами данных. Напомним, что схемы ARQ имеют следующие элементы.

• Выявление ошибок. С помощью кода обнаружения ошибок CRC, дополняющегося кодом FEC, адресат выявляет ошибки и отбрасывает искаженные пакеты.

• Положительное подтверждение (АСК). Адресат возвращает положительное подтверждение по всем успешно полученным, безошибочным пакетам.

• Повторная передача после истечения времени ожидания. По истечении предопределенного промежутка времени источник повторно передает пакет, который не был подтвержден.

• Отрицательное подтверждение (NAK) и повторная передача. Адресат возвращает отрицательное подтверждение по пакету, в котором обнаружена ошибка, после чего источник передает этот пакет повторно.

В Bluetooth применяется так называемая схема быстрого ARQ, которая использует тот факт, что ведущее и подчиненное устройства связываются через разные временные слоты (рис. 6.10). Когда стация получает пакет, она (на основе 16-битового кода CRC) определяет, имеются ли ошибки. Если да, биту ARQN в заголовке присваивается значение О (NAK), если нет — значение 1 (АСК). В случае приема станцией сообщения NAK она повторно передает тот же пакет, что и в предыдущем слоте, с тем же значением бита SEQN в заголовке пакета. При описанном подходе о неудачной передаче отправитель извещается в следующем слоте и может попытаться повторить ее. Использование 1 -битовых порядковых номеров и немедленная повторная передача пакета минимизирует служебные издержки и максимизирует быстроту реагирования.

Рисунок 6.10 - Пример операции повторной передачи

На рис. 6.11 механизм ARQ показан более подробно. После приема пакета (рис. 6.11, а) устройство, используя поле НЕС, проверяет, не поврежден ли заголовок. Если он поврежден, пакет отклоняется, а полю ARQN в следующем слоте присваивается значение NAK. Далее устройство сопоставляет адреса и проверяет, используется ли в пакетах указанного типа механизм ARQ. После того как обе проверки будут успешно пройдены, устройство проверяет, не совпадает ли новый порядковый номер (SEQN) с предыдущим. Если они различны, устройство проверяет CRC. При отсутствии ошибок в следующем исходящем пакете значение поля ARQN устанавливается равным АСК, при сбое на любом этапе проверок значение поля устанавливается равным NAK.

Рисунок 6.11 - Схема ARQ в Bluetooth

Со стороны передатчика (рис. 6.1.1, б) следующий передаваемый пакет DM, DH или DV определяется значением предшествующего поля ARQN. Если принимаются поля со значениями АСК, устройство передает новую полезную нагрузку, в которой периодически чередуются значения SEQN = 0 и 1. При получении сообщения NAK или отсутствии подтверждения устройство будет передавать старую полезную нагрузку до тех пор, пока не будет получено сообщение АСК или пока число неудачных попыток повторной передачи не превысит некоторую пороговую величину. В последнем случае из буфера передачи удаляется старая полезная нагрузка и начинает передаваться новая.

Логические каналы

В Bluetooth определено пять типов логических каналов передачи данных, предназначенных для переноса различных типов трафика.

• Управление каналом (Link Control — LC). Используется для управления потоком пакетов по интерфейсу канала. Канал LC отображается в заголовок пакета и переносит низкоуровневую управляющую информацию, относящуюся к схеме ARQ, управлению потоком и определению характеристик полезной нагрузки. Канал LC переносится во всех пакетах, кроме пакета ID, у которого нет заголовка.

• Администратор канала (Link Manager — LM). Используется для передачи информации по управлению каналом между станциями. Этот логический канал поддерживает трафик LMP и может передаваться либо по каналу SCO, либо по каналу ACL.

• Пользовательский асинхронный канал (User Asynchronous — UA). Переносит асинхронные данные пользователя. Этот канал обычно переносится по каналу ACL, но может переноситься в пакетах DV по каналу SCO.

• Пользовательский изохронный канал (User Isochronous — UI). Переносит изохронные данные (повторяющееся с известной периодичностью) пользователя. Этот канал обычно переносится по каналу ACL, но может также переноситься в пакетах DV по каналу SCO. На узкополосном уровне канал UI трактуется так же, как канал UA. Синхронизация для поддержки изохронности обеспечивается на высшем уровне.

• Пользовательский синхронный канал (User synchronous — US). Переносит синхронные данные пользователя по каналу SCO.

Управление каналом

Работу пикосети можно понять исходя из состояний работы в процессе установления и эксплуатации канала (рис. 6.12). Существуют два основных состояния.

• Холостое. Состояние по умолчанию. Состояние с низким энергопотреблением, в котором работают только собственные часы устройства.

• Соединение. Устройство присоединяется к пикосети в качестве ведущего или подчиненного.

Кроме того, существуют семь промежуточных подсостояний, которые используются для введения в пикосеть новых подчиненных устройств. Для смены состояния используются либо команды от администратора Bluetooth, либо внутренние сигналы в контроллере канала. Перечислим возможные подсостояния.

• Запрос. Устройство выпустило запрос. Используется ведущим устройством для активизации подчиненного устройства и связи с ним. Ведущее устройство отправляет сообщение запроса путем передачи кода доступа к подчиненному устройству (device access code — DAC) в различных каналах, на которые может перестраиваться частота.

• Поиск запроса. Устройство ожидает запрос с его собственным кодом DAC.

• Ответ ведущего устройства. Устройство, выступающее как ведущее, получает от подчиненного устройства ответ на запрос. Теперь устройство может переходить в состояние соединения или возвращаться в состояние запроса для обращения к другим подчиненным.

• Ответ подчиненного устройства. Устройство, выступающее как подчиненное, отвечает на запрос ведущего. Если установление соединения прошло успешно, устройство входит в состояние соединения; в противном случае оно возвращается в состояние поиска запроса.

Рисунок 6.12 - Диаграмма переходов между состояниями Bluetooth

• Опрос. Устройство пытается определить, что находится в пределах его досягаемости.

• Поиск опроса. Устройство ожидает опрос.

• Ответ на опрос. Устройство, которое инициировало опрос, получает ответ на него.

Процедура опроса

Первое, что должно сделать потенциальное ведущее устройство для организации пикосети, — определить, какие еще устройства находятся в пределах его досягаемости, там, где предполагается развертывание пикосети. Для этого устройство начинает процедуру опроса, призванную активизировать пользователя или приложение на устройстве. Процедура начинается с передачи потенциальным ведущим устройством пакета ID с кодом доступа к опросу (inquiry access code — IAC), который является общим для всех устройств Bluetooth. Напомним, что пакет ID не имеет ни заголовка, ни полезной нагрузки.

Из 79 радионесущих 32 считаются активизирующими (wake-up carriers). Ведущее устройство ретранслирует код IAC на всех 32 таких несущих по очереди. Само устройство при этом находится в состоянии опроса (рис. 6.12). Между тем, устройства в холостом состоянии периодически переходят в состояние поиска опроса с целью поиска сообщений IAC на активизирующих радионесущих. Как только устройство получает это сообщение, оно переходит в состояние ответа на опрос и возвращает пакет FHS (табл. 6.5), который содержит адрес этого устройства и информацию по синхронизации, необходимую ведущему устройству для инициации подключения. Ведущее устройство не отвечает на пакет FHS и может остаться в состоянии опроса, пока не убедится, что найдены все устройства в переделах его досягаемости.

Как только устройство ответило на опрос, оно переходит в состояние поиска запроса и ожидает от ведущего устройства запрос на установление соединения. В то же время если в фазе ответа на опрос случится конфликт (два или более устройств одновременно ответят на опрос), не будет получен ни один запрос, устройство будет вынуждено вернуться в состояние поиска опроса и попытаться получить другие сообщения опроса и запроса (Диаграмма состояний на рис. 6.12 взята из узкополосной спецификации, и на ней не показан переход из состояния ответа на опрос в состояние поиска запроса, но показан переход из состояния ответа на опрос в состояние поиска опроса. ).

Процедура запроса

Как только ведущее устройство нашло устройства в пределах своего диапазона, оно может установить соединение с каждым из них, формируя, таким образом, пикосеть. Для запроса каждого устройства ведущее устройство использует адрес данного устройства (BD_ADDR), на основе которого вычисляет последовательность изменения частоты в передаче-запросе. Запрос осуществляется посредством ID-пакета, в котором указан код доступа (ВАС) к требуемому устройству. Напомним, что ВАС — это нижняя часть адреса подчиненного устройства. В ответ подчиненное устройство возвращает ведущему тот же пакет ID ВАС на тех же частотах (последовательность их изменения именуется последовательностью режима запроса), что использовались ведущим устройством. После этого ведущее устройство в следующем слоте передает собственный пакет FHS, который содержит его адрес устройства и время. Далее подчиненное устройство еще раз посылает ответный пакет ID ВАС, таким образом подтверждая получение пакета FHS. В этот момент подчиненное устройство переходит из состояния ответа подчиненного устройства в состояние соединения и начинает использовать последовательность перестройки частоты режима соединения, определенную ведущим устройством в пакете FHS. Тем временем ведущее устройство может запрашивать другие устройства, пока не соединится со всеми желаемыми подчиненными; после этого ведущее устройство переходит в состояние соединения.

Состояние соединения

Для каждого подчиненного устройства состояние соединения начинается с отправки ведущим устройством пакета Poll (опрос), после которого подчиненное устройство синхронизируется с временем ведущего и начинает использовать ту же последовательность изменения частоты. Подчиненное устройство может ответить пакетом любого типа.

Как только подчиненное устройство перешло в состояние соединения, возможны четыре режима работы.

• Активный. Подчиненное устройство активно участвует в работе пикосети, ожидая, передавая и принимая пакеты. Ведущее устройство периодически передает подчиненному устройству пакеты, на основе которых поддерживается синхронизация.

• Подслушивание. Подчиненное устройство прослушивает не все слоты приема, а только те, в которых могут находиться сообщения, предназначенные данному устройству. В течение других слотов подчиненное устройство может работать в режиме пониженного энергопотребления. Для передачи подчиненному устройству, находящемуся в состоянии подслушивания, ведущее устройство выделяет меньше слотов, чем обычно.

• Удержание. В этом состоянии устройство не поддерживает пакеты ACL и переходит в режим пониженного энергопотребления. Подчиненное устройство может по-прежнему участвовать в обменах по каналам SCO. В периоды неактивности подчиненное устройство может прослушивать сеть в состоянии пониженного энергопотребления или участвовать в работе другой пикосети.

• Парковка. Если от подчиненного устройства не требуется активного участия в работе пикосети, но оно должно оставаться ее частью, устройство может переходить в режим парковки — состояние пониженного энергопотребления с крайне малой активностью. Устройство теряет * активный адрес (AM_ADDR) и получает адрес элемента в режиме парковки (PM_ADDR). Если в пикосети используется режим парковки, она может состоять более чем из семи подчиненных устройств.

Аудио

В узкополосной спецификации указано, что могут использоваться две схемы шифрования речи: импульсно-кодовая модуляция (Pulse Code Modulation — PCM) или дельта-модуляция с непрерывной переменной огибающей (continuously variable slope delta — CVSD). Схему выбирают администраторы двух связанных устройств, исходя из конкретного приложения.

Модуляция РСМ была рассмотрена в разделе 6.4. CVSD - это разновидность дельта-модуляции (delta modulation — DM), которая также рассматривалась в указанном разделе. Напомним, что при дельта-модуляции, аналоговые входные данные аппроксимируются ступенчатой функцией, значение которой изменяется на один уровень квантования (δ) на каждом интервале дискретизации (Ts). Таким образом, для представления выхода дельта-модуляции достаточно одного бита на выборку. По сути, поток таких битов — это аппроксимация производной аналогового сигнала, а не его амплитуды: значение 1 генерируется, если ступенчатая функция увеличивает свое значение на следующем интервале дискретизации; в противном случае генерируется значение 0.

Ранее уже отмечалось, что в схемах DM существует два типа ошибок: шум квантования, имеющий место при очень медленном изменении сигнала, и шум перегрузки по крутизне — при очень быстром изменении сигнала. Схема CVSD предназначена для минимизации ошибок обоих типов путем применения разных уровней квантования: малых, когда сигнал меняется медленно, и больших, когда сигнал меняется быстро (рис. 6.13). Крутизна сигнала определяется на основе изучения К предшествующих битов выходных данных. Получающаяся в результате схема устойчивее к ошибкам, чем РСМ, и более устойчивая к ошибкам квантования и перегрузки по крутизне, чем DM.

Рисунок 6.13 - Пример дельта - модуляции с непрерывной переменной огибающей

На рис. 6.14 показано кодирование и декодирование CVSD (сравните с рис. 6.19). Как и при дельта-модуляции, двоичный выход преобразуется в ступенчатую функцию, которая пытается максимально близко повторить оригинал. При кодировании происходит следующее. Вход — это выборки РСМ, поступающие со скоростью 64 Кбит/с. В каждый момент дискретизации вход РСМ сравнивается с предшествующим значением аппроксимирующей ступенчатой функции, которое представляется как x(k - 1). Выход компаратора b(k) определяется следующим образом:

При передаче эти числа представляются битом знака (отрицательные числа отображаются в двоичную 1; положительные — в двоичный 0). Затем выход b(k) используется для определения амплитуды на следующем интервале ступенчатой функции, δ(k).

если по крайней мере J или K

последних битов равны

в противном случае

Рисунок 6.14 - Дельта - модуляция с непрерывной переменной огибающей

В табл. 6.6 показаны значения параметров по умолчанию. Из данного выше определения следует, что если сигнал меняется быстро (по крайней мере J из последних К шагов выполнены в одном направлении), то величина изменения шага (δ(k)) линейно увеличивается на постоянную величину δmin, вплоть до некоторой максимальной величины δmax. С другой стороны, если сигнал изменяется небыстро, то величина изменения шага постепенно (с коэффициентом затухания β) уменьшается вплоть до минимального значения δmin. Знак изменения шага определяется значением выходных данных b(t).

Таблица 6.6 - Значения параметров CVSD

Параметр | Значение
H | 1 - 1/32 = 0,96875
β | 1 - 1/1024 = 0,999
J | 4
K | 4
δmin | 10
δmax | 1280
ymin | -215 или -215+1
ymax | 215-1

После выполнения указанных вычислений изменение шага добавляется к последнему значению ступенчатой функции; результат обозначается ŷ(k) . Затем это значение задерживается на один интервал дискретизации, что записывается как ŷ(k - 1) . После этого применяется функция насыщения, которая определяется следующим образом:

где ymin и ymax — значения отрицательного и положительного насыщения кодера, ограничивающие диапазон ступенчатой функции.

В завершение y(k - 1) умножается на коэффициент затухания h, в результате чего получается оценка сигнала x(k - 1) .

Безопасность

В узкополосной спецификации Bluetooth определены следующие средства организации безопасного канала между любыми двумя устройствами Bluetooth:

• аутентификация;

• шифрование (конфиденциальность);

• управление использованием ключей.

В алгоритмах безопасности фигурируют четыре параметра.

• Адрес модуля. Общеизвестный 48-битовый адрес устройства.

• Секретный ключ аутентификации. Секретный 128-битовый ключ.

• Секретный частный ключ. Секретный ключ длиной от 4 до 128 бит.

• Случайное число. 128-битовое случайное число, сгенерированное на устройстве Bluetooth.

Два названных секретных ключа создаются и используются только устройством Bluetooth; разглашаться они не должны.

Цель аутентификации — проверить, действительно ли устройство Bluetooth, с которым планируется обмен данными, является тем, за кого себя выдает. На рис. 6.15 показана процедура аутентификации модулем А модуля В. Аутентификация заключается в проверке того, что оба устройства используют один предопределенный общий ключ аутентификации. Вначале А генерирует случайное число AU_RANDA и передает это значение В. Обе стороны используют алгоритм аутентификации E1 для генерации 32-битового подписанного ответа SRES. На вход E1 подается значение AU_RANDA, 48-битовый адрес устройства В и общий секретный ключ, а на выходе получается 128-битовое значение; 32 бит выхода формируют SRES. Алгоритм E1 (основанный на алгоритме шифрования SAFER) генерирует код аутентификации сообщения (message authentication code — MAC), представляющий собой хэш-код входных данных, основанный на секретном ключе. После того как В сгенерирует значение SRES, это значение возвращается А. А сравнивает поступившее значение SRES с локально сгенерированным. Если они совпадают — модуль В прошел аутентификацию.

Рисунок 6.15 - Аутентификация с запросом и ответом

На рис. 6.15 показана аутентификация только в одном направлении. Для взаимной аутентификации описанную выше процедуру должен инициировать модуль В.

Пользовательская информация может защищаться путем шифрования полезной нагрузки пакета; код доступа и заголовок пакета никогда не шифруются. Шифрование производится по алгоритму, известному как Е0. Соответствующий процесс показан на рис. 6.16. Если шифрование данных возможно, ведущее устройство посылает подчиненному случайное число RAND. Для каждой передачи пакета генерируется новый ключ шифрования. Вначале генерируется разовый ключ полезной нагрузки: сложным способом комбинируются число RAND, адрес ведущего устройства, текущее время и общий секретный ключ. Этот ключ полезной нагрузки используется как вход алгоритма Е0, в результате получается непрерывный поток битов (на рис. 6.16 обозначен символом z). Алгоритм Е0 реализуется на линейном регистре сдвига с обратной связью (linear feedback shift register — LFSR), для инициализации которого используется ключ полезной нагрузки. При шифровании (и дешифровании) к полезной нагрузке и выходу Е0 применяется операция побитового исключающего ИЛИ. Поскольку для каждого сеанса шифрования текущее время будет разным, безопасность увеличивается еще и за счет постоянного изменения ключей шифрования.

Рисунок 6.16 - Поточное шифрование Bluetooth


Беспроводные сети. Современное состояние и перспективы развития. 15.4 СПЕЦИФИКАЦИЯ АДМИНИСТРАТОРА СВЯЗЕЙ

6.4 СПЕЦИФИКАЦИЯ АДМИНИСТРАТОРА СВЯЗЕЙ

Протокол LMP (link manager protocol — протокол администратора связей) отвечает за различные аспекты радиоканала между ведущим и подчиненным устройствами. Протокол включает обмен сообщениями в форме PDU (protocol data unit — модуль данных протокола) LMP между объектами LMP ведущего и подчиненного устройств. Сообщения всегда посылаются как однослотовые пакеты с 1-байтовым заголовком полезной нагрузки, идентифицирующим тип сообщения и тело полезной нагрузки, в котором содержится дополнительная информация сообщения.

Процедуры, определенные для LMP, группируются в 24 функциональных области и каждая включает обмен одним или несколькими сообщениями. Эти области перечислены в табл. 6.7, указаны также соответствующие PDU8. Ниже приводится краткий обзор каждой области.

Таблица 6.7 - PDU протокола LMP

Функция | PDU
Общий ответ | accepted, not_accepted
Службы безопасности
Аутентификация | au_rand, sres
Образование пар | in_rand, au_rand, sres, comb_key, unit_key
Изменение ключа канала | comb_key
Изменение текущего ключа канала | temp__rand, temp_key, use_semi_permanent_key
Шифрование | encyption_mode_req, encyption_key_size_req, start_encyption_req, stop_encyption_req
Время/синхронизация
Запрос расхождения во времени | clkoffset_req, clkoffset_res
Информация по смещению слотов | Slot_offset
Запрос информации о точности отсчета времени | timing_accuracy_req, timing_accuracy_res
Возможности станции
Версия LMP | version_req, version_res
Поддерживаемые возможности | features_req, features_res
Управление режимами
Переключение роли "ведущий/подчиненный" | Swich_req
Запрос имени | name_req, name_res
Отсоединение | detach
Режим удержания | hold, hold_req
Режим подслушивания | sniff, sniff_req, unsniff_req
Режим парковки | park_req, park, set_broadcast_window, modify_beacon, unpark_PM_ADDR_req, un-park_BD_ADDR_req
Контроль мощности | incr_power_req, decr_power_req, max_power, min_power
Переход между пакетами DM и DH на основе качества канала | auto_rate, preferred_rate
Качество обслуживания | quality_of_service, quality_of_service_req
Каналы SCO | SCO_link_req, remove_SCO_link_req
Управление многослотовыми пакетами | max_slot, max_slot_req
Схема избирательного запроса | page_mode_req, page_scan_mode_req
Надзор за каналом | supervision_timeout

Для ответа на PDU во многих процедурах используются два сообщения общего ответа. Модуль accepted содержит идентификатор принятого сообщения. Модуль not_accepted содержит идентификатор непринятого сообщения и причину отказа.

LMP поддерживает различные службы безопасности с механизмами управления аутентификацией, шифрованием и распределением ключей. В число данных служб входят следующие.

• Аутентификация. Аутентификация определена в узкополосной спецификации, но включает обмен двумя PDU LMP: содержащим случайное число и содержащим подписанный ответ (рис. 6.15).

• Образование пар. Данная служба позволяет взаимно аутентифицированным пользователям автоматически устанавливать ключ шифрования канала. На первом этапе ключ инициализации генерируется обеими сторонами и используется в процедуре аутентификации для подтверждения того, что обе стороны имеют одинаковый ключ. Ключ инициализации генерируется из общего личного идентификационного номера (personal identification number — PIN), введенного в оба устройства. Затем обе стороны обмениваются сообщениями и определяют, каким будет ключ канала для дальнейшего шифрования: уже подтвержденным секретным ключом или комбинационным ключом, который вычисляется на основе ключа канала ведущего устройства.

• Изменение ключа канала. Если два устройства соединены в пару и используют комбинационный ключ, то этот ключ можно менять. Одна сторона генерирует новый ключ и посылает его другой стороне, применив операцию исключающего ИЛИ к новому и старому ключам канала. Другая сторона ключ принимает или отклоняет.

• Изменение текущего ключа канала. Текущий ключ канала можно изменить временно. При создании временного (на один сеанс) ключа фигурируют случайные числа и операции исключающего ИЛИ.

• Шифрование. LMP не задействован непосредственно в шифровании канала, но предлагает службы для управления процессом шифрования. В процессе могут оговариваться несколько параметров, в том числе рабочий режим шифрования (шифрование отсутствует, только двухточечное шифрование, двухточечное и широковещательное шифрование), размер ключа и случайный начальный ключ для начала нового сеанса шифрования. Протокол LMP также фигурирует, когда начинается и прекращается использование шифрования.
LMP предлагает механизмы синхронизации часов различных участников пикосети.

• Запрос расхождения во времени. Когда подчиненное устройство получает пакет FHS, оно определяет разницу между его собственным временем и временем ведущего устройства, которое указано в полезной нагрузке пакета FHS. Величина расхождения во времени постоянно обновляется с каждым пакетом, полученным от ведущего устройства. Ведущее устройство может запросить значение расхождения во времени в любой момент соединения. Запомнив эту величину, ведущее устройство может предсказать, в каком радиоканале данное устройство отзовется на сообщение поиска запроса, после того как покинет пикосеть. Это может использоваться для уменьшения времени запроса данного устройства, когда оно вновь войдет в данную пикосеть.

• Информация по смещению слотов. Инициирующее устройство может передать сообщение, которое характеризует отличия в отсчете времени (промежутки между границами слотов) в двух соседних пикосетях.

• Запрос информации о точности отсчета времени. Используется устройством, чтобы определить, насколько точно работает подсистема синхронизации другого устройства. В число параметров, представляющих интерес, входят накапливающееся расхождение во времени двух устройств и случайное смещение счета времени.
LMP включает два PDU, которые используются для обмена информацией о сообщающихся устройствах.

• Версия LMP. Позволяет каждому объекту LMP определить версию LMP, реализованную на других объектах. На настоящий момент существует единственная версия.

• Поддерживаемые возможности. Радио и контроллер канала Bluetooth могут поддерживать только некоторые типы пакетов, описанные в узкополосной спецификации и радиоспецификации. Для обмена этой информацией используются PDU LMP_features_req и LMP_features_res. LMP поддерживает следующее:

• 3-слотовые пакеты;

• 5-слотовые пакеты;

• шифрование;

• смещение слотов;

• точность синхронизации;

• переключение;

• режим удержания;

• режим подслушивания;

• режим парковки;

• RSSI;

• изменение скорости передачи данных на основе качества канала; ,

• канал SCO;

• пакеты HV2;

• пакеты HV3;

• логарифмическую μ-характеристику;

• логарифмическую А-характеристику;

• CVSD;

• схему избирательного запроса;

• контроль мощности.

Устройство Bluetooth имеет несколько состояний и режимов, в которых оно может находиться. Для управления режимами протокол LMP предлагает следующие PDU.

• Переключение роли "ведущий/подчиненный". Позволяет подчиненному устройству становиться ведущим устройством пикосети. Это требуется, например, когда устройством, производящим запрос, должно быть ведущее устройство. Если новому устройству требуется произвести запрос, оно может использовать указанную службу.

• Запрос имени. Позволяет устройству запросить текстовое имя другого устройства.

• Отсоединение. Позволяет устройству разорвать соединение. Данный PDU может передаваться ведущим или подчиненным устройством.

• Режим удержания. Переводит канал между ведущим и подчиненным устройствами в режиме удержания на заданный период времени.

• Режим подслушивания. Чтобы перейти в режим подслушивания, ведущее и подчиненное устройства согласовывают интервал подслушивания Т и смещение подслушивания D, которое определяет время подслушивания. Смещение определяет время первого слота подслушивания; после этого слоты будут прослушиваться с периодом Т.

• Режим парковки. Переводит подчиненное устройство в режим парковки.

• Контроль мощности. Используется устройством для того, чтобы указать другому устройству увеличить или уменьшить мощность передачи.

• Переход между пакетами DM и DH на основе качества канала. Устройство можно настроить так, чтобы оно постоянно использовало пакеты DM, постоянно использовало пакеты DH или автоматически выбирало тип пакетов, соответствующий качеству канала. Эта служба позволяет явное переключение между тремя указанными вариантами. Различие между пакетами DM и DH состоит в том, что первые защищаются кодом FEC 2/3, а вторые не защищены кодом FEC.

• Качество обслуживания (QoS). Качество обслуживания Bluetooth определяется двумя параметрами. Интервал опроса, максимальное время между передачами от ведущего устройства данному подчиненному, используется для распределения пропускной способности и управления ожиданием. Второй параметр — это число повторений для широковещательных пакетов (number of repetitions for broadcast packets — NBC). Широковещательные пакеты не подтверждаются, таким образом, чем большее число раз они будут транслироваться повторно, тем выше вероятность их приема.

• Каналы SCO. Используются для создания канала SCO.

• Управление многослотовыми пакетами. Оговаривает максимальное число слотов в пакете. Значение по умолчанию — 1; возможны также значения 3 и 5.

• Схема избирательного запроса. Управляет типом схемы избирательного запроса устройств в пикосети. Существует схема по умолчанию, реализация которой является обязательной. Могут определяться дополнительные схемы.

• Надзор за каналом. Определяет максимальное время, по прошествии которого устройство может объявлять о сбое в работе канала.


Беспроводные сети. Современное состояние и перспективы развития. 15.2 ПРОТОКОЛ УПРАВЛЕНИЯ ЛОГИЧЕСКИМ КАНАЛОМ И АДАПТАЦИИ (L2CAP)

6.5 ПРОТОКОЛ УПРАВЛЕНИЯ ЛОГИЧЕСКИМ КАНАЛОМ И АДАПТАЦИИ (L2CAP)

Подобно протоколу управления логическим каналом (logical link control — LLC) в спецификации IEEE 802 L2CAP предоставляет объектам среды совместного использования протокол канального уровня. Как и LLC, L2CAP предлагает некоторые услуги и полагается на нижестоящий уровень (в данном случае — узкополосный) в вопросах управления потоком и защиты от ошибок.

L2CAP использует каналы ACL; каналы SCO он не поддерживает. С помощью каналов ACL протокол L2CAP предоставляет протоколам высших уровней две альтернативные услуги.

• Служба без установления соединения. Одна из услуг, основанных на надежных дейтаграммах.

• Служба режима соединения. Эта услуга подобна услуге предлагаемой протоколом HDLC. Между двумя пользователями, обменивающимися данными, устанавливается логическое соединение и обеспечивается управление потоком и защита от ошибок.

Каналы L2CAP

L2CAP предлагает три типа логических каналов.

• Без установления соединения. Поддерживает услуги без установления соединения. Каждый канал является однонаправленным и обычно используется для широковещания от ведущего устройства.

• На основе соединения. Поддерживает услуги на основе соединений. Каждый канал является двунаправленным (полнодуплексным), причем в обоих направлениях задается определенное качество обслуживания (quality of service — QoS).

• Канал передачи сигналов. Предусмотрен для обмена сигнальными сообщениями между объектами L2CAP.

Пример использования логических каналов L2CAP приведен на рис. 6.17. С каждым логическим каналом соотнесен идентификатор канала (channel identifier — CID). Для каналов на основе соединения уникальное значение CID присваивается обоим концам канала, таким образом каждое соединение идентифицируется и сопоставляется с пользователем L2CAP на соответствующей стороне канала. Для идентификации каналов без установления соединения используется значение CID = 2, а каналов передачи сигналов — CID = 1. Таким образом, между ведущим и любым подчиненным устройством существует только один канал без установления соединения и один канал передачи сигналов, а каналов на основе соединения может быть несколько.

Пакеты L2CAP

На рис. 6.18 показан формат пакетов L2CAP. Для услуг без установления соединения пакет содержит следующие поля.

• Длина. Размер (в байтах) полезной информационной нагрузки плюс поле PSN.

• Идентификатор канала. 2 — канал без установления соединения.

• Мультиплексор протоколов/услуг (protocol/service multiplexer — PSM).

Определяет пользователя на высшем уровне, которому предназначена полезная нагрузка данного пакета.

• Полезная информационная нагрузка. Данные пользователя более высокого уровня. Размер данного поля может доходить до 65533 (216 - 3) байт.

Пакеты на основе соединения имеют такой же формат, но без поля PSM. Это поле не требуется, поскольку получатель данных на вышестоящем уровне определяется из значения CID. Поле полезной нагрузки информации может иметь размер до 65535 (216 - 1) байт.

Рисунок 6.17 - Каналы L2CAP

Рисунок 6.18 - Форматы L2CAP

Пакеты сигнальных команд имеют такой же формат заголовка, что и пакеты на основе соединения. В данном случае значение CID = 1 означает, что по этому каналу передается сигнальная информация. Полезная нагрузка сигнального пакета — это одна или большее число команд L2CAP, каждая из которых состоит из четырех полей.

• Код. Идентифицирует тип команды.

• Идентификатор. Используется для сопоставления запроса с ответом. При ответе реагирующее устройство использует то же значение этого поля, что было установлено запрашивающим устройством. Для каждой новой исходной команды должен использоваться другой идентификатор.

• Длина. Размер (в байтах) поля данных этой команды.

• Данные. Если необходимо, команду могут сопровождать дополнительные данные.

Сигнальные команды

Существует одиннадцать сигнальных команд, разбитых на пять категорий (табл. 6.9). Для отмены любой команды может передаваться команда отклонения команды. Причиной отмены может быть, например, неприемлёмый идентификатор CID или превышение длины.

Таблица 6.8 - Коды сигнальных команд L2CAP

Код | Описание | Параметры
0х01 | Отмена команды | Причина
0х02 | Запрос соединения | PSM, CID источника
0х03 | Ответ на запрос соединения | СШ адресата, CID источника, результат, статус
0х04 | Запрос конфигурации | СШ адресата, флаги, опции
0х05 | Ответ на запрос конфигурации | СШ источника, флаги, результат, опции
0х06 | Запрос разрыва соединения | СШ адресата, СШ источника
0х07 | Ответ на запрос разрыва соединения | СШ адресата, CID источника
0х08 | Эхо-запрос | Данные (не обязательно)
0х09 | Эхо-ответ | Данные (не обязательно)
0х0А | Информационный запрос | Тип информации
0х0В | Ответ на информационный запрос | Тип информации, результат, данные (не обязательно)

Команды соединения используются для установления нового логического канала. Команда запросов содержит значение PSM, определяющее пользователя L2CAP для данного соединения. На настоящий момент разрешены три значения: для протокола обнаружения услуги, RFCOMM и протокола управления телефонией. Другие значения PSM присваиваются динамически и зависят от реализации. Команда запроса также содержит значение CID, которое присвоится источником этому соединению. Команда ответа включает CID источника и адресата, последний присваивается каналу отвечающей стороной. Параметр результата определяет результат запроса (успешный, в стадии рассмотрения, отклоненный), и если запрос находится в стадии рассмотрения (например, незаконченная аутентификация, незаконченная авторизация), в поле статуса указывается текущее состояние запроса.

Для установления исходного логического канала между двумя объектами L2CAP и пересмотра параметров этого канала могут передаваться команды конфигурации. Каждый параметр в команде-запросе связан с входящим или с исходящим трафиком. Команда запроса содержит поле флагов; в настоящее время определен только один флаг, указывающий, будут ли переданы дополнительные команды конфигурации. Поле опций содержит список параметров и их значений, подлежащих обсуждению. Каждый параметр определяется тремя полями.

• Тип (1 байт). Семь младших битов данного байта определяют опцию. Если старший бит равен 0, опция является обязательной, и если распознать ее не удалось, адресат должен отклонить конфигурационный запрос. Если старший бит равен 1, опция необязательна и может игнорироваться адресатом.

• Длина (1 байт). Размер полезной нагрузки, в качестве которой выступают опции. Длина 0 указывает на отсутствие полезной нагрузки.

• Полезная нагрузка — опции. Дальнейшая информация об опции. Согласовываться могут следующие параметры.

• Максимальный модуль передачи (maximum transmission unit — MTU).

Наибольшая полезная нагрузка пакета L2CAP (в байтах), которую автор запроса может принять в данном канале. Вследствие асимметричности MTU отправитель запроса должен указать, какой MTU он готов принять по обратному каналу (если это значение отличается от значения, принятого по умолчанию). Реализации L2CAP должны поддерживать MTU минимального размера — 48 байт. Значение по умолчанию — 672 байт. Оно не подлежит согласованию, это просто информация о том, MTU какого размера может принимать отправитель запроса.

• Время ожидания отказа. Напомним, что в схеме ARQ определен отказ от полезной нагрузки, если некоторое число попыток ее передачи завершилось сбоем. Время ожидания отказа — это параметр, определяющий промежуток времени, в течение которого источник будет предпринимать попытки передачи, прежде чем отказаться от пакета L2CAP.

• Качество обслуживания (quality of service — QoS). Определяет спецификацию потока трафика в канале для трафика локального устройства (исходящего трафика). Этот параметр описывается ниже.
В двух последних случаях возможно согласование параметров: сторона-ответчик может принять параметры QoS и время ожидания отказа или предложить согласовать их. Сторона-источник может в ответ принять или отклонить измененные параметры.

Команда ответа на запрос конфигурации также включает поле флагов, имеющее такое же значение, как в команде-запросе. Поле результата в команде ответа указывает, был переданный запрос принят или отклонен. Поле опций содержит тот же список параметров, что имеется в соответствующей команде запроса. Если запрос был успешен, эти параметры включают возвратные значения всех безразличных параметров (см. последующее обсуждение QoS). Если запрос был неудачным, в ответ должны включаться отклоненные параметры, значения которых меняются на приемлемые для станции-ответчика.

Команды разрыва соединения используются для разрыва логического канала.

Эхо-команды — это требование запроса от удаленного объекта L2CAP. Такие команды обычно используются для тестирования канала или передачи информации о поставщике с использованием дополнительного поля данных.Информационные команды — это запросы информации о реализации от удаленного объекта L2CAP.

Качество обслуживания

Параметр QoS в L2CAP определяет на основе RFC 13639 спецификацию потока трафика. По сути, спецификация потока — это набор параметров, отражающих уровень производительности, к которому будет стремиться передатчик.

Если данная опция включена в запрос конфигурации, она описывает поток трафика, исходящий от устройства, которое послало запрос, по направлению к запрашиваемому устройству. Если данная опция включена в положительный запрос конфигурации, она описывает соглашения по потоку входящего трафика, как их представляет отвечающее устройство. Если данная опция включена в отрицательный запрос конфигурации, она описывает предпочтительный поток входящего трафика, как его представляет отвечающее устройство.

Спецификация потока состоит из следующих параметров:

• тип услуги;

• скорость маркера (байты в секунду);

• размер сегмента в маркерах (байты);

• максимальная ширина полосы (байты в секунду);

• ожидание (микросекунды);

• разброс задержек (микросекунды).

Параметр тип услуги показывает уровень услуги для данного потока. При значении 0 по данному каналу трафик распространяться не будет; 1 — услуга "без обязательств", устройство будет передавать данные с максимально возможной скоростью, но без гарантий производительности; 2 — гарантированная услуга, отправитель будет передавать данные, которые соответствуют остальным параметрам QoS.

Параметры скорости маркера и размера сегмента в маркерах определяют схему маркерного сегмента, которая часто используется в спецификациях QoS. Преимуществом этой схемы является емкое описание максимального и среднего трафика, который может ожидать получатель, и удобная реализация стратегии управления трафиком.

Спецификация трафика по схеме маркерного сегмента включает два параметра: скорость пополнения маркера (R) и размер сегмента (В). Маркерная скорость R задает среднюю непрерывную скорость передачи данных; т.е. за относительно долгий период времени среднее значение скорости передачи данных этого потока равно R. Размер сегмента В определяет величину разрешенного кратковременного превышения скорости R. Точное условие звучит так: в течение любого периода времени Т объем посланных данных не может превышать RT + В.

Данная схема показана на рис. 6.19, там же приведены иллюстрации используемых терминов. Сегмент представляет счетчик, который в любое время отображает допустимое количество байтов данных, которые могут посылаться. Сегмент заполняется маркерами байтов со скоростью R (т.е. значение счетчика увеличивается R раз в секунду) вплоть до его полного заполнения (максимальное значение счетчика). Данные поступают от пользователя L2CAP в форме пакетов, которые для передачи выстраиваются в очередь. Пакет может передаваться, только если есть достаточное количество маркеров байтов для маркировки всего пакета. Если маркеров достаточно, пакет передается и из сегмента уходит соответствующее число маркеров. Если маркеров недостаточно, то спецификация потока запрещает передачу такого пакета. В стандартах не указывается, что происходит с такими пакетами дальше; обычно пакет просто находится в очереди на передачу до тех пор, пока не будет накоплено нужное число маркеров.

Рисунок 6.19 - Схема маркерного сегмента

В течение достаточно большого промежутка времени скорость передачи данных, которую разрешает маркерный сегмент, равна R. Однако в период отсутствия данных или при относительно медленной скорости их поступления емкость сегмента увеличивается, чтобы в дальнейшем принять на В байтов больше, чем определяется средней скоростью. Таким образом, В обозначает допустимую степень неравномерности потока данных.

Если оба параметра протокола L2CAP имеют значение 0, то для данного приложения маркерная схема не требуется и использоваться не будет. Если оба параметра равны 1, это значение называется безразличным. Для услуг "без обязательств" безразличное значение указывает, что запрашивающей стороне требуется настолько большой маркер или сегмент, насколько может гарантировать отвечающая сторона, а для гарантированной услуги оно означает, что на момент запроса скорость передачи данных будет максимальной или максимальным будет размер сегмента.

Максимальная ширина полосы (измеряется в байтах в секунду) определяет, насколько быстро может происходить пересылка пакетов между приложениями. Некоторые промежуточные системы используют эту информацию для более эффективного распределения ресурсов. Предположим, что маркерный сегмент полон, а в поток поступает серия пакетов, размер которых равен размеру сегмента. Если не ввести ограничивающий механизм, такое событие может надолго "засорить" сегмент. Максимальная скорость передачи — это и есть такой ограничитель, который определяет, с какой частотой последовательные пакеты могут вводиться в сеть.

Ожидание — это максимально допустимая задержка (выражается в микросекундах) между отправкой бита и началом его передачи по радиоканалу.

Разброс задержек — это разность (в микросекундах) возможных максимальной и минимальной задержек пакета. Указанное значение используется приложениями для вычисления объема буфера, необходимого принимающей стороне для восстановления схемы передачи данных. Если принимающему приложению требуется, чтобы данные поступали так же, как передавались, ему, возможно, придется временно занести поступающие данные в буфер, чтобы приемник смог подстроиться под схему передачи. В качестве примера можно привести ситуацию, когда приложение передает данные, такие, как выборки речи, которые генерируются и проигрываются через регулярные промежутки времени. В зависимости от размера буфера, который может предоставить принимающий хост, будет меняться и разброс задержек, допустимый при передаче отдельных пакетов потока.


Беспроводные сети. Современное состояние и перспективы развития. 2.1 ПРИНЦИПЫ СОТОВОЙ СВЯЗИ

Из всех потрясающих воображение успехов, достигнутых в сфере телекоммуникаций и обмена данными, возможно, самым революционным является создание сотовой сети. Именно на сотовой технологии основана мобильная беспроводная связь, которая открыла доступ к связи даже тем пользователям, которых трудно было обслужить с помощью обычной проводной сети. Сотовая технология лежит в основе мобильных телефонов, систем персональной коммуникации, беспроводной работы в Internet, беспроводных Web-приложений и многого другого.

Эта глава начнется с обзора основных принципов, на которых построены все сотовые сети. Затем будут рассмотрены конкретные сотовые технологии и стандарты, удобно группируемые в три поколения. Технологии первого поколения основаны на аналоговых сигналах и в настоящее время все еще широко используются, хотя постепенно сходят со сцены. Доминирующей технологией на сегодня являются цифровые системы, принадлежащие второму поколению. Наконец, высокоскоростные цифровые системы третьего поколения только начали появляться.

2.1 ПРИНЦИПЫ СОТОВОЙ СВЯЗИ

Сотовой радиосвязью называется технология, разработанная для увеличения пропускной способности мобильных радиотелефонных услуг. До введения сотовой радиосвязи для предоставления этих услуг требовались передатчики и приемники высокой мощности. Типичная система связи могла обслуживать около 25 каналов и имела эффективный радиус действия около 80 км. Для увеличения пропускной способности такой системы нужно было использовать оборудование более низкой мощности и, следовательно, меньшего радиуса действия при участи в ней нескольких передатчиков и приемников. В начале данного раздела кратко рассматривается организация сотовой системы, после чего анализируются некоторые особенности ее внедрения.

Организация сотовой сети

Принцип организации сотовой связи состоит в использовании множества маломощных (100 Вт и ниже) передатчиков. Поскольку диапазон действия таких передатчиков довольно мал, зону обслуживания системы можно разбивать на ячейки, каждая из которых будет обслуживаться собственной антенной. Каждая ячейка, которой выделяется своя полоса частот, обслуживается базовой станцией, состоящей из передатчика, приемника и модуля управления. Смежные ячейки используют разные частоты, чтобы избежать интерференции или перекрестных помех. В то же время ячейки, находящиеся на довольно большом расстоянии друг от друга, могут использовать одинаковые полосы частот.

При проектировании такой системы первое, что нужно сделать, — это решить, какую форму должны иметь ячейки, на которые будет разбита зона обслуживания. Самым простым решением была бы сетка, состоящая из квадратных ячеек (рис. 2.1, а). Однако такая геометрическая форма оказалась не идеальной. Если сторона квадратной ячейки равна d, тогда ячейка будет иметь

четыре соседа на расстоянии d и четыре — на расстоянии √2d . В то же время, если пользователь мобильных услуг находится в пределах одной ячейки и движется по направлению к ее границе, было бы лучше, чтобы все смежные антенны находились на равных расстояниях друг от друга. В этом случае проще определить момент, в который следует переключать пользователя на другую антенну, также выбирать новую антенну. Равное расстояние между смежными антеннами достигается только в шестиугольной схеме (см. рис. 2.1, б). Радиус шестиугольника определяется как радиус окружности, описанной вокруг него (эта величина равна расстоянию от центра фигуры до каждой из ее вершин, а также длине стороны шестиугольника). Для ячейки с радиусом К расстояние между центром ячейки и центром любой смежной ячейки равняется d = √3 R.

Рисунок 2.1 - Геометрические структуры сотовых систем

На практике точная шестиугольная структура не используется. Отклонения от идеальных шестиугольников обусловлены топографическими ограничениями, местными условиями распространения сигнала и соображениями целесообразности расположения антенн.

В беспроводной сотовой системе нельзя неограниченно использовать одну и ту же частоту для разных сообщений, так как при передаче на произвольных частотах разные сигналы могут интерферировать, даже если географически они разделены. Поэтому для систем, поддерживающих большое количество одновременных сеансов связи, нужен механизм, определяющий принципы использования спектра.

Многократное использование частот

В каждой ячейке сотовой сети имеется базовый трансивер. Мощность передаваемых сигналов тщательно регулируется (несколько это возможно для быстро меняющихся условий сред мобильной связи), поскольку (1) требуется осуществлять связь в пределах одной ячейки, но (2) это не должно приводить к интерференции сигналов данной ячейки с сигналами соседних. Как правило, каждой ячейке выделяется 10-50 частот, в зависимости от планируемой нагрузки. Кроме того, нужен механизм использования одной и той же частоты в ячейках, расположенных недалеко друг от друга, чтобы одну частоту можно было использовать для нескольких одновременных сеансов связи.

Важным вопросом, разумеется, является определение удаленности двух ячеек, использующих одну частоту, поскольку сигналы этих ячеек не должны интерферировать друг с другом. Были предложены различные модели многократного использования частот, некоторые примеры приведены на рис. 2.2. Если схема состоит из N ячеек, для которых выделяется одинаковое количество частот, то каждая ячейка будет иметь K/N частот, где К — общее число частот, выделяемых системе. Мобильная телефонная система AMPS, в которой К = 395, а N = 7, представляет собой наименьшую систему, в которой можно обеспечить достаточную изоляцию двух сеансов использования одной и той же частоты. Это означает, что в среднем на одну ячейку должно приходиться не более 57 частот.

Рисунок 2.2 - Модели многократного использования частот

Для характеристики повторного использования частоты существуют следующие параметры:

D — минимальное расстояние между центрами ячеек, которые используют одну и ту же полосу частот (называемую группой внутренних каналов);

R — радиус ячейки;

d — расстояние между центрами смежных ячеек (d = √3 R).

N — число ячеек в минимальном фрагменте, периодическим повторением которого образуется вся схема (каждая ячейка фрагмента использует уникальную полосу частот). Этот параметр еще называют кратностью использования.

В шестиугольной схеме возможны только следующие значения N:

N = I2 + J2 + (I x J), I, J = 0, 1, 2, 3, ...

Таким образом, возможными значениями N являются числа 1, 3, 4, 7, 9, 12, 13, 16, 19, 21 и т.д. Верно следующее соотношение:

D / R = √N.

Это можно записать и по-другому: D/d = √N.

Увеличение пропускной способности

Со временем, когда система будет обслуживать все больше клиентов, трафик может распределиться таким образом, что какой-нибудь ячейке для обслуживания звонков не хватит выделенных ей частот. Для выхода из такой ситуации используется несколько подходов.

• Добавление новых каналов. Обычно, когда система установлена в определенном регионе, используются не все каналы, и с расширением системы можно просто добавлять новые.

• Заимствование частот. В самом простом случае перегруженные ячейки могут "одалживать" частоты у смежных ячеек.

• Расщепление ячеек. На практике распределение трафика и топография местности неоднородны, что также дает возможность увеличения пропускной способности. Ячейки в областях с повышенным спросом на услуги мобильной связи можно расщеплять. Как правило, размеры исходных ячеек колеблются от 6,5 до 13 км. Меньшие ячейки также можно разбивать, однако следует помнить, что на практике радиус 1,5 км считается минимальным (см. ниже обсуждение микроячеек). При использовании меньших ячеек нужно уменьшать уровень мощности, чтобы сигнал оставался в пределах ячейки. Кроме того, при движении мобильные устройства переходят из одной ячейки в другую, что требует передачи вызова от одного базового трансивера другому. Этот процесс называется переключением (handoff). Так вот, по мере уменьшения размера ячейки переключения будут происходить все чаще. На рис. 2.3 изображена схема расщепления ячейки, которая обеспечивает увеличение пропускной способности системы. При уменьшении радиуса ячейки в F раз размеры покрываемой области уменьшаются в F2 раз, а требуемое число базовых станций увеличивается в те же F2 раз.

• Разбивка ячеек на секторы. При разбивке на секторы ячейка делится на несколько клиновидных секторов, в каждом из которых остается свой набор каналов. Обычно на ячейку приходится 3-6 секторов. Каждому сектору предоставляется отдельный набор каналов ячейки, а для фокусировки сигнала на отдельных секторах используются направляемые антенны базовой станции.

• Микроячейки. По мере уменьшения ячейки антенны перемещаются с крыш высотных зданий и вершин холмов на крыши зданий поменьше или на стены высотных домов и в конце концов оказываются на фонарных столбах, с высоты которых они обслуживают микроячейки. Любое уменьшение размеpa ячейки сопровождается уменьшением уровня мощности сигналов, излучаемых базовой станцией. Микроячейки полезно располагать на городских улицах в густо населенных районах, а также внутри больших зданий общественного пользования.

Рисунок 2.3 - Расщепление ячейки

В табл. 2.1 представлены характерные параметры традиционных ячеек, именуемых макроячейками, и микроячеек, созданных описанным выше способом. Средний разброс задержек — это усреднение разброса задержек по многим трактам распространения (ведь один и тот же сигнал может распространяться несколькими путями, и существует временная задержка между прибытием в приемник самого раннего и самого позднего сигнала). Как отмечалось выше, меньшие ячейки позволяют использовать меньшую мощность и обеспечивают прекрасные условия распространения сигнала.

Таблица 2.1. Характерные параметры макро- и микроячеек

 | Макроячейка | Микро ячейка
Радиус ячейки | 1-2 км | 0,1-1 км
Мощность передаваемого сигнала | 1-10 Вт | 0,1-1 Вт
Средний разброс задержек | 0,1-10 мкс | 10-100 нс
Максимальная скорость передачи данных | 0,3 Мбит/с | 1 Мбит/с

Пример. Пусть система состоит из 32 ячеек с радиусом 1,6 км каждая, имеет выделенную полосу частот, позволяющую поддерживать 336 информационных каналов, и кратность использования частоты N= 7. Какую географическую зону обслуживают эти 32 ячейки, сколько каналов приходится на одну ячейку, и какое число одновременно поступающих звонков может обрабатываться? Повторите задачу для 128 ячеек с радиусом 0,8 км.

На рис. 2.4, а показана схема, покрывающая приблизительно квадратную область. Площадь одного шестиугольника с радиусом R составляет 1,5 R √3 . Т.е. шестиугольник с радиусом 1,6 км покрывает зону площадью 6,65 км2, а 32 ячейки покрывают зону площадью 6,65 х 32 = 213 км2. Для N= 1 количество каналов на одну ячейку составляет 336/7 = 48, а общая пропускная способность составляет 48 х 32 = 1536 каналов. Для схемы, показанной на рис. 2.4, б, площадь покрываемой зоны равна 1,66 х 128 = 213 км2. Количество каналов на одну ячейку составляет 336/7 = 48, а общая пропускная способность — 48 х 128 = 6144 каналов.

Рисунок 2.4 - Пример схемы с многократным использованием частот

Функционирование сотовой системы

На рис. 2.5 показаны основные элементы сотовой системы. Примерно в центре каждой ячейки находится базовая станция. Базовая станция состоит из антенны, контроллера и нескольких трансиверов, которые служат для связи в каналах, выделенных этой ячейке. Контроллер используется для обработки соединений мобильного устройства с остальной сетью. В любой момент в пределах ячейки могут быть активными и перемещаться несколько пользователей мобильной связи, сообщающихся с базовой станцией. Каждая базовая станция подсоединена к коммутатору мобильных телекоммуникаций (mobile telecommunications switching office — MTSO), причем один коммутатop MTSO может обслуживать несколько базовых станций. Обычно связь между коммутатором MTSO и базовой станцией является проводной, хотя возможна также беспроводная связь. Коммутатор MTSO устанавливает соединение между мобильными устройствами. Кроме того, MTSO соединен также с общественной телефонной или телекоммуникационной сетью и может соединять стационарных абонентов с сетью общего пользования и мобильных абонентов с сотовой сетью. Коммутатор MTSO выделяет для каждого соединения голосовой канал, выполняет переключения (о которых мы поговорим ниже) и контролирует звонки для передачи информации о счетах.

Работа сотовой системы полностью автоматизирована и не требует от пользователя никаких действий, кроме заказа разговоров и ответа на звонки. Между мобильным устройством и базовой станцией можно устанавливать каналы связи двух типов: каналы управления и информационные каналы. Каналы управления используются для обмена информацией, касающейся заказа и поддержания звонка, а также установления связи между мобильным устройством и ближайшей к нему базовой станцией. Информационные каналы служат для передачи голоса или данных между пользователями. На рис. 2.6 показаны шаги, которые следует 'предпринять для обычного соединения двух мобильных пользователей, находящихся в зоне действия одного коммутатора MTSO.

Рисунок 2.5 - Общий вид сотовой системы

• Инициализация мобильного устройства. Включенное мобильное устройство проводит сканирование и выбирает самый сильный настроечный канал управления, используемый данной системой (см. рис. 2.6, а). Ячейки с различными полосами частот периодически транслируют сигналы в различных настроечных каналах. Приемник мобильного устройства выбирает самый сильный настроечный канал и начинает его прослушивать. В результате этой процедуры мобильное устройство автоматически выбирает антенну базовой станции той ячейки, в пределах которой оно будет действовать1. Затем выполняется квитирование между мобильным устройством и коммутатором MTSO, контролирующим данную ячейку, что тоже осуществляется через базовую станцию этой ячейки. Квитирование используется для опознания пользователя и для регистрации его местоположения. Все время, пока включено мобильное устройство, эта процедура сканирования периодически повторяется, что позволяет следить за движением устройства. Если устройство входит в новую ячейку, выбирается новая базовая станция. Кроме того, мобильное устройство следит за сигналами избирательного вызова, о чем мы поговорим ниже.

Рисунок 2.6 - Пример мобильного сотового соединения

• Звонок с мобильного устройства. Звонок с мобильного устройства начинается с отправки номера вызываемого устройства по предварительно выбранному каналу (см. рис. 2.6, б). Приемник мобильного устройства сначала проверяет, свободен ли настроечный канал, анализируя информацию в прямом (от базовой станции) канале. Когда обнаруживается, что канал свободен, мобильное устройство может начинать передачу в соответствующем обратном (к базовой станции) канале. Базовая станция в свою очередь отправляет запрос на коммутатор MTSO.

• Избирательный вызов. Далее коммутатор MTSO пытается установить связь с вызываемым устройством. Коммутатор отправляет адресное сообщение определенной базовой станции, в зависимости от номера вызывающего мобильного устройства (см. рис. 2.6, в). Каждая базовая станция передает сигналы избирательного вызова в собственном выделенном настроечном канале.

• Принятие вызова. Вызываемое мобильное устройство распознает свой номер в настроечном канале, за которым следит в настоящий момент, и отвечает данной базовой станции. Базовая станция отправляет ответ на коммутатор MTSO, который устанавливает канал связи между вызывающей и вызываемой базовыми станциями. В то же самое время коммутатор MTSO выбирает подходящий канал информационного обмена внутри ячейки каждой базовой станции и уведомляет каждую базовую станцию, которые в свою очередь уведомляют свои мобильные устройства (см. рис. 2.6, г). Оба мобильных устройства настраиваются на выделенные им каналы.

• Текущий вызов. Пока поддерживается соединение, два мобильных устройства обмениваются голосовыми сигналами или данными, проходящими через соответствующие базовые станции и коммутатор MTSO (см. рис. 2.6, д).

• Переключение. Если мобильное устройство во время соединения выходит за пределы одной ячейки и входит в зону действия другой, то старый информационный канал следует заменить каналом, выделенным новой базовой станции в новой ячейке (см. рис. 2.6, е). Система осуществляет это изменение, не прерывая звонка и не беспокоя пользователя.

Система также выполняет некоторые другие функции, не представленные на рис. 2.6.

• Блокирование вызова. Если при звонке с мобильного устройства все информационные каналы, выделенные ближайшей базовой станции, заняты, то мобильное устройство предпринимает предварительно заданное количество последовательных попыток установления связи. После определенного количества неудачных попыток пользователю возвращается сигнал "занято".

• Завершение вызова. Когда один или оба пользователя вешают трубку, об этом узнает коммутатор MTSO и освобождает информационные каналы обеих базовых станций.

• Потеря вызова. Если в определенный период соединения из-за интерференции или слабого сигнала базовая станция не может поддерживать минимально требуемую интенсивность сигнала, то информационный канал связи с пользователем прерывается, о чем уведомляется коммутатор MTSO.

• Звонки стационарным и удаленным мобильным абонентам/от стационарных и удаленных мобильных абонентов. Коммутатор MTSO подключен к коммутатору общественной телефонной сети. Это означает, что коммутатор MTSO может устанавливать соединение между мобильным пользователем из своей зоны и стационарным абонентом через телефонную сеть. Более того, MTSO может соединяться через телефонную сеть либо через выделенные каналы связи с удаленными MTSO и устанавливать соединение между мобильным пользователем из своей зоны и удаленным мобильным пользователем.

Эффекты распространения радиоволн в мобильной связи

Радиосвязь с подвижными объектами имеет свои сложности, отсутствующие в проводных или стационарных беспроводных системах связи. Особого внимания требуют два аспекта: интенсивность сигнала и эффекты распространения сигнала.

• Интенсивность сигнала. Интенсивность сигнала между базовой станцией и мобильным устройством должна быть достаточно высокой, чтобы поддерживать качество сигнала на приемнике, но при этом не слишком высокой, чтобы не создавать сильной интерференции с каналами других ячеек, которые используют ту же полосу частот. Ситуацию дополнительно усложняют несколько факторов. Уровень искусственного шума бывает очень разным. Например, шум зажигания автомобилей в диапазоне частот сотовой связи в городе гораздо больше, чем в пригороде. Есть и другие источники шумовых сигналов, характеристики которых в большой степени зависят от места. Поэтому интенсивность сигнала является переменной величиной и ведет себя как функция расстояния от базовой станции до точки в пределах ячейки. Кроме того, интенсивность сигнала динамически меняется по мере движения мобильного устройства.

• Замирание. Даже если интенсивность сигнала лежит в эффективном диапазоне, разрушить сигнал или вызвать его отклонение могут эффекты, возникающие при распространении сигнала.

При проектировании сотовой сети инженеры-связисты должны учитывать различные эффекты распространения сигнала, желаемый максимальной уровень мощности передачи на базовой станции и на мобильном устройстве, обычную характерную высоту антенны мобильного устройства и доступную высоту антенны базовой станции. На основе этих факторов и определяются размеры отдельной ячейки. К сожалению, как было отмечено выше, эффекты распространения являются динамическими и их бывает трудно предсказать. Наилучшее, что можно сделать, — это разработать модель, основываясь на опытных данных, и, применив эту модель к данной окружающей среде, разработать правило определения размера ячейки. Одна из наиболее широко используемых моделей была представлена Окумурой (Okumura), а ее усовершенствование предложено Хатой (На1а). В качестве исходных данных был принят подробный анализ района Токио и получена информация о потерях на тракте для городской среды. Модель Хаты является обобщением опытных фактов, в котором учтено много условий и типов сред. В городской среде предлагается следующее выражение для потерь в тракте.

LдБ = 65,55 + 26,16 lg fc - 13.82 lg ht - A(hr) + (44,9 - 6,55 lg ht) lg d

Здесь

fc — частота несущей в мегагерцах, которая варьируется от 150 до 1500 МГц;

ht — высота передающей антенны (базовой станции) в метрах, лежит в пределах 30-300 м;

hr — высота принимающей антенны (мобильного устройства) в метрах, лежит в пределах 1-10 м;

d — расстояние между антеннами в километрах, варьируется в пределах 1-20 км;

A(hr) — поправочный коэффициент для высоты мобильной антенны.

Для небольших или средних городов поправочный коэффициент вычисляется по такой формуле:

A(hr) = (1,1 lg fc - 0,7) hr - (1,56 lg fc - 0,8) дБ

Для больших городов множитель вычисляется по следующей формуле:

A(hr) = 8,29 [lg (1,54 hr)]2 - 1,1 дБ для fc <= 300 МГц

A(hr) = 3,2 [lg (11,75 hr)]2 - 4,97 дБ для fc >= 300 МГц

Чтобы оценить потери на тракте для пригорода, формулу потерь для городской среды (2.1) нужно изменить следующим образом:

LдБ(пригород) = LдБ(город)- 2 [lg (fc/28)]2 - 5,4

Для потерь на открытом пространстве формула выглядит следующим образом:

LдБ(открытая местность) = LдБ(город)- 4,78 lg (fc)2 - 18,773 (lg fc) - 40,98

Модель Окумуры/Хаты считается одной из лучших по точности предсказания потерь на тракте и представляет собой практический способ оценки потерь на тракте для множества ситуаций.

Пример. Пусть fc = 900 МГц, ht, = 40 м, hr = 5 м и d = 10 км. Оцените потери на тракте для города средней величины.

A(hr) = (1,1 lg 900 - 0,75) 5 - (1,56 lg 900 - 0,8) дБ = 12,75 - 3,8 = 8,95 дБ

LдБ = 69,55 + 26,16 lg 900 - 13,82 lg 900 - 8,95 + (44,9 - 6,55 lg 40) lg 10
= 69,55 + 77,28 - 22,14 - 8,95 +34,4 = 150,14 дБ

Переключение

Переключение — это процедура изменения "прописки" мобильного устройства с одной базовой станции на другую при переходе мобильного пользователя из одной ячейки в другую. Переключение пользователя осуществляется в разных системах по-разному, при этом задействовано множество факторов. Здесь будет дан только краткий обзор этой процедуры.

Переключение может инициироваться сетью, тогда решение о переключении принимается исключительно на основе сетевых измерений сигналов, принимаемых от мобильного устройства. Существуют альтернативные схемы переключения с участием пользователя, которые позволяют мобильному устройству участвовать в принятии решения о переключении, предоставляя возможность обратной связи с сетью по сигналам, принимаемым мобильным устройством. В любом случае для принятия решения могут использоваться различные метрики производительности. Например, такие.

• Вероятность блокирования вызова. Вероятность того, что новая ячейка окажется заблокированной вследствие превышения возможностей (пропускной способности) базовой станции. В таком случае решение о передаче мобильного устройства соседней ячейке принимается не на основе качества сигнала, а в зависимости от степени использования пропускной способности.

• Вероятность потери соединения. Вероятность того, что в процессе переключения звонок будет потерян.

• Вероятность завершения звонка. Вероятность того, что разрешенный звонок не будет прерван до его завершения.

• Вероятность неудачного переключения. Вероятность того, что переключение будет выполнено при неподходящих условиях приема.

• Вероятность блокирования переключения. Вероятность того, что переключение не будет завершено успешно.

• Вероятность переключения. Вероятность того, что до завершения разговора произойдет одно переключение.

• Частота переключений. Число переключений за единицу времени.

• Длительность прерывания. Промежуток времени в ходе переключения, в течение которого мобильный пользователь не будет соединен с базовой станцией.

• Задержка переключения. Расстояние, на которое переместится мобильное устройство от точки, где должно было произойти переключение, до точки, в которой оно действительно произошло.

Основным параметром, используемым при принятии решения о переключении, является измеренная интенсивность сигнала от мобильного устройства к базовой станции. Обычно на базовой станции сигнал усредняется по времени движения, чтобы отбросить быстрые флуктуации, возникающие вследствие эффектов многолучевого распространения. На рис. 2.7, а показана усредненная мощность, принимаемая на двух смежных базовых станциях от мобильного устройства, которое движется от станции А, находящейся в точке LA, к станции В, находящейся в точке LB. Этот рисунок служит иллюстрацией различных стратегий переключения, используемых для определения момента переключения.

• Относительная интенсивность сигнала. Обслуживание мобильного устройства передается с базовой станции А базовой станции В в тот момент, когда интенсивность сигнала, принимаемого на станции В, впервые превысит интенсивность на станции А. Если в дальнейшем интенсивность сигнала на станции В упадет ниже значения, регистрируемого на станции А, то мобильное устройство снова будет переключено на станцию А. На рис. 2.7, а переключение происходит в точке L. В этой точке интенсивность сигнала, регистрируемого на базовой станции А, все еще достаточна, но имеет тенденцию к снижению. Поскольку вследствие эффектов многолучевого распространения интенсивность сигнала флуктуирует, то даже при усреднении мощности такой подход может дать эффект пинг-понга, когда устройство периодически переключается между двумя базовыми станциями.

Рисунок 2.7 - Переключение между двумя ячейками

Интенсивность сигнала относительно порога. Переключение происходит, если (1) сигнал на текущей базовой станции становится довольно слабым (ниже установленного порога) и если (2) появляется другой, более сильный сигнал. Смысл этой стратегии состоит в том, что пока сигнал на текущей базовой станции является достаточно сильным, переключать мобильное устройство необязательно. Если использовать большой порог, например Th1, эта схема будет равносильна схеме с определением относительной интенсивности сигнала. При пороговом значении Th2 переключение произойдет в точке L2. Если задать достаточно низкий порог по сравнению с критической интенсивностью сигнала (т.е. с интенсивностью сигнала в точке L1), например Th2, то мобильное устройство может зайти довольно глубоко в новую ячейку (L4), прежде чем произойдет переключение. Это снизит качество канала связи и способно привести к разрыву соединения. Пороговое значение нельзя определять, не учитывая другие параметры, поскольку его эффективность зависит от предварительных знаний о критической интенсивности сигнала между текущей базовой станцией и потенциальной новой базовой станцией.

Относительная интенсивность сигнала и гистерезис. Переключение происходит только в том случае, если сигнал на новой базовой станции значительно сильнее (на величину Н, показанную на рис. 2.7, а), чем на текущей станции. Тогда переключение происходит в точке L3. Эта схема предотвращает эффект пинг-понга, так как если переключение уже произошло, знак порогового значения Н меняется на противоположный.

Термином гистерезис обозначается явление, известное как магнитный гистерезис, которое можно пояснить с помощью рис. 2.7, б. Механизм переключения можно представить состоящим из двух состояний. Пока мобильное устройство относится к станции А, переключение произойдет только тогда, когда относительная интенсивность сигнала достигнет порога Н или превысит его. Мобильное устройство, переданное станции В, останется там до тех пор, пока относительная интенсивность сигнала не упадет ниже -H, и только тогда устройство будет передано обратно станции А. Единственный недостаток этой схемы: первая передача может все еще быть необязательной, если базовая станция А имеет достаточно интенсивный сигнал.

• Относительная интенсивность сигнала, гистерезис и порог. Переключение происходит, только если (1) текущий уровень сигнала упадет ниже порога и (2) базовая станция-кандидат окажется сильнее, чем текущая станция, на величину Н. В нашем примере переключение мобильного устройства произойдет в точке L3, если пороговое значение будет либо Th1, либо Th2, и в точке L4 — если пороговое значение будет равно Th1.

• Технологии прогнозирования. Решение о переключении принимается на основе ожидаемого в будущем значения интенсивности принимаемого сигнала. Принятие решения о переключении осложняется использованием схем регулирования мощности, которые позволяют базовым станциям динамически настраивать мощность сигналов, передаваемых мобильными устройствами. На этом вопросе мы остановимся подробно в следующем разделе.

Регулирование мощности

Учитывая наличие многих спорных моментов, при проектировании в сотовой системе желательно предусмотреть возможность динамической регулировки мощности.

1. Чтобы сообщение проходило эффективно, мощность принимаемого сигнала должна существенно превышать фоновые шумы, в связи с этим предъявляются повышенные требования к мощности передатчика. По мере того как мобильное устройство удаляется от передатчика, принимаемая мощность уменьшается из-за обычного затухания. Кроме того, эффекты отражения, дифракции и рассеяния могут вызвать быструю смену уровней принимаемой мощности даже на небольших расстояниях. Ведь уровень мощности является суммой сигналов, приходящих по множеству различных путей, а фазы, соответствующие этим путям, являются случайными, так что при их сложении сигнал иногда усиливается, а иногда ослабляется. Отметим также, что при движении мобильного устройства воздействие сигналов, поступающих разными путями, может меняться.

2. В то же время желательно минимизировать мощность сигнала, передаваемого мобильным устройством, чтобы уменьшить интерференцию с каналами удаленных ячеек, использующих одну и ту же полосу частот, уменьшить вред, наносимый здоровью людей, и сэкономить энергию батарей.

3. В системах с расширенным спектром (SS), использующих множественный доступ с кодовым разделением каналов (CDMA), желательно выравнять уровни мощности сигналов, принимаемых базовой станцией от разных мобильных устройств. Это влияет на производительность системы, так как всем пользователям выделены одни и те же частоты.

На рис. 2.8 показано два варианта регулирования мощности. Регулирование мощности по разомкнутому циклу зависит исключительно от мобильного устройства, без учета ответной реакции базовой станции, и используется в некоторых системах расширенного спектра. В таких системах базовая станция непрерывно передает немодулированный пилот-сигнал. Этот сигнал позволяет мобильному устройству синхронизироваться с прямым каналом (от базовой станции к мобильному устройству) CDMA и дает эталонную фазу для демодуляции. Его можно также использовать для контроля мощности. Мобильное устройство следит за уровнем мощности принимаемого контрольного сигнала и устанавливает передаваемую мощность в обратном канале (от мобильного устройства к базовой станции), обратно пропорциональную мощности сигнала. При таком подходе предполагается, что интенсивности сигналов в прямом и обратном каналу связи сильно коррелируют, как обычно и бывает. Регулирование по разомкнутому циклу не такое точное, как регулирование по замкнутому циклу. При этом первая схема позволяет оперативнее реагировать на быстрые флуктуации интенсивности сигнала, например, подобные тем, что возникают при появлении мобильного устройства из-за большого здания. Такая быстрая реакция требуется в обратном канале связи систем CDMA, где при случайном увеличении интенсивности принимаемого сигнала на базовой станции могут подавляться все прочие сигналы.

При регулировании мощности по замкнутому циклу выравнивается интенсивность сигнала в обратном канале (от мобильного устройства к базовой станции). При этом учитываются характеристики этого обратного канала, такие, как уровень мощности принимаемого сигнала, отношение сигнал/шум или частота появления в принимаемом сигнале ошибочных битов. Базовая станция принимает решение о регулировании мощности и передает команды регулирования мощности в канал управления мобильного устройства. Регулирование по замкнутому циклу также используется для выравнивания мощности в прямом канале. В этом случае мобильное устройство предоставляет базовой станции информацию о качестве принимаемого сигнала, а базовая станция затем регулирует передаваемую мощность.

Рисунок 2.8 - Регулирование мощности в обратном канале

В табл. 2.2 показаны классы мощности, используемые в стандарте GSM, который является стандартом для систем ТDМА и будет рассмотрен в разделе 2.3. В соответствии с мощностью выходных сигналов стандарт GSM определяет восемь классов базовых станций и пять классов мобильных станций. Регулирование в направлениях проводится по схеме замкнутого цикла.

Таблица 2.2 Классы передатчиков согласно стандарту GSM

Класс мощности | Мощность базовой станции, Вт | Мощность мобильной станции, Вт
1 | 320 | 20
2 | 160 | 8
3 | 80 | 5
4 | 40 | 2
5 | 20 | 0,8
6 | 10 |
7 | 5 |
8 | 2,5 |

Регулирование трафика

Для систем FDMA пропускная способность ячейки равна количеству выделенных ей частотных каналов. В идеальной ситуации количество доступных каналов в ячейке должно равняться общему числу абонентов, которые могут быть активны в любой момент. На практике же невозможно достичь такой пропускной способности, которая позволяла бы выдержать любую возможную нагрузку в любой момент времени. К счастью, не все абоненты заказывают разговоры одновременно, поэтому разумно иметь сеть такого размера, чтобы она могла выдерживать некоторый ожидаемый уровень трафика. Во многом производительность системы зависит от схемы регулирования трафика.

Концепция регулирования трафика была разработана при проектировании телефонных коммутаторов и телефонных сетей с коммутацией каналов, однако эта концепция в равной степени применима и к сотовым сетям. Рассмотрим ячейку, способную обслуживать N пользователей одновременно (т.е. пропускная способность которой равна N каналов), у которой есть L потенциальных абонентов (L мобильных устройств). Если L < N, систему называют неблокируемой; одновременно могут быть обработаны все звонки. Если L>N, систему называют блокируемой; абонент, пытающийся заказать разговор, может обнаружить, что пропускная способность использована полностью, т.е. заблокирована для него. Для блокируемых систем основными интересующими нас вопросами производительности являются следующие.

1. Какова степень блокирования, т.е. какова вероятность того, что запрос соединения будет блокирован? Или какая пропускная способность (N) необходима для того, чтобы достигнуть определенной верхней границы вероятности блокирования?

2. Если заблокированные соединения ожидают предоставления услуги, то каково среднее время задержки? Или какая пропускная способность нужна для достижения определенного значения средней задержки?
В этом разделе мы кратко изложим соответствующие концепции регулирования трафика и приведем примеры их применения. В приложении Б этот вопрос рассмотрен более подробно.

Величину загрузки системы определяют два параметра:

λ — средняя частота звонков (запросов соединения), поступающих в единицу времени;

h — среднее время разговора.

Основной мерой нагрузки является интенсивность трафика, которая выра-ясается в безразмерных единицах, эрлангах.

А = λ h.

Величину А можно интерпретировать несколькими способами. Это нормированная версия λ: А равно среднему числу звонков, поступающих в течение среднего времени разговора. Можно также рассматривать ячейку как систему обслуживания с несколькими серверами, в которой количество серверов равно пропускной способности N. Среднее время предоставления услуги на сервере равно h. Основным соотношением в системе обслуживания с несколькими серверами является λ h = ρ N, где ρ — использование сервера, или часть времени, в течение которого сервер занят. Отсюда А = ρ N, и параметр А является мерой среднего числа требуемых каналов.

Пример. Если частота вызовов в среднем составляет 20 вызовов в минуту, а среднее время разговора — 3 минуты, тогда А - 60. Можно ожидать, что ячейка с пропускной способностью 120 каналов будет использоваться наполовину в любой момент времени. В то же время коммутатора с пропускной способностью 50 будет явно недостаточно. Пропускная способность в 60 каналов будет удовлетворять средний спрос, однако из-за флуктуации около среднего значения А временами ее будет не хватать.

Пример. Чтобы прояснить эти концепции, рассмотрим рис. 2.9, на котором показана модель функционирования ячейки с пропускной способностью 10 каналов в течение одного часа. Частота вызовов в минуту составляет 97/60. Среднее время разговора на один вызов в минутах составляет 294/97. Таким образом, А = (97/60) х (294/97) = 4,9 эрлангов. Другой способ трактовки параметра А — рассматривать его как среднее число обрабатываемых вызовов. Т.е. в среднем задействовано 4,9 канала. В то же время последняя интерпретация соответствует действительности только для неблокируемых систем. Параметр А был определен как частота попыток соединения, а не обслуживаемого трафика.

Обычная блокируемая система ограничивается некоторым верхним пределом интенсивности трафика. Считается неразумным проектировать систему с Учетом трафика, ожидаемого в пиковое время. Чаще всего системы проектируются в расчете на среднюю частоту попыток соединения, имеющую место в час наибольшей нагрузки. Час наибольшей нагрузки определяется как 60-минутный период в течение дня, когда трафик наибольший. Союз ITU-T рекомендует усреднять трафик в часы пик по 30 самым загруженным дням года; данный пара-Метр называется "средним трафиком в часы пик". В Северной Америке практикуют усреднение по 10 наиболее загруженным дням. Отметим, что это типичные Измерения обработанного, а не запрашиваемого трафика, и они являются лишь оценкой истинной нагрузки.

Рисунок 2.9. Пример распределения нагрузки в ячейке с пропускной способностью 10 каналов

Параметр А — мера трафика в часы пик — является входным при моделировании нагрузки. Затем, исходя из конкретной модели, ищутся ответы на вопросы, подобные тем, что приведены в начале раздела. Природу модели определяют два ключевых фактора:

• способ обработки блокированных звонков;

• число источников трафика.

Блокированные звонки можно обрабатывать двумя способами. Во-первых, их можно помещать в очередь ожидания свободного канала. Эта практика называется задержкой неудачного вызова (LCD), хотя в действительности вызов не является неудачным, он просто отложен. Во-вторых, блокированный вызов можно отклонить или прервать. Это, в свою очередь, приводит к двум предположениям по поводу действий пользователя. Если пользователь вешает трубку, ожидает в течение некоторого случайного интервала времени и только потом возобновляет попытку дозвониться, то это называется очисткой неудачного вызова (LCC). Если же пользователь периодически пытается дозвониться, то это называется удержанием неудачного вызова (LCH). Для каждой их этих двух возможностей блокирования выведены формулы, которые характеризуют производительность системы. Для сотовых систем обычно используется модель LCC, которая, как правило, более точно описывает систему.

Вторым ключевым элементом модели трафика является предположение о том, конечно или бесконечно количество пользователей. В модели с бесконечным количеством источников нагрузки предполагается фиксированная частота прибытия звонков. Для конечного числа источников частота прибытия звонков за висит от числа уже занятых источников. В частности, если общее число пользователей, равно L и каждый пользователь заказывает соединения со средней частотой λ/L, тогда, если ячейка совсем не занята, частота прибытия звонков равна λ. В то же время если в момент времени / обслуживаются К пользователей, тогда мгновенная частота прибытия звонков в этот момент равна λ(L - K)/L. Отметим, что модели с бесконечным числом источников аналитически проще, а применять их стоит, если число источников по крайней мере в 5-10 раз превышает пропускную способность системы.

Модель с бесконечным числом источников и очисткой неудачных вызовов

Для модели LCC с бесконечным числом источников ключевым интересующим нас параметром является вероятность потери вызова, или уровень обслуживания. Итак, уровень обслуживания 0,01 означает, что в течение часа повышенной нагрузки вероятность блокирования вызова равна 0,01. Вполне приемлемыми считаются значения вероятности в пределах 0,01-0,001.

Уравнение для модели LCC с бесконечным числом источников имеет следующий вид:

Здесь

А — поступающий трафик в эрлангах;

N — количество серверов;

Р — вероятность блокирования (уровень обслуживания).

Это уравнение легко ввести в программу, кроме того, доступно множество таблиц с уже готовыми значениями параметра А (фрагмент одной из них приведен в табл. 2.3). Задавая поступающую нагрузку и количество серверов, можно подсчитать уровень обслуживания по формуле или определить его из таблицы. Чаще всего, правда, стоит обратная задача: определить трафик, который можно обслужить при данной пропускной способности, чтобы достичь данного уровня обслуживания. Еще одной задачей является определение пропускной способности, требуемой для обработки данного трафика при данном уровне обслуживания. Для решения таких задач нужны либо таблицы, либо подходящие программы, способные определить нужное значение методом перебора.

Таблица 2.3 Качество обслуживания

Пропускная способность (в эрлангах) для определенных значений уровня обслуживания
Число серверов (N) | P = 0,02 (1/50) | P = 0,01 (1/100) | P = 0,005 (1/20) | P = 0,002 (1/500) | P = 0,001 (1/1000)
1 | 0,02 | 0,01 | 0,0005 | 0,002 | 0,001
4 | 1,09 | 0,87 | 0,7 | 0,53 | 0,43
5 | 1,66 | 1,36 | 1,13 | 0,9 | 0,76
10 | 5,08 | 4,46 | 3,96 | 3,43 | 3,09
20 | 13,19 | 12,03 | 11,10 | 10,07 | 9,41
24 | 16,64 | 15,27 | 14,21 | 13,01 | 12,24
40 | 31,0 | 29,0 | 27,3 | 25,7 | 245
70 | 59,13 | 56,1 | 53,7 | 51,0 | 49,2
100 | 87,97 | 84,1 | 80,9 | 77,4 | 75,2

Изучая табл. 2.3, можно сделать два важных вывода.

1. При одинаковом уровне обслуживания более эффективны системы с большей пропускной способностью.

2. Системы с большей пропускной способностью более восприимчивы к снижению уровня обслуживания.

Пример. Для иллюстрации первого утверждения рассмотрим две ячейки, каждая из которых имеет пропускную способность 10 каналов. Их общая пропускная способность равна 20 каналам, и вместе они могут справляться с поступающим трафиком интенсивностью 6,86, обеспечивая уровень обслуживания, равный 0,002. В то же время одна ячейка с пропускной способностью 20 каналов при уровне обслуживания 0,002 может обрабатывать трафик в 10,07 эрлангов. Для иллюстрации второго утверждения рассмотрим ячейку с 10 каналами, имеющую уровень обслуживания 0,002 и трафик 3,43 эрланга. При увеличении трафика на 30% уровень обслуживания уменьшается до 0,01. В то же время для ячейки с пропускной способностью 70 каналов уровень обслуживания падает с 0,002 до 0,01 всего лишь при 10%-ном увеличении трафика.

В приведенном примере фигурировал поступающий трафик, но если измерения различных метрик производятся в системе, то в них входит обработанный трафик. Несложно разработать программу, которая в качестве входных данных будет принимать обработанный трафик и превращать его в поступающий. Связь между обработанным трафиком С и поступающим трафиком Л выглядит так:

С = А(1 - Р).

Для малых значений Р А является хорошим приближением С.

Эффект переключения

Одной из сложностей моделей трафика сотовой системы, отсутствующей в моделях других систем, является влияние переключения. Указанный эффект продемонстрирован на рис. 2.2. Частота поступления вызовов — это сумма двух величин: новые звонки, поступившие с мобильных устройств ячейки (λ1), и звонки мобильных устройств, переданные ячейке при входе этих устройств в ячейку (λ2). Общая частота поступления звонков: λ = λ1 + λ2.Точно так же, частота завершения звонков состоит из собственно прекращенных звонков и звонков, переключенных на другую ячейку. Таким образом, требуется соответствующая коррекция модели.

Рисунок 2.10 - Модель нагрузки ячейки


Беспроводные сети. Современное состояние и перспективы развития. 2.2 АНАЛОГОВЫЕ СИСТЕМЫ ПЕРВОГО ПОКОЛЕНИЯ

2.2 АНАЛОГОВЫЕ СИСТЕМЫ ПЕРВОГО ПОКОЛЕНИЯ

Первоначально сотовые телефонные сети предоставляли для обмена информацией аналоговые каналы. Теперь такие сети называют системами первого поколения. С начала 80-х годов самой популярной технологией первого поколения в Северной Америке была AMPS (Advanced Mobile Phone System — усовершенствованная система мобильной телефонной связи), разработанная компанией AT&T. Этот подход также получил распространение в Южной Америке, Австралии и Китае. Несмотря на то что на смену этим системам постепенно приходят системы второго поколения, технология AMPS используется все еще довольно широко. Краткий обзор этой технологии приводится ниже.

Распределение спектра

В Северной Америке для системы AMPS выделены две полосы частот по 25 МГц (табл. 2.4): одна для передачи сигналов с базовой станции на мобильные устройства (869-894 МГц), вторая — для передачи сигналов с мобильных устройств на базовую станцию (824-849 МГц). Каждая полоса с целью создания условий для конкуренции разделена на две (т.е. чтобы на каждом рынке можно было разместить двух операторов). Оператору для его системы выделяется только 12,5 МГц в каждом направлении. Каналы разделены полосами по 30 кГц, что позволяет каждому оператору поддерживать по 416 каналов. Двадцать один канал выделен для управления, оставшиеся 395 — для передачи вызовов. Каналы управления представляют собой каналы обмена данными, в которых поддерживается скорость передачи данных 10 Кбит/с. Разговоры передаются по каналам для переговоров в аналоговом виде, с использованием частотной модуляции. Управляющую информацию также можно отправлять как данные по каналам Для переговоров, в форме пакетов. Поскольку указанного количества каналов недостаточно для большинства основных рынков, приходится либо довольствоваться меньшей полосой частот на один разговор, либо внедрять многократное использование частот. В различных подходах к мобильной телефонии применяются оба варианта. Стандарт AMPS предусматривает многократное использование частот.

Таблица 2.4 Параметры системы AMPS

Полоса частот для передачи сигналов с базовой станции | 869-894 МГц
Полоса частот для передачи сигналов с мобильного устройства | 824-849 МГц
Расстояние между прямым и обратным каналами | 45 МГц
Ширина канала | 30 кГц
Количество полнодуплексных голосовых каналов | 792
Количество полнодуплексных каналов управления | 42
Максимальная мощность мобильного устройства | 3 Вт
Размер ячейки, радиус | 2-20 км
Модуляция в голосовом канале | Частотная модуляция, максимальное отклонение 12 кГц
Модуляция в канале управления | Частотная манипуляция, максимальное отклонение 8 кГц
Скорость передачи данных | 10 Кбит/с
Код защиты от ошибок | БХЧ (48, 36, 5) и (40, 28, 5)

Функционирование систем первого поколения

В постоянной памяти каждого сотового телефона, поддерживающего стандарт AMPS, имеется модуль числового распределения (numeric assignment module — NAM). В модуле NAM хранится номер телефона, выделенный ему поставщиком услуг, а также регистрационный номер телефона, присвоенный мобильному устройству производителем. Когда телефон включается, он начинает передавать коммутатору MTSO свой регистрационный номер и номер телефона (см. рис. 2.5). Коммутатор MTSO имеет базу данных с информацией о мобильных устройствах, которые заявлены украденными, поэтому зная регистрационный номер, можно заблокировать украденный телефон. Телефонный же номер используется коммутатором MTSO для операций со счетом. Если телефоном пользуются в другом городе, то счет за услуги все равно выставляется местному поставщику услуг.

При заказе разговора имеют место такие действия.

1. Абонент инициирует вызов, вводя телефонный номер вызываемой стороны, и нажимает кнопку "send" (отправить).

2. Коммутатор MTSO проверяет, действителен ли номер телефона и уполномочен ли пользователь заказывать разговор; некоторые поставщики услуг требуют, чтобы пользователь вводил не только номер телефона вызываемого абонента, но и PIN-код (личный номер) во избежание использования украденных устройств.

3. Коммутатор MTSO посылает на сотовый телефон пользователя сообщение, в котором указано, какой информационный канал следует использовать для отправления и приема сигналов.

4. Коммутатор MTSO также отправляет сигнал вызываемой стороне. Действия 2-4 происходят в течение 10 с процесса инициации вызова.

5. После ответа вызываемой стороны коммутатор MTSO устанавливает канал связи между двумя абонентами и начинает считать стоимость разговора.

6. Когда один из абонентов вешает трубку, коммутатор MTSO освобождает канал связи и радиоканалы передачи данных и вычисляет окончательную стоимость разговора.

Каналы управления в системе AMPS

Система AMPS состоит из 21 полнодуплексного канала управления шириной 30 кГц. Каждый из них включает в себя 21 обратный канал (reverse control channel — RCC) от абонента к базовой станции и 21 прямой канал от базовой станции к абоненту. По этим каналам передаются (в форме кадров) данные с использованием схемы частотной манипуляции (FSK).

На рис. 2.11, а показана структура кадра канала RCC. Кадр начинается с 48-битового поля-предтечи, состоящего из 30-битового поля тактовой синхронизации (чередующиеся нули и единицы), 11-битовой последовательности синхронизации слов (11100010010) и 7-битового цифрового кода цвета (digital color code — DCC). Код DCC используется для распознавания данных, передаваемых в ячейках внутренних каналов; он представляет собой уникальный идентификатор базовой станции и служит адресом назначения для кадра RCC. За предтечей следует собственно информационный кадр, который содержит от одного до шести слов данных. Каждое слово вмещает 36 бит данных и закодировано с помощью укороченной версии кода БХЧ (63, 51, 5). В этой укороченной версии к 36 битам данных добавляется 12 контрольных разрядов и образуется 48-битовое слово. Для дальнейшего повышения надежности каждое слово передается пять раз в одном и том же кадре, а для восстановления слова на базовой станции используется мажоритарная логика. Если учесть все служебные сигналы, то скорость передачи данных будет порядка нескольких сотен битов в секунду. Примерами сообщений RCC являются сообщения инициации связи, отклик на избирательный вызов и подтверждение порядка.

Структура кадра FCC (см. рис. 2.11, б) начинается с 10-битовой последовательности тактовой синхронизации и 11-битовой последовательности синхронизации слов. Каждый кадр состоит из двух слов данных. Каждое слово закодировано с помощью кода БХЧ и содержит 28 бит данных и 12 контрольных битов. Как и ранее, из соображений надежности каждое слово повторяется пять раз. Кроме того, в каждом кадре FCC предоставляется информация о состоянии соответствующего кадра RCC (свободен или занят), для чего применяется бит "занято/свободно", который вводится в каждый десятый бит кадра. Таким образом, общий объем кадра равен 463 бит. При скорости передачи сигналов 10 Кбит/с скорость передачи данных (за вычетом служебных сигналов) составляет около 1,2 Кбит/с. Сообщения FCC включают в себя сообщения избирательного вызова и сообщения о распределении частот.

Наконец, управляющую информацию можно передавать по голосовым каналам в течение разговора. Мобильное устройство или базовая станция могут вставлять пакеты данных, прекращая передачу голоса примерно на 100 мс и заменяя его FSK-модулированным сообщением. Этот вариант используется для обмена срочными сообщениями, например связанными с изменением уровня мощности или переключением.

Рисунок 2.11. Форматы кадров каналов управления AMPS


Беспроводные сети. Современное состояние и перспективы развития. 2.3 СИСТЕМЫ TDMA ВТОРОГО ПОКОЛЕНИЯ

2.3 СИСТЕМЫ TDMA ВТОРОГО ПОКОЛЕНИЯ

С этого раздела начинается изучение сотовых систем второго поколения. Вначале предлагается краткий обзор, а затем подробно рассматривается один тип сотовых систем второго поколения.

Сотовые системы первого и второго поколений

Сотовые системы первого поколения, подобные AMPS, быстро приобрели широкую популярность и постоянно наращивают пропускную способность. Системы второго поколения разрабатывались для предоставления высококачественных сигналов, более высокой скорости обмена данных с поддержкой цифровых услуг большей пропускной способности. Существуют следующие ключевые различия этих двух поколений.

• Цифровые информационные каналы. Наиболее заметным отличием систем двух поколений является то, что системы первого поколения практически полностью аналоговые, в то время как системы второго поколения являются цифровыми. В частности, системы первого поколения спроектированы для поддержки голосовых каналов с использованием частотной модуляции; цифровые данные можно передавать только с использованием модема, который преобразует цифровые данные в аналоговую форму. Системы второго поколения предоставляют цифровые информационные каналы. Эти каналы уже поддерживают передачу цифровых данных, а голосовые каналы сначала нужно закодировать в цифровую форму, а лишь затем передавать. Разумеется, в системах второго поколения пользовательские данные (информация и оцифрованная речь) нужно вначале преобразовать в аналоговые сигналы, а лишь потом передавать их между мобильным устройством и базовой станцией.

• Шифрование. Поскольку весь обмен пользовательскими сообщениями и управляющими данными в системах второго поколения является цифровым, то для защиты от подслушивания данные довольно легко зашифровать. Эту возможность предоставляют все системы второго поколения, а системы первого поколения отправляют пользовательские данные в чистом виде, не обеспечивая никакой защиты.

• Обнаружение и исправление ошибок. В результате можно обеспечить довольно чистый прием речи.

• Доступ к каналам. В системах первого поколения каждая ячейка поддерживает несколько каналов. В любой момент времени канал может быть выделен только одному пользователю. В системах второго поколения ячейкам также выделяется по несколько каналов, однако каждый канал может совместно использоваться несколькими пользователями посредством схем множественного доступа с временным разделением (ТDМА) или множественного доступа с кодовым разделением (СDМА). Системы, основанные на ТDМА, будут рассмотрены в этом разделе, а системы, основанные на СDМА, — в разделе 2.4.

Начиная с 90-х годов, было внедрено немало различных систем второго поколения. В табл. 2.5 перечислены некоторые ключевые характеристики трех наиболее важных систем этого поколения.

Таблица 2.5. Сотовые телефонные системы второго поколения

 | GSM | IS-136 | IS-95
Год введения | 1990 | 1991 | 1993
Метод доступа | TDMA | TDMA | CDMA
Полоса частот для передачи сигналов базовой станции | 935-960 МГц | 869-894 МГц | 869-894 МГц
Полоса частот для передачи сигналов мобильного устройства | 890-915 МГц | 824-849 МГц | 824-849 МГц

Множественный доступ с временным разделением каналов

Доступ многих пользователей к сотовой системе первого поколения осуществляется с помощью технологии FDMA (frequency division multiple access — множественный доступ с частотным разделением). Этот термин был введен ранее, при рассмотрении спутниковой связи; для сотовых систем принцип работы схемы не изменился, и его можно описать следующим образом. Для каждой ячейки выделяется 2М каналов, шириной δ Гц каждый. Половина каналов (обратные каналы) используются для передачи данных с мобильного устройства на базовую станцию: fс, fс + δ, fc + 2δ, ..., fс + (М - 1)δ, где fс — центральная частота в самом низкочастотном канале. Оставшаяся половина каналов (прямые каналы) используется для передачи данных с базовой станции на мобильное устройство: fс, fс + δ + Δ, fc + 2δ + Δ, ..., fс + (М - 1)δ + Δ, где Δ — расстояние между обратным и прямым каналами. При установлении соединения с мобильным пользователем для полнодуплексного сообщения выделяются два канала — на частоте f и на частоте f + Δ. Такой порядок предоставления каналов довольно неэкономичен, так как большую часть времени один или оба канала остаются незанятыми.

Технология разделения каналов TDMA уже упоминалась при обсуждения спутниковой связи (см., например, рис. 1.14). Применение схемы TDMA в сотовой системе можно описать следующим образом. Так же, как и при использовании FDMA, каждой ячейке выделяется некоторое количество каналов, половина из которых используются для обратной связи, а половина — для прямой. И снова для полнодуплексного соединения мобильному устройству выделяется пропускная способность на парных — прямом и обратном — каналах. Кроме того, каждый физический канал подразделяется на несколько логических каналов. Передача данных осуществляется в виде последовательности кадров с повторяющейся структурой: каждый кадр делится на некоторое число слотов. Положение каждого слота в последовательности кадров определяет отдельный логический канал. Пример логического канала приводился на рис. 1.13.

Вопросы проектирования мобильных беспроводных систем TDMA

Перед тем как переходить к рассмотрению системы GSM, будет полезно изучить некоторые общие принципы. После этого анализа станут понятны мотивы некоторых проектных решений, принятых в GSM. Общая цель состоит в определении такой длины и структуры слота трафика, которые обеспечат эффективную передачу речи и данных, а также эффективное использование спектра радиодиапазона. Рассмотрим следующий набор требований.

• Количество логических каналов (число слотов в кадре TDMA) — 8; оказывается, что это минимальное количество слотов, при котором оправдываются затраты на разделение каналов.

• Максимальный радиус ячейки (R) — 35 км; он обеспечивает достаточный уровень трафика в сельской местности.

• Частота — около 900 МГц; обычно именно такая частота выделяется для мобильных радиоприложений.

• Максимальная скорость движения (Vm) — 250 км/ч или 69,4 м/с, чтобы можно было пользоваться мобильными устройствами в скоростных поездах.

• Максимальная задержка кодирования — приблизительно 20 мс, чтобы не приводить к чрезмерным задержкам в стационарных сетях, в которых может использоваться спутниковая связь.

• Максимальный разброс задержек (Δm) — 10 с (в горных районах); эта задержка представляет собой разницу задержек распространения различных компонентов многолучевых сигналов, прибывающих на одну и ту же антенну.

• Ширина полосы частот не должна превышать 200 кГц, что соответствует 25 кГц на один канал (именно эта величина в настоящее время принята для европейских аналоговых сотовых систем с частотной модуляцией).

На рис. 2.12 приведены шаги, которые предлагается выполнить при проектировании слота системы TDMA. Этой схемой мы будем руководствоваться при дальнейшем обсуждении.

Кодер речи должен обеспечивать удовлетворительное качество речи при минимальной скорости передачи данных. Традиционным видом речевого кодирования, дающим поток цифровых битов, является импульсно-кодовая модуляция (РСМ), которая приводит к скорости передачи данных 64 Кбит/с. Эта скорость слишком высока для сотовой связи. Для имеющихся в настоящее время технологий разумно использовать скорость передачи данных около 12 Кбит/с, что дает хорошее качество воспроизведения речи.

Рисунок 2.12 - Проектирование слота для системы TDMA

Если ограничить задержку кодирования величиной 20 мс, тогда закодированную речь можно группировать блоками по 20 мс или выборками речи по 240 бит. При скорости 12 Кбит/с данные также группируются в 240-битовые блоки. Затем к этим блокам можно применять схемы исправления ошибок.

В цифровых системах второго поколения обычно используются сверточные коды коррекции ошибок со степенью кодирования 1/2. При таком кодировании число битов в блоке данных увеличивается до 480. Кроме того, к блоку данных нужно добавить восемь бит, чтобы учесть длину регистра сдвига. Таким образом, длина блока речи составит 488 битов.

При выбранных параметрах минимальная скорость передачи битов для восьмиканальной системы составит

8 каналов х 488 бит/канал / 20 x 10-3 c = 195,2Кбит/с.

В действительности потребуется несколько более высокая скорость передачи битов, что обусловлено другими соображениями, о которых мы поговорим ниже. Это означает, что в доступной полосе шириной 200 кГц придется обеспечивать скорость передачи данных выше, чем 200 Кбит/с. На практике таких скоростей передачи данных невозможно достигнуть без использования адаптивного выравнивания. Lля осуществления адаптивного выравнивания в мобильной среде потребуется включать новую настроечную последовательность всякий раз, когда мобильное устройство переместится на расстояние, достаточное для изменения характеристик тракта передачи. Предположим, что настроечная последовательность включена в каждый слот. Грубый критерий состоит в том, что фаза несущего сигнала после настроечной последовательности не должна превышать 1/20 длины волны (т.е. Я/10). При частоте 900 МГц длина волны составляет 0,333 м. Итак,

максимальная длительность передачи = λ / 20 = 0,333 / 20 / 69,4 = 0,24мс.

Настроечную последовательность можно использовать более выгодно, если передавать 0,24 мс речи или данных до нее и после нее и использовать настроечную последовательность в сочетании с 0,48 мс данных.

Далее требуется определить длину настроечной последовательности. При проектировании эквалайзера для многолучевого сигнала, ширина полосы которого примерно равна скорости передачи битов (200 кГц, 200 Кбит/с), используют эвристическое правило: число отводов эквалайзера должно в шесть раз превышать число битов, передаваемых за максимальное время рассеивания (Δm = 0,01 мс). Таким образом, для настроечной последовательности в слоте выделяется 0,06 мс.

Теперь предположим, что в конце каждого слота нужен защитный интервал. Его вводят из-за различия во времени задержек между разными мобильными устройствами и базовой станцией. Поскольку один и тот же кадр TDMA совместно используют восемь мобильных устройств, требуется синхронизировать передачу данных с мобильных устройств, чтобы данные с одного из них не приходились на чужие слоты. В функции базовой станции входит предоставление каждому мобильному устройству информации о синхронизации, что позволяет выравнивать относительные задержки и сохранять структуру кадра TDMA. Однако мобильные устройства могут двигаться и относительно базовой станции, и относительно друг друга, так что для учета этих отклонений после каждого слота вставляется защитный интервал. Когда мобильное устройство впервые заказывает соединение базовой станции, базовая станция предоставляет мобильному устройству информацию о синхронизации, которая зависит от текущего времени задержки распространения сигнала между мобильным устройством и базовой станцией. Избежать частого обновления информации о синхронизации можно путем введения достаточного защитного времени. Приведем пример расчета защитного интервала. Средний телефонный звонок занимает 130 с, так что радиальное расстояние до базовой станции, которое может покрыть мобильное устройство, составляет (130 с) х (69,4 м/с) = 9022 м. Изменение задержки распространения сигнала, обусловленное перемещением на такое расстояние, составляет 9022 / (3 х 108 м/с) = 0,03 мс.

На рис. 2.13, а показана полученная схема слота. Следующий этап состоит в распределении закодированного блока данных между несколькими слотами, в Которые также войдут настроечная последовательность и защитные биты. Максимальная длительность слота равна приблизительно 0,57 мс. Учитывая, что Каждый кадр состоит из 8 слотов, получаем длину кадра 4,6 мс. Пусть данные Нужно отправить с задержкой кодирования 20 мс, так что если длину кадра считать равной 4 мс, а длину каждого слота равной 0,5 мс, удобно будет отправить блоки речи в пяти последовательных слотах в одном и том же канале. Блок речи состоит из 488 бит, так что в каждый слот следует поместить 488/5 или около 98 бит данных. Это даст скорость передачи битов 98/0,4 = 245 Кбит/с. При такой скорости передачи данных минимальное количество требуемых настроечных битов составляет (0,06 мс) х (245 Кбит/с) = 14,7, что при округлении даст 15 бит. Подобным образом рассчитывается и минимальное количество защитных битов, которое оказывается равным (0,03 мс) х (245 Кбит/с) = 7,35, т.е. при округлении в большую сторону — 8 бит.

Рисунок 2.13 - Слот TDMA

Получившаяся в результате структура кадра показана на рис. 2.13, б. По каналу со скоростью передачи 242 Кбит/с передается 121 бит за 0,5 мс.

Глобальная система мобильной связи

До того как была разработана Глобальная система мобильной связи (GSM), в странах Европы использовалось множество разных несовместимых сотовых телефонных технологий первого поколения. Стандарт GSM был разработан для внедрения в Европе общей технологии второго поколения, чтобы одни и те же абонентские устройства можно было использовать по всему континенту. Эта технология оказалась весьма успешным и, возможно, самым популярным мировым стандартом для систем нового поколения. Впервые стандарт GSM появился в 1990 году в Европе. Теперь подобные системы внедрены в Северной и Южной Америке, Азии, Северной Африке, а также в Средней Азии и в Австралии. Ассоциация GSM заявила, что к концу 2000 года она обслуживала три четверти всех абонентов сотовой сети по всему миру, причем подавляющее большинство абонентов GSM находилось в Европе и на тихоокеанском побережье Азии, 8 миллионов проживает также в Северной Америке.

Архитектура сети GSM

На рис. 2.14 показаны ключевые функциональные элементы системы GSM-Линии Um, Abis и А обозначают интерфейсы между функциональными элементами, которые стандартизированы в документации GSM. Таким образом, можно приобретать оборудование у разных поставщиков и ожидать, что оно будет успешно взаимодействовать. В стандарте GSM определены также дополнительные интерфейсы, но здесь они рассматриваться не будут.

Рисунок 2.14. Общая архитектура GSM

Мобильная станция

Через интерфейс Um, называемый также радиоинтерфейсом, мобильная станция сообщается с трансивером базовой станции в той ячейке, в которой находится мобильное устройство. Термином мобильное оборудование (mobile equipment — ME) обозначается физический терминал, такой, как телефон или устройство персональной службы связи (personal communication service -PCS), включающее в себя радиотрансивер, процессоры для обработки цифровых сигналов и модуль идентификации абонента (subscriber identity module -SIM). SIM представляет собой портативное устройство, имеющее вид интеллектуальной карточки или встраиваемого модуля, в котором хранится идентификационный номер абонента, координаты сетей, которыми разрешено пользоваться абоненту, ключи шифрования и другая информация об абоненте. Абонентские устройства GSM до вставки модуля SIM абсолютно неотличимы друг от друга. Поэтому путешествующий абонент, захвативший с собой свой модуль SIM, может в разных странах использовать разные устройства, вставляя в них свой модуль. В действительности, за исключением определенных срочных соединений, абонентские устройства не будут работать без вставленного модуля SIM. Поэтому носить с собой везде нужно именно модуль SIM, а само устройство брать с собой необязательно.

Подсистема базовой станции

Подсистема базовой станции (base station subsystem — BSS) состоит из контроллера базовых станций и одной или нескольких базовых трансиверных станций. Каждая базовая трансиверная станция (base transceiver station — BTS) определяет ячейку, в которую входит радиоантенна, радиотрансивер и канал связи с контроллером базовых станций. Ячейка GSM может иметь радиус от 100 м до 35 км, в зависимости от среды. Контроллер базовой станции (base station controller — BSC) может совмещаться с BTS или управлять работой нескольких устройств BTS, а следовательно, несколькими ячейками. Контроллер BSC резервирует радиочастоты, управляет переключениями мобильных устройств с одной ячейки на другую в пределах одной подсистемы BSS и контролирует избирательное обращение.

Сетевая подсистема

Сетевая подсистема (network subsystem — NS) обеспечивает связь между сотовой сетью и общественными коммутируемыми телекоммуникационными сетями. Подсистема NS управляет переключениями между ячейками, находящимися в различных подсистемах базовых станций, опознает пользователей и подтверждает достоверность их счетов, а также выполняет функции роуминга мобильных пользователей. Центральным элементом подсистемы NS является мобильный центр коммутации (mobile switching center — MSC). Он управляет четырьмя базами данных.

• База данных регистра исходного положения (home location register — HLR). В регистре HLR хранится информация, как временная, так и постоянная, о каждом из абонентов, который "принадлежит" системе (т.е. об абонентах, телефонные номера которых связаны с центром коммутации).

• База данных регистра местонахождения посетителей (visitor location register — VLR). Одну из важных частей информации составляет местонахождение абонента. Местонахождение определяется из регистра VLR, в который введен абонент. В регистре местонахождения посетителей хранится информация об абонентах, которые в данный момент физически находятся в районе, обслуживаемом данным центром коммутации. В регистре отмечается, является ли абонент активным, а также фиксируются другие параметры, связанные с абонентом. При поступлении звонка абоненту система использует связанный с абонентом телефонный номер для опознания исходного для данного абонента центра коммутации. Этот центр коммутации, в свою очередь, в своем регистре HLR может найти центр коммутации, в зоне действия которого в данный момент физически находится абонент. При поступлении звонка от абонента регистр VLR используется для инициирования звонка. Даже если абонент находится в зоне, принадлежащей его исходному центру коммутации, он может также быть представлен в регистрах VLR других центров коммутации.

• База данных центра аутентификации (authentication center — AuC). Эта база данных используется в процессе аутентификации; например, в ней хранятся ключи аутентификации и шифрования для всех абонентов, представленных как в регистрах исходного положения, так и в регистрах место нахождения посетителей. Центр управляет доступом к данным пользователей, а также процессом аутентификации при присоединении абонента к сети. Данные, передаваемые системами GSM, шифруются, поэтому они конфиденциальны. Для шифровки данных, передаваемых от абонента трансиверу базовой станции, используется поточный шифр А5. В то же время переговоры по сети с наземными линиями связи проходят без шифрования. Другой поточный шифр, A3, используется для аутентификации.

• База данных регистра идентификации оборудования (equipment identity register — EIR). В этой базе данных хранятся записи о типе оборудования, которое имеется на мобильной станции. Эта база данных также важна для безопасности (например, для блокирования звонков с украденных мобильных устройств и предотвращения использования сети станциями, которым не было дано такого разрешения).

Аспекты радиосвязи

Системам GSM выделяется 25 МГц для передачи данных с базовых станций (935-936 МГц) и 25 МГц для передачи с мобильных устройств (890-915 МГц). Вне Европы для систем GSM определены также и другие полосы частот. Пользователи получают доступ к сети с помощью комбинации схем FDMA (множественный доступ с частотным разделением) и TDMA (множественный доступ с временным разделением) (обе схемы были рассмотрены в предыдущей главе). Несущие расположены через каждые 200 кГц, т.е. всего имеется 125 полнодуплексных каналов. Каналы модулированы для использования скорости передачи данных 270,833 Кбит/с. Как и в системе AMPS, существует два типа каналов — информационные каналы и каналы управления.

Формат TDMA

В системах GSM используется сложная иерархия кадров TDMA, определяющая логические каналы (рис. 2.15). По сути, каждая полоса частот шириной 200 кГц делится на 8 логических каналов, определяемых повторяющимися последовательностями слотов.

На низшем уровне иерархии находится слот, длительность которого равна 15/26 мс, или примерно 0,577 мс. При скорости передачи битов 270,833 Кбит/с каждый слот будет иметь длину 156,25 бит. Слот состоит из следующих полей.

• Завершитель. Позволяет синхронизировать передачу данных с мобильных устройств, находящихся на разных расстояниях от базовой станции (будет рассмотрено ниже).

• Зашифрованные биты. Данные шифруются в блоки с помощью обычного шифрования 114 открытых битов в 114 зашифрованных битов. Затем зашифрованные биты помещаются в два 57-битовых поля слота.

• Захваченные биты. Используются для указания, содержит ли блок данные или же он "захвачен" для срочного сигнала управления.

• Настроечная последовательность. Используется для настройки параметров приемника в соответствии с особенностями текущего тракта распространения сигнала, а при многолучевом распространении еще и для выбора наиболее сильного сигнала. Настроечная последовательность является известной комбинацией битов, индивидуальной для каждой ячейки. Она позволяет мобильным устройствам и базовой станции определять, действительно ли пришел принимаемый сигнал с передатчика или же он возник в результате сильных помех.

Кроме того, настроечная последовательность используется для выравнивания сигналов, распространяющихся по множественным траекториям, которое позволяет отделять нужный сигнал от нежелательных отражений. Зная, как изменяется известная настроечная последовательность вследствие многолучевого замирания, в оставшейся части сигнала этот эффект можно компенсировать.

• Защитные биты. Используются во избежание наложения пакетов данных вследствие разных задержек на тракте.

Рисунок 2.15. Формат кадра GSM

Формат слота, показанный на рис. 2.15, называется нормальным пакетом и несет пользовательские данные (сравните с рис. 2.13, б). Для управления передачей сигналов используются другие форматы пакетов.

Более крупной иерархической единицей являются мультикадры из 26 кадров, в которые обычно собираются 8-слотовые кадры TDMA. Один из кадров мультикадра используется для управления передачей сигналов, а другой пока не используется, т.е. для передачи данных используются 24 кадра. Таким образом, каждому информационному каналу выделяется по одному слоту на кадр и по 24 кадра на каждый мультикадр длительностью 120 мс. Вычислим скорость передачи данных.

114 бит/слот х 24 слота/мультикадр / 10 мс/мультикадр = 22,8 Кбит/с .

В спецификации GSM допускаются также информационные каналы половинной скорости передачи данных, когда имеются два информационных канала, каждый из которых занимает один слот в 12 из 26 кадров. При использовании кодеров речи с половинной скоростью передачи данных пропускная способность системы удваивается. Есть также мультикадры, содержащие по 51 кадру, которые используются для управления трафиком.

Кодирование речи

На рис. 2.16 показана схема обработки речевых сигналов для передачи данных по логическому информационному каналу. Все этапы обработки последовательно рассмотрены ниже.

Рисунок 2.16. Обработка речевых сигналов в системе GSM

Речевой сигнал сжимается с помощью алгоритма RPE-LPE (Regular Pulse Excited -- Linear Predictive Coder, активизация регулярными импульсами — линейный кодер с предсказанием). Суть алгоритма состоит в том, что для предсказания текущей выборки используются данные из предыдущих выборок. При кодировании каждая выборка представляется в виде линейной комбинации предыдущих выборок и описывается с помощью коэффициентов этой линейной комбинации и закодированной разности предсказанной и действительной выборок. В результате такого кодирования каждые 20 мс получается 260 бит, т.е. приблизительно скорость передачи данных составляет 13 Кбит/с. По качеству речи, воспроизводимой с помощью такого кодирования, биты в 260-битовом блоке можно разделить на три класса.

• Класс Iа: 50 бит, наиболее чувствительных к битовым ошибкам.

• Класс Ib: 132 бит, умеренно чувствительных к битовым ошибкам.

• Класс IIа: 78 бит, минимально чувствительных к битовым ошибкам.

Для защиты первых 50 бит используется 3-битовая циклическая проверка четности с избыточностью (CRC). При обнаружении ошибки вся выборка отбрасывается и заменяется измененной версией предыдущего блока. Эти 53 бит, 132 бит класса Ib, а также 4-битовая остаточная последовательность затем защищаются сверточным кодом (1, 2, 5), что в итоге дает 189 х 2 = 378 бит. Оставшиеся 78 бит остаются незащищенными и прилагаются к защищенным битам для того, чтобы дополнить блок до 456 бит, что в результате даст скорость передачи данных 456/20 мс = 22,8 Кбит/с, которая является характерной скоростью передачи данных в информационных каналах систем GSM.

Для того чтобы защитить передаваемые данные от пакетов ошибок, каждый 456-битовый блок делится на восемь 57-битовых блоков, которые передаются в восьми последовательных слотах. Так как каждый слот может вмещать в себя два 57-битовых блока, в каждом пакете оказываются данные из двух различных выборок речи.

С помощью описанных шагов речевые данные шифруются по 114 бит за такт, собираются в слоты (сборка пакета) и, наконец, модулируются для передачи. Используемая схема модуляции, OMSK (Gaussian Minimum Shift Keying — гауссова манипуляция с минимальным частотным сдвигом), представляет собой разновидность частотной модуляции (FSK).

Кодирование данных

Цифровые данные обрабатываются тем же способом, что применяется к речевым сигналам. Данные обрабатываются блоками по 240 бит каждые 20 мс, что дает скорость передачи данных 12 Кбит/с. В зависимости от определения логических каналов реальная поддерживаемая скорость передачи данных может составлять 9,6, 4,8 и 2,4 Кбит/с. Каждый блок дополняется четырьмя остаточными битами. Для получения блока размером 244 х 2 = 488 бит используется сверточный код (1, 2, 5). Затем 32 бит из этого блока опускаются, и в блоке остается 456 бит. Для распределения данных по пакетам используется схема чередования битов, что, опять же, уменьшает влияние импульсных помех. 488 бит распределяются по 22 пакетам следующим образом:

• 1-й и 22-й пакеты содержат по 6 бит каждый;

• 2-й и 21-й пакеты содержат по 12 бит каждый;

• 3-й и 20-й пакеты содержат по 18 бит каждый;

• пакеты с 4-го по 19-й содержат по 24 бит каждый.

В результате каждый пакет переносит информацию из 5 или 6 последовательных блоков данных.

Медленная скачкообразная перестройка частоты

Выше было сказано, что информационному каналу выделяется определенная частота как для передачи, так и для приема данных. Это не совсем верно. В GSM и во многих других сотовых схемах используется технология, известная как медленная скачкообразная перестройка частоты, которая призвана повысить качество сигнала. Каждый следующий кадр TDMA в данном канале переносится на своей несущей частоте. Таким образом, частота передачи изменяется один раз каждые 4,615 мс. Медленная скачкообразная перестройка частоты позволяет скомпенсировать эффект многолучевого замирания, который зависит от несущей частоты. Медленная скачкообразная перестройка частоты позволяет также уменьшить эффект интерференции соседних каналов. Напомним, что эта технология является разновидностью связи с расширенным спектром.

Выравнивание задержек

Поскольку мобильные устройства находятся на разных расстояниях от базовой станции в пределах одной ячейки, передаваемые ими данные приходят с f разными задержками. Это явление создает проблемы при проектировании системы, так как один кадр TDMA одновременно использует до восьми мобильных устройств. Потому решающее значение имеет синхронизация слотов кадра. Базовая станция передает разным мобильным устройствам управляющие сигналы, которые позволяют синхронизировать распределение слотов. В формате кадра предусмотрены остаточные биты и защитные биты, которые обеспечивают зазор, позволяющий предотвратить перекрывание битов данных из разных слотов. Базовая станция может синхронизировать любое активное мобильное устройство, посылая управляющие сигналы, в которых будет указано, следует ускорить или замедлить отсчет времени.

Протокольная архитектура передачи сигналов GSM

Между ключевыми объектами, изображенными на рис. 2.14, связанными с мобильностью, радиоресурсами и управлением соединением, происходит интенсивный обмен управляющими сообщениями. Подробное описание различных форматов и семантики сообщений заняло бы целую книгу. Здесь будет представлен только краткий обзор структуры, из которого станет видна сложность проектирования систем второго поколения.

На рис. 2.17 обобщаются протоколы, используемые между основными элементами архитектуры сети. Нижний уровень архитектуры предназначен для физической связи между объектами. Между мобильной станцией и базовой станцией-трансивером действует радиосвязь, описанная в предыдущих разделах, посредством которой переносятся данные высших уровней. Между другими объектами используется стандартный цифровой канал со скоростью передачи данных 64 Кбит/с.

Рисунок 2.17 - Протокольная архитектура передачи сигналов GSM

На канальном уровне используется протокол управления каналом передачи иных (см. рис. 4.3), известный как LAPDm. Он представляет собой модифицированную версию протокола LAPD, определенного для сети ISDN (Integrated Services gital Network — цифровая сеть с интеграцией услуг). Оставшиеся каналы связи пользуют обычный протокол LAPD. По сути, протокол LAPD разработан для образования потенциально ненадежных физических каналов связи в надежные малы передачи данных. Осуществляется это посредством использования циклической проверки четности с избыточностью, которая проводится для обнаружения ошибок, а также автоматического запроса на повторение (ARQ) для повторной передачи поврежденных кадров.

Над канальным уровнем размещено множество протоколов, которые обеспечивают выполнение особых функций, включая перечисленные ниже.

• Управление радиоресурсами. Управление установкой, эксплуатацией и удалением радиоканалов, включая переключения.

• Управление мобильностью. Процедуры обновления и регистрации местоположения, а также защита и аутентификация.

• Управление соединением. Управление заказом, обслуживанием и завершением звонков (соединений между пользователями).

• Мобильная прикладная часть (mobile application part — MAP). Осуществление передачи большинства сигналов между различными объектами, находящимися в фиксированных точках сети, например между регистром HLR и регистром VLR.

• Управление базовой трансиверной станцией. Выполнение различных функций управления и административных функций на базовой трансиверной станции под руководством контроллера базовых станций.

MAP находится не непосредственно над канальным уровнем, а над двумя промежуточными протоколами, SCCP и МТР. Эти протоколы являются частью Системы передачи сигналов номер 7 (SSN7), которая представляет собой набор протоколов, разработанных для обеспечения контроля над передачей сигналов а коммутируемых сетях, таких, как цифровые общественные телекоммуникационные сети. Эти протоколы обеспечивают выполнение общих функций, которые используются различными приложениями, включая MAP.


Беспроводные сети. Современное состояние и перспективы развития. 2.4 СИСТЕМЫ CDMA ВТОРОГО ПОКОЛЕНИЯ

2.4 СИСТЕМЫ CDMA ВТОРОГО ПОКОЛЕНИЯ

Множественный доступ с кодовым разделением каналов (code division multiple access — CDMA) представляет собой основанную на расширении спектра схему, которая является второй, после TDMA, альтернативой разделения каналов для сотовых сетей второго поколения. Этот раздел начинается с краткого обзора преимуществ подхода CDMA, а затем рассматривается наиболее широко используемая схема такого типа — IS-95.

Множественный доступ с кодовым разделением каналов

Схему CDMA для сотовых систем можно описать следующим образом. Как и при использовании FDMA, каждой ячейке выделяется некоторая полоса частот, которая делится на две части — половина для обратного канала (от мобильного устройства к базовой станции) и половина для прямого канала (от базовой станции к мобильному устройству). Для полнодуплексной связи мобильное устройство использует оба канала, прямой и обратный. Передача данных осуществляется по схеме расширения спектра методом прямой последовательности (DSSS), при котором используется раздробленный код для увеличения скорости передачи данных, а это дает увеличение полосы сигнала. Множественный доступ обеспечивается путем присваивания нескольким пользователям ортогональных раздробленных кодов, чтобы приемник мог выделить отдельные передачи из общего сигнала.

Использование схемы CDMA для сотовых сетей имеет несколько преимуществ.

• Частотное разнесение. Из-за того что передаваемые сигналы рассеяны по широкой полосе частот, искажение передачи на определенной частоте, например вследствие шума или селективного замирания, меньше влияет на сигнал.

• Снижение негативных эффектов многолучевого распространения. Кроме способности DSSS противостоять многолучевому замиранию посредством частотного разнесения, раздробленные коды, используемые для CDMA, имеют низкую автокорреляцию. Поэтому версия сигнала, который задерживается более чем на один элементарный интервал, не интерферирует с доминирующим сигналом, как это происходит в других средах многолучевого распространения.

• Конфиденциальность. Так как расширенный спектр получается посредством использования шумоподобных сигналов, где каждый пользователь имеет свой код, такой схеме изначально присуща конфиденциальность.

• Постепенное снижение эффективности функционирования системы. В схемах ТОМА или FDMA к системе может одновременно обращаться только фиксированное число пользователей. В CDMA же по мере того как все больше пользователей получают одновременный доступ к системе, уровень шума и, следовательно, частота появления ошибок увеличиваются. Система приближается к моменту неприемлемого качества связи постепенно.

Следует упомянуть и о многочисленных недостатках сотовой схемы CDMA.

• Самоподавление. Если все мобильные пользователи синхронизированы не идеально, данные, поступающие от разных пользователей, не будут идеально выравнены по границам раздробленных кодов. Расширенные последовательности разных пользователей не будут ортогональными, поэтому будет присутствовать некоторая взаимная корреляция. Это отличает данную схему от FDMA и TDMA, в которых существуют защитные временные или частотные интервалы, соответственно, т.е. сигналы являются хотя бы приближенно ортогональными.

• Проблема расположения. Сигналы, поступающие от более близких к передатчику объектов, не так затухают, как сигналы, пришедшие издалека. При отсутствии полной ортогональности данные, передаваемые с удаленного мобильного устройства, бывает довольно трудно восстановить. Поэтому в системах CDMA очень важное значение имеют схемы регулирования мощности.

• Мягкое переключение. Как будет показано далее, для плавности переключения с одной ячейки в следующую требуется, чтобы мобильное устройство вошло в новую ячейку до того, как оно оставит старую. Это называется мягким переключением, которое является более сложным, чем жесткое переключение, используемое в схемах FDMA и ТОМА.

Вопросы проектирования мобильных беспроводных систем CDMA

Перед тем как переходить к конкретному примеру —системе GSM, — будет полезно рассмотреть некоторый вопросы проектирования, общие для всех сотовых систем CDMA.

RAKE-приемник

Если в многолучевой среде, которая является весьма распространенной для сотовых систем, множественные версии сигнала пребывают на расстоянии более одного элементарного интервала друг от друга, то приемник может восстановить сигнал, соотнося элементарные последовательности с доминирующим входящим сигналом. Оставшиеся сигналы рассматриваются как шум. Однако более производительным оказывается восстановление сигналов, прошедших по разным маршрутам, и последующее их суммирование (с подходящими значениями задержек). Этот принцип используется в RAKE-приемниках.

На рис. 2.18 проиллюстрирован принцип действия RAKE-приемника. Исходный двоичный сигнал расширяется с помощью применения к нему и раздробленному коду передатчика операции исключающего ИЛИ (XOR). Затем расширенная последовательность модулируется для передачи по беспроводному каналу связи. Из-за эффектов многолучевого распространения в канале оказывается много копий сигнала, каждая из которых имеет свое время задержки (t1, t2 и т.д.) и свой коэффициент затухания (а1, а2 и т.д.). В приемнике полученный сигнал демодулируется. Дсмодулированный поток элементов сигнала затем подается на блок корреляторов, причем каждый задерживается на определенную величину (свою для каждого сигнала). Затем сигналы суммируются с весовыми коэффициентами, подходящими для данного канала.

Рисунок 2.18 - Принцип работы RAKE-приемника

Мягкое переключение

В системах FDMA и ТDМА соседние ячейки используют различные участки доступного спектра (т.е. кратность использования частоты больше единицы и обычно составляет N = 7). Когда интенсивность сигнала в соседней ячейке превышает интенсивность в текущей ячейке, мобильной станции приходит указание переключиться на новую полосу частот, которая выделена для новой ячейки. Такая процедура называется жестким переключением. В типичной сотовой системе CDMA пространственное разделение частот не используется (т.е. N = 1), так как большую часть времени интерференция с соседними ячейками не будет препятствовать корректному приему сигналов DSSS. При мягком переключении мобильная станция временно подключается к более чем одной базовой станции одновременно. Мобильное устройство поначалу могло быть соединено с одной станцией. Если затем устройство входит в зону, в которой качество передачи двух базовых станций сравнимо (с некоторым порогом по отношению друг к другу), то мобильное устройство переходит в состояние мягкого переключения, в котором оно подключено к обеим базовым станциям. Мобильное устройство остается в этом состоянии до тех пор, пока одна из базовых станций не станет явно преобладать, и тогда устройство переключится непосредственно на эту ячейку. Находясь в состоянии мягкого переключения, данные, передаваемые с мобильного устройства, достигают обеих базовых станций и отправляются в центр коммутации, который оценивает качество обоих сигналов и выбирает один из них. Затем коммутатор отправляет данные или оцифрованную речь обеим станциям, которые передают эти сигналы на мобильное устройство. Мобильное устройство комбинирует два входящих сигнала и восстанавливает информацию.

IS-95

Наиболее популярной схемой CDMA второго поколения является система IS-95, которая первоначально была внедрена в Северной Америке. В табл. 2.5 перечислены некоторые ключевые параметры системы IS-95. Структура передачи данных в прямом и обратном каналах связи отличается, потому будет описана для каждого направления отдельно.

Прямой канал системы IS-95

В табл. 2.6 приведены параметры прямого канала связи. Прямой канал связи состоит из 64 логических каналов CDMA, каждый из которых занимает полосу частот шириной 1228 кГц (рис. 2.19, а). При прямой связи поддерживаются четыре типа каналов.

• Пилот-сигнал (канал 0). Постоянно передаваемый сигнал. Этот канал позволяет мобильному устройству получать информацию о синхронизации, дает точку отсчета для определения сдвига фаз в процессе демодуляции и средство для сравнения интенсивности сигнала для определения момента переключения. Пилот-канал состоит из всех нулей.

• Синхронизация (канал 32). Канал со скоростью передачи данных 1200 бит/с используется мобильной станцией для получения идентификационной информации о сотовой системе (системное время, состояние длинного кода, проверка протоколов и т.д.)

• Избирательные сообщения (каналы 1—7). Содержат сообщения для одной или нескольких мобильных станций.

• Информационный обмен (каналы 8—31 и 33—63). В прямом канале поддерживается 55 информационных каналов. В исходной спецификации указано, что поддерживаются скорости передачи данных до 9600 бит/с. Позже был добавлен второй набор скоростей до 14400 бит/с.

Обратите внимание, что все эти каналы используют одну и ту же полосу частот. Для распознавания разных каналов используется раздробленный код. Раздробленный код прямого канала включает 64 ортогональных 64-битовых кодов, полученных из матрицы Уолша размером 64 х 64.

Таблица 2.6. Параметры прямого канала связи системы IS-95

Канал | Синхро-низация | Избиратель-ный вызов |  | Первый набор инфор-мационных каналов |  |  |  | Второй набор инфор-мационных каналов
Скорость передачи данных (бит/с) | 1200 | 4800 | 9600 | 1200 | 2400 | 4800 | 9600 | 1800 | 3600 | 7200 | 14400
Количество повторений кода | 2 | 2 | 1 | 8 | 4 | 2 | 1 | 8 | 4 | 2 | 1
Скорость передачи символов модуляции (символ/с) | 4800 | 19200 | 19200 | 19200 | 19200 | 19200 | 19200 | 19200 | 19200 | 19200 | 19200
Количество чипов на символ модуляции | 256 | 64 | 64 | 64 | 64 | 64 | 64 | 64 | 64 | 64 | 64
Количество чипов на бит | 1024 | 256 | 128 | 1024 | 512 | 256 | 128 | 682,67 | 341,33 | 170,67 | 85,33

Рисунок 2.19 - Структура канала системы IS-95

На рис. 2.20 показана схема обработки данных, передаваемых по прямому информационному каналу со скоростью, соответствующей первому набору. Для голосовых передач речь кодируется со скоростью 8550 бит/с. После добавления дополнительных битов для обнаружения ошибок скорость повышается до 9600 бит/с. Когда пользователь молчит, вся пропускная способность канала не используется. В такие периоды тишины скорость передачи данных снижается до 1200 бит/с. Скорость 2400 бит/с используется для передачи переходов в фоновом шуме, а скорость 4800 бит/с — для смешивания оцифрованной речи и сигнальных данных.

Данные или оцифрованная речь передаются блоками по 20 мс с использованием схемы прямого исправления ошибок (сверточный код со степенью кодирования 1/2). Таким образом, эффективная скорость передачи данных удваивается и достигает максимум 19,2 Кбит/с. Если скорости передачи данных ниже, то биты, выходящие из кодера (называемые кодовыми символами) копируются, что позволяет достичь скорости 19,2 Кбит/с. Затем данные чередуются в блоках для уменьшения влияния длительных помех.

После чередования биты данных скремблируются. Этот шаг необходим для обеспечения конфиденциальности данных, а также для предотвращения отправки одинаковых фрагментов данных, что, в свою очередь, уменьшает вероятность одновременного отправления данных пользователями в момент наибольшей загрузки системы. Скремблирование осуществляется посредством длинного кода — псевдослучайного числа из 42-битового регистра сдвига. Регистр сдвига устанавливается в исходное положение с помощью электронного регистрационного номера пользователя. Выходные данные генератора длинного кода передаются со скоростью 1,2288 Мбит/с, что в 64 раза выше скорости 19,2 Кбит/с, так что выбирается только один бит из 64 (операция децимации). Получающийся поток сравнивается (операция !исключающего ИЛИ) с выходными данными устройства блочного чередования.

Рисунок 2.20 - Схема передачи данных по прямому каналу системы IS-95

На следующем этапе обработки вводится информация о регулировании мощности в информационном канале. Этот поток, имеющий скорость 800 бит/с, вводится в данные, передаваемые со скоростью 19,2 Кбит/с посредством замены некоторых битов кода и кодирования контрольных битов с помощью генератора длинного кеда. В таких "захваченных" битах передается информация, указывающая мобильному устройству, что следует увеличить, уменьшить или оставить неизменным текущий уровень мощности.

Следующий шаг — применение схемы DSSS; используется одна строка матрицы Уолша (64 х 64), скорость увеличивается от 19,2 Кбит/с до 1,2288 Мбит/с. Одна строка матрицы выделяется мобильной станции еще во время установления соединения. При наличии в передаваемых данных нуля посылается 64 бит выделенной строки; в противном случае посылается результат применения к строке побитового исключающего ИЛИ. Таким образом, окончательная скорость передачи данных получается равной 1,2288 Мбит/с. Этот цифровой поток битов затем модулируется на несущей с использованием схемы QPSK. Напомним из главы 6, что QPSK предполагает создание двух потоков битов, которые модулируются раздельно (см. рис. 6.6.). В схеме IS-95 данные разделяются на синфазный (I) и квадратурный (Q) каналы, и к данным и уникальному короткому коду применяется операция исключающего ИЛИ. Короткие коды генерируются 15-битовым регистром сдвига как псевдослучайные числа.

Обратный канал системы IS-95

В табл. 2.7 представлены параметры обратного канала связи. Обратный какал связи может включать в себя до 94 логических каналов CDMA, каждый из которых занимает одну и ту же полосу частот шириной 1228 кГц (см. рис. 2.19, б). Обратный канал связи поддерживает до 32 каналов доступа и до 62 информационных каналов.

При обратной связи каждый информационный канал однозначно связан с одним мобильным устройством. Каждая станция имеет уникальную маску длинного кода, основанную на ее электронном регистрационном номере. Маска длинного кода представляет собой 42-битовое число, так что всего может быть (242 - 1) различных масок. Каналы доступа используются мобильным устройством для инициации звонка, ответа на сообщения нисходящего канала избирательного вызова и для обновления сведений о местоположении.

На рис. 2.21 показаны этапы обработки данных, передаваемых по обратному информационному каналу при скорости, соответствующей первому набору. Первые несколько шагов те же, что и для прямого канала. Для обратного канала сверточный кодер имеет степень кодирования 1/3, т.е. эффективная скорость передачи данных утраивается до максимального значения 28,8 Кбит/с. Затем применяется блочное чередование данных.

Следующим этапом является расширение данных с помощью матрицы Уолша. Способ и цель использования матрицы отличаются от способа и цели в I прямом канале. В обратном канале связи данные, получающиеся в результате г, блочного чередования, группируются в модули по 6 бит. Каждый 6-битовый модуль играет роль индекса для выбора строки матрицы Уолша 64 х 64, и эта строка заменяется входными данными. Таким образом, скорость передачи данных увеличивается в 64/6 раз, т.е. до 307,2 Кбит/с. Целью такого кодирования является улучшение приема на базовой станции. Так как 64 возможных варианта кодирования являются ортогональными, блочное кодирование облегчает процесс принятия решения на приемнике, это удобно также с точки зрения вычислений. Модуляцию Уолша можно рассматривать как разновидность блочного кода коррекции ошибок (n, k) = (64, 6) с dmin = 32. Фактически здесь все расстояния равны 32.

Для уменьшения интерференции с другими мобильными станциями вводится генератор случайных чисел для пакета данных. Его действие основано на использовании маски длинного кода для сглаживания данных в каждом 20-миллисекундном кадре.

Следующий шаг — применение схемы DSSS. В обратном канале длинный код, являющийся уникальным для мобильного устройства, с помощью операции исключающего ИЛИ сравнивается с выходными данными генератора случайных ; чисел, что позволяет получить окончательную скорость передачи данных, равную 1,2288 Мбит/с. Затем этот цифровой поток модулируется на несущей с использованием ортогональной схемы QPSK. Эта модуляция отличается от использованной в прямом канале, так как здесь в модуляторе используется задержка, гарантирующая ортогональность. Причина использования разных модуляторов заключается в том, что в прямом канале коды расширения являются ортогональными, поскольку все получены из матрицы Уолша, в то время как в обратном канале ортогональность кодов расширения не гарантирована.

Рисунок 2.21 - Обратный канал связи системы IS-95


Беспроводные сети. Современное состояние и перспективы развития. 2.5 СИСТЕМЫ ТРЕТЬЕГО ПОКОЛЕНИЯ

2.5. СИСТЕМЫ ТРЕТЬЕГО ПОКОЛЕНИЯ

Беспроводные системы связи третьего поколения разрабатываются с целью по лучения высокоскоростных беспроводных средств передачи не только речи, но и данных, мультимедиа и видео. По инициативе ITU IMT-2000 определено следующее видение союзом ITU возможностей систем третьего поколения.

• Качество речи сравнимо с качеством речи в общественной коммутируемой телефонной сети. Пользователям, имеющим высокоскоростные автомобили, в пределах довольно большой зоны доступна скорость передачи данных 144 Кбит/с.

• Пешеходам, стоящим или медленно идущим в пределах небольших участков, доступна скорость передачи данных 384 Кбит/с.

• Для учреждений будет поддерживаться скорость передачи данных 2,048 Мбит/с.

• Передачи данных могут быть симметричными и асимметричными.

• Поддерживается связь как с коммутацией пакетов, так и с коммутацией каналов.

• Имеется адаптивный интерфейс с Internet, который позволяет эффективно отразить асимметрию прибывающего и отправляемого трафика.

• Как правило, доступный спектр частот используется более эффективно.

• Поддерживается разнообразное мобильное оборудование.

• Система достаточно гибка для введения новых услуг и технологий.

Вообще одной из движущих сил современных технологий коммуникации является тенденция к универсализации персональных средств телекоммуникации и доступа к сообщениям. Первая концепция означает, что человек, используя один персональный счет, сможет легко идентифицировать себя и использовать с максимальным удобством любую систему коммуникации по всей стране, континенту или даже по всему миру. Второе понятие означает возможность использовать один терминал для соединения с информационными службами в разнообразных средах (например, можно было бы иметь портативный терминал, который будет одинаково хорошо работать в учреждении, на улице и на борту самолета). Осуществлению этих целей будет, несомненно, способствовать революция, происшедшая в области персональной вычислительной техники. Большим шагом вперед являются, например, модули идентификации абонента (SIM), использующиеся в сотовых телефонных системах GSM.

Эти концепции глобальной беспроводной связи были названы персональными службами связи (PCS) и персональными сетями связи (PCN), а их воплощение в жизнь является задачей беспроводных систем третьего поколения.

Вообще планируется, что в дальнейшем технология будет цифровой с возможностью множественного доступа с временным или кодовым разделением каналов, чтобы эффективно использовать спектр частот и обеспечивать высокую пропускную способность.

Телефоны PCS, согласно проекту, должны иметь меньшую мощность и быть относительно маленькими и легкими. Во всех странах сейчас ведутся работы, по завершении которых одни и те же терминалы можно будет использовать повсеместно.

Альтернативные интерфейсы

На рис. 2.22 показаны альтернативные .схемы, которые были разработаны как Часть IMT-2000. В спецификации охвачен набор радиоинтерфейсов для оптимизации производительности в разных радиосредах. Для обеспечения постепенного перехода от существующих систем первого и второго поколения к системам третьего поколения понадобились пять альтернативных схем.

Рисунок 2.22 - Наземные радиоинтерфейсы IMT-2000

Эти пять альтернатив являются эволюцией систем второго поколения. Две спецификации были созданы на основе работ Европейского института стандартов по телекоммуникациям (European Telecommunications Standards Institute — ETSI) по разработке универсальной мобильной телекоммуникационной системы (universal mobile telecommunications system — UMTS) как стандарта для беспроводных систем третьего поколения в Европе. Системы UMTS включают в себя два стандарта. Один из этих стандартов известен как широкополосная схема CDMA, или W-CDMA. В этой схеме для обеспечения высокой скорости передачи данных при эффективном использовании полосы частот применяется технология CDMA. В табл. 2.8 приведены некоторые основные параметры схемы W-CDMA. Еще одна схема систем UMTS, предложенная в Европе, называется IMT-TC, или CDMA с временным разделением (TD-CDMA). Этот подход представляет собой сочетание технологий W-CDMA и ТОМА. Технология IMT-TC должна обеспечить обновление систем GSM, основанных на технологии TDMA.

Еще одна система, основанная на CDMA, известная как cdma2000, имеет североамериканское происхождение. Эта схема похожа на широкополосную схему CDMA, но несовместима с ней. Отчасти это потому, что в стандартах используются разные скорости передачи элементов сигнала (чипов). Кроме того, в системе cdma2000 используется технология, именуемая работой с несколькими несущими, которая не применяется в схеме W-CDMA.

В других разделах книги мы уже рассматривали некоторые технологии, которые появляются в системах третьего поколения. Это турбокоды, коды Голда и коды расширения переменной длины.

Еще две спецификации интерфейса показаны на рис. 2.22. Схема IMT-SC разработана преимущественно для сетей, использующих исключительно TDMA. Использование IMT-FC с несущими TDMA и CDMA позволяет предложить некоторые услуги третьего поколения. Эта схема является частью стандарта DECT (Digital European Cordless Telecommunications — цифровые европейские беспроводные телекоммуникации), который будет рассмотрен в главе 3.

Вопросы проектирования систем CDMA

Доминирующей технологией для систем третьего поколения является CDMA. И хотя были разработаны три различные схемы CDMA, их проекты имеют некоторые общие особенности. Например:

• Ширина полосы частот. Важной целью при проектировании систем третьего поколения является ограничение использования каналов до 5 МГц. Существует несколько причин принятия такого решения. С одной стороны, полоса шириной 5 МГц и более повышает шансы приемника на восстановление многолучевого сигнала. С другой стороны, доступный спектр ограничен из соображений конкуренции, и 5 МГц являются разумной верхней границей, которая может быть выделена системам третьего поколения. И, наконец, 5 МГц подходят для поддержки скоростей передачи данных 144 и 384 Кбит/с, что является одной из основных услуг третьего поколения.

• Скорость передачи элементов сигнала. При заданной ширине полосы скорость передачи элементов сигнала (чипов) зависит от желаемой скорости передачи данных, потребности в обработке ошибок и ограничений, накладываемых на ширину полосы частот. При заданных параметрах проекта разумной будет скорость передачи элементов сигнала 3 * 106 элементов/с и выше.

• Передача на нескольких скоростях: Термин передача на нескольких скоростях (multirate) означает предоставление определенному пользователю нескольких логических каналов с фиксированной скоростью передачи данных, причем разные скорости передачи данных предоставляются в разных логических каналах. Далее, логические каналы могут независимо обрабатываться коммутатором и направляться через беспроводные и стационарные сети различным адресатам. Преимуществом передачи на нескольких скоростях является то, что система становится достаточно гибкой, чтобы поддерживать несколько приложений данного пользователя, и может эффективно использовать пропускную способность, предоставляя каналы, требуемые только для данной услуги.

Передачи на нескольких скоростях можно добиться в одном канале CDMA с использованием схемы TDMA. Для достижения различных скоростей передачи данных в кадре выделяется различное количество слотов. Все подканалы при данной скорости передачи данных будут защищены схемами исправления ошибок и чередования (рис. 2.23, а). Альтернативой является использование нескольких кодов CDMA с отдельным кодированием и чередованием и наложение их на отдельные каналы CDMA (см. рис. 2.23, б).

Рисунок 2.23 - Принципы временного и кодового разделения каналов


Беспроводные сети. Современное состояние и перспективы развития. 4.1 ОБЗОР

В последние годы беспроводные локальные сети заняли существенную нишу на рынке локальных сетей. Все больше и больше организаций считают, что беспроводные сети являются необходимым дополнением традиционных проводных локальных сетей, удовлетворяющим требованиям мобильности, возможности передислокации, организации эпизодических сетей и охвата мест труднодоступных при использовании проводных методов.

В данном разделе дается обзор беспроводных локальных сетей. Вначале приводятся мотивы использования таких сетей и обобщаются различные подходы. В следующих трех подразделах подробнее исследуются три основных типа беспроводных локальных сетей, классифицированных согласно технологии передачи: сети передачи в инфракрасном диапазоне, сети с расширенным спектром и сети с узкополосной СВЧ-передачей.

4.1 ОБЗОР

Беспроводная локальная сеть связана с беспроводной средой передачи. До недавнего времени беспроводные сети использовались не очень интенсивно. Среди причин — высокие цены, низкие скорости передачи данных, проблемы профессиональной безопасности и необходимость лицензирования. По мере того как решались эти проблемы, популярность беспроводных локальных сетей быстро росла. В данном разделе мы вначале рассмотрим требования к беспроводным локальным сетям и преимущества этих сетей, после чего перейдем к обзору ключевых подходов к реализации локальных сетей.

Применение беспроводных локальных сетей

Существуют четыре области применения беспроводных локальных сетей: расширение локальных сетей, связь зданий, кочевой доступ и создание эпизодических сетей.

Расширение локальных сетей

Ранние продукты рынка беспроводных локальных сетей, появившегося в конце 1980-х, представлялись как замена традиционных проводных локальных сетей. Беспроводные локальные сети экономят средства на прокладку кабеля локальных сетей, облегчают задачу передислокации и другие модификации структуры сети. Впрочем, события опередили этот мотив использования беспроводных локальных сетей. Во-первых, по мере того, как становилась понятнее необходимость использования локальных сетей, архитекторы разрабатывали новые здания, изначально включающие кабелепроводку, которую можно было использовать для нужд сферы информационных технологий. Во-вторых, с прогрессом в технологии передачи данных бурно развилось использование в локальных сетях витой пары. Большинство старых зданий уже в изобилии снабжено кабелями категории 3; многие новые здания имеют кабели категории 5. Следовательно, замены проводных локальных сетей беспроводными в широких масштабах не произошло.

Впрочем, существуют среды, в беспроводные локальные сети нашли себя как альтернатива проводным. Примеры: здания с большими открытыми территориями, такие, как предприятия обрабатывающей промышленности, операционные этажи фондовых бирж и склады, исторические строения с недостаточным объемом проложенных витых пар, в которых запрещено сверление каналов под проводку, а также небольшие офисы, в которых установка и эксплуатация проводных локальных сетей неэкономична. Во всех названных случаях беспроводные локальные сети предоставляют эффективную и более привлекательную альтернативу. В большинстве из названных случаев в организации также будет существовать проводная локальная сеть для поддержки серверов и нескольких стационарных рабочих станций. Например, на предприятиях офисная территория обычно отделена от заводских этажей, но должна быть с ними связана с целью организации сети. Таким образом, беспроводные и проводные сети одного здания обычно связываются. Такая область применения беспроводных сетей называется расширением локальной сети.

На рис. 4.1 показан пример конфигурации беспроводной локальной сети, типичной для большинства сред. Имеется магистральная проводная локальная сеть, такая, как Ethernet, поддерживающая серверы, рабочие станции и один или несколько мостов или маршрутизаторов для связи с другими сетями. Имеется также модуль управления (control module — СМ), действующий как устройство сопряжения с беспроводной сетью. Модуль управления обладает функциональными возможностями моста или маршрутизатора для связи беспроводной локальной сети и магистрали. Кроме того, он включает некоторую логику управления доступом, такую, как механизм опроса или схему передачи маркера для регулирования доступа от конечных систем. Отметим, что некоторые из конечных систем являются самостоятельными устройствами, такими, как рабочая станция или сервер. Частью конфигурации могут быть также концентраторы или другие пользовательские модули (user module — UM), управляющие несколькими станциями вне проводной локальной сети.

Рисунок 4.1 - Пример одноячеечной конфигурации беспроводной локальной сети

Конфигурацию, представленную на рис. 4.1, можно назвать одноячеечной беспроводной локальной сетью; все беспроводные конечные системы находятся в сфере влияния одного модуля управления. Другая распространенная конфигурация представляет собой многоячеечную беспроводную локальную сеть (рис. 4.2). В этом случае имеем несколько модулей управления, связанных проводной локальной сетью. Каждый модуль управления поддерживает несколько беспроводных конечных систем в пределах своей области связи. Например, в локальной сети, использующей передачу в инфракрасном диапазоне, передача ограничена одной комнатой; следовательно, для каждой комнаты офисного здания, нуждающегося в беспроводной поддержке, нужна отдельная ячейка.

Связь зданий

Еще одним применением технологии беспроводных сетей является соединение локальных сетей близлежащих зданий, имеющих проводные или беспроводные локальные сети. В этом случае между двумя зданиями используется двухточечный беспроводный канал связи. Как правило, таким образом соединяются мосты или маршрутизаторы. Этот единственный канал передачи данных сам по себе не является локальной сетью, но его принято рассматривать как один из способов применения беспроводных локальных сетей.

Рисунок 4.2 - Пример многоячеечной конфигурации беспроводной локальной сети

Кочевой доступ

Кочевой доступ предлагает беспроводный канал связи между концентратором локальной сети и мобильным информационным терминалом, снабженным антенной, таким, как лэптоп или ноутбук. Одним из примеров применения такого соединения является передача сотрудником, вернувшимся из командировки, данных из персонального портативного компьютера на сервер в офисе. Кочевой доступ также полезен в обширной среде, такой, как кампус или предприятие, функционирующее за пределами блока зданий. В обоих случаях пользователи со своими портативными компьютерами могут перемещаться и могут связываться с серверами проводной локальной сети из различных мест.

Организация эпизодических сетей

Эпизодическая сеть — это одноранговая сеть (без централизованного сервера), настроенная временно для срочного удовлетворения некоторых потребностей. Например, группа сотрудников, каждый из которых обладает лэптопом или карманным компьютером, может собраться в конференц-зале для деловой или классной встречи. Сотрудники соединяют свои компьютеры во временную сеть только на период встречи.

На рис. 4.3 показаны отличия беспроводной локальной сети, удовлетворяющей требованиям расширения сети и кочевого доступа, от эпизодической беспроводной локальной сети. В первом случае беспроводная сеть формирует стационарную инфраструктуру, состоящую из одной или нескольких ячеек с модулем управления в каждой. Каждая ячейка может иметь несколько стационарных конечных систем. Кочующие станции могут перемещаться из одной ячейки в другую. В эпизодической сети такая инфраструктура отсутствует. В этом случае имеем набор равноправных станций в пределах досягаемости друг друга, которые могут динамически организоваться во временную сеть.

Рисунок 4.3 - Конфигурации беспроводных локальных сетей

Требования к беспроводным локальным сетям

Беспроводные сети должны удовлетворять некоторым требованиям, типичным для всех локальных сетей, в том числе: высокая пропускная способность, возможность охвата небольших расстояний, связность подключенных станций и возможность широковещания. Кроме того, существует набор требований, характерных только для беспроводных локальных сетей. Перечислим важнейшие из них.

  • Производительность. Протокол управления доступом к среде должен максимально эффективно использовать беспроводную среду для максимизации пропускной способности.
  • Число узлов. От беспроводных локальных сетей может требоваться поддержка сотен узлов из множества ячеек.
  • Соединение с магистральной локальной сетью. В большинстве случаев требуется взаимосвязь со станциями магистральной локальной сети. Для беспроводных локальных сетей, имеющих внутреннюю инфраструктуру, это требование легко удовлетворяется посредством использования модулей управления, присоединяемых к локальным сетям обоих типов. Может также понадобиться специальное помещение для мобильных пользователей и организация эпизодических беспроводных сетей.
  • Обслуживаемая область. Типичная сфера охвата беспроводной локальной сети имеет диаметр 100-300 м.
  • Потребление питания от батарей. Мобильные сотрудники используют рабочие станции с питанием от батарей, потребление которого не должно быть большим при использовании беспроводных адаптеров. Это делает неприменимым протокол MAC, требующий, чтобы мобильные узлы постоянно следили за точками доступа или часто связывались с основной станцией.
  • Устойчивость передачи и безопасность. Беспроводные сети, если они разработаны неправильно, могут быть подвержены интерференции и легко прослушиваться. Структура беспроводной локальной сети должна обеспечивать надежную передачу даже в обстановке шума, а также некоторый уровень зашиты от прослушивания.
  • Совместная работа в сети. С ростом популярности беспроводных сетей повысилась вероятность того, что две или более сетей будут работать в одной области или в нескольких областях, допускающих интерференцию разных локальных сетей. Такая интерференция может мешать нормальной работе алгоритма MAC и способствовать несанкционированному доступу к отдельной локальной сети.
  • Работа без лицензии. Пользователи желали бы приобретать продукты рынка беспроводных локальных сетей и работать с ними на нелицензируемой полосе частот.
  • Переключение/роуминг. Протокол MAC, используемый в беспроводных локальных сетях, должен позволять мобильным станциям перемещаться из одной ячейки в другую.
  • Динамическая конфигурация. МАС-адресация и сетевое управление локальной сети должны позволять динамическое и автоматическое добавление, удаление и передислокацию конечных систем, не причиняя неудобств другим пользователям.

На рис. 4.4 представлены диаграммы Кивиата (Диаграмма Кивиата является графическим средством сравнения систем по нескольким параметрам. Переменные располагаются через равные угловые интервалы. На каждой оси ставится одна точка, соответствующая данной системе; соединение точек образует контур, являющийся характеристикой системы) для сравнения беспроводных локальных сетей, проводных локальных сетей и мобильных сетей передачи данных.

Рисунок 4.4 - Диаграммы Кивиата для сетей передачи данных

Технология беспроводных локальных сетей

Беспроводные локальные сети обычно классифицируются согласно использованной в них технологии передачи. Все современные продукты рынка локальных сетей относятся к одной из следующих категорий.

  • Инфракрасные (infrared — IR) локальные сети. Отдельная ячейка сети, использующей передачу в инфракрасном диапазоне, ограничена размерами одной комнаты, поскольку инфракрасное излучение не проходит сквозь непрозрачные стены.
  • Локальные сети с расширенным спектром. Данный тип локальных сетей использует при передаче технологию расширенного спектра. В большинстве случаев эти локальные сети работают на диапазонах ISM (Industrial, Scientific and Medical Radio Frequency Band — радиочастотные диапазоны для промышленного, научного и медицинского применения), поэтому для их использования в США не требуется лицензия FCC (Federal Communications Commission — Федеральная комиссия по средствам связи).
  • Узкополосная СВЧ-передача. Эти локальные сети работают на СВЧ, но не используют расширенный спектр. Некоторые из этих продуктов работают на частотах, требующих лицензии FCC, другие используют нелицензируемые частоты ISM.

Некоторые ключевые характеристики названных технологий приведены в табл. 4.1.

Таблица 4.1 Сравнительные характеристики беспроводных локальных сетей

 | Инфракрасное излучение |  | Расширенный спектр |  | Радио
 | Рассеянное инфракрасное излучение | Инфракрасное излучение с направленным лучом | Перестройка частоты | Прямая после-дователь-ность | Узкополосная СВЧ-передача
Скорость передачи данных (Мбит/с) | 1-4 | 1-10 | 1-3 | 2-20 | 10-20
Мобильность | Стационарные / мобильные | Стационарные в пределах линии прямой видимости | Мобильные |  | Стационарные / мобильные
Диапазон (м) | 15-60 | 25 | 30-100 | 30-250 | 10-40
Возможность обнаружения | Незначительная |  | Малая |  | Некоторая
Длина волны / частота | λ: 800-900 нм |  | 902-928 МГц 2,4-2,4835 ГГц 5,725-5,85 ГГц |  | 902-928 МГц 5,2-5,775 ГГц 18,825-19,205 ГГц
Схема модуляции | ASK |  | FSK | QPSK | FS/QPSK
Излучаемая мощность | ― |  | < 1 Вт |  | 25 мВт
Схема доступа | CSMA | Token Ring, CSMA | CSMA |  | ALOHA с резерви-рованием, CSMA
Необходимость лицензии | Не требуется |  | Не требуется |  | Только вне частот ISM


Беспроводные сети. Современное состояние и перспективы развития. 4.2 ИНФРАКРАСНЫЕ СЕТИ

4.2 ИНФРАКРАСНЫЕ СЕТИ

Оптическая беспроводная связь в инфракрасной части спектра нашла свое применение в помещениях, где имеются многочисленные удаленные устройства. В последнее время все большее внимание уделяется использованию инфракрасных технологий для создания беспроводных локальных сетей. В данном разделе сравниваются характеристики инфракрасных сетей и радиосетей, после чего приводятся некоторые подробности относительно инфракрасных локальных сетей.

Плюсы и минусы

В беспроводных локальных сетях используются две технологии: передача в инфракрасном диапазоне и радиопередача в СВЧ-диапазоне с использованием расширенного спектра или узкополосной передачи. Инфракрасная передача предлагает несколько существенных преимуществ. Во-первых, спектр для такой связи обычно неограничен, что дает возможность получать весьма высокие скорости передачи. Кроме того, для инфракрасного диапазона не существует регулирующих правил или стандартов, чего нельзя сказать о некоторых участках СВЧ-диапазона.

Кроме того, инфракрасное излучение имеет некоторые свойства видимого, что делает его привлекательным для определенных конфигураций локальных сетей. Инфракрасное излучение диффузно отражается от светлоокрашенных объектов; таким образом, для покрытия всей комнаты можно использовать отражение от потолка. Инфракрасное излучение не проникает сквозь стены или другие непрозрачные объекты. Это дает два преимущества: во-первых, связь в инфракрасном диапазоне легче защитить от прослушивания, чем связь в СВЧ-диапазоне; во-вторых, в каждой комнате здания может существовать своя инфракрасная конфигурация, и они не будут интерферировать между собой, что позволяет создавать значительные инфракрасные локальные сети.

Еще одним плюсом передачи в инфракрасном диапазоне является относительная простота и дешевизна соответствующего оборудования. При инфракрасной передаче данных используется модуляция интенсивности, так что ИК-приемники должны обнаруживать только амплитуду оптических сигналов, тогда как большинство СВЧ-приемников должны обнаруживать частоту или фазу.

Следует также отметить несколько недостатков рассматриваемой среды. Многое оборудование, используемое внутри помещений, дает существенное фоновое излучение в ИК-диапазоне. Это внешнее излучение воспринимается ИК-приемником как шум, значит, требуются передатчики большей мощности. В то же время следует учитывать вопросы чрезмерных затрат мощности и безопасности для зрения.

Методы передачи

В настоящее время для передачи данных в ИК-диапазоне используются три альтернативных метода: сигнал может быть сфокусированным и направленным (пульт дистанционного управления телевизором); может излучаться равномерно во всех направлениях; может отражаться от светлоокрашенных потолков.

Направленный луч

Инфракрасная передача с направленным лучом используется для создания двухточечных каналов связи. В этом режиме радиус связи зависит от излучаемой мощности и степени фокусировки. Сфокусированный инфракрасный канал передачи Данных может измеряться километрами. Такие диапазоны передачи не нужны для создания комнатных беспроводных локальных сетей. В то же время инфракрасный канал связи используется для связи зданий, точнее, мостов или маршрутизаторов, расположенных в зданиях, находящихся в пределах прямой видимости.

При комнатном использовании двухточечных инфракрасных каналов может настраиваться локальная сеть типа Token Ring (рис. 4.5). Набор инфракрасных трансиверов настраивается так, чтобы данные циркулировали между ними как в кольцевой конфигурации. Каждый трансивер поддерживает рабочую станцию или концентратор станций, причем концентратор выполняет функции маршрутизатора.

Рисунок 4.5 - Локальная сеть Token Ring с использованием двухточечных инфракрасных каналов

Ненаправленная передача

Ненаправленная конфигурация включает одну базовую станцию, находящуюся в пределах прямой видимости остальных станций локальной сети. Как правило, такая выделенная станция располагается на потолке (рис. 4.6, а) и действует как многопортовый ретранслятор. Связь осуществляется следующим образом. Передатчик базовой станции ретранслирует ненаправленный сигнал, который могут принимать все другие ИК-приемники, находящиеся в охваченном диапазоне, а данные трансиверы передают направленный луч, нацеленный на базовый модуль станции.

Отражение

В такой конфигурации все ИК-передатчики сфокусированы и нацелены на точку в диффузно отражающем потолке (рис. 13.6, б). Инфракрасное излучение поступает на потолок и отражается от него, после чего принимается всеми приемниками области.

Рисунок 4.6 - Конфигурация ненаправленной инфракрасной локальной сети

Пример типичной беспроводной локальной сети с инфракрасной передачей приведен на рис. 4.7. Имеется несколько (по одной на комнату) размещенных на потолке базовых станций. Каждая станция обеспечивает связь между несколькими стационарными и мобильными рабочими станциями, находящимися в обслуживаемой комнате. Между собой базовые станции соединяются проводом, они также связаны с сервером, который может выступать как точка доступа к проводной ЛВС или глобальной сети. Кроме того, могут существовать конференц-залы, в которых отсутствуют базовые станции, а связь организуется эпизодическим образом.

Рисунок 4.7 - Сети портативных и стационарных беспроводных станций, использующих передачу в инфракрасном диапазоне


Беспроводные сети. Современное состояние и перспективы развития. 4.3 СЕТИ С РАСШИРЕННЫМ СПЕКТРОМ

4.3 СЕТИ С РАСШИРЕННЫМ СПЕКТРОМ

В настоящее время наиболее популярные беспроводные локальные сети используют технологию расширенного спектра.

Конфигурация

Беспроводные локальные сети с расширенным спектром используются в многоячеечных конфигурациях, исключая только небольшие офисы (рис. 13.2). Чтобы избежать интерференции между соседними ячейками в них используются различные центральные частоты.

В пределах данной ячейки топология может иметь выделенную станцию-концентратор или быть одноранговой. Первый случай изображен на рис. 13.2. Концентратор обычно располагается на потолке и соединяется с магистральной локальной сетью с целью обеспечения связи со станциями, присоединенными к проводной локальной сети, и станциями, принадлежащими той же локальной сети, но расположенными в других ячейках. Концентратор может также управлять доступом: выступать как точечный координатор IEEE 802.11 или как многопортовый ретранслятор с функциями, подобными ретрансляторам 10 Мбит/с и 100 Мбит/с Ethernet. В последнем случае все станции ячейки передают только концентратору и принимают только от него. Возможен альтернативный вариант, не зависимый от механизма управления доступом: каждая станция использует свою ненаправленную антенну для широковещания, так что эту передачу могут принимать все другие станции ячейки; данная конфигурация соответствует шинной топологии.

Еще одной потенциальной функцией концентратора является автоматическое переключение мобильных станций. В любой момент времени число станций, обслуживаемых данным концентратором, определяется динамически и зависит от пространственной близости. Если концентратор отмечает, что сигнал станции начинает слабеть, он может автоматически перепоручить обслуживание этой станции ближайшему концентратору.

В однородной топологии концентратор отсутствует и для управления доступом используется алгоритм MAC, например CSMA. Лучше всего такая топология подходит эпизодическим сетям.

Вопросы передачи

Желательной, но не необходимой, характеристикой беспроводной локальной сети является возможность ее использования без процедуры лицензирования. Условия лицензирования отличаются в разных станах, что только усложняет ситуацию. В США Федеральная комиссия по средствам связи (FCC) разрешила использование приложений двух типов в нелицензируемой полосе ISM: системы с расширенным спектром с мощностью до 1 Вт и маломощные системы (< 0,5 Вт). Таким образом, для использования беспроводных локальных сетей с расширенным спектром не требуется получения лицензии, и их популярность неуклонно растет.

В США для нелицензируемого использования в системах с расширенным спектром выделены три частотных диапазона: 902-928 МГц ("полоса 915 МГц"), 2,4-2,4835 ГГц ("полоса 2,4 ГГц") и 5,725-5,825 ГГц ("полоса 5,8 ГГц"). Второй из этих диапазонов также используется в Европе и Японии. Чем выше частота, тем больше потенциальная ширина полосы, так что данные три диапазона перечислены в порядке возрастания привлекательности с точки зрения способности. Кроме того, следует рассматривать возможность интерференции. Существует множество устройств, работающих на частоте порядка 900 МГц, в том числе радиотелефоны, радиомикрофоны и любительские радиостанции. На частоте порядка 2,4 ГГц работает меньшее число устройств; к ним относится микроволновая печь, внешнее излучение которой увеличивается с возрастом печи. В настоящее время полоса 5,8 ГГц используется относительно мало; впрочем, чем выше частота, тем дороже оборудование для ее эксплуатации.

До недавнего времени типичные беспроводные локальные сети с расширенным спектром ограничивались скоростями передачи 1-3 Мбит/с. Как показано в главе 14, новые стандарты дают возможность использовать скорости 5,5 и 11 Мбит/с, а некоторые частные решения — более высокие скорости.


Беспроводные сети. Современное состояние и перспективы развития. 13.4. СЕТИ С УЗКОПОЛОСНОЙ СВЧ-ПЕРЕДАЧЕЙ

4.4. СЕТИ С УЗКОПОЛОСНОЙ СВЧ-ПЕРЕДАЧЕЙ

Термином узкополосная СВЧ-передача (narrowband microwave) обозначают использование для передачи сигнала полосы сверхвысоких частот при относительно узкой полосе — широкой ровно настолько, насколько требуется для вмещения сигнала. До недавнего времени все локальные продукты сетей с узкополосной СВЧ-передачей использовали СВЧ-диапазон, требующий получения лицензии. Затем по крайней мере один поставщик произвел продукт, предназначенный для полосы ISM.

Лицензируемые узкополосные системы

СВЧ, которые используются для передачи речи, данных и видео, требуют получения лицензии, и их использование координируется, что позволяет избежать потенциальной интерференции между системами. В США лицензирование контролирует Федеральная комиссия по средствам связи. Каждая географическая область имеет радиус 28 км, и в ней могут выдаваться до пяти лицензий, причем каждая лицензия выдается на две частоты. Motorola имеет 600 лицензий (1200 частот) в полосе 18 ГГц, которые позволяют охватить все области с населением свыше 30 000 человек.

В узкополосной схеме обычно используется конфигурация, представленная на рис. 4.2. Соседние ячейки используют неперекрывающиеся диапазоны частот в пределах общей полосы 18 ГГц. Поскольку Motorola контролирует распределение своих частот, эта компания может гарантировать, что близко расположенные независимые локальные сети не будут мешать друг другу. Отметим также, что для защиты от подслушивания все передачи шифруются.

Одним из преимуществ лицензируемых узкополосных локальных сетей является гарантированная связь без интерференции. В отличие от использования нелицензируемого спектра, такого, как диапазон ISM, владелец лицензии имеет легальное право на создание канала передачи данных без интерференции. Передачи пользователей локальных сетей, функционирующих в диапазоне ISM, могут повреждаться вследствие интерференции с передачами других пользователей и воспрепятствовать этому законным способом нельзя.

Нелицензируемые узкополосные системы

В 1995 году компания RadioLAN стала первым поставщиком продуктов для локальных беспроводных сетей с использованием нелицензируемой полосы частот ISM, которая может применяться для маломощной (< 0,5 Вт) узкополосной передачи. Продукты RadioLAN обеспечивают скорость передачи 10 Мбит/с и работают в полосе 5,8 ГГц. Область действия продуктов ограничена расстоянием 50 м в полуоткрытом офисе и 100 м в открытом офисе.

Продукты RadioLAN предназначены для одноранговой конфигурации, но с одной любопытной особенностью. Взамен стационарного концентратора в сети автоматически выбирается одна динамическая ведущая станция (Dynamic Master), причем выбор основывается на параметрах станции, таких, как расположение, наличие интерференции и интенсивность сигнала. При изменении условий ведущая станция также может меняться. Еще одной особенностью данных сетей является наличие функции динамической ретрансляции, которая позволяет каждой станции выступать как ретранслятор при передаче данных станциям, находящимся вне пределов досягаемости.


Значение спутниковой связи для развития телекоммуникации и средств передачи данных трудно переоценить. Появление спутниковой связи здесь сыграло не менее важную роль, чем внедрение оптоволокна. В первом разделе этой главы приводится обзор ключевых понятий и параметров беспроводной связи, связанных с использующимися здесь спутниковыми антеннами. Оставшаяся часть главы посвящена механизмам распределения пропускной способности.

1.1. ПАРАМЕТРЫ И КОНФИГУРАЦИИ СПУТНИКА

Сердцем системы спутниковой связи является антенна спутника, находящегося на стационарной орбите. С помощью одного или нескольких таких спутников, используемых как космические ретрансляторы, осуществляется связь между двумя или несколькими станциями, принадлежащими одной системе спутниковой связи и расположенными на Земле или близ Земли. Системы антенн, расположенных на Земле или близ Земли, называют наземными станциями. Канал передачи данных с наземной станции на спутник называется восходящим (uplink), а канал передачи данных в обратном направлении — нисходящим (downlink). Электронное оборудование спутника, которое принимает сигналы восходящего канала и преобразует их в сигналы нисходящего канала, называется транспондером.

Спутники связи можно классифицировать по таким признакам.

• Зона обслуживания: может быть глобальной, региональной или национальной. Чем больше зона обслуживания, тем больше спутников будет задействовано в организации сети.

• Тип услуг: существуют спутники стационарной службы связи (fixed service satellite-- FSS), радиовещательной службы (broadcast service satellite — BSS) и мобильной- службы (mobile service satellite — MSS). В этой главе будут рассматриваться преимущественно спутники FSS и BSS.

• Характер использования: коммерческие, военные, любительские или экспериментальные.

При проектировании станций беспроводной связи следует учитывать те многочисленные особенности, которые отличают станции, базирующиеся на спутниках, от наземных станций.

• Зона обслуживания спутниковой системы намного превышает зону обслуживания наземной системы. Для одной антенны спутника, находящегося на геостационарной орбите, доступно около одной четвертой поверхности Земли.

• Такие ресурсы космического аппарата, как мощность и выделенная ширина полосы, весьма ограничены. Поэтому на стадии проектирования нужно выбирать оптимальное соотношение между параметрами наземной станции и спутника.

• Условия, в которых находятся сообщающиеся спутники, не так меняются со временем, как условия связи спутника с наземной станцией или же как условия связи двух наземных беспроводных антенн. Поэтому каналы связи спутник-спутник можно рассчитать с довольно высокой степенью точности.

Если передатчик и приемник находятся в зоне обслуживания одного спутника, то затраты на передачу данных не зависят от расстояния между ними.

• Легко внедряются широковещательные, многоадресные и двухточечные приложения.

• Пользователю доступен очень широкий диапазон частот или высокая скорость передачи данных.

• В целом качество данных, передаваемых с помощью спутника, поддерживается исключительно высоким, несмотря на кратковременные отключения или ухудшение качества связи.

• Для спутников, находящихся на геостационарной орбите, задержка распространения сигнала с земли на спутник и обратно равна примерно одной четвертой секунды.

• Передающие наземные станции во многих случаях могут принимать и собственные сигналы.

Спутниковые орбиты

Существует несколько классификаций орбит спутников.

1. Орбита может быть круговой, с центром окружности, расположенном в центре Земли, или эллиптической, для которой центр Земли находится в одном из фокусов эллипса.

2. Спутник может вращаться вокруг Земли в разных плоскостях. Экваториальные орбиты расположены в плоскости земного экватора. Полярные орбиты проходят над обоими полюсами Земли. Все остальные орбиты называются наклонными.

3. По высоте над уровнем моря орбиты классифицируются следующим образом: геостационарные околоземные орбиты (geostationary earth orbit — GEO), средние околоземные орбиты (medium earth orbit — MEO) и низкие околоземные орбиты (low earth orbit — LEO). Подробнее орбиты всех типов рассмотрены позднее.

Расстояние

На рис. 1.1 приведена геометрическая схема, в соответствии с которой рассчитывается зона обслуживания спутника. Ключевым параметром данной схемы является угол возвышения наземной станции 6, который является углом между горизонтальной линией (т.е. линией, касательной к поверхности Земли в точке расположения антенны) и направлением основного луча антенны, наделенного непосредственно На спутник. Максимальная величина зоны обслуживания спутника получается при нулевом угле возвышения. Тогда зона обслуживания во всех направлениях ограничивается только оптическим горизонтом спутника. Однако существуют по крайней «ере три проблемы, которые не позволяют строить антенны наземных станций с нулевым углом возвышения и определяют минимальный угол возвышения.

1. Нельзя игнорировать здания, деревья и другие наземные объекты, которые могут находиться на пути луча, идущего от антенны. Подобные помехи приводят к ослаблению сигнала, так как происходит его частичное поглощение или искажение вследствие многократного отражения луча.

2. Чем меньше значение угла возвышения, тем больше атмосферное поглощение, так как при малых углах возвышения сигнал проходит в атмосфере большое расстояние.

3. На качество приема также неблагоприятно влияет электрический шум, обусловленный высокой температурой около поверхности Земли.

Рисунок 1.1 - Охват и угол возвышения

При проектировании нисходящего канала принято использовать минимальный угол возвышения, который, в зависимости от частоты сигнала, может составлять 5-20°. Для восходящего канала Федеральная комиссия по средствам связи США предписывает использовать угол возвышения не менее 5°.

Угол охвата β — это мера части земной поверхности, которая видна со спутника с учетом минимального угла возвышения. Угол β задает окружность на поверхности Земли, центр которой находится в точке, расположенной непосредственно под спутником. Справедливо следующее соотношение:

Здесь

R — радиус Земли, который равен 6370 км;

h — высота орбиты (т.е. кратчайшее расстояние от спутника до Земли);

β — угол охвата;

θ — минимальный угол возвышения.

Расстояние от спутника до ближайшей к нему точки зоны обслуживания ; рассчитывается по следующей формуле:

Следовательно, задержка кругового обращения сигнала принадлежит такому диапазону:

где с — скорость света, которая равна примерно 3 х 108 м/с.

Размер зоны обслуживания спутника обычно выражается через диаметр покрываемой области, равный 2β R, где β выражается в радианах.

На рис. 1.2 показаны период обращения, зона обслуживания (выраженная через радиус охваченной области земной поверхности), а также максимальная задержка кругового обращения сигнала.

Геостационарные спутники

В настоящее время самыми распространенными среди спутников связи являются геостационарные (GEO). Любопытно, что первым, кто выдвинул идею использования таких спутников, был писатель-фантаст Артур Кларк, пославший в 1945 году статью на эту тему в журнал Wireless World. Идея заключалась в следующем: если спутник находится на круговой орбите на высоте 35 863 км над поверхностью Земли и движется в плоскости земного экватора, то угловая частота вращения такого спутника будет совпадать с угловой частотой вращения Земли и спутник все время будет находиться над одной и той же точкой на экваторе. Такая орбита изображена на рис. 1.3 с соблюдением масштаба. На орбите показано множество символов, соответствующих спутникам, что также отражает реальную картину. На геостационарной орбите действительно находится довольно много спутников, некоторые из них расположены вплотную друг к другу.

Рисунок 1.2 - Параметры, спутника как функция высоты орбиты

Геостационарные орбиты имеют ряд преимуществ, которые выгодно отличают их от орбит других типов.

• Так как спутник не движется относительно Земли, то не возникает проблем с изменением частоты сигнала из-за относительного движения спутника и наземных антенн (обусловленного эффектом Доплера).

• Упрощается процедура отслеживания спутника с наземных станций.

• Спутник, находящийся на высоте 35 863 км над Землей, может связаться примерно с четвертой частью земной поверхности. Для того чтобы покрыть все населенные зоны Земли, исключая участки близ северного и южного полюсов, понадобится вывести на геостационарную орбиту всего три спутника, расположив их на расстоянии 120° друг от друга.

С другой стороны, есть и недостатки.

• После прохождения расстояния свыше 35 000 км сигнал может стать довольно слабым.

• Полярные области и приполярные участки северного и южного полушарий практически недоступны для геостационарных спутников.

Несмотря на то что скорость света равна 300 000 км/с, задержка прохождения сигнала из точки на экваторе, расположенной под спутником, на спутник и обратно довольно существенна.

Рисунок 1.3 - Геостационарная орбита (GEO)

Задержка связи между двумя наземными абонентами, расположенными непосредственно под спутником, в действительности составляет (2 х 35 863)/300 000 = 0,24 с. Для других абонентов, не находящихся непосредственно под спутником, задержка связи еще больше. Если использовать спутниковую связь для телефонных переговоров, то суммарный интервал между завершением фразы одного абонента и ответом другого удваивается и получается равным примерно половине секунды. Такую задержку трудно не '"заметить. Еще одним свойством геостационарных спутников является то, что выделенные для них частоты используются над очень большим участком поверхности Земли. Для многоточечных приложений, таких, как передача телевизионных программ, это даже к лучшему, однако для двухточечной связи спектр частот геостационарного спутника будет использоваться очень неэкономно. Можно использовать специальные антенны с направленным или управляемым лучом, которые позволяют ограничить область, покрываемую сигналом спутника, и таким образом контролировать размеры области, в пределах которой принимается сигнал спутника. Для решения некоторых из перечисленных проблем были разработаны другие типы орбит. Для персональных устройств связи третьего поколения важную роль играют спутники на низких околоземных орбитах (LEOS) и спутники на средних околоземных орбитах (MEOS).

Рисунок 1.4. Орбиты низких и средних околоземных спутников

Спутники LEO

Спутники LEO (рис. 1.4, а) имеют следующие характеристики.

Круговые или эллиптические орбиты на высоте до 2000 км. Все предлагаемые и реальные системы располагаются на высоте от 500 до 1500 км.

• Период орбиты равен 1,5-2 ч.

• Диаметр зоны обслуживания равен примерно 8000 км. I • Задержка кругового распространения сигнала составляет не более 20 мс.

• Максимальное время, в течение которого спутник виден с фиксированной точки на поверхности Земли (в пределах радиогоризонта), достигает 20 мин.

• Ввиду высокой скорости относительного движения спутника и стационарного расположения наземной станции оборудование системы связи должно быть способно учитывать большие доплеровские сдвиги, которым подвергается частота сигнала.

• Для спутников LEO велико сопротивление атмосферы, поэтому орбита спутника постепенно деформируется.
Чтобы ввести в действие такую систему связи, нужно довольно много орбитальных плоскостей; кроме того, на каждой орбите должны находиться по несколько спутников. Тогда при сообщении двух наземных станций сигнал, как правило, будет передаваться с одного спутника на другой.

Спутники LEO имеют ряд преимуществ по сравнению с геостационарными спутниками. Кроме уже упомянутого сокращения задержки распространения сигнала, принимаемый сигнал, отправленный со спутника LEO, гораздо сильнее сигнала со спутника GEO при той же энергии передачи. Зону обслуживания спутника LEO можно локализовать с гораздо большей степенью точности, так что можно эффективнее распорядиться спектром частот, выделенным для спутника LEO. Именно поэтому данная технология сейчас предложена для связи с мобильными и персональными терминалами, для функционирования которых нужны более сильные сигналы. С другой стороны, чтобы 24 часа обеспечивать широкую зону обслуживания, нужно много спутников LEO.

Было выдвинуто несколько коммерческих предложений по использованию кластеров спутников LEO для предоставления услуг связи. Эти предложения можно разделить на две категории.

• Малые кластеры LEO. Такие кластеры, предназначенные для работы при частоте связи ниже 1 ГГц, используют полосу частот шириной не более 5 МГц и обеспечивают скорость передачи данных до 10 Кбит/с. Эти системы предназначены для поиска, слежения и низкоскоростного обмена сообщениями. Примером такой спутниковой системы является система Orbcomm, которая стала первой из малых действующих систем LEO: ее первые два спутника были запущены в апреле 1995 года. Система Orbcomm разрабатывалась для поиска и пакетной передачи данных и предназначалась для работы с небольшими пакетами данных длиной 6-250 байт. Она используется для отслеживания передвижения прицепов, железнодорожных составов, тяжелого оборудования и других удаленных и мобильных активов. Такую систему можно также использовать для наблюдения за удаленными приборами, резервуарами-хранилищами нефти и газа, скважинами и трубопроводами или для поддержки связи с рабочими, в какой бы точке земного шара они не находились. Для передачи данных на спутники этой системы используются частоты от 148,00 до 150,05 МГц, а для передачи сигналов со спутников — частоты от 137,00 до 138,00 МГц. g распоряжении системы Orbcomm находятся более 30 спутников на низких околоземных орбитах. Она поддерживает абонентскую скорость передачи данных на спутник, равную 2,4 Кбит/с, и со спутника — 4,8 Кбит/с.

• Большие кластеры LEO. Такие системы работают на частотах более 1 ГГц и поддерживают скорость передачи данных до нескольких мегабайтов в секунду. Эти системы стремятся предоставлять те же услуги, что и малые кластеры LEO, а также дополнительные услуги по передаче голоса и по определению местоположения. Примером большой системы LEO является система Globalstar. Ее спутники довольно примитивны. В отличие от некоторых малых систем LEO, на спутниках этой системы не установлено оборудования для обработки данных или связи между спутниками. Обработка данных большей частью проводится наземными станциями системы. В системе используется технология CDMA, подобная стандарту CDMA сотовой связи. Нисходящая связь с мобильными пользователями осуществляется в диапазоне 5-полосы (около 2 ГГц). Система Globalstar тесно интегрирована с традиционными звуковыми службами-носителями. Все звонки должны обрабатываться на наземных станциях. Группа спутников системы Globalstar состоит из 48 действующих спутников и 8 запасных. Эти спутники находятся на орбитах на высоте 1413 км.

Спутники МЕО

Спутники МЕО (рис. 1.4, б) имеют следующие характеристики.

• Круговая орбита, расположенная на высоте 5000-12 000 км.

• Период орбиты около 6 ч.

• Диаметр зоны обслуживания колеблется от 10 000 до 15 000 км.

• Задержка кругового распространения сигнала составляет менее 50 мс.

• Максимальное время, в течение которого спутник виден из фиксированной точки на земной поверхности (находящейся в пределах радиогоризонта), составляет несколько часов.

В системах МЕО не требуется так много переключений между спутниками, как в системах LEO. Значения таких параметров спутника МЕО, как задержка распространения сигнала со спутника МЕО на Землю и его требуемая мощность, выше, чем у спутников LEO, однако существенно меньше, чем у геостационарных спутников. Для новой программы ICO, разработанной в январе 1995 года, была предложена система МЕО. Запуски спутников МЕО начались в 2000 году. На орбиты выстой 10 400 км планировалось поместить двенадцать спутников (из них два запасных). Спутники должны быть равномерно распределены между двумя плоскостями и иметь угол наклона к экватору в 45°. Системы МЕО предлагается использовать для предоставления таких услуг, как цифровая передача речи, данных, факсимильных сообщений, широковещательных уведомлений, и для обмена сообщениями.

Полосы частот

В табл. 1.1 перечислены полосы частот, доступные для спутниковой связи. Обратите внимание, что чем выше частота полосы, тем больше ее доступная ширина. Впрочем, полосы более высокой частоты сильнее подвержены искажениям передачи. Службам мобильной спутниковой связи (MSS) выделены частоты в полосах S и L. Если сравнить эти полосы с полосами более высоких частот, то здесь наблюдается большее преломление луча и его проникновение через физические преграды, такие, как листва и неметаллические структуры. Эти характеристики являются крайне важными для услуг мобильной связи. Кроме того, полосы L и S широко используются для других наземных приложений, поэтому в настоящее время существует конкуренция между поставщиками услуг в СВЧ-диапазоне за возможность использования полос L и S.

Таблица 1.1. Полосы частот для спутниковой связи

Полоса | Диапазон частот, ГГц | Суммарная ширина полосы, ГГц | Распространенные приложения
L | 1-2 | 1 | Мобильная спутниковая связь (MSS)
S | 2-4 | 2 | Службы MSS, NASA, исследование дальнего космоса
C | 4-8 | 4 | Спутники стационарной службы связи (FSS)
X | 8-12,5 | 4,5 | Военные службы FSS, исследования Земли и метеорологические спутники
Ku | 12,5-18 | 5,5 | Службы FSS, радиовещательные спутниковые службы (BSS)
K | 18-26,5 | 8,5 | Службы FSS и BSS
Ka | 26,5-40 | 13,5 | Службы FSS

При предоставлении службе полосы частот диапазоны для восходящего и нисходящего каналов определяются отдельно, причем частота восходящего канала всегда выше. Как известно, для сигнала с более высокой частотой рассеяние или потери в свободном пространстве больше, чем для его низкочастотного дополнения. Впрочем, наземные станции располагают достаточной мощностью, позволяющей компенсировать низкую производительность на высоких частотах.

Ухудшение качества связи

Производительность спутникового канала связи зависит от трех факторов:

• расстояния между антенной наземной станции и антенной спутника;

• в нисходящем канале — от расстояния между антенной наземной станции и "точкой прицела" спутника;

• атмосферного поглощения.

Рассмотрим данные факторы подробнее.

Расстояние

Формула потерь в свободном пространстве:

LдБ = 10 lg (Pt/Pr) = 10 lg (4πd/λ) = -20 lg(λ) + 20 lg(d) +21,98

Здесь

Рt — мощность сигнала на передающей антенне;

Рr — мощность сигнала на принимающей антенне;

λ — длина волны несущей;

d — расстояние распространения между антеннами.

Величины d и λ измеряются в одних единицах (например, в метрах).

Чем выше частота сигнала (т.е. чем меньше его длина волны), тем большими будут потери. Для геостационарного спутника потери в свободном пространстве на экваторе составляют:

LдБ = -20 lg(λ) + 20 lg (35,863 х 106) + 21,98 дБ = -20 lg(λ) + 173,07.

Потери для точек земной поверхности, удаленных от экватора, но все еще видимых со спутника, будут несколько больше. Максимальное расстояние (от спутника до горизонта) для геостационарного спутника равно 42 711 км. Потери в свободном пространстве при прохождении сигналом такого расстояния равны:

LдБ = -20 lg(λ) + 174,51.

Затухание сигнала как функции частоты и высоты орбиты показано на рис. 1.5.

След спутника

Для работы на СВЧ, которые используются в спутниковой связи, применяются узконаправленные антенны. Таким образом, сигнал со спутника не распространяется во все стороны, а нацеливается на определенную точку Земли. Выбор точки прицела производится с учетом местоположения и размеров области, которая должна покрываться. На центральную точку этой области придется наиболее мощный сигнал, интенсивность сигнала будет спадать по мере удаления от центральной точки в любом направлении. Этот эффект обычно демонстрируется на примере модели, называемой следом спутника (satellite footprint), представленной на рис. 1.6. Показано, какая эффективная часть излученной энергии антенны попадает в каждую точку на территории США. Результат зависит от мощности сигнала, поступающего в принимающую антенну, а также от направленности передающей антенны. В рассматриваемом примере мощность сигнала, принимаемого в Арканзасе, составляет +36 дБВт, а в Массачусетсе — +32 дБВт. Чтобы получить реальную мощность сигнала, принимаемого в каждой точке покрываемой области, из эффективной мощности, указанной на рисунке, следует вычесть потери в свободном пространстве.

Атмосферное поглощение

Главной причиной затухания сигнала в атмосфере является наличие кислорода, от которого, конечно же, никуда не деться, а также влаги. Поглощение, обусловленное наличием воды, происходит в туман и в дождь. Еще одним фактором, влияющим на затухание сигнала, является значение угла возвышения спутника, который зависит от положения наземной станции (угол 9 на рис. 1.1). Чем меньше угол возвышения, тем больший путь в атмосфере придется пройти сигналу. Наконец, величина атмосферного затухания зависит от частоты сигнала. В общем случае чем выше частота сигнала, тем сильнее он затухает. На рис. 1.7 показана характерная величина затухания как функция угла возвышения для частот полосы С. Конечно затухание, обусловленное туманом и дождем, возникает только в случае присутствия этих явлений в атмосфере.

Рисунок 1.5 - Минимальные потери в свободном пространстве как функция высоты орбиты

Рисунок 1.6 - Типичный след спутника

Рисунок 1.7 - Затухание сигнала (полосы С), обусловленное атмосферным поглощением

Конфигурации спутниковой сети

На рис. 1.8 схематично изображены две наиболее распространенные конфигурации спутниковых систем связи. В первой конфигурации спутник используется для обеспечения двухточечной связи между двумя удаленными наземными антеннами. Во второй конфигурации спутник обеспечивает сообщение между одним наземным передатчиком и несколькими наземными приемниками.

Рисунок 1.8 - Конфигурации систем спутниковой связи

Существует также разновидность второй конфигурации, в которой осуществляется двухсторонняя связь между комплексом наземных станций, состоящим из одного центрального концентратора и множества удаленных абонентских Станций. Такой тип конфигурации, показанный на рис. 1.9, используется в системах VSAT (Very Small Aperture Terminal — терминал со сверхмалой апертурой луча). Недорогими антеннами VSAT оснащены многие абонентские станции. Установив определенный порядок, эти станции совместно используют пропускную способность спутника для передачи данных станции-концентратору. Концентра, тор может обмениваться сообщениями с любым абонентом и ретранслировать со. общения, идущие от одного абонента другому.

Рисунок 1.9 - Конфигурация типичной системы VSAT


Беспроводные сети. Современное состояние и перспективы развития. 9.2 РАСПРЕДЕЛЕНИЕ ПРОПУСКНОЙ СПОСОБНОСТИ - ЧАСТОТНОЕ РАЗДЕЛЕНИЕ

1.2 РАСПРЕДЕЛЕНИЕ ПРОПУСКНОЙ СПОСОБНОСТИ - ЧАСТОТНОЕ РАЗДЕЛЕНИЕ

Как правило, один геостационарный спутник работает в довольно широкой полосе частот (например, 500 МГц), которая делится на несколько каналов, имеющих меньшую ширину (например, по 40 МГц). В каждом из таких каналов требуется распределить пропускную способность. Иногда, например при телевещании или передаче единичного потока цифровых данных со скоростью 50 Мбит/с, весь канал выделяется для одного пользователя или приложения. В то же время если отбросить такие крайние случаи, то можно сказать, что экономное использование спутника невозможно без разделения канала между несколькими пользователями. Поэтому задача распределения, в основном, сводится к уплотнению каналов. В некоторых случаях распределение проводится под централизованным управлением, осуществляемым обычно со спутника. Пропускная способность может также распределяться динамически посредством команд, передаваемых наземными станциями. Ниже на примерах рассмотрены оба случая.

Все стратегии распределения относятся к одной из трех категорий.

• Множественный доступ с частотным разделением (Frequency Division Multiple Access — FDMA).

• Множественный доступ с временным разделением (Time Division Multiple Access — TDMA).

• Множественный доступ с кодовым разделением (Code-Division Multiple Ас-• cess — CDMA).

В этом и следующих разделах мы изучим схемы FDMA и ТОМА.

Уплотнение с частотным разделением (FDM)

Как уже упоминалось, полная пропускная способность спутника связи делится на несколько каналов. Это верхний уровень уплотнения, далее пропускная способность распределяется внутри каждого канала. На рис. 1.10 приведен пример схемы уплотнения с частотным разделением (FDM), типичной для геостационарных спутников связи. Эта схема используется в спутниках Galaxy корпорации PanAmSat3. Используемые спутником частоты принадлежат полосе С, ширина полосы спутника равна 500 МГц и разбита на 24 канала по 40 Мгц. Втиснуть 24 канала в полосу шириной 500 Мгц удается посредством многократного использования частоты: каждая из выделяемых частот используется двумя несущими, поляризации которых ортогональны. В каждый канал шириной 40 МГц входит защитная полоса, составляющая 4 МГц, так что реальная ширина каждого канала равна 36 МГц. При использовании двухточечной конфигурации (рис. 1.8, а) каждый канал можно применять для различных альтернативных целей. Например:

• 1200 каналов речевого диапазона (VF); ft один поток данных со скоростью 50 Мбит/с;

• 16 каналов со скоростью 1,544 Мбит/с в каждом;

• 400 каналов со скоростью 64 Кбит/с в каждом;

• 600 каналов со скоростью 40 Кбит/с в каждом;

• один аналоговый видеосигнал;

• от шести до девяти цифровых видеосигналов.

Ширина полосы для аналогового видеосигнала может показаться слишком Выпой. Рассчитаем ее, используя правило Карсона. Ширина полосы видеосигнала, сопровождаемого аудиосигналом, приблизительно равна 6,8 МГц. Затем суммарный сигнал посредством частотной модуляции (FM) переносится на несущую 6 ГГц. Максимальное отклонение частоты сигнала при использовании этой процедуры равно AF= 12,5 МГц. Определим ширину полосы передаваемого сигнала:

ВТ = 2ΔF + 2В = 2(12,5 + 6,8) = 38,6 МГц,

что приемлемо для транспондера на 36 МГц.

В цифровом видео использование сжатия может привести к тому, что скорость передачи данных в одном канале составит 3-5 Мбит/с, в зависимости от того, насколько видеоматериал насыщен движением.

Рисунок 1.10 - Типичный план распределения частот спутникового транспондера для нисходящих каналов связи (чтобы составить план для восходящих каналов связи, к приведенным на рисунке значениям следует прибавить 2225 МГц)

Множественный доступ с частотным разделением (FDMA)

В предыдущем разделе предполагалось, что спутник используется в качестве промежуточного устройства, обеспечивающего, по сути, двухточечную связь между двумя наземными станциями. Поскольку зона обслуживания спутника весьма велика, он может выполнять гораздо больше функций. Например, для серии спутников INTELSAT (INTELSAT (International Telecommunications Satellite Organization — Международная организация спутниковых телекоммуникаций) — это консорциум национальных поставщиков спутниковой связи, основанный согласно международному договору. INTELSAT занимается приобретением космических аппаратов, учитывая глобальный спрос на телефонные и телевизионные услуги. Действует консорциум как оптовый продавец, предоставляя участки космического пространства конечным пользователям, работающим на собственных наземных станциях. Представителем Соединенных Штатов в этом консорциуме является COMSAT. В настоящее время INTELSAT находится в процессе приватизации) канал шириной 36 МГц можно разделить, используя уплотнение с частотным разделением, на несколько меньших каналов, в каждом из которых можно использовать частотную модуляцию. Каждый из этих меньших каналов, в свою очередь, несет несколько сигналов речевого диапазона (VF), для чего используется уплотнение с частотным разделением. Возможность получения несколькими наземными станциями доступа к одному и тому же каналу называется схемой FDMA (frequency division multiple access — множественный доступ с частотным разделением).

Количество подканалов, на которые можно разбить спутниковый канал с помощью технологии FDMA, ограничено тремя факторами:

• тепловой шум;

• комбинационные помехи;

• перекрестные помехи.

Воздействие первых двух факторов прямо противоположно. Передаваемый сигнал очень малой интенсивности будет искажаться фоновым шумом. При очень большой интенсивности сигнала нелинейные эффекты, имеющие место в усилителях спутников, приведут к сильным комбинационным помехам. Перекрестные помехи происходят при попытках увеличить пропускную способность путем многократного использования частот. Перекрестные помехи ограничивают применение этой практики, однако не сводят ее на нет. Полосу частот можно многократно использовать в том случае, если имеются антенны, которые могут излучать два поляризованных сигнала одинаковой частоты с ортогональными поляризациями. Как и ранее, если интенсивность сигнала слишком высока, то становится значительной и интерференция.

Возможны две формы FDMA.

• Множественный доступ с фиксированным распределением (fixed-assignment multiple access — FAMA). Распределение пропускной способности спутникового канала между множеством станций производится заранее. В результате значительная часть пропускной способности не используется, t поскольку спрос на частоты может меняться в процессе связи.

• Множественный доступ с распределением по запросу (demand-assignment multiple access — DAM А). Распределение пропускной способности среди множества станций меняется с изменением спроса на частоты. Это позволяет оптимально распределить пропускную способность спутника.

FAMA-FDMA

На рис. 1.11 приведен частный пример схемы FAMA-FDMA, в которой семь наземных станций совместно используют восходящий канал связи с пропускной способностью 36 МГц. Станции А выделяется полоса частот шириной 5 МГц, от 6237,5 до •2,5 МГц, в которой можно разместить 60 голосовых каналов, используя уплотнение с разделением частот в сочетании с частотной модуляцией (FDM-FM). Т.е. FDM используется для разделения полосы на 60 каналов, а частотная модуляция — для модулирования каналов на несущей 6240 МГц. Как указано на рисунке, трафик от станции А к другим станциям выглядит следующим образом: 24 канала к станции B, 24 канала к станции D и 12 каналов к станции Е. Оставшийся спектр канала, общая ширина которого составляет 36 МГц, распределяется между другими наземными станциями в соответствии с их потребностью в трафике. В связи с этим примером следует отметить несколько поучительных моментов.

На схеме показаны элементы как технологии FAMA, так и технологии FDMA. Термин FAMA отражает тот факт, что между станциями наперед заданы логические связи. Поэтому на рис. 1.11 показано, что станция А имеет три прямые двухточечные связи — по одной со станциями В (24 канала), D (24 канала) и Е (12 каналов). Термин FDMA отражает тот факт, что множество станций имеют доступ к спутниковой связи, используя при этом разные полосы частот.

Рисунок 1.11 - Схема фиксированного распределения частот FDMA для спутниковой связи

Несмотря на то что наземная станция может передавать на спутник только одну несущую (например, станция А передает на частоте 6,24 ГГц в полосе шириной 5 МГц), она должна быть способна к приему по крайней мере по одной несущей от каждой удаленной станции, с которой она хочет поддерживать связь (к примеру, станция А должна принимать три несущие, которые являются частью передачи станций В, D и Е).

Спутник не выполняет функций коммутатора, хотя он принимает от различных источников отдельные участки канала шириной 36 МГц. На спутнике происходит только прием сигналов в пределах этого спектра, их преобразование в полосу, центрированную на частоте 4 ГГц, и повторная передача. Используемая полоса частот имеет довольно значительную ширину. Например, станция А должна передавать 60 голосовых каналов, которые занимают всего 240 кГц (т.е. один канал занимает 4 кГц), а выделена для этой станции полоса шириной 5 МГц. Такая широкая полоса требуется из-за использования частотной (а не амплитудной) модуляции, которая позволяет сохранить сигнал при передаче его на большие расстояния, а также минимизировать требования к мощности спутника.

DAMA-FDMA

Только что описанная схема FAMA-FDMA оказывается не очень эффективной. В полосе С используемая ширина каждого канала обычно равна 36 МГц. В одной схеме FDMA, используемой корпорацией INTELSAT, эта полоса поделена на 7 блоков по 5 МГц, каждый из которых несет группу из 60 голосовых каналов. Таким образом, их общее количество составляет 420. В рассмотренном примере (рис. 1.11) также присутствуют 420 голосовых каналов. Если полосу частот разделить на 14 подканалов шириной по 2,5 МГц, то в каждом подканале можно будет разместить 48 голосовых каналов, т.е. всего 336 каналов. Эффективнее всего оказывается избегать создания групп и просто делить полосу в 36 МГц на отдельные голосовые каналы. Эта схема известна как "один канал — одна несущая" (single channel per carrier — SCPC).

Схема SCPC в настоящее время реализована в полосе С. Один канал шириной 36 МГц разделяется на 800 аналоговых каналов по 45 кГц, каждый из которых выделяется для симплексного канала связи с использованием частотной модуляции. Существует также цифровой вариант схемы SCPC, в котором используется модуляция QPSK, дающая в той же полосе 45 кГц скорость передачи 54 Кбит/с; этого достаточно для передачи оцифрованной речи. С помощью технологии FAMA пары (полнодуплексных) каналов распределяются по парам наземных станций. Как правило, каналы каждой наземной станции приходится дополнительно уплотнять, поскольку она обслуживает некоторое количество пользовательских станций. Если каждая наземная станция работает с большим числом пользовательских станций, то даже при использовании технологии FAMA достигается высокая степень связности. Тогда, как и в обычной схеме FDMA, спутник принимает частоты в пределах канала шириной всего 36 МГц, транслирует их в полосу, центрированную на частоте 4 ГГц, и передает канал всем станциям.

Технология SCPC привлекательна для удаленных областей, в которых находится хотя бы несколько пользовательских станций. Если FDMA используется качестве основного средства в системах связи на большие расстояния, SCPC доставляет услуги напрямую конечному пользователю. Хотя в схеме SCPC ширина полосы используется более эффективно, чем в FDMA, эта технология имеет все недостатки фиксированного распределения. Она оказывается особенно удобной для слишком удаленных областей, в которых наземная станция часто суживает всего одну или две пользовательские станции. Повысить эффективность позволяет использование схемы DAMA, согласно которой в канале выделяется набор подканалов, рассматриваемый в качестве резерва связи. Если требуется установить полнодуплексную связь между двумя наземными станциями, резерва выделяется пара подканалов.

Первой доступной для коммерческих целей системой DAMA SCPC была SPADE (single-channel-per-carrier, pulse code modulation, multiple-access demand ssignment equipment — оборудование импульсно-кодовой модуляции с множественным доступом с распределением запросов по требованию и одноканальным пользованием несущей), введенная в действие в начале 70-х и в настоящее время доступная через спутники INTELSAT. Каждый подканал этой системы несет QPSK-модулированный сигнал со скоростью 64 Кбит/с, что занимает полосу 38 кГц, а также защитную полосу 7 кГц. Как правило, этот сигнал используется для передачи голосового сигнала с импульсно-кодовой модуляцией. Вместе со служебными подканалами, которые будут рассмотрены ниже, общее количество доступных подканалов достигает 794 (рис. 1.12, а). Эти подканалы разбиты на пары таким образом, чтобы два канала, отстоящие друг от друга на 18,045 МГц, всегда создавали полнодуплексный контур связи (например, каналы с номерами 3 и 404, 4 и 405, 399 и 800). Кроме того, имеется общий канал передачи сигналов (common-signaling channel — CSC) шириной 160 кГц, по которому передается сигнал PSK со скоростью 128 Кбит/с.

Рисунок 1.12 - Система спутниковой связи SPADE для коммутируемой службы SCPC

Выделение каналов по требованию осуществляется наземной станцией с помощью канала CSC. Канал CSC используется для передачи повторяющихся кадров TDM, как показано на рис. 1.12, в. Кадр разделен на 50 интервалов, первый из которых содержит начальную последовательность битов, требуемую для синхронизации. Остальные интервалы закреплены за 49 станциями. Эти станции имеют привилегию при формировании полнодуплексных контуров по требованию. Распределение по требованию осуществляется следующим образом. Предположим, что станция Si желает установить канал связи со станцией Sj. Si случайным образом выбирает подканал из доступных незанятых каналов и передает идентификатор подканала и адрес станции Sj во временной интервал станции Si . Примерно через 0,25 с станция Sj получит запрос по нисходящему каналу связи. Если предположить, что подканал остался доступным и что доступна станция Sj, то она передаст подтверждение в свой собственный временной интервал, который станция Si , получит еще через четверть секунды. Когда сеанс связи завершится, во временном интервале одной из станций будет передана информация о разъединении, чтобы уведомить другие станции о том, что подканал снова свободен.

Так как в описанной схеме могут участвовать только 49 станций, для распределения по требованию большинство подканалов не нужны и используются по обычной схеме FAMA SCPC.


Беспроводные сети. Современное состояние и перспективы развития. 9.3 РАСПРЕДЕЛЕНИЕ ПРОПУСКНОЙ СПОСОБНОСТИ - ВРЕМЕННОЙ РАЗДЕЛЕНИЕ

1.3 РАСПРЕДЕЛЕНИЕ ПРОПУСКНОЙ СПОСОБНОСТИ - ВРЕМЕННОЙ РАЗДЕЛЕНИЕ

Хотя уплотнение с частотным разделением до сих пор широко используется в спутниковой связи, все большую популярность приобретают схемы уплотнения с временньш разделением. Перечислим причины, по которым это происходит.

• Непрерывное падение стоимости цифровых составляющих.

• Преимущества цифровых методов обработки, включая возможность исправления ошибок.

• Повышенная эффективность схем TDM, которая обусловлена отсутствием комбинационных помех.

Как и при частотном разделении, все схемы временного разделения обеспечивают множественный доступ и включают схемы FAMA-TDMA и DAMA-TDMA. Метод FAMA-TDMA, по сути, не отличается от синхронного временного разделения. Передача осуществляется в форме повторяющейся последовательности кадров, каждый из которых делится на несколько временных интервалов. Каждое положение интервала в последовательности кадров соответствует определенному передатчику. Периоды кадров лежат в диапазоне от 10 мкс до более чем 2 мс и состоят из 3-100 интервалов и более. Скорость передачи данных составляет от 10 Мбит/с до более чем 100 Мбит/с.

Типичный формат кадра показан на рис. 1.13. Как правило, кадр начинается с двух опорных пакетов, определяющих начало кадра. Эти два пакета предоставляются двумя разными наземными станциями, так что «стема может продолжать функционировать даже при потере связи с одной из шорных станций вследствие неисправности. Каждый опорный пакет начинается с последовательности для восстановления тактовой синхронизации и несущей, являющейся уникальной и позволяющей синхронизироваться с центральным тактовым генератором. Каждой из N станций выделяется один или несколько интервалов в кадре. Станция использует выделенный ей интервал для передачи пакета данных, состоящего из предварительной последовательности и пользовательской информации. Предварительная последовательность содержит управляющую информацию и информацию о синхронизации плюс данные, идентифицирующие станцию назначения. Отдельные пакеты разделены защитными интервалами, предотвращающими наложение данных.

Рисунок 1.13 - Пример формата кадра TDMA

На рис. 1.14 показан принцип действия систем FAMA-TDMA. Отдельные наземные станции по очереди используют восходящий канал связи и могут помещать пакеты данных в выделенные для них временные интервалы. Спутник ретранслирует входящие данные всем станциям. Таким образом, передача и прием информации каждой станцией осуществляется в определенный временной интервал. Спутник также повторяет опорные пакеты данных, поэтому все станции, принимающие эти пакеты, имеют возможность синхронизировать свою работу.

Каждый из повторяющихся временных интервалов является каналом и не зависит от других каналов. Поэтому его можно использовать любым способом, по выбору передающей станции. Можно, например, организовать коммутацию, включив в каждый временной интервал поле адреса. Тогда, хотя временные интервалы и останутся закрепленными за станциями, в каждом нисходящем интервале несколько станций смогут ожидать данные, адресованные именно им. С помощью еще одной схемы передающая наземная станция может разделить свой временной интервал на подынтервалы и, таким образом, отправлять данные по нескольким подканалам в одном канале TDMA.

Рисунок 1.14 - Функционирование системы FAMA-TDMA

Обычная схема TDMA эффективнее традиционной схемы FDMA, так как на защитные интервалы и управляющие биты TDMA расходуется меньшая пропускная способность, чем на защитные полосы FDMA. Это проиллюстрировано на рис. 1.15. Обратите внимание на впечатляющее падение пропускной способности для FDMA по мepe увеличения числа каналов. В случае использования схемы TDMA при увеличении числа временных интервалов (тех же каналов) пропускная способность уменьшается гораздо медленнее. Кроме того, при использовании более длинных кадров также увеличивается эффективность связи. Для сравнения, система SCPC обеспечивает постоянную пропускную способность в 800 каналов, независимо от того, поделена ее полоса частот между множеством станций или между всего несколькими наземными станциями.

Рисунок 1.15 - Относительная эффективность различных спутниковых схем распределения пропускной способности

В полосах с более высокой частотой (Ки и К) можно достичь даже большей эффективности. При таких частотах лучи, передаваемые со спутника, можно довольно точно сфокусировать, что позволит передавать много лучей одной и той же частоты в разные зоны. Таким образом, спутник сможет обслуживать довольно много зон, в каждой из которых может находиться много наземных станций. Сообщение между этими станциями в пределах одной зоны осуществляется по обычной схеме FAMA-TDMA. Более того, можно организовать сообщение между станциями, принадлежащими различным областям, если спутник имеет возможность переключать временные интервалы с одного луча на другой. Этот метод известен как TDMA со спутниковой коммутацией (satellite-switched TDMA — SS/TDMA).

На рис. 1.16 показана простая система SS/TDMA, обслуживающая две зоны, в каждой из которых расположено по две станции. Как и в обычной схеме TDMA, в пределах одной зоны в каждый момент времени передавать может столько одна станция. Таким образом, в пределах зоны А в любой конкретный временной интервал может передавать либо станция 1, либо станция 2. Так же и в пределах зоны В передавать в данный момент времени может либо станция 3, либо станция 4. Сигналы со станций из разных зон не интерферируют, благодаря использованию по-разному поляризованных сигналов либо использованию разных частот. На спутнике принимаемые данные тут же ретранслируются на частоте нисходящего канала связи. При этом используются два различных нисходящих луча. На спутнике имеется коммутатор для соединения входящих и выходящих лучей. Варианты соединений, выполняемых коммутатором, могут меняться со временем. На рисунке нисходящий луч А повторяет восходящий луч А в течение периодов 1 и 3 и повторяет восходящий луч В течение периода 2. Таким образом, любая станция в любой зоне может отправлять данные любой другой станции.

Для спутника, обслуживающего N зон, существует N входящих потоков TDM. В любой конкретный момент времени переключатель настроен на особый вид преобразования этих восходящих лучей в N нисходящих лучей. Каждая конфигурация называется режимом, и для полной связности системы требуется N! различных режимов. В табл. 1.2 приведены режимы для системы с тремя лучами. Например, станции в зоне А могут сообщаться друг с другом в режимах 1 и 2, сообщаться со станциями зоны В режимах 3 и 5 и т.д. Спутник периодически меняет режим. Скорее всего, смена режимов будет происходить один раз за интервал. Структуру режима и его длительность обычно можно настраивать командами с Земли, чтобы вовремя реагировать на изменившиеся требования.

Таблица 1.2 Режимы системы SS/TDMA (три луча)

Выход
Вход | Режим 1 | Режим 2 | Режим 3 | Режим 4 | Режим 5 | Режим 6
A | A | A | B | C | B | C
B | B | B | C | A | C | B
C | C | C | A | B | A | A

Наконец, со спутниковыми схемами TDMA используются методы DAMA. Система SS/TDMA является в определенном смысле системой DAMA, если структура режима может быть изменена командой с Земли. Довольно часто, если речь заходит о временном разделении, схему DAMA называют схемой множественного доступа с совместным использованием одного канала. Такие методы обычно служат основой для кооперации наземных станций с целью совместного использования канала.

Рисунок 1.16 - Функционирование системы SS/TDMA


Беспроводные сети. Современное состояние и перспективы развития. 11.1 БЕСШНУРОВЫЕ СИСТЕМЫ

В этой главе рассмотрены две технологии, позволяющие оборудовать беспроводными системами жилые дома и учреждения: бесшнуровые системы и беспроводные абонентские линии связи (wireless local loop — WLL).

3.1 БЕСШНУРОВЫЕ СИСТЕМЫ

Стандартизованные бесшнуровые системы основаны на технологии беспроводного телеграфа. Первоначально радиотелефоны разрабатывались для предоставления пользователям свободы передвижения в пределах их жилья или небольшого учреждения. Все началось с отделения телефонной трубки от остальной части телефона (именуемой базовой станцией, или базой) и установления простого беспроводного аналогового канала связи. По мере совершенствования технологии были разработаны и цифровые радиотелефоны. Разные устройства имели разные беспроводные интерфейсы. Впрочем, поскольку производители продавали и базу и телефонную трубку как одно устройство, стандарты вводить не требовалось.

Организации по стандартизации заинтересовались бесшнуровыми технологиями, когда встал вопрос о расширении диапазона их применения, причем в двух направлениях. Во-первых, в бесшнуровых системах одна базовая станция может обслуживать нескольких пользователей и взаимодействовать не только с несколькими телефонными трубками, но и с устройствами обработки речи и данных (например, факсом или принтером). Во-вторых, бесшнуровые системы можно использовать в различных средах.

• По месту жительства. Установленная в жилом доме базовая станция может обеспечивать передачу речи и данных, что предоставит пользователю не только местную связь, но и связь с общественной телефонной сетью.

• Учреждения. Одна базовая станция может поддерживать связь в пределах небольшого учреждения, обслуживая при этом несколько телефонных трубок и устройств обработки данных. В более крупном учреждении несколько базовых станций можно объединить в некое подобие сотовой конфигурации, подсоединив при этом все базовые станции к коммутатору РВХ (private branch exchange — телефонная сеть частного использования). Такая конфигурация может обслуживать сотни и даже тысячи пользователей.

• Телеточки. Телеточкой называется размещение базовой станции в общественном месте, например в торговом пассаже или в аэропорту. Впрочем, этот вид услуг не пользуется успехом на рынке.

В стандартах бесшнуровных систем должны учитываться множество технических моментов. Перечислим некоторые из них.

1. Радиус удаления телефонной трубки от базовой станции является небольшим, до 200 м, поэтому используются устройства малой мощности. Как правило, выходная мощность бесшнуровой системы должна быть на два-три порядка ниже мощности сотовых систем.

2. Телефонная трубка и базовая станция должны быть недорогими. Поэтому в таких областях, как кодирование речи и выравнивание каналов, следует использовать простые технические решения.

3. Большой выбор частот будет доступен не всегда, поскольку пользователи являются владельцами как базовой станции, так и мобильной части телефона и могут устанавливать свои телефоны где угодно. Следовательно, где бы ни использовалась система, она должна уметь отыскивать канал с наименьшей интерференцией.

Для бесшнуровых систем было предложено много разных стандартов, самым известным из которых является разработанный в Европе стандарт DECT (Digital Enhanced Cordless Telecommunications — цифровые расширенные беспроводные телекоммуникации)1. Эквивалент этого стандарта, разработанный в США, известен как PWT (personal wireless communications — персональные беспроводные коммуникации). В табл. 3.1 приведены некоторые ключевые параметры стандартов DECT и PWT. В этих системах используется схема, известная как дуплекс с временным разделением (time division duplex — TDD). Поэтому сначала в общих чертах будет рассмотрена схема TDD, а затем мы перейдем к подробностям стандарта DECT.

Таблица 3.1 Параметры систем DECT и PWT

 | DECT | PWT
Ширина полосы частот | 20 МГц | 20 МГц
Полоса частот | от 1,88 до 1,9 ГГц | от 1,91 до 1,92 ГГц
Схема доступа | TDD/TDMA/FDMA | TDD/TDMA/FDMA
Ширина несущей полосы частот | 1,728 МГц | 1,25 МГц
Количество несущих | 10 | 8
Количество каналов на одну несущую | 12 | 12
Общее количество каналов | 120 | 120
Переключение | Возможно | Возможно
Скорость передачи данных | 1,152 Мбит/с | 1,152 Мбит/с
Скорость передачи речи | 32 Кбит/с | 32 Кбит/с
Схема кодирования речи | ADPCM | ADPCM
Схема модуляции | Гауссова FSK | π/4 DQPSK
Максимальная выходная мощность | 250 мВт | 90 мВт
Средняя выходная мощность | 10 мВт | 10 мВт
Максимальный радиус ячейки | 30-100 м | 30-100 м

Дуплекс с временным разделением

В схеме TDD, известной также как уплотнение с временным сжатием (time-compression multiplexing — ТСМ), в любой момент времени передача данных ведется только в одном направлении, а направления передачи чередуются. Ниже последовательно рассматриваются схема TDD и TDD - TDMA.

Простая схема TDD

Чтобы с помощью обычной схемы TDD получить необходимую абоненту скорость передачи данных поток битов сначала разделяется передатчиком на равные сегменты, которые сжимаются во времени до более высоких скоростей передачи данных и передаются в форме пакетов, а принимающая сторона затем восстанавливает исходную скорость передачи данных. Между передачей пакетов в противоположных направлениях имеется короткий перерыв,. нужный для установления канала связи. Таким образом, реальная скорость передачи данных в канале должна быть более чем в два раза выше, чем скорость передачи данных, требуемая двумя конечными системами.

Рисунок 3.1 - Передача данных с помощью дуплекса с временным разделением

На рис. 3.1 показана хронологическая схема передачи. Право передачи данных периодически переходит от одной стороны к другой. При этом каждая сторона отправляет блоки некоторой фиксированной длины, передача которых занимает время Тb (линейная функция числа битов в блоке). Для распространения сигнала от передатчика к приемнику требуется время Тр (линейная функция расстояния между передатчиком и приемником). Наконец, для обращения канала введено защитное время Ts. Таким образом, время, требуемое для отправки одного блока, равно (Тр + Тb + Tg). Кроме того, поскольку две стороны должны передавать данные по очереди, скорость передачи блоков любой стороной можно записать как 1/2(Тр + Тb+ Tg). Эту величину можно связать с эффективной скоростью передачи данных, R, с которой ведут свои передачи обе стороны. Пусть размер блока равен В бит, а требуемое значение скорости передачи равно R бит/с. Тогда эффективное число битов, передаваемых в секунду, будет

R = B/2(Тр + Тb + Tg).

Реальную скорость передачи данных в среде, А, легко записать как

А = В/Тb.

Из двух последних формул получаем

Таким образом, реальная скорость передачи данных по каналу связи более чем вдвое превышает эффективную скорость передачи, которую наблюдают сообщающиеся стороны. Выбор размера блока, В, диктуется противоречивыми требованиями к системе. По мере увеличения значения В снижается реальная скорость передачи данных, А. В этом случае упрощается реализация системы. С другой стороны, повышение размеров блока сопровождается увеличением времени задержки из-за необходимости буферизации, что нежелательно при передаче речи.

Пример. Среди стандартных интерфейсов, определенных для сетей ISDN (Integrated Services Digital Network — цифровая сеть с интеграцией услуг), есть базовый интерфейс, обеспечивающий скорость 192 Кбит/с при передаче 48-битовых кадров. Пусть используется технология TDD и размер блока равен длине кадра. Предположим, что расстояние между абонентом и коммутатором сети равно 1 км, а защитный интервал равен 10 мкс. Какова реальная скорость передачи данных?

I Время передачи пакета — (48 бит)/(192 Кбит/с) = 250 мкс. Задержка распространения — (1 км)/(3 х 108 м/с) = 3,33 мкс. Таким образом, получаем

А = 2 х 192 х [1 + (3,33 +10)/250] = 404 Кбит/с.

TDD - TDMA

Схема TDD первоначально предназначалась для проводных абонентских систем, однако в настоящее время она нашла применение и в системах с беспроводной конфигурацией. В беспроводной системе TDD позволяет передавать и принимать сигналы на одной и той же несущей частоте, но в разные моменты времени. Беспроводная схема TDD, как правило, используется в сочетании с технологией TDMA, в которой несколько абонентов могут по очереди принимать сигналы в прямом канале (от базовой станции к трубке) и затем передавать сигналы в обратном канале (от трубки к базовой станции) по очереди, используя при этом одну и ту же несущую частоту.

Использование дуплекса с временным разделением имеет два важных преимущества перед использованием системы TDMA с двумя разными несущими частотами, по одной на каждое направление. Первым преимуществом является возможность устранения быстрого замирания, а вторым — улучшенное распределение пропускной способности.

Что касается быстрого замирания, то его эффект меняется с изменением частоты2. Поэтому связь с мобильным пользователем, принимающим на одной частоте, а передающим на другой, может ухудшаться только в одном направлении. Одним из способов преодоления быстрого замирания является пространственное разнесение антенн. В такой схеме приемник использует две антенны, расстояние между которыми не меньше длины волны. При такой конфигурации довольно велика вероятность того, что при сильном замирании сигнала от одной из антенн сигнал от другой антенны будет распространяться нормально. В этом случае приемник сможет выбрать для демодуляции более сильный из поступающих сигналов. Такой метод подходит для крупной базовой станции, однако непрактичен для маленьких, недорогих. Более того, желательно избегать использования сложных алгоритмов выравнивания или прямой защиты от ошибок. Впрочем, в схеме TDD все же можно использовать пространственное разнесение антенн. Для приема каждого пакета, прибывающего на базовую станцию по прямому каналу связи, базовая станция выбирает ту антенну, сигнал которой сильнее. Затем базовая станция использует ту же антенну для последующей передачи в соответствующем прямом канале. Ввиду того что для обоих направлений используется одна и та же частота, эта антенна должна давать самый сильный сигнал и в обратном направлении, к трубке.

Второе преимущество схемы TDD - TDMA перед схемой FDMA - TDMA проявляется в механизме распределения пропускной способности. Для многих приложений, ориентированных на работу с данными (в отличие от приложений, предназначенных для работы с речью), наибольший объем нагрузки приходится, как правило, на прямое направление, а не на обратное. При использовании обычной схемы FDMA с предоставлением прямому и обратному каналам полос частот одинаковой ширины, системы проектируются с учетом нагрузки в прямом канале, так что большая часть полосы обратного канала обычно не используется. Если же использовать схему TDD, то контроллер системы динамически распределяет слоты TDMA в каждом направлении, так что при необходимости прямому каналу может предоставляться большее число слотов.

Формат кадра DECT

При объяснении стандарта DECT лучше всего начинать с формата кадра TDD - TDMA, схема которого показана на рис. 3.2. Один кадр занимает 10 мс и состоит из 24 временных интервалов (слотов) TDMA. По умолчанию первые 12 слотов определяют 12 логических каналов, по которым осуществляется передача данных от базовой станции к трубке (прямое направление), а оставшиеся 12 определяют 12 логических каналов для передачи от трубки к базовой станции (обратное направление). Таким образом, на одной несущей поддерживаются 12 полнодуплексных логических каналов. Направления передачи чередуются, сначала идут 12 слотов в прямом направлении, за которыми следуют 12 слотов в обратном направлении.

Каждый слот имеет длину 10/24 = 0,417 мс и всего вмещает 480 бит, распределенных по 6 полям. Таким образом, скорость передачи данных составляет 480/0,417 = 1,152 Мбит/с. Перечислим названные шесть полей.

• Предварительная последовательность (16 бит). Предупреждает приемник о поступлении информации.

• Синхронизация (16 бит). Позволяет синхронизировать прием, предоставляя в качестве точки отсчета начало временного интервала.

• Поле А (64 бит). Используется для управления сетью.

• Поле В (320 бит). Содержит пользовательские данные.

• Поле X (4 бит). Состоит из четырех битов контроля четности, которые позволяют терминалам и базовой станции проверять качество передачи сигнала.

• Защитное поле (60 бит). Представляет собой защитный интервал длиной 52 мкс, соответствующий интервалу Tg на рис. 3.1.

Рисунок 3.2 - Форматы DECT

Поле А

Поле А, которое служит для передачи управляющей информации, состоит из трех подполей.

• Заголовок (8 бит). Указывается тип информации, передаваемой в полях А и В.

• Данные (40 бит). Здесь находится сообщение управления сетью.

• CRC (16 бит). 16-битовый код обнаружения ошибок в заголовке и данных.

В поле А уплотняются пять логических каналов управления, обозначаемых С, М, N, Р и Q (см. табл. 3.2). Первые три бита заголовка определяют тип информации, содержащейся в 40-битовом поле данных. Биты Q1 и Q2 образуют сигнальный канал, предоставляющий информацию о качестве сигнала на устройстве с другой стороны.

Таблица 3.2 Логические каналы DECT

Канал | Скорость передачи данных, Кбит/с |  | Назначение
 | Передача от базы | Передача от терминала
IN | 2 | 2 | Незащищенная пользовательская информация (телефон)
IP | Переменная | Переменная | Защищенная пользовательская информация (данные)
C | 0-2 | 0-2 | Управление соединением
M | 0-2 | 0-2 | Управление физическим уровнем
N | 0,25-3,75 | 2-4 | Квитирование
P | 0-1,5 | 0 | Избирательное обращение
Q | 0,25 | 0 | Системная информация

Канал Q используется для широковещательной передачи общей системной информации от базовой станции всем терминалам. Информация канала Q содержится в одном кадре 16-кадрового мультикадра. Поэтому скорость передачи битов в канале Q составляет 40 бит за 160 мс, или 250 бит/с. Канал Р обеспечивает передачу сообщений от базовой станции к некоторым терминалам. Так же, как и в сотовой системе, избирательное сообщение служит для извещения определенного пользователя о входящем звонке. Канал Р может занимать до 6 кадров мультикадра, что дает максимальную скорость передачи 1,5 Кбит/с. В ответ на избирательное сообщение или во время переключения терминалы используют двусторонний канал М, служащий для обмена с базовой станцией сообщениями, касающимися управления доступом к среде. Эти сообщения позволяют координировать распределение нагрузки и переключение в канале. Для сообщений канала М могут использоваться до 8 кадров мультикадра в каждом направлении, или половина пропускной способности поля А. Если соединение уже установлено, канал N предоставляет протокол квитирования. Базовая станция передает идентификационный код в прямом канале, а терминалы отражают этот код в соответствующих обратных N-каналах. Это позволяет обеим сторонам обнаруживать сильные сигналы, прибывающие из интерферирующих источников по одному и тому же физическому каналу. Канал N использует от 1 до 15 из 16 кадров в прямом мультикадре, в зависимости от потребностей каналов М, С и Р. В обратном направлении канал N занимает от 8 до 16 кадров каждого мультикадра, в зависимости от потребностей каналов М и С. Наконец, канал С предоставляет возможность управления активным соединением и может занимать до 8 кадров мультикадра в каждом направлении.

Поле В

Данные в поле В передаются в одном из двух режимов. Незащищенный режим используется для передачи оцифрованной речи. Скорость передачи данных в каждом канале каждого направления равна примерно 320 бит за 10 мс (32 Кбит/с). Следовательно, можно использовать только такую схему кодирования речи, которая соответствует скорости 32 Кбит/с (см. последующее обсуждение).

В защищенном режиме передаются неголосовые данные. В этом случае поле В разбито на четыре блока по 64 бит, причем каждый блок защищен 16-битовым полем CRC. Отметим, что коррекция ошибок не производится, выполняется только их обнаружение. Восстановление данных, в которых обнаружены ошибки, происходит на более высоком уровне с использованием протокола ARQ (см. раздел 8.4). В защищенном режиме достигается скорость передачи данных до 25,6 Кбит/с для канала, который занимает один слот кадра. Схема DECT позволяет динамически распределять слоты между логическими каналами в обоих направлениях, так что указанная величина — это базовая скорость передачи данных.

Работа схемы DECT

На рис. 3.3 показана архитектура протокола, который поддерживает операции DECT. На физическом уровне данные передаются в кадрах TDD - TDMA (см. рис. 3.2) на одной из 10 несущих радиочастот. Схема модуляции — гауссова FSK с номинальным отклонением 288 кГц. По сути, это та же схема GMSK, что используется в системе GSM. Скорость передачи данных и ширина полосы частот относятся друг к другу как 2:1, скорость передачи данных — 1,152 Мбит/с.

Рисунок 3.3 - Архитектура протоколов DECT

На уровне управления доступом к среде (MAC) осуществляется выбор физических каналов и устанавливается или освобождается соединение в этих каналах. Кроме того, на этом уровне информация уплотняется в формат кадров TDD - TDMA. На уровне MAC предоставляются три типа услуг.

• Широковещание. Передача широковещательных сообщений в поле А.

• Услуги с установлением соединения. Передача пользовательских данных в поле В.

• Услуги без установления соединения. Поддержка отдельных сообщений DECT, отправляемых в поле А.

Уровень управления каналом передачи данных обеспечивает надежную передачу сообщений с помощью традиционных процедур управления каналом передачи данных, включая обнаружение ошибок и автоматический запрос повторной передачи.

Выше уровня управления каналом передачи данных предлагается такой набор услуг.

• Управление вызовами. Управление звонками с коммутацией каналов, включая установление и освобождение соединения.

• Дополнительные услуги. Услуги, для предоставления которых не нужны звонки.

• Службы сообщений без установления соединения. Поддержка передачи сообщений без установления соединения. Длинные сообщения на время передачи разбиваются на блоки.

• Службы сообщений с установлением соединения. Поддержка передачи сообщений с установлением соединения.

• Управление мобильностью. Функции, необходимые для конфиденциального предоставления услуг DECT. Управление мобильностью разделено на семь групп услуг.

• Процедура идентификации. Используется для распознавания базовой станцией мобильного устройства.

• Процедура аутентификации. Определяется, является ли мобильное устройство легальным пользователем.

• Процедура определения местонахождения. Используется в системах, в которых местоположение мобильного устройства отслеживается несколькими базовыми станциями.

• Процедура предоставления прав доступа. Мобильному устройству предоставляется право доступа к локальной или глобальной сети определенного типа.

• Процедура назначения ключа. Распределяются ключи шифрования для защиты сетевой управляющей информации, а также пользовательской информации.

• Процедура запроса параметров. Используется для обмена информацией о мобильном устройстве и функционировании сети.

• Процедура шифрования данных. Операции шифрования и дешифрования.

Адаптивная дифференциальная импульсно-кодовая модуляция

Для оцифровки речи в схеме DECT используется процедура ADPCM (adaptive differential pulse code modulation — адаптивная дифференциальная импульсно-кодовая модуляция). Эта процедура была стандартизована ITU-T и используется во многих приложениях, включая цифровые сети с коммутацией каналов, такие, как ISDN, и при реализации многих беспроводных абонентских линий связи. Далее будут рассмотрены принципы, лежащие в основе модуляции, будет описана более простая дифференциальная схема PCM (DPCM) и, наконец, рассмотрена собственно схема ADPCM.

Дифференциальное квантование

Дифференциальное квантование основано на принципе, согласно которому речевые сигналы незначительно изменяются от выборки к выборке. При обычной импульсно-кодовой модуляции квантованные значения смежных выборок будут, в общем случае, близки друг к другу, поэтому передаваемые модулированные значения будут содержать много избыточной информации. Следовательно, имеет смысл передавать только значение разности двух смежных выборок, а не их абсолютные значения, тогда для передачи одной выборки потребуется меньшее число битов (см. рис. 3.4). Если значение k-й выборки равно m(k), то передается лишь разница d(k) = m(k) - m(k - 1). Тогда если приемник будет располагать точным начальным значением, то по последовательности разностей d(k) будет восстановлена последовательность абсолютных значений выборок m(k).

Рисунок 3.4 - Обычное и дифференциальное квантование

В то же время, если передавать только значения разностей между текущими и непосредственно предшествующими им выборками (для чего потребуется меньшее число битов), существует опасность постепенного нарастания отклонения выходных данных приемника от истинных значений. Если значение разности двух выборок превысит значение, которое можно представить с помощью передаваемых битов, приемник не сможет правильно воспроизвести входные данные и не сможет впоследствии исправить ошибку. Для решения этой проблемы передатчик должен не только передавать значения разностей, но также дублировать декодирующую функцию, которая будет использоваться приемником. Тогда кодер будет выдавать разность между текущей выборкой и той выборкой, которая, по сведениям кодера, подучена на приемнике при предыдущей передаче. В результате кодер будет инструктировать декодер, как вносить изменения в уже полученные выходные данные и таким образом автоматически производить коррекцию.

Дифференциальная РСМ

Описанная выше схема основана на предположении о том, что значения разностей будут меньшими, чем абсолютные значения выборок. Еще большую выгоду можно извлечь, если предположить, что голосовые сигналы изменяются относительно медленно, поэтому можно довольно точно оценить или предсказать значение k-й выборки m(k) на основе значений предыдущих выборок. Для оценки k-й выборки, m'(k) , нужно будет передать разность d(k) — m(k) - m'(k) . Если использовать достаточно точную оценочную функцию, то эта разность будет меньше разности значений двух последовательных выборок. На приемнике, где используется та же оценочная функция, входящее значение разности будет добавлено к оценке предыдущей выборки и таким образом будет оценена текущая выборка. Этот принцип положен в основу дифференциальной импульсно-кодовой модуляции (DPCM). Отметим, что простая разностная схема, описанная в предыдущем параграфе, является всего лишь частным случаем DPCM, в котором для оценки выбрана функция m'(k) = m(k - 1).

На рис. 3.15, а показана блок-схема передатчика. Чтобы понять, что представляет собой эта диаграмма, рассмотрим подробно все ее составляющие. На вход передатчика подается голосовой сигнал g(r). Сначала из сигнала извлекается аналоговая выборка m(k), представляющая собой выборку амплитудно-импульсной модуляции (РАМ). Уже на этом этапе начинаются трудности. Казалось бы, ничто не мешает построить оценочное значение m'(k) , найти разность и передать значение этой разности. Однако принимающая сторона вместо предыдущих аналоговых выборок m(k - 1), m(k - 2) и т.д., которые находились на передатчике, будет располагать последовательностью квантованных разностей, на основе которых можно воссоздать только квантованную выборку mq(k). Поэтому на приемнике воссоздать m'(k) не удастся, а можно будет, основываясь на значениях предыдущих квантованных выборок mq(k - 1), mq(k - 2) и т.д., определить только m'q(k) , оценку квантованной выборки mq(k). Если передатчик будет основывать предсказания на значениях m(k), а приемник — на значениях mq(k), то выборка на приемнике будет восстановлена неправильно. Передатчик должен, как и приемник, определять значения mq(k) и передавать разность d(k) = m(k) - m'q(k) . Тогда приемник на основе полученных разностей d(k) сможет правильно восстановить выборку mq(k).

Рисунок 3.5 - Передатчик и приемник DPCM

Осталось только показать, что схема, изображенная на рис. 3.5, а, воспроизводит нужные значения квантованных разностей. На выходе предсказателя определяется значение mq(k) , которое является предсказанным значением выборки m(k). Затем берется разность

d(k) = m(k)-m'q(k).

Далее, полученная разность квантуется, чтобы получить значение квантованной разности dq(k), которое можно представить следующим образом:

dq(k) = d(k)-e(k)

где e(k) представляет собой ошибку квантования, получающуюся вследствие аппроксимации аналоговой величины d(k) цифровой величиной dq(k). Таким образом, входные данные предсказателя состоят из квантованных разностей и выходных данных предыдущего предсказания:

mq(k) = m'q(k) +dq(k) = [m(k) - d(k)] + [d(k) + q (k)] = m(k) + q(k).

Видно, что mq(k) является квантованным аналогом m(k). Таким образом, как и было задумано, на вход предсказателя подаются значения mq(k), необходимые для работы приемника. Логика приемника показана на рис. 3.5, б. Часть приемника, которая заключена в пунктирную рамку, ничем не отличается от заключенного в пунктирную рамку участка передатчика. На вход этих участков подается одно и то же значение, dq(k), следовательно, на выходе получаются одинаковые значения mq(k). Затем на приемнике выходные данные этого участка пропускаются через фильтр, вследствие чего получается аналоговый сигнал, являющийся приближением исходного аналогового сигнала.

Как правило, предсказатель — это реализованная с использованием регистров сдвига линейная взвешенная сумма предыдущих выборок и задержек, равных интервалу выборки (рис. 3.6).

Рисунок 3.6 - Схема линейного предсказателя

Адаптивная дифференциальная РСМ

Производительность схемы DPCM можно повысить, если использовать адаптивные методы предсказания и квантования, которые позволят предсказателю и устройству квантования адаптироваться к изменяющимся характеристикам кодируемой речи. В этом разделе описывается схема ADPCM, стандартизованная ITU-T в Рекомендации G.7265, которая используется в системах DECT и во многих абонентских линиях связи.

На рис. 3.7 показана базовая логика ADPCM. Передатчик преобразует поток оцифрованной речи со скоростью 64 Кбит/с в сжатый поток со скоростью 32 Кбит/с. Общая блок-схема аналогична схеме, приведенной для модуляции DPCM. В этом случае адаптивный предсказатель использует не только значения своих предыдущих выходных данных, но и значения предыдущих квантованных разностей. В предсказателе и в устройстве квантования параметры алгоритмов регулируются динамически, в зависимости от статистических свойств предыдущих выборок. Как и при использовании схемы DPCM, ядро декодера — копия части логики кодера.

Рисунок 3.7 - Упрощенная схема передатчика и приемника ADPCM

Адаптивное устройство квантования (аналого-цифрового преобразователя — АЦП) в качестве входных данных принимает значение разности d(k) между модулированным сигналом s(k) и оценкой этого сигнала sf(k), а на выходе выдает 4-битовый модулированный сигнал ADPCM I(k). Соответствующее отображение значений приведено в первых двух столбцах табл. 3.3. До квантования d(k) представляется в виде логарифма по основанию 2, масштабируется на величину y(k) — множитель адаптации, основанный на скорости изменения сигнала от выборки к выборке. Полученный результат представляется как 4 бит, которые и передаются как сигнал ADPCM.

Таблица 3.3 Нормированные характеристики входа/выхода устройства квантования ADPCM

Диапазон нормированных входных значений АЦП, log2|d(k)| - y(k) | Выход адаптивного АЦП, I(k) | Выход обратного адаптивного АЦП, dq(k)
[3,12; + ∞) | 7 | 3,32
[2,72; 3,12) | 6 | 2,91
[2,34; 2,72) | 5 | 2,53
[1,91; 2,34) | 4 | 2,13
[1,38; 1,91) | 3 | 1,66
[0,62; 1,38) | 2 | 1,05
[-0,98; 0,62) | 1 | 0,031
(- ∞; -0,98) | 0 | - ∞

На вход обратного адаптивного АЦП подается 4-битовый сигнал I(k), а на выходе получается разностный сигнал dq(k), который затем используется в качестве входного сигнала для адаптивного предсказателя. Это отображение представлено во втором и третьем столбцах табл. 3.3.

Адаптивный предсказатель имеет структуру линейного предсказателя (см. рис. 3.6), который, впрочем, сложнее, чем предсказатель схемы DPCM. Предсказатель для схемы ADPCM является комбинацией рекурсивного фильтра второго порядка и нерекурсивного фильтра шестого порядка, что можно представить следующим уравнением:

где коэффициенты А и В обновляются с помощью алгоритмов адаптации к скорости изменения выборок se(k) и dq(k). Таким образом, адаптивный предсказатель настраивается на скорость изменения разностей выборок, а также на скорость изменения оценочных значений сигнала.

Субъективное измерение производительности кодера

Целью кодирования речи является использование избыточности сигнала, структуры сигнала и знаний об особенностях человеческого восприятия для предоставления различных скоростей передачи данных с сохранением при этом максимально возможного качества сигнала. При оценке производительности кодера речи более подходят субъективные измерения качества, чем объективные, например, по отношению сигнал/шум или среднеквадратической ошибке. Впрочем, надежные значения субъективных измерений, как правило, труднее получить.

Из субъективных измерений, используемых как стандарт качества услуг, наиболее распространенным является усредненная оценка разборчивости речи (mean opinion score — MOS), которая устанавливается на основе субъективного тестирования. Для измерений параметра MOS группу субъектов просят прослушать образец кодированной речи и оценить его по пятибалльной шкале. Для повышения надежности результатов тест проводится несколько раз, с разными образцами речи и разными группами слушателей. Шкала MOS используется во множестве спецификаций как стандарт качества (например, в спецификации IEEE 802.16, описанной в разделе 3.3).

Используемая шкала приведена в табл. 3.4, где также даны две ее альтернативные (но при этом эквивалентные) интерпретации. На рис. 3.8 показаны результаты тестов MOS из отчета для различных схем кодирования речи, включая ADPCM. Обратите внимание, что даже некодированная речь не получает наивысшей оценки 5. Это происходит потому, что слушатели иногда склонны ставить оценку 4 даже тем образцам речи, которые вполне заслуживают оценки 5. Учитывая это явление, оценки от 4 до 4,5 можно считать признаком высокого качества оцифровки.

Рисунок 3.8 - Субъективное качество речи для различных кодеров

Таблица 3.4 Усредненная оценка разборчивости речи (MOS)

Оценка | Качество | Недостатки
5 | Отличное | Незначительные
4 | Хорошее | (Еле) ощутимые, но не раздражающие
3 | Достаточное | (Ощутимые и) слегка раздражающие
2 | Плохое | Раздражающие (но не неприемлемые
1 | Неудовлетворительное | Очень раздражающие (неприемлемые)


Беспроводные сети. Современное состояние и перспективы развития. 11.2. БЕСПРОВОДНЫЕ АБОНЕНТСКИЕ ЛИНИИ СВЯЗИ

3.2. БЕСПРОВОДНЫЕ АБОНЕНТСКИЕ ЛИНИИ СВЯЗИ

Традиционно услуги передачи речи и данных предоставляются конечным пользователям посредством местной (или абонентской) линии связи, т.е. с помощью проводных систем. Для абонентов, находящихся в жилых домах, в качестве стандартного средства соединения использовались и продолжают использоваться витые пары. Для организаций и государственных учреждений используются витые пары, коаксиальный кабель и оптоволокно.

По мере роста спроса на пропускную способность, особенно после возникновения Internet, традиционной технологии витых пар становилось недостаточно. Поставщики телекоммуникационных услуг разработали множество удовлетворяющих предъявляемым требованиям технологий, включая ISDN (Integrated Services Digital Network — цифровая сеть с интеграцией услуг), а также семейство технологий цифровых абонентских линий, известное как xDSL. Кроме того, фирмы, занимающиеся кабельным телевидением, ввели двусторонние высокоскоростные услуги с использованием технологии кабельного модема. Таким образом, надежный и высокоскоростной доступ к средствам связи в жилых домах, частных и государственных конторах вполне может быть обеспечен и проводными технологиями.

Тем не менее растет интерес и к конкурирующим технологиям беспроводного абонентского доступа. Эти технологии объединяют под общим названием беспроводные абонентские линии связи (wireless local loop — WLL), или стационарный беспроводный доступ. Существует два вида беспроводных абонентских линий связи: узкополосные линии, которыми предлагается заменить существующие телефонные линии, и широкополосные линии, которые обеспечивают двусторонние высокоскоростные услуги передачи речи и данных. Табл. 3.5, составленная на основе данных, позволяет сравнить линии WLL с другими технологиями, предоставляющими беспроводный доступ стационарным абонентам.

Таблица 3.5 Альтернативные поставщики доступа конечным пользователям

Объект | Технология | Приложение
 |  | Услуги телефонии | Широковещание | Компьютерные приложения
Общественная телефонная сеть | Витая пара, ISDN, xDSL | Одна и две линии | Видео по заказу | Высокоскоростной асимметричный доступ
Поставщик кабельных услуг | Коаксиальный кабель | Одна и две линии | 50 и более каналов | Высокоскоростной асимметричный доступ
Поставщик услуг сотовой связи | Сотовая и бесшнуровая связь | Одна линия | Не предлагается | Возможна поддержка мобильности
Поставщик услуг сотовой связи третьего поколения | Сотовая связь | Одна линия | Не предлагается | Высокоскоростной асимметричный доступ
Оператор узкополосных линий WLL | Беспроводная связь | Две линии | Не предлагается | Доступ к линии 64 Кбит/с
Оператор широкополосных линий WLL | Беспроводная связь | Предлагаются | 50 и более каналов | Высокоскоростной асимметричный доступ
Компания наземного вещания | Аналоговое и цифровое телевидение | Не предлагаются | 5-10 каналов | Небольшие возможности загрузки
Компания спутникового вещания | Аналоговое и цифровое телевидение | Не предлагаются | 50 и более каналов | Не предлагаются

После обзора беспроводных абонентских линий связи будут рассмотрены некоторые технические вопросы и приведены две разновидности линий WLL. Раздел 3.3 посвящен развивающемуся стандарту для линий WLL, известному как IEEE 802.16.

Роль линий WLL

На рис. 3.9 показана конфигурация простейшей беспроводной абонентской линии связи. Один поставщик WLL обслуживает от одной до нескольких ячеек. В каждой ячейке имеется антенна базовой станции, установленная на вершине высокого здания или на башне. У каждого отдельного абонента также имеется стационарная антенна, установленная на крыше здания или на столбе, откуда видна антенна базовой станции. Между базовой станцией и коммутатором существует канал связи, который может быть как проводным, так и беспроводным. Коммутатор обычно находится в здании местной телефонной компании, откуда имеется доступ к локальной и междугородной телефонным сетям. Поставщики услуг Internet (Internet service provider — ISP) могут располагаться там же, где и коммутатор, или подключаться к коммутатору посредством высокоскоростного канала связи.

На рис. 3.9 показана система с двухуровневой иерархией. Существуют также и более сложные конфигурации, в которых базовая станция может обслуживать несколько антенн низшего уровня, каждая из которых обслуживает множество абонентов.

Беспроводные абонентские линии связи имеют ряд преимуществ перед проводными схемами поддержки абонентов.

• Стоимость. Беспроводные системы обходятся не так дорого, как проводные. Хотя электронное оборудование передатчика и приемника беспроводной сети стоит дороже аналогичного оборудования для проводного соединения, отсутствуют затраты на прокладывание километров кабеля (под землей или от столба к столбу) и содержание проводной инфраструктуры.

Рисунок 3.9 - Конфигурация беспроводной абонентской линии связи

• Время установки. Беспроводные системы, как правило, устанавливаются довольно быстро. Время в основном тратится только на получение разрешения на использование полосы частот и на поиск подходящей возвышенности для антенн базовой станции. Если решены эти два вопроса, то установка системы WLL займет малую толику того времени, которое потребовалось бы для установки новой проводной системы.

• Выборочная установка. Радиоустройства устанавливаются только для тех абонентов, которым нужны услуги в настоящее время. При прокладывании кабелей проводной системы, как правило, предполагается, что придется обслуживать всех абонентов в данном районе.

Целесообразность установки абонентских беспроводных линий связи можно оценить, сравнив схему WLL с двумя другими технологиями.

• Проводная схема с использованием проложенного кабеля. Большая часть жителей Земли не имеет телефонов. Многие абоненты телефонных линий либо не имеют доступа к линиям достаточно высокого качества либо находятся слишком далеко от центральной станции, чтобы эффективно использовать xDSL, что не позволяет поддерживать высокоскоростные приложения. Кроме того, многие абоненты не имеют кабельного телевидения либо поставщики не могут обеспечить услуг двусторонней передачи данных. Наконец, по стоимости линии WLL вполне способны конкурировать с проводными схемами. Поэтому при установке новой системы приходится призадуматься, какую из схем выбрать: проводную или беспроводную.

• Мобильные сотовые технологии. Современные сотовые системы слишком дороги и слишком ограничены в средствах, чтобы представлять собой реальную альтернативу линиям WLL. Даже тогда, когда станут доступны сотовые системы третьего поколения, они, скорее всего, будут более дорогими и менее функциональными, чем широкополосные системы WLL. Основным преимуществом систем WLL перед мобильными сотовыми системами является то, что абонентское устройство стационарно, поэтому абонентская антенна направляется на антенну базовой станции и обеспечивает максимально возможное качество передачи в обоих направлениях.

В США Федеральная комиссия по средствам связи выделила для коммерческих стационарных беспроводных услуг 15 полос частот, находящихся в диапазоне 2-40 ГГц. В других странах выделены подобные полосы частот. Следует отметить, что эти частоты значительно выше тех, что используются для сотовых систем. На этих частотах, которые часто называют миллиметровыми, характеристики распространения сигналов существенно отличаются от характеристик мегагерцевого диапазона. Далее будут проанализированы характеристики распространения сигналов, а затем представлена технология, используемая во множестве систем WLL и известная как ортогональное FDM (OFDM). В заключение будут рассмотрены два наиболее интересных подхода к приложениям WLL: локальные многоточечные распределительные услуги (LMDS) и многоканальные многоточечные распределительные услуги (MMDS).

Распространение сигнала в системах WLL

В большинстве высокоскоростных схем WLL используется диапазон частот, называемый миллиметровым. Хотя четкого определения термина миллиметровая волна нет, как правило, считается, что она имеет частоту не менее 10 ГГц. Т.е. Миллиметровым считается диапазон 10-300 ГГц7. Этот диапазон был выбран для систем WLL по следующим причинам.

Выше частоты 25 ГГц находятся широкие полосы частот, которые практически не используются.
При таких высоких частотах можно использовать широкие каналы, что приводит к увеличению скорости передачи данных.

Можно использовать трансиверы малых размеров и блоки адаптивных антенн.

В то же время миллиметровые системы имеют ряд нежелательных характеристик распространения.

Потери в свободном пространстве растут как квадрат частоты, т.е. в этом диапазоне потери оказываются значительно больше, чем в диапазонах, используемых для обычных микроволновых систем.

2. Для частот ниже 10 ГГц, как правило, можно игнорировать эффекты затухания сигнала, обусловленные осадками и атмосферным или газовым поглощением. При частотах выше 10 ГГц эти эффекты затухания становятся довольно заметными.

3. Существенно возрастают потери вследствие многолучевого распространения. Как отмечалось в главе 5, при падении электромагнитной волны на поверхность, характерные размеры которой значительно превышают длину волны сигнала, происходит отражение. Если размеры препятствия сравнимы с длиной волны или меньше ее, происходит рассеяние, если же волновой фронт попадает на края препятствия, которые велики по сравнению с ; ной волны, то происходит дифракция.

Ввиду перечисленных негативных характеристик системы WLL могут обслуживать только ячейки ограниченного радиуса, который обычно не превышает одного километра. Кроме того, нужно обходить барьеры, встречающиеся на ли-нии прямой видимости, включая листву. Наконец, на диапазон применения и доступность систем WLL влияют осадки и уровень влажности.

Зоны Френеля

Для эффективной связи с помощью миллиметровых волн нужно обеспечить беспрепятственную линию прямой видимости между передатчиком и приемником. Возникает вопрос: сколько же пространства вокруг прямого тракта между передатчиком и приемником должно быть свободно от преград? При ответе на него удобно использовать такое понятие, как зоны Френеля.

Понятие зон Френеля основано на принципе Гюйгенса, согласно которому любой малый элемент пространства на пути электромагнитной волны может рассматриваться как источник вторичных волн, и поле излучения может рассматриваться как суперпозиция всех вторичных волн. На основе этого принципа можно показать, что объекты, лежащие внутри концентрических окружностей, проведенных вокруг линии прямой видимости двух трансиверов, могут влиять на качество связи как положительно, так и отрицательно. Все препятствия, попадающие внутрь первой окружности, первой зоны Френеля, оказывают наиболее негативное влияние.

Рассмотрим точку, находящуюся на прямом тракте между передатчиком и приемником, причем расстояние от точки до передатчика равно S, а расстояние от точки до приемника равно D, т.е. расстояние между передатчиком и приемником равно S + D (рис. 3.10). Вычислим радиус первой зоны Френеля в этой точке:

где R, S и D измеряются в одних и тех же единицах, а Л, обозначает длину волны сигнала вдоль тракта. Для удобства формулу можно переписать следующим образом:

где R выражается в метрах, два остальных расстояния — в километрах, а частота сигнала — в гигагерцах.

Пример. Пусть расстояние между двумя трансиверами равно 10 км, а частота несущей — 2,4 ГГц. Тогда радиус первой зоны Френеля в точке, расположенной посередине между трансиверами, равен 17,66 м. Если частота сигнала — 28 ГГц, радиус зоны в той же точке равен 5,17 м. Рассмотрим теперь точку тракта, которая отстоит на 1 км от одного из трансиверов. Для сигнала частотой 28 ГГц радиус первой зоны Френеля в этой точке будет равен 3,1 м.

Рисунок 3.10 - Первая зона Френеля

Было установлено, что если внутри окружности, радиус которой составляет примерно 0,6 радиуса первой зоны Френеля, проведенной вокруг любой точки между двумя трансиверами, нет никаких преград, то затуханием сигнала, обусловленным наличием преград, можно пренебречь. Одной из преград является земля. Следовательно, высота двух антенн должна быть такой, чтобы вдоль тракта не было ни одной точки, расстояние от которой до земли было бы меньше, чем 0,6 радиуса первой зоны Френеля.

Атмосферное поглощение

При распространении радиоволн с частотой свыше 10 ГГц через атмосферу происходит молекулярное поглощение. Интенсивность этого поглощения является нечетной функцией частоты, которая показана на рис. 3.3. Приблизительно на частоте 22 ГГц находится пик, соответствующий поглощению водяным паром, а на частоте около 60 ГГц — пик, соответствующий поглощению кислородом. На рисунке видно, что существует два благоприятных окна для сообщения, одно расположено в диапазоне примерно от 28 ГГц до 42 ГГц, и затухание в нем не превышает 0,13 дБ/км, другое находится в диапазоне 75-95 ГГц, и здесь затухание составляет порядка 0,4 дБ/км.

Впрочем, следует отметить, что данные о поглощении, представленные на рис. 3.11, соответствуют определенным значениям температуры, относительной влажности и атмосферного давления. Для других значений этих параметров форма кривых остается той же, однако изменяются абсолютные значения, особенно при изменении температуры и относительной влажности. В табл. 3.6, составленной на основе данных, показано влияние температуры и влажности.

Таблица 3.6 Поглощение сигнала с частотой 28 ГГц чистым воздухом (дБ/км)

 |  | Относительная влажность
 |  | 0 % | 50 % | 100 %
Температура, 0С | 00 | 0,02 | 0,05 | 0,08
 | 100 | 0,02 | 0,08 | 0,14
 | 200 | 0,02 | 0,12 | 0,25
 | 300 | 0,02 | 0,20 | 0,44
 | 400 | 0,01 | 0,33 | 0,79

Рисунок 3.11. Поглощение атмосферным газом (атмосферное давление — 1013 мбар; температура — 15°'С; плотность водяного пара — 7,5 г/м3)

Пример. Рассмотрим линию связи длиной 6 км с частотой передачи 25 ГГЦ. -Каковы будут потери в свободном пространстве? Чему будут равны дополнительные потери из-за атмосферного затухания в жаркий сырой день при температуре 30°С и относительной влажности 100% ?

Из уравнения (5.2) находим потери в свободном пространстве: 20 lg(f)+ 20 lg(d) - 147,56 = 136,95 дБ. Дополнительные потери, обусловленные атмосферным затуханием, составляют 6 х 0,44 = 2,64 дБ.

Влияние осадков

Одной из самых серьезных проблем при распространении миллиметровых волн является поглощение, вызванное осадками. Наличие капель дождя может привести к значительному снижению надежности и производительности канала связи, а в периоды сильных дождей может является решающим фактором. Учесть влияние дождя на распространение миллиметровых волн довольно сложно, так как нужно определять форму и размеры капли, частоту падения капель, интенсивность выпадения осадков и т.п. Наиболее распространена формула оценки поглощения вследствие дождя, согласно которой

A = aRb, (3.3)

где поглощение измеряется в децибелах на 1 км, интенсивность дождя измеряется в миллиметрах в час, а параметры а и b зависят от распределения размеров капель и от частоты. Более того, поглощение зависит также от поляризации электромагнитной волны. В табл. 3.7, составленной на основе данных, приведены типичные значения параметров а и b как функций частоты для горизонтально и вертикально поляризованных волн.

Таблица 3.7 Коэффициенты для оценки поглощения вследствие дождя

Частота, ГГц | ah | av | bh | bv
1 | 0,0000387 | 0,0000352 | 0,912 | 0,880
2 | 0,000154 | 0,000138 | 0,963 | 0,923
6 | 0,00175 | 0,00155 | 1,308 | 1,265
10 | 0,0101 | 0,00887 | 1,276 | 1,264
20 | 0,0751 | 0,0691 | 1,099 | 1,065
30 | 0,187 | 0,167 | 1,021 | 1,000
40 | 0,350 | 0,310 | 0,939 | 0,929
50 | 0,536 | 0,479 | 0,873 | 0,868

При определенных значениях а и b поглощение зависит от интенсивности дождя, R. Основное беспокойство вызывают те периоды времени, в течение которых интенсивность дождя превышает некоторый порог. Здесь все зависит от климатической зоны. В табл. 3.8, разработанной Международным телекоммуникационным союзом (ITU), Земля разделена на 15 климатических зон в зависимости от выпадения осадков и показаны значения R, которые в течение года превышаются на различные периоды времени. Эту информацию можно использовать для определения доступности канала радиосвязи.

Пример. Для вертикально поляризованной волны с частотой 30 ГГц, распространяющейся в климатической зоне Р, 0,01% времени распространения интенсивность осадков превышает 145 мм/ч. Определим поглощение, которое следует добавить к потерям в свободном пространстве: А= 0,167 х 145 = 24,2 дБ/км.

Таблица 3.8. Превышаемая интенсивность осадков (в мм/ч) для разных регионов

 |  | Дождевая климатическая зона
Процент времени, в течение которого превышается указанное значение |  | A | B | C | D | E | F | G | H | J | K | L | M | N | P | Q
 | 1 | 0,1 | 0,5 |  | 2,1 | 0,6 | 2 | 3 | 2 | 8 | 1,5 | 2 | 4 | 5 | 12 | 24
 | 0,3 | 0,8 | 2 | 13 | 4,5 | 2,4 | 5 | 7 | 4 | 13 | 4,2 | 7 | 11 | 15 | 34 | 49
 | 0,1 | 2 | 8 | 5 | 8 | 6 | 8 | 12 | 10 | 20 | 12 | 15 | 22 | 35 | 64 | 72
 | 0,01 | 8 | 12 | 15 | 19 | 22 | 28 | 30 | 32 | 35 | 42 | 60 | 63 | 95 | 145 | 115

Влияние растительности

Часть тракта канала связи WLL может проходить сквозь растительность, по большей части сквозь листву высоких деревьев. В некоторых пригородных областях и в маленьких городах такие преграды, скорее всего, устранить не удастся, даже устанавливая антенны на крышах. Исследование привело к следующим выводам.

1. Наличие деревьев вблизи местоположения абонента может привести к замиранию вследствие многолучевого распространения.

2. Основными многолучевыми эффектами, к которым приводит наличие лиственного покрова, являются дифракция и рассеяние.

3. Измерения, проведенные в садах с периодической структурой, дали такие результаты: поглощение 12-20 дБ на одно дерево для лиственных пород и до 40 дБ для группы из 1-3 хвойных деревьев, когда листва находится внутри 60% первой зоны Френеля.

4. Эффекты многолучевого распространения находятся в сильной зависимости от ветра.

Таким образом, при установке систем WLL для каждого абонента нужно постараться, чтобы в 60% первой зоны Френеля не было листвы. Тем не менее наличие деревьев не делает связь невозможной, оно просто означает, что т обуются некоторые адекватные контрмеры, например применение схем прямого исправления ошибок.

Ортогональное уплотнение с частотным разделением

В ортогональной схеме FDM (OFDM), именуемой также модуляцией с множественными несущими, используется несколько несущих сигналов с разными частотами, посредством каждого из которых отправляется некоторое количество битов. Схема напоминает уплотнение FDM, однако в схеме OFDM все подканалы предоставлены единственному источнику данных.

На рис. 3.12 показана схема OFDM. Предположим, имеется поток данных со скоростью R бит/с и доступной полосой NΔf, центрированной на частоте f0. Для отправки потока данных можно использовать полосу частот целиком, и в таком случае время передачи одного бита будет равно 1/R. Кроме того, можно разделить поток данных на N подпотоков с помощью преобразователя последовательного потока в параллельный. Тогда каждый подпоток данных будет иметь скорость передачи R/N бит/с и будет передаваться на собственной несущей частоте, причем расстояние между смежными (несущими частотами будет равно Д/. Теперь время передачи бита будет составлять N/R.

Рисунок 3.12 - Ортогональное уплотнение с частотным разделением

Схема OFDM имеет несколько преимуществ. Во-первых, селективному замиранию будут подвержены только некоторые подканалы, а не весь сиг-вал. Если поток данных защищен кодом прямого исправления ошибок, то с этим замиранием легко бороться. Но что более важно, OFDM позволяет подавить межсимвольную интерференцию (ISI) во многолучевой среде. ISI оказывает значительное влияние при высоких скоростях передачи данных, так как расстояние между битами (или символами) является малым. В схеме OFDM скорость передачи данных уменьшается в N раз, что позволяет увеличить время передачи символа в N раз. Таким образом, если время передачи символа для исходного потока составляет Ts, то период сигнала OFDM будет равен NTs. Это позволяет существенно снизить влияние межсимвольных помех. При проектировании системы N выбирается таким образом, чтобы величина NTs, значительно превышала среднеквадратичный разброс задержек канала.

Как видно из предыдущих рассуждений, при использовании схемы OFDM можно обойтись без эквалайзеров. Напомним, что эквалайзеры представляют собой сложные устройства, причем их сложность возрастает с увеличением количества символов, на которых приходится ISI.

Чаще всего со схемой OFDM используется модуляция QPSK (quadrature phase-shift keying — квадратурная фазовая манипуляция). В рассматриваемом случае каждый передаваемый символ представляет два бита. Вариант схемы OFDM/QPSK, используемой в системе MMDS, занимает полосу 6 МГц, имеет 512 отдельных несущих частот, причем расстояние между соседними несущими немного меньше 12 кГц. Для минимизации меже м-вольных помех данные передаются в пакетах, причем каждый пакет включает циклический префикс, за которым следуют символы данных. Циклический префикс используется для сглаживания переходов между соседними пакетами, обусловленных многолучевыми эффектами. Для рассматриваемой системы префикс состоит из 64 символов, за которыми в каждом пакете следуют 512 символов QPSK. Таким образом, в каждом подканале символы QPSK разделены префиксом длительностью 64/512 от длительности пакета. В общем случае, к моменту окончания префикса сигнал, полученный путем комбинирования сигналов, пришедших по различным трактам, не зависит от выборок предыдущих пакетов. Значит, в таком сигнале межсимвольная интерференция отсутствует.

Многоканальные многоточечные распределительные услуги (MMDS)

В табл. 3.9 перечислены 15 полос частот, выделенных в Соединенных Штатах для беспроводного доступа. Пять из них, от 2,15 ГГц до 2,68 ГГц, используются в системах MMDS. Лицензии на первые две полосы были выданы в 70-х годах на вещание 6-мегагерцовых телевизионных каналов, или, как тогда говорилось, на многоточечные распределительные услуги (multipoint distribution service — MDS). В 1996 году Федеральная комиссия по средствам связи США увеличила долю таких полос до нынешнего уровня и разрешила предоставлять многоканальные услуги, называемые MMDS. Системы MMDS конкурировали с поставщиками телевизионных услуг и обслуживали сельскохозяйственные районы, до которых не доходило широковещательное или кабельное телевидение. По этим причинам MMDS также называют беспроводными кабельными системами.

Таблица 3.9. Полосы стационарной беспроводной связи, выделенные федеральной комиссией по средствам связи США

Частота, ГГц | Использование
2,1500-2,1620 | Лицензируемые услуги MDS и MMDS; две полосы по 6 МГц каждая
2,4000-2,4835 | Нелицензируемые услуги ISM
2,5960-2,6440 | Лицензируемые услуги MMDS; восемь полос по 6 МГц каждая
2,6500-2,6560 | Лицензируемые услуги MMDS
2,6620-2,6680 | Лицензируемые услуги MMDS
2,6740-2,6800 | Лицензируемые услуги MMDS
5,7250-5,8750 | Нелицензируемые услуги ISM-UNII
24,000-24,250 | Нелицензируемые услуги ISM
24,250-25,250 | Лицензируемые услуги
27,500-28,350 | Лицензируемые услуги LMDS (Блок А)
29,100-29,250 | Лицензируемые услуги LMDS (Блок А)
31,000-31,075 | Лицензируемые услуги LMDS (Блок Б)
31,075-31,225 | Лицензируемые услуги LMDS (Блок А)
31,225-31,300 | Лицензируемые услуги LMDS (Блок Б)
38,600-40,000 | Лицензируемые услуги LMDS

Передаваемая мощность, разрешенная Федеральной комиссией по средствам связи, позволяет базовой станции MMDS обслуживать зону радиусом 50 км, однако абонентские антенны должны находиться на линии прямой видимости. Систему MMDS можно использовать для поддержки двусторонних услуг; в других странах система MMDS используется также для организации двустороннего доступа. Таким образом, MMDS представляет собой альтернативу широкополосным службам обмена данными, таким, как доступ к Internet.

В отличие от систем LMDS, которые будут рассмотрены ниже, основным недостатком систем MMDS является то, что они работают на более низких частотах и могут предложить гораздо меньшую ширину полосы частот, чем системы LMDS. Даже при использовании современных технологий один канал MMDS может обеспечить в восходящем направлении (от абонента к базовой станции) скорость передачи данных 27 Мбит/с. Т.е. для отдельных абонентов скорость передачи данных будет лежать в Диапазоне от 300 Кбит/с до 3 Мбит/с. Предоставить более высокие скорости передачи данных или поддерживать больше пользователей в восходящем направлении может позволить внедрение ортогонального FDM. И все же, скорее всего, из-за меньшей ширины полосы, системы MMDS будут использоваться в основном абонентами в жилых домах и в небольших компаниях, тогда как системы LMDS окажутся более привлекательными для компаний побольше, нуждающихся в полосах частот большей ширины.

Перечислим преимущества систем MMDS перед системами LMDS.

1. У сигналов MMDS больше длина волны (более 10 см), и они могут распространяться на большие расстояния без существенного снижения мощности Следовательно, системы MMDS могут работать в значительно больших ячейках, что позволяет снизить затраты на оборудование для дополнительных базовых станций.

2. Оборудование для работы на более низких частотах стоит дешевле, что выгодно как для абонента, так и для владельца базовой стации.

3. Сигналы MMDS труднее блокировать объектами, и они не так подвержены поглощению осадками.

Локальные многоточечные распределительные услуги (LMDS)

Локальные многоточечные распределительные услуги (local multipoint distribution service — LMDS) представляют собой относительно новый тип услуг WLL по доставке телевизионных сигналов и обеспечению двусторонней широкополосной связи на миллиметровых частотах. В Соединенных Штатах для систем LMDS будут выделены частоты порядка 30 ГГц, в Европе и некоторых других областях земного шара — порядка 40 ГГц. В табл. 3.9 показаны полосы частот, используемые в Соединенных Штатах для стационарного беспроводного доступа с помощью LMDS. Системы LMDS имеют следующие преимущества.

1. Относительно высокая скорость передачи данных, измеряемая мегабитами в секунду.

2. Возможность передачи видеосигналов, телефонной связи и обмена данными.

3. Относительно низкая стоимость по сравнению с альтернативными кабельными услугами.

Основным недостатком LMDS является малый радиус зоны обслуживания для одной базовой станции. Поэтому для обслуживания одного района приходится вводить большое количество базовых станций.

В типичной системе LMDS антенна базовой станции располагается на крыше высотного здания или на высоком столбе, с которого видна вся зона обслуживания, причем линия прямой видимости, по возможности, не должна проходить через листву. Одна антенна базовой станции покрывает угловой сектор от 60° до 90°. Таким образом, для полного охвата зоны обслуживания необходимо иметь на базовой станции от 4 до 6 антенн. Радиус же зоны обслуживания одной базовой станции обычно лежит в пределах 2-4 км. Если пропускная способность нисходящего канала связи составляет 36 Мбит/с, то, учитывая доступную ширину полосы, вполне разумно установить скорость передачи данных в восходящем канале от абонента равной 1 Мбит/с.

Немаловажно то, что коротковолновые сигналы систем LMDS не могут огибать такие объекты, как здания, стены или густая листва, или проходить сквозь них. Как говорилось выше, допустимым является только некоторое количество листвы, а при наличии густой листвы придется применять специальные контрмеры. Вводя базовые станции с перекрывающимися зонами обслуживания, можно обслуживать экранированные области из ячейки одной базовой станции с базовой станции соседней ячейки. Кроме того, можно использовать ретрансляторы и отражатели.


Беспроводные сети. Современное состояние и перспективы развития. 11.3 СТАНДАРТ IEEE 802.16

3.3 СТАНДАРТ IEEE 802.16

С ростом интереса к услугам LMDS возникла потребность в разработке стандартов в этой области. В результате в 1999 году комитет IEEE 802 образовал рабочую группу 802.16 для разработки стандартов для беспроводного широкополосного доступа, которые должны были обеспечить удовлетворение следующих требований.

• Использование беспроводной связи в СВЧ-диапазоне или миллиметровом диапазоне.

• Использование лицензируемого спектра (в основном).

• Охват в региональном масштабе.

• Наличие доступа к сети общего пользования (в основном).

• Использование точечно-многоточечной архитектуры со стационарными антеннами, размещаемыми на крышах или башнях.

• Возможность эффективной передачи неоднородного трафика при поддержании приемлемого качества обслуживания (QoS).

• Наличие возможности широкополосной передачи (>2 Мбит/с).

По сути, рабочая группа IEEE 802.16 стандартизовала радиоинтерфейс и функции, связанные с LMDS. На момент написания этой книги разработкой стандарта занимались три рабочие группы.

• IEEE 802.16.1. Радиоинтерфейс для диапазона 10-66 ГГц.

• IEEE 802.16.2. Сосуществование систем с широкополосным беспроводным доступом.

• IEEE 802.16.3. Радиоинтерфейс для лицензируемых частот 2-11 ГГц.

В табл. 3.10-3.12 определены область деятельности и цели этих трех групп, сформулированные при их образовании. На рис. 3.13 показано, какое место занимают стандарты 802.16.1 и 802.16.3 в общей структуре беспроводных услуг.

Таблица 3.10. IEEE 802.16.1. Радиоинтерфейс для полосы 10-66 ГГц

Область деятельности
Стандарт определяет физический уровень и уровень управления доступом к среде радиоинтерфейса точечно-многоточечных систем, способных к взаимодействию и имеющих стационарный широкополосный беспроводный доступ. Спецификация позволяет передавать данные, видео и речь. Стандарт применяется к системам, действующим на частотах порядка 30 ГГц, а также к системам, работающим на частотах 10-66 ГГц.
Цель
Проект призван содействовать быстрому внедрению инновационных, рентабельных продуктов с широкополосным беспроводным доступом, обеспечивая возможность взаимодействия продуктов от разных производителей. Предоставляя альтернативы проводному широкополосному доступу, проект будет стимулировать конкуренцию в сфере предоставления широкополосного доступа. Кроме того, проект будет стимулировать изучение сосуществования систем, поощрять глобальное регулирование и содействовать ускорению коммерциализации спектра беспроводных систем с широкополосным доступом.

Таблица 3.11. IEEE 802.16.2. Сосуществование систем с широкополосным беспроводным доступом

Область деятельности
В рамках этого проекта разрабатываются рекомендованные правила проектирования и координирования систем с широкополосным беспроводным доступом (BWA). Эти правила минимизируют интерференцию, а также максимизируют производительность системы а качество предоставляемых услуг. Правила должны обеспечить сосуществование систем посредством использования частотного и пространственного разделения и будут охватывать три сферы. Во-первых, через излучаемую мощность, спектральные маски и диаграммы направленности антенн будут установлены рекомендуемые границы внутриполосного и внеполосного излучения передатчиков систем BWA. Во-вторых, будут определены рекомендуемые значения допустимых параметров приемника, включая понижение уровня шума и блокирование пропускной способности, которое возникает вследствие интерференции с другими системами BWA, а также с другими наземными или спутниковыми системами. В-третьих, будут предоставлены параметры согласования, включая схемы распределения частот, расстояния разнесения и пределы плотности потока мощности, что обеспечит успешное внедрение систем BWA с допустимой интерференцией. В область деятельности стандарта попадает интерференция систем с одинаковой полосой частот, систем, внедренных в одной географической области на разных полосах частот (включая различные системы, внедренные одним владельцем лицензии в подполосах частот, определенных в лицензии). В область деятельности стандарта не входят проблемы сосуществования, вызванные внутрисистемным многократным использованием частот в пределах полосы частот, указанной в лицензии оператора, и не будет рассматриваться влияние интерференции систем BWA с наземными или спутниковыми не BWA-системами.
Цель
Целью рекомендуемых правил является обеспечение условий сосуществования владельцев лицензий, поставщиков услуг, групп внедрения и системотехнических предприятий. Параметры оборудования, определенные в этих правилах, помогут производителям оборудования и комплектующих, а также промышленным ассоциациям действовать в едином русле. Польза разрабатываемых правил заключается в следующем.
• Будет обеспечено сосуществование различных систем с надежной гарантией того, что будут удовлетворены требования к производительности систем.
• Будет минимальной потребность в изучении случайной интерференции и координации действий операторов для решения проблем интерференции.
• Будет обеспечена благоприятная электромагнитная среда для внедрения и работы систем BWA, включая будущие системы, удовлетворяющие стандарту 802.16.
• Будут оптимизированы покрытие зоны обслуживания и использование спектра.
• Системы будут внедрены максимально экономно.

Таблица 3.12. IEEE 802.16.3. Радиоинтерфейс для лицензируемых частот 2-11 ГГц

Область деятельности
Стандарт определяет физический уровень и уровень управления доступом к среде радиоинтерфейса точечно-многоточечных систем, способных к взаимодействию и имеющих стационарный широкополосный беспроводный доступ (например, систем, поддерживающих скорости передачи данных DS1/E1 и выше). Спецификация позволяет передавать данные, видео и речь с определенным качеством в лицензируемых полосах частот, выделенных для доступа к общественной сети. Спецификация применяется к системам, действующим на частотах 2-11 ГГц.
Цель
Проект призван содействовать быстрому внедрению инновационных, рентабельных продуктов с широкополосным беспроводным доступом, обеспечивая возможность взаимодействия продуктов разных производителей. Предоставляя альтернативы проводному широкополосному доступу, проект будет стимулировать конкуренцию в сфере предоставления широкополосного доступа. Кроме того, проект будет стимулировать изучение сосуществования систем, поощрять глобально согласованное распределение и содействовать ускорению коммерциализации спектра беспроводных систем с широкополосным доступом. Использование полос частот в диапазоне 2— 11 ГГц охватывает рынок, который включает жилые дома, малые и домашние офисы (SOHO), а также малые и средние предприятия (SME).

Рисунок 3.13. Многоуровневая перспектива беспроводной связи и распределительных систем

На настоящий момент больше других преуспела группа 802.16.1, работа которой, по-видимому, вызовет наиболее живой интерес в отрасли, так как касается определения доступных полос частот для систем LMDS. В этом разделе будет представлен обзор архитектуры и услуг стандарта 802.16, а затем более подробно рассмотрена спецификация стандарта 802.16.1.

Архитектура IEEE 802.16

Эталонная архитектура системы

Стандарты 802.16 разрабатываются по отношению к абстрактной эталонной модели системы, показанной на рис. 3.14. Согласно данным стандартам, беспроводная услуга — это предоставление тракта передачи сообщений между абонентом, которым может являться как одно абонентское устройство, так и абонентская сеть (например, ЛВС, РВХ, сеть на основе IP), и базовой сетью (доступ к которой определяется протоколом 802.16). Примерами базовых сетей являются общественная телефонная сеть и Internet. В этой модели определены три типа интерфейса. В стандарте IEEE 802.16 особое значение уделяется радиоинтерфейсу между трансиверной станцией абонента и базовой трансиверной станцией. В стандарте указаны все детали этого интерфейса, которые будут последовательно описаны ниже. В эталонной модели системы также представлены интерфейсы между трансиверными станциями и сетями, расположенными за ними (SNI и BNI). Подробное описание этих интерфейсов не является целью стандартов 802.16. В эталонной модели технологии, используемые в абонентских и базовых сетях (речь, ATM и т.д.), влияют на технологии, используемые в радиоинтерфейсе, и на услуги, предоставляемые трансиверными станциями через этот интерфейс.

Рисунок 3.14 - Основные элементы системы IEEE 802.16

Наконец, в эталонную модель системы включен некий ретранслятор. В спецификации радиоинтерфейса предусмотрена возможность использования ретрансляторов или отражателей для обхода препятствий и расширения зоны обслуживания ячейки.

Архитектура протоколов

Протоколы, определенные для беспроводной передачи, решают вопросы, связанные с передачей блоков данных по сети. В терминах OSI высокоуровневые протоколы (уровни 3, 4 и выше) не зависят от архитектуры сети и применимы к различным сетям и коммуникационным интерфейсам. Поэтому рассмотрение протоколов 802.16 затронет только два первых уровня модели OSI.

На рис. 3.15 показана взаимосвязь четырех уровней протоколов, определенных в архитектуре 802.16. Рассмотрим уровни снизу вверх. Два нижних уровня модели 802.16 соответствуют физическому уровню модели OSI и включают такие функции:

• кодирование и декодирование сигналов;

• создание и удаление начальной последовательности битов (используется для синхронизации);

• передача и прием битов.

Кроме того, физический уровень модели 802 включает в себя спецификацию среды передачи и полосы частот. Вообще считается, что эти вопросы рассматриваются "под" нижним уровнем модели OSI. Тем не менее выбор среды передачи и полосы частот играет решающую роль при проектировании беспроводной связи, поэтому включено также и описание среды. На самом деле все вопросы, касающиеся среды, относят к физическому уровню протокола 802.16, а приведенный выше перечень вопросов рассматривают на уровне передачи.

Рисунок 3.15 - Архитектура протоколов IEEE 802.16

Над физическим уровнем и уровнем передачи находятся функции, связанные с предоставлением услуг абонентам. Приведем примеры таких функций.

• При передаче: сбор данных в кадр, имеющий адресное поле и поле обнаружения ошибок.

• При приеме: разбор кадра, распознавание адреса и обнаружение ошибок.

• Управление доступом к беспроводной среде передачи.

Эти функции собраны на уровне управления доступом к среде (MAC). На этом уровне протокол между базовой станцией и абонентской станцией отвечает за предоставление доступа к радиоканалу. В частности, в протоколе MAC определяется, как и когда базовая станция и абонентская станция могут начинать передачу в канале. Поскольку для некоторых уровней, находящихся выше уровня MAC (например, ATM), нужно определять уровень предоставляемых услуг (QoS), протокол MAC должен уметь распределять пропускную способность таким образом, чтобы удовлетворить требованиям, предъявляемым к этим услугам. В нисходящем направлении (от базовой станции к абонентским станциям) находится только один передатчик, потому протокол MAC для этого направления является достаточно простым. В восходящем направлении за доступ состязаются несколько абонентских станций, в результате чего протокол MAC усложняется.

Над уровнем MAC находится уровень сходимости, в котором собраны функции, характерные для конкретного вида предоставляемых услуг. Протокол уровня сходимости должен выполнять такие действия:,

• инкапсулировать PDU (модули данных протокола) верхних уровней в естественные для 802.16 кадры MAC/PHY;

• отображать адреса верхнего уровня в адреса 802.16;

• преобразовывать параметры QoS в естественный формат 802.16 MAC;

• адаптировать временные зависимости трафика верхнего уровня в эквивалентную услугу MAC.

В некоторых случаях, таких, как передача цифрового аудио и видео, уровень сходимости не нужен, и поток цифровых данных передается уровню передачи. Уровень сходимости требуется для услуг высшего уровня, в которых используется структура PDU.

Пример структуры протокола с уровнем сходимости для управления трафиком на основе протокола TCP/IP показан на рис. 3.16. Данные высшего уровня передаются на подуровень управления логическим каналом (LLC), на котором управляющая информация прилагается как заголовок, создавая модуль данных протокола (PDU) LLC. Эта управляющая информация используется для работы протокола LLC, представляющего собой разновидность протокола управления каналом передачи данных. Затем PDU LLC передается на уровень MAC, на котором перед модулем и за модулем присоединяется управляющая информация, образуя кадр MAC. Как и раньше, управляющая информация нужна для работы протокола MAC. На рисунке также показано использование протокола TCP/IP и уровень приложений, который находится над протоколами 802.16.

Рисунок 3.16 - Протоколы IEEE 802.16 в контексте

Услуги

Требования, предъявляемые к стандартам IEEE 802.16, определяются в терминах услуг-носителей, которые должны поддерживать системы 802.16. Под услугами-носителями понимаются разновидности трафика, создаваемые абонентской или базовой сетью, которые изображены на рис. 3.14. Например, интерфейс 802.16 должен быть способен поддерживать скорость передачи данных и качество передачи, требуемые сетью ATM или сетью, основанной на протоколе IP, либо интерфейс должен поддерживать скорость передачи данных и удовлетворять требованиям, предъявляемым к задержкам при передаче аудио- и видеосигналов. Требования для отдельных услуг-носителей определены в стандартах 802.16.1 и 802.16.3.

Услуги IEEE 802.16.1

Протокол IEEE 802.16.1 разработан для поддержки следующих услуг-носителей.

• Многоадресная передача цифрового аудио и видео. Односторонняя передача потоков цифровых аудио- и видеосигналов абонентам. Главным примером этой услуги является радиовещание и передача видеоданных, подобная цифровому кабельному телевещанию и цифровому спутникрвому телевидению. Частным случаем этой услуги является двустороннее видео, подобное телеконференциям. В таких случаях задержка неприемлема, так как здесь важно обеспечить интерактивность соединения.

• Цифровая телефония. Поддержка разделенных цифровых телефонных потоков. Эта классическая услуга WLL является альтернативой проводному доступу к общественной телефонной сети.

• ATM. Предоставление канала связи, который поддерживает передачу ячеек ATM как части общей сети ATM. Канал связи в стандарте 802.16 должен поддерживать различные услуги QoS, определенные для систем ATM.

• Протокол Internet. Поддержка передачи дейтаграмм IP. Канал связи 802.16 должен предоставлять эффективные своевременные услуги. Кроме того, для сетей, основанных на протоколе IP, в настоящее время определены различные виды услуг и стандарт 802.16 должен поддерживать их все.

• ЛВС с соединением через мосты. Услуга подобна предыдущей и позволяет передавать данные между двумя ЛВС с коммутацией на уровне MAC.

• Магистрали. Реализуется для сотовых или цифровых беспроводных телефонных сетей. Система 802.16 может быть удобным средством предоставления беспроводных каналов связи для беспроводных телефонных базовых станций.

• Ретрансляция кадров. Подобна услуге ATM, но при ретрансляции кадров используются кадры переменной длины, тогда как ячейки ATM имеют фиксированный размер.

Требования, предъявляемые услугами к стандарту 802.16, также можно представить в табличной форме — табл. 3.13 взята непосредственно из документа функциональных требований. Услуги-носители группируются в три обширных категории.

Таблица 3.13 Требования IEEE 802.16.1 к услугам и качеству обслуживания

 | Услуги - носитель | Скорость переда-чи полезной нагрузки MAC | Максимальная вероятность ошибки | Максимальная задержка
Основанные на каналах | Высококачественные узкополосные, телефония речевого диапазона (MOS вокодера > 4,0) | 32-64 Кбит/с | BER: 10-6 | 5 мс
 | Низкокачественные узкополосные, телефония речевого диапазона (MOS во-кодера < 4,0) | 6-16 Кбит/с | BER: 10-4 | 10 мс
 | Магистраль | < 155 Мбит/с | BER: 10-6 | 5 мс
Пакеты переменной длины | Срочные услуги передачи пакетов | 4-13 Кбит/с (речь) от 32 Кбит/с до 1,5 Мбит/с (видео) | BER: 10-6 | 10 мс
 | Несрочные услуги: IP, IPX, ретранс-ляция кадров, непрерывное аудио и видео, групповая передача данных и т.д. | < 155 Мбит/с | BER: 10-8 | Не определена
 | Видео в формате MPEG | < 8 Мбит/с | BER: 10-11 | TBD
Ячейки и пакеты фик-сированной длины | Ретрансляция кадров ATM — CBR | От 16 Кбит/с до 155 Мбит/с | CLR: 3x10-8 CER: 10-6 CMR: 1 ошибка в сутки SEBCR:10-4 | 10 мс
 | Ретрансляция кадров ATM — rt-VBR | От 16 Кбит/с до 155 Мбит/с | CLR: 10-5 CER: 4x10-6 CMR: 1 ошибка в сутки SEBCR:10-4 | 10 мс
 | Ретрансляция кадров ATM — другие услуги | < 155 Мбит/с | CLR: 10-5 CER: 4x10-6 CMR: 1 ошибка в сутки SEBCR:10-4 | Не определена

• Основанные на каналах. Эти услуги предоставляют пропускную способность с возможностью коммутации каналов, в которой соединения с абонентами устанавливаются через базовую сеть.

• Пакеты переменной длины. Примерами услуг, в которых используются PDU переменной длины, являются передача пакетов IP и ретрансляция кадров. Еще одним примером является видео в формате MPEG, представляющем собой схему сжатия видеоданных, в которой последовательные блоки цифровой видеоинформации могут иметь разные размеры.

Ячейки и пакеты фиксированной длины. Эта услуга предоставляется системам ATM.

Требования в таблице сгруппированы по трем пунктам. Первая категория — это скорость передачи данных, которую должны поддерживать системы. Вторая — частота появления ошибок. Для большинства услуг установлен верхний предел частоты появления ошибочных битов (bit error ratio — BER). Для систем ATM используются также различные параметры QoS.

Последняя категория — максимальная односторонняя задержка. Для отображения этого параметра в контексте на рис. 3.14 показаны три категории задержек, определенных в стандарте 802.16.

• Средняя задержка доступа. Когда трансиверная станция готова к передаче, средняя задержка доступа означает время ожидания станции перед началом передачи.

Задержка передачи. Задержка распространения сигнала от SNI к BNI или от BNI к SNI. В нее входит средняя задержка доступа плюс время обработки сигнала на уровне MAC для подготовки его к передаче (с STS или BTS) и время подготовки к приему на уровне MAC (на BTS или STS).

Сквозная задержка. Суммарная задержка передачи между терминалом в сети абонента и конечной услугой за пределами базовой сети. В нее входит и задержка передачи.

Максимальная односторонняя задержка в табл. 3.13 — это задержка передачи.

Услуги IEEE 802.16.3

Стандарт IEEE 802.16.3 разрабатывался для поддержки следующих услуг-носителей.

• Передача речи. Основанные на передаче пакетов (в противоположность коммутации каналов) услуги, эквивалентные предлагаемым общественной коммутируемой телефонной сетью.

• Передача данных. Поддержка трафика, основанного на протоколе IP, включая определяемые IP требования к качеству обслуживания.

ЛВС с соединением через мосты. Услуга подобна предыдущей и позволяют передавать данные между двумя ЛВС с коммутацией на уровне MAC.

Цифровой эквивалент перечисленных требований дан в табл. 3.14.

Уровень MAC стандарта IEEE 802.16.1

Структура данных, передаваемых абоненту или абонентом по радиоинтерфейсу 802.16.1, — это последовательность кадров MAC. В данном контексте термин кадр MAC обозначает PDU, который содержит управляющую информацию MAC и данные более высокого уровня. Не стоит путать этот кадр с кадром TDMA, который состоит из последовательности слотов, каждый из которых выделен для конкретного абонента. Слот кадра TDMA может содержать один кадр MAC, какую-то часть кадра MAC или же несколько кадров MAC. Последовательность слотов в группе кадров TDMA, которая выделена одному абоненту, образует логический канал, по которому передаются кадры MAC.

Таблица 3.14 Требования IEEE 802.16.3 к услугам и качеству обслуживания

Услуга | Максимальная вероятность ошибки | Максимальная задержка (односторонняя)
Телефония высокого качества (MOS вокодера > 4.0) | BER: 10-6 | 20 мс
Телефония стандартного качества (MOS вокодера < 4.0) | BER: 10-4 | 40 мс
Срочные услуги передачи пакетов | BER: 10-6 | 20 мс
Несрочные услуги | BER: 10-9 | Не определена

Соединения и поток услуги

Протокол MAC стандарта 802.16.1 является ориентированным на соединение. Т.е. перед обменом данными между одноранговыми объектами (пользователями MAC) устанавливается логическое соединение. Каждый кадр MAC включает в себя идентификатор соединения, который используется протоколом MAC для доставки поступающих данных нужному пользователю MAC. Кроме того, существует однозначное соответствие между идентификатором соединения и потоком услуги. Поток услуги определяет параметры качества обслуживания (QoS) для модулей PDU, которыми обмениваются сообщающиеся объекты.

Понятие потока услуги является центральным моментом в работе протокола MAC. Потоки услуг предоставляют механизм управления качеством обслуживания в нисходящем и восходящем направлениях. В частности, они являются важной составляющей процесса распределения полосы частот. Базовая станция распределяет полосу частот для передачи в восходящем и нисходящем направлениях на основании потоков услуг для каждого активного соединения. Примерами параметров потоков услуг являются время ожидания (максимально допустимая задержка), дрожание (максимально допустимая вариация задержки) и пропускная способность (минимальная приемлемая скорость передачи битов).

Формат кадра

Чтобы разобраться в работе протокола MAC, лучше всего рассмотреть формат его кадра (рис. 3.17). Кадр делится на три секции.

• Заголовок. Содержит информацию управления протоколом, необходимую для функционирования протокола MAC.

• Полезная нагрузка. В этой секции могут находиться данные более высокого уровня (например, ячейки ATM, пакеты IP, блоки оцифрованной речи) или управляющее сообщение MAC.

• CRC. Поле циклической проверки четности с избыточностью содержит код обнаружения ошибок (рассмотрен в разделе 8.1).

Определены три формата заголовка. Существуют общие форматы заголовков в восходящем (к базовой станции) и в нисходящем (к абоненту) направлениях. Эти форматы используются для кадров, в которых содержатся как данные более высокого уровня, так и управляющие сообщения MAC. Третий формат используется для кадра, содержащего запрос на предоставление полосы частот.

Рисунок 3.17 - Формат кадра IEEE 802.16.1

Формат нисходящего заголовка показан на рис. 3.18, а. Он состоит из следующих полей.

• Управление шифрованием (1 бит). Указывает, зашифрована ли полезная нагрузка.

• Последовательность ключа шифрования (4 бит). Указатель на вектор информации о ключе шифрования, который используется при шифровании полезной нагрузки.

• Длина (11 бит). Длина в байтах всего кадра MAC.

• Идентификатор соединения (16 бит). Однонаправленный адрес уровня MAC, идентифицирующий соединение с одноранговыми объектами на уровнях MAC абонента и базовой станции. Данный идентификатор отображается в идентификатор SFID, который определяет параметры качества обслуживания потока услуг, связанного с данным соединением.

• Тип заголовка (1 бит). Позволяет определить, является заголовок обычным или же он соответствует кадру с запросом на предоставление полосы частот.

• Индикатор ARQ (1 бит). Указывает, относится ли кадр соединению, допускающему ARQ. Если да, то используется механизм ARQ, описанный в разделе 8.4, и в начало кадра добавляется 2-байтовое контрольное поле. Данная структура состоит из 4-битового числа, обозначающего количество попыток повторной передачи, и 12-битового порядкового номера. Значение в поле числа попыток сбрасывается при первой отправке пакета и возрастает на единицу всякий раз, когда пакет передается повторно (до последнего значения 15). Поле порядкового номера присоединяется к каждому пакету при его первой передаче, а затем также увеличивается на единицу при последующих передачах.

• Управление фрагментами (2 бит). Используется при фрагментации и повторной сборке, что будет рассмотрено ниже.

• Порядковый номер фрагмента (4 бит). Помер текущего фрагмента в последовательности.

• Последовательность проверки заголовка (8 бит). Для обнаружения ошибок в заголовке используется 8-битовый код CRC.

Фрагментация используется для разделения блоков данных более высокого Уровня на два или большее количество фрагментов с целью уменьшения размера кадров MAC. Это позволяет увеличить эффективность использования доступной полосы частот в соответствии с требованиями качества обслуживания потока услуг. Если фрагментация не проводится, значение в поле управления фрагментами (FC) равно 00. Если же кадр делится на фрагменты, тогда всем фрагментам будет выделен один и тот же порядковый номер (FSN), а значение в поле FC интерпретиру следующим образом: 01 — первый фрагмент, 11 — промежуточный фрагмент, 1 последний фрагмент. Пользователь MAC, которому передаются эти кадры, должен будет собрать воедино все фрагменты с одним и тем же номером FSN.

Рисунок 3.18 - Форматы заголовка MAC стандарта IEEE 802.16

Формат восходящего заголовка показан на рис. 3.18, б. Этот заголовок содержит те же поля, что и нисходящий заголовок, плюс 8-битовое поле предоставления управления (GM). Это поле используется абонентом для передачи управления полосой частот базовой станции. Для этого поля существуют три различных типа кодирования, в зависимости от типа соединения. В поле GM находятся такие подполя.
• Индикатор продвижения очереди (1 бит). Если этот бит установлен, он определяет продвижение права передачи относительно длины очереди восходящего канала.

• Бит опроса (1 бит). Если этот бит установлен, базовую станцию просят произвести опрос.

• Требуемый ресурс (7 бит). Запрос пропускной способности, требуемой для соединения.

• Каскадный запрос (8 бит). Число байтов пропускной способности восходящего канала, требуемых абоненту для этого соединения.

Первые два формата поля GM связаны с незапрашиваемым предоставлением услуги (UGS). Эта услуга разработана для поддержки потока услуг в реальном времени. По сути, базовая станция периодически, используя управляющие сообщения MAC, предоставляет абоненту право передачи некоторого количества байтов йа данное соединение. Распределение происходит в соответствии с требованиями передачи в реальном времени. Если абонент обнаруживает, что очередь передаваемых им данных превышает пороговый размер, он отправляет поле GM, в котором установлен бит SI, и либо просит провести опрос на желание использовать полосу частот, задавая бит РМ, либо заказывает требуемую пропускную способность в следующем слоте. Последний метод используется для услуг UGS с обнаружением активности; это означает, что поток может просто стать неактивным на значительный период времени. Для других типов услуг поле GM можно использовать для запроса пропускной способности. Это называется каскадным запросом, поскольку запрос не является отдельным кадром MAC с запросом управления полосой частот, а является частью кадра MAC, содержащего также пользовательские данные.

Наконец, заголовок запроса предоставления полосы частот используется абонентом для запроса дополнительной полосы частот. Этот заголовок используется для кадров MAC, не содержащих полезной нагрузки. В 15-битовом поле запроса указывается число байтов пропускной способности, требуемое для передачи данных по восходящему каналу.

Управляющие сообщения MAC

В стандарте IEEE 802.16.1 определено несколько типов управляющих сообщений, которые могут использоваться базовой станцией и абонентом для управления радиоинтерфейсом и обменом данными по различным соединениям. Сообщения используются для обмена рабочими параметрами и информацией, относящейся к состоянию или шифрованию, а также для управления пропускной способностью. Ниже кратко описаны все типы управляющих сообщений, определенные в настоящее время.

Дескриптор восходящего и нисходящего каналов. Передает характеристики физического канала.

• Определение доступа к восходящему и нисходящему каналам. Предослляет доступ к восходящему и нисходящему каналам.

• Зондирующий запрос и ответ на запрос. Запрос используется абонентом ддя определения задержки сети и для запроса регулирования мощности и/или модуляции. Ответ базовой станции содержит запрашиваемые параметры.

• Запрос регистрации, ответ на запрос и подтверждение регистрации. Запрос передается абонентом во время инициализации и содержит соответствующие параметры. Базовая станция .посылает ответ на запрос, а абонент для завершения квитирования отправляет подтверждение получения ответа.

• Запрос управления ключом секретности и ответ на запрос. Используется для обмена информацией о ключах шифрования.

• Запрос динамического добавления услуги, ответ и подтверждение. Запрос отправляется абонентом с целью заказа нового потока услуг.

• Запрос динамического изменения услуги, ответ и подтверждение. Запрос отправляется абонентом или базовой станцией с целью динамического изменения параметров существующего потока услуг.

• Запрос динамического удаления услуги, ответ и подтверждение. Запрос отправляется базовой станцией с целью удаления существующего потока услуг.

• Запрос предоставления широковещательного опроса и ответ на запрос. Отправляется абонентом с просьбой включить его в группу широковещательного опроса.

• Запрос типа предоставления права передачи по нисходящему каналу. Отправляется базовой станцией абоненту для указания метода модуляции и схемы FEC определенному соединению с целью повышения производительности.

• Подтверждение ARQ. Используется для подтверждения успешного приема одного или нескольких пакетов от однорангового объекта MAC.

Физический уровень стандарта IEEE 802.16.1

На физическом уровне стандарта 802.16.1 поддерживаются различные структуры точечно-многоточечных нисходящих каналов и многоточечно-точечных восходящих каналов (табл. 3.15). Эти структуры отражают расхождения в требованиях, предъявляемых к этим двум направлениям. Как правило, большинству систем требуется большая пропускная способность в нисходящем направлении, чтобы можно было поддерживать асимметричное соединение с отдельными абонентами для использования, например, Web-приложений в Internet. Для восходящего направления нужно рассмотреть также вопрос доступа к передающей среде, так как за доступную пропускную способность состязаются множество абонентов. Эти требования и отражены в спецификации физического уровня.

Восходящая передача

Для передачи в восходящем направлении используется технология DAMA-TDMA (множественный доступ с распределением по запросу; множественный доступ с временным разделением). Как было определено в главе 9, DAMA — это схема распределения пропускной способности, адаптируемая для оптимального соответствия меняющимся требованиям различных станций. TDMA— это просто схема разделения времени в канале на последовательность кадров, каждый из которых состоит из нескольких слотов, и один или несколько слотов в каждом кадре выделяется для создания логического канала. При использовании комбинированной схемы DAMA-TDMA распределение слотов в канале происходит динамически.

Для исправления ошибок при передаче в восходящем направлении используется код Рида-Соломона (Reed-Solomon) и схема модуляции, основанная на QPSK.

Таблица 3.15 Модели физического уровня стандарта IEEE 802.16.1

 | Восходящий канал связи | Непрерывный нисходящий канал связи (режим А) | Пакетный нисходящий канал связи (режим В)
Схема доступа | DAMA-TDMA | TDM | DAMA-TDMA
Схема дуплексной передачи | Согласовывается с нисходящим каналом | FDD | FDD с адаптивной модуляцией; FSDD; TDD

Нисходящая передача

В нисходящем направлении стандартом определено два режима работы: один для передачи непрерывного потока (режим А), такого, как аудио- или видеоданные, а другой — для передачи отдельных пакетов (режим В), таких, как трафик на основе протокола IP.

Для доступа к каналу в режиме передачи непрерывного потока используется простая схема TDM. Для распределения пропускной способности между восходящей и нисходящей нагрузкой используется дуплекс с частотным разделением каналов (FDD). Схема FDD означает, что для передачи данных в разных направлениях используются разные полосы частот. Эта схема эквивалентна схеме FAMA-FDMA (множественный доступ с фиксированным распределением; множественный доступ с частотным разделением). Для FDD предполагается, что все абоненты могут одновременно передавать и принимать данные, каждый на собственной частоте.

В режиме передачи пакетов для доступа к каналу используется схема DAMA-TDMA. Для разделения нагрузки между восходящим и нисходящим потоками можно использовать три альтернативные схемы.

• FDD с адаптивной модуляцией. Это та же схема FDD, что используется для передачи восходящего потока, но дополненная механизмами динамического регулирования пропускной способности для изменения модуляции и прямого исправления ошибок.

• Дуплекс с разделением каналов методом сдвига частоты (FSDD). Эта схема похожа на FDD, только не все абоненты могут передавать и принимать сигналы одновременно.

• Дуплекс с временным разделением каналов (TDD). Используется кадр TDMA, одна часть слотов в котором вы. делена для передачи восходящего потока, а другая — для передачи нисходящего потока.

Наличие этих альтернативных схем обеспечивает значительную гибкость при проектировании системы, что позволяет оптимизировать использование пропускной способности.